🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Bug Reports Sticky

A topic by Dasius created 159 days ago Views: 19,926 Replies: 1,133
Viewing posts 481 to 600 of 600 · Previous page · First page

Once I started up the game, it looked great. Perfect appearance, running fine, small bit of lag. Went into the Quality settings and reduced my graphical settings to 1920x1080 from 3840x2160. I do have a double monitor setup. One monitor's current resolution is 4k, while the other is 1080p. Once I pressed the button to exit the quality settings menu, my screen broke entirely. The game was split onto both monitors, one monitor being zoomed in (1080p monitor) while half of the other (4k) monitor wasn't even showing, Gamma was reset to 0% for absolutely no reason. Now I can't see the game because of the low gamma and It's unplayable because I am unable to adjust any settings because of how major the screens have been adjusted.

Of course, this occurs once the game has loaded up.

I have tried completely deleting and re-installing the game. Seems to be stuck no matter what I try to do... If there's any possible fix you know about, please let me know. Great game by the way, looks incredibly addicting!

Computer Specs:

Intel i7-6700, 32 GB RAM, GeForce GTX 960.

(+1)

Same as ayrios said above


"Unfortunately, reinstalling the game won't fix the problem since it doesn't delete your savegame or your current settings. They are stored elsewhere on your computer. Try deleting the Settings.sav file located here: C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames"

Have you tried to play on only one screen?

Im on a windows 10 and the game runs and the audio runs super slowly

Developer

Hey FliryDragon,

I'm not familiar with that issue but maybe check if your audio drivers are up to date? Maybe try restarting your compute rand running the game again?

I downloaded the game and it seems to be running fine except for the fact that i cant move my pov around, So I am just staring at the wall while i walk around. Thanks in advance.

Developer

Hey Solnoid,

Are you in fullscreen mode or windowed mode? Are you able to access any of the menu options?

yea I can access the menu option and alternate between full screen and window, I can do everything even closing and openin doors, it's just I can't look around

Developer

I apologize. I'm looking into the issue. Not quite sure why that is happening.

Do you by any chance have other peripherals connected to your computer that might cuase the issue?

Nah man, I'm sorry, its just i really want to play this game, so i get a little too excited. But as for your question, the only other thing i have connected to my computer is my keyboard.

thank you for responding i know you are a busy person :)

(Edited 1 time)

Can do anything with the audio settings. the music is way too loud. Alpha 0.0.72

(+1)

I believe music settings are coming in the next patch. Currently, you can only adjust your volume using the Windows Volume Mixer. Thanks and Happy Smithing!

(Edited 1 time)

An AI got stuck in the right side post outside the door (looking toward the house) and apparently kept all others from coming.

I'm running 0.0.72 Alpha

All I did was give him the one handed hammer he desired and a he started running in circles eventually running into the post outside the door and getting stuck.

I'm using a laptop with 12gigs RAM. and I7 Core processor.

Though must findeth a virgin to sacrifice in a ritual to release them from thy spell. No seriously just run into them, and eventually it will pop them out, and reset the AI to walk away.

After i downloaded and launched the game everything in the game was hella blurry and sometimes when i click, my cursors appears then freezes my game after that the only buttons i can press in the menu are "continue, save game, new game, and controls" so i dont know what to do now. HELP

Hello.

When the game is in full screen, I am only able to interact with the top left corner of the game. Now I am unable to change the settings to go to windowed mode since it is out of the area that I am able to click on.

Is there any way that I can revert back to windowed mode. I have tried deleting and reinstalling the game several times and to different hard drives (one SSD and one HDD).

Per the requirments:

1. I am running Alpha 0.0.72

2. See above

3. N/A

4.See above as well

5. CPU:i5-6600k 3.5 GHz 16GB Ram 64 bit Windows 10 GTX 1080

I was really looking forward to playing this game and I am sad that I am unable to get to play it yet. It looks like its just up my ally.

Thanks, roknout1294

Unfortunately, reinstalling the game won't fix the problem since it doesn't delete your savegame or your current settings. They are stored elsewhere on your computer. Try deleting the Settings.sav file located here: C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames

If you're having trouble finding it, reading this post (and its replies) should help: https://itch.io/post/128793/view-in-topic

Hope this helps!

(+1)

Im on .72 and theres a glitch i encountered twice in a day and requires me to restart the game every once in awhile after completeing a sale the say this will do and turn around outside the door and no new customers will come.

(+1)

Hi,

I have had a problem with the AI not being able to pick up weapons. I don't know if this is something that you know about, but I have had problems with the AI walking towards the weapon that I made for them and then when it ends up inside them it takes sometimes 10-20 seconds for them to pick it up, all the while their timer counts down. If it hits 0 before they have managed to pick it up then they will leave, sometimes coming back a bit later other times they won't. Also I have had a one handed sword that the AI who ordered it couldn't pick up, and everyone who came in after wanting a one handed sword will not take it. They don't even recognize that I have a sword in my hand in that they will not try to come towards it to pick it up they just stand there waiting for me to give them a sword.

(Edited 1 time) (+1)

i am trying to play the newest version, .72 i think it is and i went to fullscreen mode, after that when i went in the pause menu, and when i put my mouse cursor over any option under controls the game would not highlight the option, nor would it let me click if i click the game would freeze. and if i just played the game the vision is so blurry i dont know where the door is. how do i reset this. please email me at "punkfunk@live.ca". i cant share screen shot for some reason, but when i took it it just showed my desktop and a small window of just black.

(+1)

Hey, so everytime I try to play the game, the game is WAY too dark for me to see anything, and whenever I try to click on an option from the pause menu, it minimizes the game, so I can't change the resolution or the brightness. and I can't open the game in a window, it just defaults to fullscreen. I've tried to uninstall and reinstall, but it didn't do anything to fix the problems.

(+1)

I have found that People who are asking for greatswords often get glitched afterwards and never pay you, but your greatsword is surely gone with them. It also breaks the game temporarily and you have no additonal guests until the glitch guest leaves or unglitches and disappears.

(+1)

I have also found that If you swipe a Polearm Grip past a One hand sword it may sometimes disconnect the blade from the one hand sword and all of a sudden create a polearm. This doesn't even necessarily need to be on the crafting station either.

any idea why I cant look around with mouse?

Another player reported having the same problem. Apologies, but I am aware of no recommended solutions at this time. The dev responded to the previous post asking about any other conflicting peripherals. You can read that post and its replies HERE. Thanks!

I'm not sure if it's just my own computer, but whenever I try to launch the game, it says that I require the component Microsoft Visual C++ 2015 Runtime, but whenever I select it and it downloads and I click launch again, it says I need to download it, but then gives me an uninstall button for it, and it just keeps on doing this in an endless cycle, and nothing I've done or looked up has worked. Please Help!!!!

(+1)

The customers won´t buy what I made them even if I made an exact replica of what was on the wall, this is especially true with all hammers. Other than that it is a great game, keep up the good work!!!

I turned my graphics too high back accident and now the game wont let me go back into the graphics settings to change it.

(+1)

Try deleting the Settings.sav file located here: C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames

If you're having trouble finding it, reading this post (and its replies) should help:

https://itch.io/post/128793/view-in-topic

As soon as I put it into fullscreen, I could no longer switch it back and the game interacts like it's still in windows mode with the cursor coming "off screen" half way through the game.

hey i downloaded the game and started running it and as soon as i did i noticed one major bug that has made the game unplayable for me. I cant rotate my screen. I moved around and found the open door to click on to make sure it wasnt my mouse and sure enough it wasnt because left and right click still work i just am unable to rotate my player in anyway. Please help. I saw this game on mr fruit's gaming channel and it seems really fun and i would like to play it. I am running alpha 0.0.72 by the way.

(+1)

I have found an exploit within the game!

If you sell an item to a person and right after it save the game and quit. When you load the game back up you will find the item you just sold on the floor taken apart with the "blade" heated. Which means you make the sale and keep the item to sell it again when the opportunity shows itself.

(Edited 1 time) (+2)

Version 0.0.72

#1 - GAME BREAKING: Does not seem to affect blades, only hammer heads, but works with great hammers, one handed hammers, and polearm hammers - pushing a cooled hammer head into a pile of grips turns every one the head touches into a sellable hammer! It only graphically adds the hammer head onto one of the grips, the rest of the pile will still visually be plain grips, but they can all be accepted by customers as fully made wares.

#2? - Not sure if this is a bug, or just mislabled. Skill point reset line says "Daily Reset Points" but as far as i can figure out, you only get one ever. I reset all my points into agility so that I could explore the map at less of a crawl, expecting to be able to change them back the next day. Was then permanently stuck with all my points in agility; and none in my other categories.

#3 - With 5 points in agility, I noticed no difference in speed whatsoever.

#4 - Saving and loading a game breaks down all pre-made items back into lone grips, guards, and heated blades/hammer heads

#5 - Sometimes when loading into the game, graphics are all messed up. The screen is nearly black, with only the heated blades and heads strewn about the shop glowing through the darkness. Going into graphics and pushing 'reset' kinda fixes this, but makes everything look washed out.

you will love 0.0.73 :)


1) was fixed, definitely!

2) is new to me, I never tried to reset more than once :D

3) yeah dasius said that this is a veeeery minor change

4) this was fixed in #73

5) yeah this has been fixed somewhat around #72 - my way of fixing it once for all was:

* enter game, fix graphics settings

* ender sandbox, fix graphics settings

* enter shop mode, fix graphics settings

Since then everything was settled :)

every time i load a game everything is heated and all my weapons are ungrouped.

When I put together onehanded swords they sometimes get stuck in the workbench, making me lose out on my money and blocking the workbench. cant remove them

I read somehwere earlier in this thread that you can try to rotate them out of the workbench. It worked for me :)

Correct, when an item gets stuck in the workbench, follow these steps to unstick it:

  1. Grab and hold the item with the Right Mouse Button (RMB)
  2. Continue holding the RMB and Press Alt (or Alt+Ctrl) and move the mouse around to rotate the item.
  3. While still holding Alt (or Alt+Ctrl) release the RMB - The item should remain in your grasp in the orientation you rotated it to
  4. At this point you can drop the item by releasing Alt (or Alt+Ctrl) or grab the item again with RMB

Happy Smithing!

(Edited 2 times)

Hey there. I've got error that I could not report via bug report tool (although it opened), as the game didn't minimize and didn't went to background. I had to restart machine.

1. I put pole arm grip in vertical position on blacksmith table.

2. I added a blade to the end of the pole arm grip.

3. New item was too wide for it went into the walls, danced for a while and then I got frozen screen with no response from the game.

---

This is Win10 x64 with GTX 850M.

I can't select a weapon type, I can bring up the menu and then it just says "Heads" in the center and I can't get it off of that.

(Edited 3 times)

Customers seem to not be able to take my Great Swords. I hold it to their faces but their clock just runs out and they walk away as if I never made the sword. Only happens with Great Swords. It also kept happening after several restarts.

I'm also wondering why the time is so short now. I'm at lever 5, and the most time I get to make a weapon is 60 seconds. That's not enough when I need to make a Great Sword or a Great Hammer. Making other items gives me 5 seconds to spare at the most. Is this just a higher level issue? Because it's starting to annoy me a bit. I've begun making weapons before hand, and just handing them over whenever customers come in, which is also unhandy since I can't predict what they want. I could be sitting with 3 Great Swords when the customer gives me 50 seconds to make a Great Hammer. This also clashes when I need to order new supplies.

There are also moments when nobody comes in for a very long time. Opening and closing my shop seems to fix that and draw new cstomers. One time I had no customers for 2 days! (or maybe this is just a good reflection of reality :p)

Another thing, the instruction blue prints show that you need 2 ignots to make a great hammer, while in reality you need 3. For a small hammer you need 2, while the blueprints say you need 1. This doesn't change, even when I change the shape of the ignot on the anvil. Using just 1 ignot will result in a small dagger blade.

(+2)

Hello BlackOreoCookie!

The AI is a little bugged in the current version. Sometimes dropping the item and picking it back up will get them to take it from you. Also, after leaving the shop, sometimes they'll run around in circles forever. When they do this, no new customers will show up (only one customer at a time currently). You can usually unstick the broken customers by pushing them around. With the timers, they get shorter every game day. So you start with over 150 seconds on day one, but after about 15 days you'll only get about 30-45 seconds. Lastly, Dasius has said that the blueprint is currently incorrectly representing the ingot total for making items so in the meantime here are the recipes:

  • 1 ingot = small (dagger) blade only
  • 2 ingots = one handed sword blade OR one handed hammer head
  • 3 ingots = greatsword blade OR greathammer head

Happy Smithing!

Thank you! :)

I pass my game in fullscreen and the game become so dark when I left click the game alt tab and I can't click on graphic when I re upload the game d'ont change

try clicking "reset" in the graphics menu and try setting your gamma to 0.20 :)

Uhhhh I just sold an Adelite Greatsword for $16

I don't think that's supposed to be able to happen.

(Edited 2 times)

So i'm running version 0.0.72 and i was changing some graphics settings and now when i open it, it's initially in windowed mode and then when done loading it goes to fullscreen but only lets me click on things in the top left quarter of my screen. Because of this i can no longer get to the graphics button to reset them to default. I tried deleting and redownloading but it didn't work and remembered all my settings. previously when i was messing with the settings it had made the screen very small i the top left corner and i had to reset it from there but now it shows the game full screen and everything can be interacted with in the top left quarter of my screen so it seem to be different from that. Edit, a post above about deleting something in GameSave fixed this

As a side note (these are smaller bugs) when i saved the game and came back to it before this happened all the pre made weapons i had sitting in the shop had all the forged parts of them as heated and they all disconnected from the rest of the weapon and all the crystals i had found and brought back to the shop were placed back in their original position. Edit, Often when i order Polearm Grips and open the box inside the shop as to not carry them the extra distance, they explode out of the box and will sometimes disconnect the blade from a great sword and attach it to the polearm. I can't recall if it's done that to any other weapon.

I'm running an i7 with 16gbs of ram and a gtx980. i was just trying to run the game in windowed mode but i can't do that with its very high base resolution since it makes it bigger than my screen, it doesn't seem to agree with any other setting.

Sorry for the long post, fun game though hope i can get back to playing it soon!

HELP!!!

my microsoft update is not updating it's giving me a red shield with an "x" inside of it

Okay, so I am running the 0.0.72 version and for some reason when I put the ginto full screen mode the screen went dark, colors got inverted and the game won't let me put it back into windowed mode. I'm running this with an Intel Core i7-6700 CPU, a 16 gb ram and a 64 bit OS

Hello I have a problem with the games when it launches it me but in small window, as the game starts it launches large and I can no longer modify the configuration so I am blocking, sorry for the fault I am French , I can post a screen

Dasius both in the previous version and in the current version (Alpha 0.0.73) i have been unable to play the game due to the fact that my character just can not rotate and i know i have seen other people comment on this and still no solution? i have been trying to play for over a week now and cant play the game just because the rotation mechanic is broken. please help me fix this as soon as possible. thanks in advance.

You should make a clean install. Delete all of your files and install it again. Maybe it works

Developer (Edited 1 time)

Also, check in your task manager if there are any programs that might be conflicting with the game. Make sure all non essential programs are not running while playing the game.

(+1)

dasius not sure if you got the notification from me posting the solution but maybe you should include this on the download and launch steps :).

Developer

Hey,

Ya just seeying it now. Ill post it for others to find the solution.

Thank you!!

(+2)

okay so i finally figured out my own problem. if you are experiencing issues with rotating your character its likely because you arent using the itch.io to launch the game. download and launch the game in itch.io and that should fix the rotation issues. hope this helped someone else besides me :)

(Edited 3 times) (+1)

Version: Alpha 0.0.73

#1 When i first started the game everything was blurry, but the fix is just to reset graphics settings.

#2 There comes no customers. I tried to go into /appdata/local and deleted the whole ShopSim folder but it didn't fix it, (bug #1 was still present after i deleted the folder, but the fix worked again). I tried to go to bed and proceed to the next day to see if that fixed it but i couldn't go to bed, (I didn't wait for night tho). I waited around for 10 minutes but there were still no customers. I even tried "turning it off and back on again".. ;)

And now I'm going to bed, the clock is 01.50 AM here in Sweden. Have a good one!

Edit 1: Spelling
Edit 2: Added some stuff
Edit 3: Worth noticing is that I don't install through itch.io program, I just download and extract the zip file in a new folder.

(+1)

about the no-customers: does your shop door say "shop open" ? if not, click that sign!

Yes it does, i played the game plenty before. Thanks anyway!

I just noticed this seems to happen if you

* load a game

* sleep


:/

how do I fix that? I too have no business in my shop

download the latest version of the game, it has been fixed yesterday :)

(+1)

Just updated to 73. Started a new game, and i've had zero customers. The game looks and runs better, but now i have no customers. I think the changes are really cool, I especially like the fan as opposed to the button. Very nice touch. Any ideas as to why i'm not getting any business?

does your shop door say "shop open" ? if not, click that sign!

it does! I never had this problem before the update!

Yeah there is a hotfix, #731, fixing this bug! It happens on save game load and when sleeping.


Works like a charm now :)

hotfix?

Yeah that means a quick update in order to fix a critical bug :)

ah okay, will i have to download another update file? Or will it automatically do it in my game?

If you use the itch.io app it will automatically update, I think - if not, you need to check the downloads every once in a while and re-download the game :)

Deleted post

me too :(

i can´t hit the ingots on the anvil no matter what, i have tried re-instaliing

Developer

Hey Shield,

Is this in sandbox or in shop mode?

sandbox

In sandbox mode I cant hit metal on the anvil... i can still break ore and interact with the left mouse button but i can not make metal heads for anything in sandbox. shop works fine though... its weird.

Developer

Hey Lightdeck,

Some aspects in sandbox are not finished.

I would at least expect the main aspect of the game would at least work.

(+1)

Yup, as the people before me already said, I get no customers, and yes, shop is opened

I started a new game because I want to experience the game again with the update, but with no customers, it just doesn't work very well, my own quick fix was to click start game again, this time I have customers... till the 2nd day, nobody came again

Developer

Hey Aldenalden4,

Ill roll out a patch today to fix that issue.

(Edited 2 times)

i had no customers, till i restarted the game and now there back! I do have a problem before the update i had 3 mitheral bars and now there gone. Anyidea if there under a tree?

well that sucks, i missed a customer wile making a great sword and they left. it got stuck. i got it fished out but no more customer came to the shop for the rest of the day.

I do like the changes, the send customer away button will come in handy. Customers just grabing stuff off my table if i have some thing pre made they need is also really good.

(+1)

then you will love the hotfix released an hour ago, it aims to fix the customers avoiding our shops :O

Bug Report
Version 0.0.73
-Can not hammer on Anvil in Sandboxmode

0.0.73, no one ever comes into my shop ever ever.

Hello I am currently running version 0.072 (while im typing this updating to version 0.073)

The issue I ran into is quite annoying considering that I worked pretty hard to get expensive ingots..

When a sword well in my case a greatswords get stuck in the crafting table after it is completed, the only way to get it out of there is to swipe a two handed grip over it and grab it with that handle. (Also whenever you do this the previous handle is unusable). When you give that weapon you saved at that moment (in this instance an iron greatsword) to a customer, game considers it as a copper greatswords and the customer pays out around 40 bucks.

Steps to recreate the problem:

1- Get an expensive sword stuck in bench

2-Get it out with the stated way

3- Sell it for 1470$ less

4-???

5-Shop closed and went bankrupt.

Running a PC with 8gigs of RAM, Nvidia 520MX graphics card, Intel i7 - 2670QM Quad Core CPU 2.2 Ghz

(+1)

my game won't open up. i'm in version 20 and i'm using windows 10. please help

same

starting on march 24, whenever i run my game, the graphics are extremely bad. i deleted the save file i have ben working on the past long while, but nothing changed and now all my hard work is gone. Is there any way to solve this?

If the screen appears blurry, it's probably the resolution scale. In the menu, click Graphics, and look for the Resolution Scale slider. Otherwise, try pressing the Reset button under Graphics, then adjust the resolution scale up.

apart from that, if you played the version that never saved weapons anyway, you will not be able to play properly with this save game, the logic has been changed to account for 1) the heat state of weapons and weapon parts and 2) weapons staying together on loading - so there have been some big changes that would not have worked as import from old save files - soooryyyyyyyy


But the new version features a ton of bug fixes, please grab the latest version, 713, just released :)

Thanks! This really helped, but I wish I could get my save game back/ have multiple save files

i posted this before the hotfix for 0.0.731. still same graphical issue. trying to run as full screen but i keep clicking trough the window. windowed mode i cannot adjust anything. if i hit reset my screen goes black and game gets put in top left corner and cannot be fixed other than deleting the settings file.

ok let's try a different approach:

  1. delete the settings file
  2. enter graphics settings
  3. check the slider "resolution scale" - is it to the far right and says 100% ? if not, drag it to the left and then the right again
  4. double check that the "Resolution" makes sense for your screen
  5. select window mode
  6. select fullscreen mode
  7. click "accept"

fingers crossed!

(+1)

let me know how that goes

(Edited 1 time)

hang on YOU have to try that, I do not have your initial issue :/


edit: I just noticed that for me the game defaults to a strange resolution that is not actually the case, so when I do reset or apply without changing that, it jumps to get BIGGER than before, so then I could not fix it IF I had a smaller screen ^^


Sooo double checking the resolution and force setting fullscreen -> window -> fullscreen might refresh the GUI to fix it for you

(Edited 2 times) (+1)

Im playing on a 50" 4k tv and my computer can handle it no problem. so size of screen is not the issue. its when in fullscreen it will click through the window on whatever is behind it out of the game. after switching to full screen and waiting for it to revert it goes back to windowed mode taking up the full screen. its playable but when i mouse down my task bar will pop up and mouse wont stay in the window. im testing on my old laptop right now to see if the issue is with the update and not just higher end monitors or machines.

Edit; works fine with my laptop. maybe its in issue with large scale or anything connected with hdmi

Edit2; [FIXED] turned down to 1080 and it stopped clicking throught the window. now im having horrible screen tearing. 60hz refresh rate on tv is my fault though. need to get a new monitor for desk.

(+1)

yeah my maximum is 1080 so I could not even test larger screen resolutions xD HDMI should not be an issue because I am using HDMI and 1080p :)

soooo might be this game is not 4k ready xD

I would so much love it if you can make this game for apple computers. I am on one of those and i can't get windows. I don't know if thats harder to do or your already doing that. But I've seen gameplay and I would like to download this game but sadly I can't. Keep up the good work though!

wrong area but it would be nice if you could do this. WHOOPS! LOL

(+1)

again i made another mistake. Well not mistake actually. Its OS X computers. Which has the apple so yeah. Keep it up!

I dont know if this has been said, but there is a bug where when you have an item on the counter while handing the customer their weapon, they take the one on the counter instead... but the game still thinks you sold the item they actually wanted. the item they were supposed to take is left behind too.

(Edited 1 time)

are you sure about that? I think for me the game actually paid me the weapon that the customer took. I got paid a great sword (which they took) even though I held a pole arm into their face

Edit: And yes, it has been reported somewhere xD sooooo should be fixed in the next patch maybeee?

Developer

Hey Lightdeck,

I am aware of the issue. I'll be working on a fix for that.

Thank you!!!

(Edited 1 time)

Bug Report
Version:0.0.731
-Double Axe Head disapers after hammer at it again
-Can not asemble Roundshield

(+1)

Yeah the sandbox is a bit buggy, but like dozens of bugs in the shop mode have been fixed :D

the blades glitch through the table, the new handles glitch through everything and when you hand them the item they take it and it flies over the counter, sends u flying back and glitches through the ground like every other item, and when u press z on the anvil its highlighting both blades and hammers but says u have blades selected no matter what!

There is a bug where every time I make a weapon and close the game, when I get back on the weapon is disassembled and the head is red hot.

Version 0.0.7

Make a weapon, leave is on the front counter, log out, log back in.

System Specs:

Windows 10 Home

AMD A4-6210 APU with AMD Radeon R3 Graphics

3.45 GB usable RAM

64 bit

(+1)

Be sure to download the latest version: 0.0.731, it has the fix for heated weapons on reload. You will probably have to start a new game, though. There are compatibility problems with previous version game saves. Happy Smithing!

(Edited 1 time)

Bugreport 0.0.7.3

steps to recreate:

- See update notification

- get excited

- download 0.0.7.3

- start new game


- make weapon X

- put it on the counter

- wait for costumer

- craft weapon Y that he wants

- hand it over (without letting go of the mousebutton?)


result:

the Costumer takes weapon X that was laying on the counter and pays for weapon Y that he ordered.

That happened twice within the first 15 minutes of gameplay.


Another Update that makes me not play the game.

I really hope there will be an update soon that doesnt steal your money and makes the gameplay enjoyable and not frustrating.

i'm not able to switch between heads on my updated game. Only allows me to do swords.

Not to mention that all of my supplies that I had ordered and ready to go on the shelf has now vanished along with my money.

And the controls are way more sluggish now.

raise the mouse sensitivity in the options menu :)

anyone know how to attract business to my shop? no customers and i know there is a glitch wherer they dont even come to your shop, please help

Have You opened the Shop?

haven't played game since no costumers but i'm about to try now , all goes well then ill have no problems. It was after i opned shop and everything, they jsut kept walking every other way.

I clicked the shopsim.exe and it said that it couldn't start the game

Have you maybe downloaded the wrong version? 32 /64

I don't know if this is just me. When I open the game, it shows the engine logo, opens the title screen and starts playing the music. I hop in, my FPS drops to 30 and it turns to like 140p and whenever i try to click some windows sounds play and the game crashes and i try to close the folders window and it stops responding and my screen goes black. All of my desktop applications get moved around. My computer is good and able to run the game fine. I don't know what the hell happened. The first time I installed the game, it worked ok. I tried to edit the sign in front of the shop and the game crashed. Now every time I re-install the game, the thing I just talked about happens. Any possible solutions help.

delete the old files

When I open a save game I loose all my coins

(+1)

Game version 0.0.731

Iron greatswords sell for $8.00

(Edited 1 time) (+1)

Hello, first of all, thank you for the really enjoyable game. I saw Mr. Fruit playing this game, thought it was fun, gave it a try, and now I love it.

That being said, on 0.0731, I've found an interesting bug. If you were to accidentally create a dagger, and have it resting near the customers (I did that as a reminder that I have a spare dagger, so not to make another one) but anyway, if you have an item resting near the customer, and they ask for something else, eg: a greatsword. There are cases where when you try to hand them the greatsword, they grab the dagger instead. They pay for the dagger as if they were purchasing a dagger, but then you're left with a greatsword instead of a dagger.

also, sometimes customers don't pay for the material. Last night I made a tin greatsword, and was only paid $20 for it, as they didn't recognize the tin large blade.

Thank you for the game, though it tends to give me headaches when playing for hours at a time.

Cheers!

*edit: Changed 0.073 to 0.0731

I also had that happen if you load up the counter with other items, they will take one of them. Not game breaking just interesting. I have a video on it my little blacksmith shop ep 39

Im playing the 0.0.731 version and if a customer were to want a polearm and i have a weapon on the counter for example a tin dagger they can take the tin dagger on the counter if i pull the polearm away before their animation finishes.

Thanks BMonkey229,

it's allready in the bug list. We are working on it. The next patch should fix this issiue.

(Edited 1 time)

My game don't start, the game opens and is left alone on the screen with a song and nothing appears.

when i open the game the resolution is fine but when it goes to the blacksmith inside it goes blurry, my pointer appears and when i click it thinks i click out of the game Help Please.

hi my version is 0.0.73 alpha and my bug is I don't have customers

(Edited 1 time)

Hello! I have 0.0.73 alpha. Got a reoccurring issue in shop mode where the cost of the ingots used in making a weapon is not factored into the price that the AI pays for them, i.e. this screenshot where I got 5 dollars for a one hand sword. Its happened multiple times in both 0.0.72 and 0.0.73 and a couple times has reversed a fair amount of game time.

http://imgur.com/enxqGJx

(+2)

Hey bobble, I've had a similar issue. One thing I suggest you do, is save every time you can afford a new ingot. (for example, if you are buying 9 iron at a time, and you can finally move up to adelite, save on every adelite ingot you can afford. That way, the worst case scenario, is you restart and lose maybe half a day in game time.

(+1)

when I try to put a weapon I already made on the counter and a person comes and ask for a different weapon I make it and give it to him and most of the time the weapon that I put on the counter he takes instead of the one he wants? is that relly a bug?

Developer

Hey jefferymccarty,

It is a bug. I am looking into fixing it.

Thank you!!

(+1)

Hello! I absolutely love this game, and I see so much potential.. I only began playing last night, but I found this game through SplatterCatGaming's YouTube channel. i continued to watch HoneyBunnyGames' series. I've always wanted to get into game development, mainly concept design. I am very passionate about Black Smithing also. I saw My Little Blacksmith Shop, and thought," This could be my chance to get started!"

I've played until day five, and I have placed pre-made weapons on the shelves and counter. The customers order a weapon that I'm out of stock with, so I go to make it. When I hand it to them, they disregard me and grab one of my pre made weapons. They pay the full price of what they grabbed, but the orders say they bought what they ordered. When I check the details, it counts the weapon they grabbed.

I have also noticed that when I have post processing on, it tends to have some kind of double exposure effect when I pick up and move an item.

Thank you for making such an amazing game! I can only see this game getting better.

Developer (Edited 1 time) (+1)

Hey Kijackthesmith,

Glad you are enjoying the game.

Thanx for posting your bug report. These are known issues and a fix is being worked on.


Also, continue following and doing what you love. It'll be hard but the reward is worth it.

Once again, opened shop even AFTER started a new game , no one comes to my shop . My game is up to date there should be nothing wrong, i am doing what you all say to do. Please help.

Also cannot use my mallot on anything.

Save and then reopen the game, that happened to me and doing that fixed it

everytime I saved it only restarted the game for me where I had day 1 start all over

did you try getting the itch.io app? ive found it runs better off of it

(Edited 1 time)

I haven't seen any other posts about this so maybe no one else has noticed or maybe I'm just lucky.

Sometimes seemingly at random when I sell a sword to a customer I dont get paid for the blade itself just the grip and guard. I haven't noticed this with any hammer or the dagger just the swords.

I am running the .731 version

I7 processor

Window 7 - 64 bit

8gb of ram

and and Nvidia Quadro 300M

Developer(+1)

Hey Kragor,

Thanx for letting me know. The issue should have been fixed but i'll look into why it's still happening.

(+1)

Hey Mr.Dasius The Download Link doesn't seems to work for Me! Can you post a New Download Link Pls! On Game Jolt Maybe! Thnks in Advance!

Developer

Hey Akun16,

I would recommend getting the Itch.io desktop app.

I would like to centralize my game in one location for the time being. In the future, when the game is more polished, I might put it on Game jolt along with steam and others.

Still cannot sell weapons BECAUSE No one comes into my shop. I have opened the shop and even restarted my game multiple times. what else is there to do besides uninstall?


Developer

Hey Jakethesnake1710,

Did you by chance download the lastest build?

0.0.731

Currently having the problem where sometimes if one heated copper ingot is on the anvil, I am unable to successfully hit the ingot. I can swing at it, but no noise is made and nothing happens. I have tried moving the ingot to a different spot to no avail. Switching to Sandbox and back to Shop is the only way I have found to fix the issue, temporarily, without completely restarting the game. Unfortunately, this happens very frequently, usually within the first 5 minutes of restarting.

(+1)

I have figured out the problem. I didn't realize that changing head type is done via the anvil itself and not the ingots. When it's set to blunt heads is when I get this issue because, obviously, 1 ingot cannot produce a blunt head.

Hey just wanted you to know that on the most recent update when you try to use the cycle wheel to create different heads it doesn't allow you to select anything and currently doesn't allow you to create hammer heads making it difficult to keep up with the AI's greedy demands.

also i thought it was a wifi or computer problem but at my friends house (who has a lot better wifi) the game runs smoothly on my laptop and i still cant make hammers

Did you place >two< ingots on the anvil and hit Z to select "BLUNT" ? :)

i tried all that but when i hit z nothing happens and if i hold z it wont allow me to select anything

I uninstalled it and reinstalled it ill see if that fixes it

same problem happened

1) place ingots on anvil

2) hold Z

3) select type

4) click or let go of Z


It has to be in this order. YOu cannot select anything without ingots on the anvil, you need to HOLD z to be able to select

My game just doesn't work. It's dark and really blurry. When in menu I can't go past down controls with my mouse. Every time I click the game puts me back in my home screen.

https://itch.io/t/61217/how-to-common-issues-pleas...

Try removing your settings:

Save Game Files can be found:

C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames


I can't click on the graphic setting

(Edited 3 times) (+2)

Hi there! I discovered your game through Mr Fruit's Gaming Channel, and I think I've developed a small addiction at this point. :P

One of the more annoying bugs I've discovered is that, sometimes, a sale is made that doesn't factor in the metal used - it'll simply say the weapon type with no metal mentioned and then a measly price. I've noticed it happening more since getting to iron (though that may just be because it's more noticeable), and it seems to be happening more often with swords and greatswords - I think it has happened with every single iron greatsword I've made (though that may simply be a coincidence). I am playing version Alpha 0.0.731.

Anyway, love the game! It's a great little pearl, and I can see it becoming quite amazing! :D

UPDATE: All right, so I've discovered that the bug already occurs at construction - it will sometimes merely say, for instance, that a greatsword has been constructed rather than an adelite greatsword. In that case I have found that I can simply take it apart and try again until it works (though it may require a few attempts). At one point I even experienced that a tin greatsword I was making turned into an iron greatsword upon construction (the blade was still identifiable as tin, but it sold for the price of an iron greatsword - perhaps incidentally the previous iron greatsword I had made only sold as a greatsword, which was the reason I was forced to make a tin one). Looking back, I can see that it was happening all the way back with copper, but the price difference was so much smaller I didn't notice. The greatsword was always the main culprit, though.

UPDATE: Regarding swords and greatswords, combining the grip and handle before attaching the blade seems to avoid the issue. I have had no cases of "metal-less" weapons being constructed today. (Though I had one greatsword that freaked out when I put it together, causing a slight mess in my workshop and ending up with a crooked handle. The customer who got it was still satisfied, though.)

The version which I am running is the most recent, 0.0.731. The issue I am having is how I can only function a quarter of the screen. For example, I can push resume, save game, new game, controls, but any other button on the pause screen I can not press. I am not sure how to reproduce this issue either, thank you.

Not sure if this would count as a "bug" but rather more of an exploit I found by accident, but can successfully replicate almost without fail. You can give someone a different item than what they are asking for if you simply hold it out of reach after showing it to them.

For example. A customer walks in and asks for a One Handed Hammer. If I have any other item on or near the front of store (2 shelves to the left, the one shelf to the right, or on the counter), if I hold the hammer out to him, but pull it back and out of their reach before they can take it, they will default to the next closest item. So although they are asking for the hammer they will take a great sword and pay for that item. Sorry if this isn't very clear it's late for me :). Great game and keep up the awesome work!

When my dad was playing about a week ago, he managed to hit the money cap. So, not really a glitch, but there's a number overflow when you hit 2 trillion dollars. He was playing on version 0.0.731.

When he sold the weapon that brought him over 2 trillion, his money went negative, so he had negative 2 trillion.


Maybe add a limit, or find some way to keep it from overflowing?

(+1)

Wow! That's real dedication there, and yes, Dasius is aware of this issue. Currently your money is stored as a signed integer, so the maximum value is 2,147,483,647. The overflow into negative was found by one of the testers. The proposed solution is to change to an unsigned integer to increase the max to 4,294,967,295 and add a cap (probably at 4 trillion) to prevent this issue. The only downside is that once you hit that cap, your sales won't mean anything other than recouping the cost of materials you just bought. Anyways, rest easy, the fix is in the works. In the meantime, Happy Smithing!

(+1)

0.0.73 here. Some times when selling great swords it won't count the blade in the price. Just sold two iron great swords for $21 each. Taking a $60k hit when I am just starting to get into the next tier kinda sucks. Guess Ardite will have to wait another day or two.

The rest of the game looks awesome and payed a bit in sandbox. Loving this game. It's fun and relaxing and can't wait to see where else you take this.

@shanadowa https://itch.io/post/141187

Thank you.

Current Version 0.0.731

Running this version, My Depth of view is really messed up, I can't see anything it's all really blurry.

(+1)

This is due to the Resolution Scale setting under Graphics being turned down (which can happen on reload). Drag the slider to the right to correct the blurry vision. Happy Smithing!

ok so i am experiencing a bug where when in the menu my cursor, isn't actually my cursor. my in gmae cursor is up and to the left of where my mouse cursor shows it's supposed to be.

Usually this is the result of the game thinking it's in a different resolution than it actually is. Try changing the resolution to something different and see if that fixes the problem.

that was the first thing i thought of. problem is, it is so off center, that i can't even change the resolution. and no amount of uninstalling helps.

if you havnt done so, instal the game with the itch.io app.. i found the normal downloadof the game had more issues than the app.

(+1)

Also, you can try deleting your settings file to reset everything to default. It can be found on your PC here: C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames

If you're having trouble finding it, reading this post (and its replies) should help: https://itch.io/post/128793/view-in-topic

(Edited 1 time)

ok that seems to have fixed the problem. thanks for your help

(+1)

Worked out how to equip tools, it's pretty buggy though.

When you first equip an axe, the axe is teleported to what I assume is the origin of the space, and floats there as if carried by a player.
When you first equip a hammer, it follows you properly, until you use it on an anvil which will freeze it in in it's place at the end of your swing.

When a tool is dropped after using it the first time, the parts physically separate, but moving the handle will make the head float in the same direction. The head still highlights, but can not be interacted with. The tool can be equipped again.

If you then equip the axe for the second time, if follows the player around properly.
If you equip a hammer for a second time, it acts just as before.

When a tool is dropped for the second time, the parts separate again (if they were fixed), and the handle no longer highlights. You can no longer use the handle for anything, or equip the tool.

Aside from equipping tools, I'm not sure how you're supposed to turn wood into boards, hitting them only seems to make firewood.

(+1)

Also, you can't equip a tool of the same type you currently have equipped. You can't equip a hammer while wielding a hammer, or an axe while wielding an axe. The default tool counts as a hammer, so you have to pick up an axe first.

My game start up in a SUPER HIGH resolution and i cant presse certain button so i cant change the resolution because the accept button in the graphics menu is too low is there a way to fix this ls or put the accept button on top next version plsssss

Ah I been Playing My little Blacksmith shop But One time someone Order an Polearm So Im gonna make a short sword But when I try to hit a one ingot nothing happen even a many times i try to hit it And My Been Playing This for Day 10 (In the Game) So help So i can progess more

(+1)

Sounds like youve selected Blunt weapon head. Which is 2 or 3 ingots. No, 1 ingot option for blunts...

im on v0.0.731 and whenever i have a weapon near the area where the npcs order their weapon, instead of waiting for their weapon they just take the closest one and pay me for that. This bugs me because if someone wants that weapon that he just took i have to get all the supplies and make it again. (Windows 8.1, GeForce GT 730, AMD A6-6400K APU, 3.9 GHz, 4.0 GB RAM, NVIDIA High Definition Audio, 187.8 GB free space) [Dunno if you need the last one]. Steps to reapeat.... Make any weapon, put it on the front counter, wait for someone to roll up, they just take it and pay you for that weapon not what they asked for. Thanks :)

Developer (Edited 1 time)

Hey Vulcan,

Thanx for posting the issue and I am aware and working on a fix. For the time being, until the next updat, keep any weapons off the counter other then the one the customer is asking for. Let me know if there are any other issues.

Cheers!

So, this is the closest thing I could find to an "Issues" thread, but that's besides the point.

I'm in version 0.0.731, and all the ingots are so... expensive. I don't know if it's because I shouldn't be in this version, or if it's just you're choice in price, but I don't know what I'm supposed to do. I just want to know if that's how it's supposed to be or if I have to do something to change that.

For now, yes.. Just keep at it, with the ingots you can afford until you can buy the next ingot.

So it's actually worth it to buy a $500 Iron ingot, make a dagger, throw a fancy grip on it, and sell it? and you still actually make profit?

Tin*. I meant Tin ingot.

yeh, you make profit on whatever you sell... just be wary of a bug, where sometimes you dont get paid for the ingot used in the weapon. Always check your sales board after a sale and save often, so you can reload the game if it does that.

I have a bug in the game. basically when I am cooling short blades like the dagger and sometimes one handed sword blade. what happends is the blade drops into the cooling tub and goes underneath off it. Then it is almost impossible to get it back out. I have lost like $510 to this glitch.

Developer

Hey Hazzard Laser,

Thanx for the bug report. I'll look into fixing it for the next update.

Hello! I Might Be The Only One Still Having This Problem. Wich is When i launch the game through the Itch.io Desktop app it says

"Fatal Error" Upon Launch. And When i Download It From a Browser It Still Does This Error. Im Running Version

0.0.731

Here are My Spec's

Processor: AMD E1-6015 APU with Radeon(TM) R2 Graphics 1.40 GHz

RAM: 4.00 GB (2.99 GB Usable)

OS: 32-bit Operating System

Developer

Hey Zap,

I would suggest sending a message to Itch about any issues with there app/website.

One suggestion I would give is open the game folder which can be done through the itch app and try running the game from there.

I can load the game up but once i enter the game, i can't play it. Yesterday i put it in full screen and ever since then whenever it gets past the loading screens it will put the game in full screen then minimize it. I can maximize it but once i do it will minimize again

I am having a problem. It's listed above this comment

Developer

Hey Mostwanted884,

Does this happen only with this game or does it happen with other games/software as well?

Just with this one. I managed to press Alt + Enter while it was trying to minimize and got it out of full screen.

I have started playing the game recently and have encountered 2 major problems so far.

The first is that if my mouse goes below, about halfway i think it is, on my monitor then i get my desktop mouse instad and it will either tab me out of the game or just not able to click on anything.


The second is that the options menu is vey slow and when i go to change options it sort of freezes for a minute or so but i can still move my mouse, this is not a major issue but more of a slight annoyance.


If needed i can provide a demonstartion of etiher of these.

Many times when I'm building weapons on the crafting table, they glitch and get stuck in the walls.

(Edited 1 time)

There is 2 ways to fix this that I know of:

Vigorously shake your mouse while holding the object,

Rotate the object out of the wall. (Neither of these work 100% tho)

hey Guys. Im Running the newest version of the Game.

I had a bug where i sold an IRON great sword and just got 21$ ...

I was Not able to reproduce the situation but it really triggered me, because i saved up for this iron peaces.

(Edited 1 time)

As of this comment, I'm on the latest version.

Whenever I change a keybinding, it doesn't stay for me. What I'm doing is changing the item wheel to another key since my Z key is broken, and whatever (working) key I choose doesn't bring up the little wheel. I have tried making it upper and lower case, neither works.

Another bug I've noticed is that I commonly drag my mouse out of the game screen, although the game is still in progress and not in the escape menu. I don't have mouse keys or anything enabled, so I don't know of a way to fix (except full, but I'm on a bad laptop so I'm trying to keep my frames as high as possible with a smaller windowed screen)

Developer

Hey Arcorior,

At the current build, there is no support for keyboard bindings. 

The lastest version should force your mouse in the game window. If not, i'll take another look at why it's not.

Thank you!

(Edited 1 time)

Heyo! I don't understand if something is actually wrong or I am just mistaking it, because I don't see anyone else with the problem. After using my daily reset token, I wait an in-game day to see if I can use it again, and I am unable to. I figured it meant real days so after a real time day, I get on and I still don't have the daily reset token. I don't understand if I have to spend a full days worth playing the game to get it or if something is wrong.

0.0.731

Processor: AMD A10-7850K Radeon R7, 12 Compute Cores 4C+8G, 3700 Mhz, 2 Cores, 4 Logical Processors

RAM: 8.00 GB

OS: 64-bit

Developer

Hey Padatsky,

I'll look into why its not resetting, but it should reset every "ingame day".

The radial menu doesn't work. I can switch to hammer head after I select blades. Restarted the game just in case it was a glitch, nope, it's defo a bug.

(+1)

The radial menu detects how many ingots are on the anvil to determine which options are available. For instance, hammers do not have a one ingot hammer head, and as such will not be selectable with only one ingot on the anvil.

I DONT know what it is but my game starts i full screen but its still in windowed and i cant change the graphics nor the res nor can i resset or accept

i,m runing the latest version as of right now and when you see this its still propably will be the newest becase i have the same prob scince 32bit so yea pls help ,thx dasius

Developer

Hey Max the soul stealer,

I would suggest deleting your "C:\Users\YourUserName\AppData\Local\ShopSim\Saved\Settings" file.

Hi I have had a problem starting the game because of an error message about an audio application. The error said" The program could not start because x3daudio1_7.dll is missing from this computer." What do I do?

Developer

Hey DJSwagger_Youtube,

Any missing dll is not a result of the game but with windows. Try this link and see if this help https://www.microsoft.com/en-u... .  If not, I would suggest contacting  Microsoft support. 

Hey, Dasius, if at all possible, could you make this game run on something that doesn't need Microsoft Visual C++ Runtime? Because whenever I try to run the game, some error with it happens, so I can't even open the game ;(. Please, if at all possible, because I do really want to try playing the game!

(+1)

Current Version 0.0.731

  1. If you have anything on the shelves next to the counter (left-hand side when you are facing outside the door),  If you sell something to someone they will take an item off that shelf instead of taken that Item you made.
  2. If you have something premade on the shelves and you try to take it off the shelf and hand it to the customer they don't register it's there, you have to break it apart and reassemble it.
  3. Swords mainly getting stuck in bench or wall when attaching to guards.  Usually when you have the blade in hand and guard on the bench.
  4. When picking up a piece off the ground after opening package another piece would tend to go flying off in a random direction.
  5. Jumping and getting stuck on something like the forge, water bucket, or rocks.
(+1)

Oh almost forgot rotation doesn't work correctly in game.  I tried to rotate grips to fit onto my bench but I couldn't get it to rotate.

(+1)
  1. Known bug. Customers seem to take the closest weapon, once they notice the weapon they want is in their range.
  2. Customers don't notice weapons that are already inside their range when they enter the store, you need to take any weapon out of the range and put it back in for them to notice it.
  3. Generally when you craft a weapon, the guard/grip stays still and the blade teleports into place. If the guard is pointing into the table, attaching a blade to it will cause the weapon to be stuck. To fix this, hold alt while looking at the weapon to rotate it (ignoring physics), until it is out of the table.
  4. This is because the grab system pulls the item to a fixed position in front of you, usually closer to you than the item originally was. When the item snaps to this position, it pushes anything on top of it at highs speeds. Be careful picking up an item at the bottom of stack, and you should be fine.

Hopefully you can use these workarounds in the meantime.

Developer(+1)

Thanx Platoonsgt1 !

(+1)

Sorry I am talking about if I have a polearm on the LH shelf next to the counter and the customer wants a one-handed hammer.  I would hand them the one-handed hammer but they would take the polearm off the shelf leaving the one-handed hammer on the counter.

(Edited 1 time)

I'm also experiencing this and it's driving me insane. Oh, you wanted a greatsword? Here's an Adamantine greatsword I just made yo- aand you've decided to take a Mithril spear off the shelf, and pay me for a Mithril greatsword. I just wasted money.

Edit:

SOMEONE JUST CAME IN ASKING FOR A POLEARM

I HAD A MITHRIL POLEARM SITTING ON THE DESK

SHE TOOK A TITANIUM SWORD OFF THE SHELF AND PAID ME $17

Footage

Just to clarify what's happening. You're showing the customer the weapons they want (1H-Hammer). They then look at the closest weapon to them (Polearm), and take that instead.

To avoid this, make sure there are no other weapons closer to them than the one you're handing them. Even better, as customer won't yet pick weapons off of selves when they arrive (Bug 2), you can keep your weapons further back in the store until needed.

I found a kind of cheat way of making money by putting out a ton of daggers out on the counter then I just wave the item they want in front of them pull it back they take the dagger I get money equivalent to the item they wanted.  Of course having the dagger in the most expensive materal and handle jacks up the price.

So I am up to the Adamantite metal and I just made an 'Adamantite One Hand Sword' for some guy and he payed me $16 for it XD. I checked the purchase list and it claims to just be a 'One Hand Sword' rather than an 'Adamantite One Hand Sword' however I definitely made it completely out of AdamantiteThis is the image ... I am running Alpha 0.073 and my specs are [Intel i7-3770 @ 3.4GHz, 16GB of ram, 64bit Windows OS, Nvidia GeForce GT-630]

This is related to an ongoing bug, where a blade already part of a weapon reattaches to another grip/guard. The resulting sword has no value associated with the blade, whereas the remaining grip which had its blade removed retains the value of the blade. (Non-sword weapons also have this bug)

If you're clever, this bug is quite exploitable. Performing the bug again (attaching the valueless blade to a new grip) will give the blade's value to the previously connected grip.

1-Version 0.0731

2-J'ai fait une séries d'armes en avance pour les héros.

Lorsque j'apportait une nouvelle arme demandé et non préparer pour un héros, le héro présent a prit une autre arme pour partir. Je ne connais pas sur le coup ce qui a fait cette différence.

3-Sorry.

4-Make a lot of weapon.

5-I send it later.

Developer

Hey Chugo,

It's been too long since i've written anything french so I will try to answer respond the best I can.

Francais: Pour cette version, tu dois seulement avoir une arme sur le contoir ou les client vont prendre le premier arme qu'il voit. Je travail sure une solution.

English: You can't have more than one weapon on the counter or the customers will take whatever they see first. I'm working on a solution.

No need to write in french, i can read haha.


And thx for the information.

Developer

Oh ok :). 

No problem.

Tbh, I just wanted to practice my french a little..

We can chat anytime if you want, no problem with that, i will do my best to use a correct french. (A défaut de l'anglais >.>)

Developer

No worries!

I was making a one hand sword from tin and when I sold it I only got 17 gold. The log said "One Hand Sword" with no "Tin" in front even though it was. I just lost all my hard earned money from this. (running latest version .731 alpha with a Geforce GTX 1050 Ti Graphics Card)

Developer

Hey W1LL14M,

It is a known bug. Sorry for that. 

Still trying to find a solution for the bug.

Appreciate the work then. ;)

(Edited 5 times) (+1)

Hey!

(I just discover i wright in french. fail in copy past with google trad XD)

A bug about shield:

1-Version 0.0731 - sand box

2- When you make the shield, the parts of the shield dont become on entity. That can do a hit box bug if you keep a part on your hand (right click). Also, shields will be fly until you brock them on the anvil. (It's funny to see :D) The hand grip cannot be take, but it is not on the shield.

2bis- The shield doesn't assembly like shild: You can't just touch each other. You need the right position, in the right angle, in the right side.

Edit: The Enarme doesn't permit to move the shields. Same with the shield boss who fall of my tower shield (Marf!)


3- After made 3 shield (on incomplet, 2 complete but don't claim to be a complet shield, like sword or hammer), i can't do this bug anymore.

4- For the first time (?) Stay right clik input when you place a element on the shield.


Edit bis: 2ter- I have put a second head on the axe. Yes, my axe have 3 head: Normal head (single axe head) and the dual blade head. That work with the hand gard.

3ter- http://image.noelshack.com/fichiers/2017/23/6/1497126222-triple-hache-1.png

4ter- Put a head on the axe already finished.


5-Mother board: Rampage V Extreme ASUS

Intel i7 6heart 3300Mhz

Graphic board:NVIDIA GeForce GTX 1070

8Gbit ram.

Developer (Edited 1 time)

Thanx Chugo for the bug report. 

In version 0.0.8, we might not see shields implemented. The weapon system still needs perfecting and implementing shields will make things more complicated but i'll come back to reports like yours when I am ready to complete implementation of shields.

Issues with axes should be cleared for version 0.0.8.

(+1)

Ok! I don't touch Shield again :D Except if i want to see something fly! \o/

(Edited 1 time) (+1)

I will be productive this night (22:37)

1-Version 0.0731 - sand box

2- I do a sword on mythril, Just for the beauty of gesture... And... i dont know why, but i've obtein a pistosword (no kidding)

3-


4- Place the gard first, place the grip after. Look funny to use :D

5-Mother board: Rampage V Extreme ASUS

Intel i7 6heart 3300Mhz

Graphic board:NVIDIA GeForce GTX 1070

When you level up, after you select where to put your points, how do you leave that menu? I have tried escape, tab, and left clicking. Along with button mashing the entire keyboard because I was stuck in the menu...

P again. for sorting the stat menu.

Thanks! My bad, I forgot that P opened the menu in the first place.

Wont let me look up and down or let me use my mouse pls make a way to change that or fix it plz

Developer

Hey ValianOrbm

Unfortunately, you didn't give me enough information to know why the issue is present. Are you running any software that might alter your mouse? Are you sure the game window is active? What are you system specs?

Hey thanks for replying i am not sure it is my mouse.

I tested another game that was created with the same software UE4 and that also didn't let me use the Y or X axis of my mouse.The right,middle and left buttons of my mouse did work however.


Specs

Processor Intel(R) Core(TM) i7 CPU         960  @ 3.20GHz, 3193 Mhz, 4 Core(s), 8 Logical Processor(s)

Name NVIDIA Quadro 4000

Installed Physical Memory (RAM) 12.0 GB


Mouse

Logitech RX1000 mouse using HID_Compliant Mouse driver.

Thanks for replying and let me know if more info is needed

Developer

Hey ValiantOrb,

I'm not quite sure why you are having issues with UE4 specifically. I'm assuming it works fine with other games outside of UE4?

It could be a internal issue with UE4

Have your tried changing the game between Fullscreen and windowed mode?

Also, is it possible you have a 3rd party software that  may interfere with UE4, like an antivirus software?

OK thanks i will try testing all of those things  and i will get back to you as soon as i can

(+1)

Version 0.0731
So the gettin paid less than what it is glitch:
I can make the customer accept any item I want by placing the item on the bench and then quickly bringing the wanted item in its vincinity and then back out. It seems like he'll grab any item closest to him once the right weapon has been detected. 
Also this seems to glitch out and mess up when you decide to hold the right weapon in their face but he/she grabs a different weapon resulting in much monies lost in investment on an item.

Already know.

That my first sentence, in french, sorry.

(+1)

Also side note, glitch can be exploited rn for anyone who lost all their money investing their newest ore by making every customer buy a great hammer/sword with my first point above. Just dont have any item within reach for the customer to avoid this bug.

(Edited 3 times)

In current version .0731 under "purchase details" it is counting a copper greatsword blade (3 ingots) as a copper short blade (1 ingot) in name and price, should be $30 but prices at $10. The names of the polearms are switched as well, prices are fine with them.

1. 0.0.731

  1. 0.0.731
  2. npc's take other weapons besides asked weapon
  3. N/A
  4. make any weapon and leave it on the counter, then when an npc come as asks for a different one, make that then put it on the table, the NPC will then take the old weapon, paying you for the new one (usually causing a loss in profit)
  5. not needed, this isnt a performance issue

I have a bug where the costumer request a certain item but takes another item. That would be very frustrating if i wouldn't make multiple items. For instance: costumer is requesting a one hand sword but takes a one hand hammer or a great hammer or dagger, not taking what he wants. Potentionally taking the wrong item. Can you take a look at it?

Newest version of the game. It wasnt like this before. Thank you

Hi I really like the game but I noticed some bugs, mainly with selling items.

1. If you (for example) stand on a greathammer and pick it up the hammer puls you in the air, it is enjoyable but most likely unintended, also items tend to fly off if you pick up something underneath them.

2. selling doesn`t work with pre made items, I premake items because it speeds up the process and gives you some extra money for the short time but it tends to be buggy. At first I put my items on rack next to the door this, however stopped customers from taking the item, you could swing the requested item in thier face forever before they took it, if they took it at all, now I leave my items in the back, next to the crafing bench and this happens no more.

3, incorrect sales. I don`t know if this only happens with pre-made items but sales are incorrect, if I check the sales log I see daggers that appearantly had gaurds, normal polearms grips that get sold for fancy polearm grips (note that the price remains $10 and this always happens, a naming bug) a dagger that has a large hammer head (also gets sold for $30) or Greatswords that get sold for $8 cause the blade isn`t recognised (also happens quite often). The polearm grip is a naming bug but all the other buggs are bugs in the sell process, daggers are sold for more cause of the (none existant) gaurds, sword have hammer heads and greatswords loose thier blades(note, only greatswords lose a part, the blade, further parst get switched, same value or more expensive or non sword items get a one hand gaurd V2 added)

I hope this is usefull, keep up the good work

(Edited 3 times)
Hello, I play the Alpha version 0.0.73.

I have fourteen days in the game and a customer asked me a great sword. I gave him a copper great sword, but the game considered a copper  great sword like a tin great sword and on the list of materials, the game considered that I had only used an ingot to do a short blade ... Inconsistency and double bug ... I can not describe the steps to follow except that I am the 14th day.


* Windows 7 Premium Family Edition
64 bits
Intel Core i5-4690K CPU 3.50 GHz
16 Go RAM
GeForce GTX 750 Ti

http://hpics.li/2eb2684

alt tabbing seems to crash the game every once in a while, but not often. 

Greatswords have a bit of a glitch where you dont get paid for the blade of the greatsword. Both myself and my two brothers have experienced this. It's not such a problem with copper but anything more expensive is a ridiculous loss. Sometimes it works but only like %20 of the time. Thanks for your great hard work. We are in love with this game :)

i am running the latest edition and wheni put a resolution on a higher state half of the screen is unusable even when im not in the menu i have a gtx 1050 ti with a i5 2320 and 8 gb ram

(Edited 1 time)

I can confirm the bug with greatswords. Game is freshly installed, third order I get is for a great sword, make it, get paid only for grip and guard. No other completed item was present at the time.

Just to clarify: All other weapons have been selling fine. I am now at day 4, and only greatswords are affected it seems, so I just stopped making them.

ic you have a problem where your screen is fullscreen and you can't minimze because you can't click aplly try finding what keys you need to press to minimize a screen o found them a while back but can't seem to remmember

Viewing posts 481 to 600 of 600 · Previous page · First page