🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

How to - Common Issues (Please Read First) Sticky Locked

A topic by Dasius created 254 days ago Views: 10,571 Replies: 68
This topic was locked by Dasius 235 days ago
Viewing posts 1 to 31
Developer (Edited 22 times)

Hey Blacksmiths,

I am seeying common issues popping up and figured i'd write this thread to , hopefully, help some of you out. If these don't fix the issue then please post a response in the bug section.

Thank you!!

Issue: LowLevelFatalError.

This issue is prevalent in a several games created on the Unreal Engine 4 and the issue seems to be dependant on hardware and load placed on the GPU. Do get more details, you can visit this link. https://unreal-engine-issues.herokuapp.com/issue/UE-42280

The team at Epic are aware of the issue and have a fix that might fix the issue for more people. If you have a very low spec GPU, the fix might do nothing for you. For the moment, all I can ask is for your patience until we release the next update.

Thank you!


Issue: Can't change tools.

1-4 changes selection in tool belt. If you are having issues change your keyboard Settings to English.

_____________________________________________________________________

Issue: Can't use Selection Wheel.

You need to have at least one Ingot on the anvil to use the seclection wheel. 

_____________________________________________________________________

Issue: Character Not Rotating

Solution was posted by User titanuprising

Be sure to install the game using Itch.io app and launch the game via the app.

_____________________________________________________________________________________

Issue: Game Crashing on start up on Win 32

If you have less then 4gb of RAM on a 32 bit OS , I would recommend getting more RAM. This should help with the crashes.

(Thanx eprosync)

____________________________________________________________________________________

Save Game Files can be found:

C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames

____________________________________________________________________________________

Issue : api-ms-win-crt-string-l1-1-0.dll

This solution might fix the issue:

http://stackoverflow.com/questions/33265663/api-ms-win-crt-runtime-l1-1-0-dll-is-missing-when-opening-microsoft-office-file

  1. Install Windows Updates:
    • Go to Start - Control Panel - Windows Update
    • Check for updates
    • Install all available updates.
    • After the updates are installed, restart your computer.
    • After the restart repeat the steps above again until no more updates are available.
  2. Download the Visual C++ Redistributable:
  3. Run the vcredist_x64.exe (64-bit) or vcredist_x86.exe (32-bit) and select Uninstall
  4. Run the .exe again and select Install\


Also Try:

https://support.microsoft.com/en-us/help/2999226/u...

________________________________________________________________________________

Issue : Failed Forbidden

Download using the Itch.io app. This could fix the issue.

https://itch.io/app

__________________________________________________________________________________

Issue: Microsoft Visual C++ 2015 Runtime Error

Uninstall non essential versions of MVC++.

Restart computer

Re-install by going to https://www.microsoft.com/en-us/download/details.a...

Install game and enjoy :)

(Hopefully!)

___________________________________________________________________________________

Issue: Game Not Starting

Make sure your graphic card is up to date.

http://www.nvidia.com/Download/index.aspx

http://support.amd.com/en-us/download


Also, update Windows with Windows Update


Lastly, install the latest DirectX Runtime from Microsoft.

https://www.microsoft.com/en-us/download/details.aspx?id=35

______________________________________________________________________________________

Issue: Items glitching through table

You can rotate objects out of other objects like the table or wall. If you RightClick(Hold) + Alt/Ctrl(Hold), you can rotate. Be sure to release the mouse button before releasing the Alt/Ctrl buttons or the object will reset its rotation. Hopefully I can make it more intuitive.

**Alternative: you can shake your camera vigorously while holding the object **

Physics...

________________________________________________________________________________________

Issue: Dark Room on start up/Blurry Room

Go to graphic settings and hit the reset button.

Adjust the Resolution Scale

_________________________________________________________________________________________

Issue: Delivery crate explosion galore

1: I'd open the crate on top of the forge, a counter or the workbench
2: I'd open the crate outside where it's delivered and carry things in one at a time.

If you do have things stuck in the floor, spam right click on it until it pops back out. I've had this work for me 100% of the time.

Posted by Willybee5514!!! (Thank you!)

(+2)

what about the issue of when you hit day 13 it makes all the customers run in and run out almost instantly without giving you a chance to even read what they wanted

Yea could you fix that

(+1)

The dev has said that Bugs like that are going to be fixed on the Next Update.

(Edited 1 time)

lol i get about 30 seconds on day 16 its nuts but possible for the most part anyways

I need to know how to make it download

its annoying but if they leave just put the weapon on the counter and the usually will walk back in the store and get it

Can someone tell me how to fix the major lag problem I have been getting?

I turned my graphics down a touch and havent had an issue

(+4)

Hey how am I able to reload my saved game ?

(Edited 1 time) (+2)

I want to know that to. I saved my game and now when I start the game my shop is empty and it's Day 0 again

(+1)

anyone had the problem where the customer stands outside and never walks into your shop?

Try setting your shop to 'open'? Look at the inside of the front door to your shop.

I had this bug occur to me too; reloading the game made him disappear.

I've had this problem too and if you haven't found a temporary solution already, I've found that if you bring a weapon just out of the front door they will come and grab it if its the weapon they want, if not bring a different type of weapon out until theytake it and leave then the next customer will come

Please help !

api-ms-win-crt-runtime-|1-1-0.dll

the same

https://itch.io/t/61217/how-to-common-issues-please-read-first

I am currently having a bug where i missed a customer and haven't had another one come in since.

they may be stuck and cant leave just reload the game and it will fix it

Im stuck in 4k and whenver I click the game it crashes

(+1)

hello

is there a way to change the controls?

How do I do if my saved game is gone?, I think its no turning back, but tell me how to do to this never happen again.

WTF i cant even download the game it keeps saying try reinstalling the app and i have done it tons of times and it doesnt do anything

(+1)

Sorry for the delayed response, but try this :)


(+1)

The first time I downloaded it I put it into fullscreen, but Windows won't let me view it, no matter how much I click on the tab. No amount of reinstalling will let me use it out of fullscreen, so I can't play it. Any ideas on how to fix?

have the same problem :/ if anybody has a fix please help!!!

Developer

Hey, try deleting the save game files.

C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames

This worked, thanks a lot!

yea where do i find appdata cuz im in c: users Daan but i cant find it

(+1)

go to the start menu, there is a area where you can type,

type %appdata% and press enter.

otherwise set your folder options to not hide files and folders.

Hey guys... I want to make a backup from my save, where do i found the save files?

Developer

Hey Fus

C:\Users\YourUserName\AppData\Local\ShopSim\Saved\SaveGames

(+1)

thank you so much!

(+1)

I am suffering from immense, near crippling lag. I just downloaded the game today for the new update I have no idea what is going wrong.

how to play game after downloade

This should help you out!


Ummm, XD, this might sound stupid buuut, I went to go into full screen ingame and after i clicked apply it said input not supported on my monitor and i've uninstalled the game and reinstalled it but it's still stuck in fullscreen, i need a little help with my problem XD, also i already know it's my gpu but i wanna switch back to windowed mode.

(+1)

Fixed it.

Developer

Please post your fix. Could help others with similar issue.

Thank you! :)

(+1)

On one of the papers it says you can place the items on the display rack on the walls

but It wont let me and there is already items there

im on the latest version for 64 bit

I am having an issue that when I open the game it sets the resolution to 2715x1500 and when I try to edit it in functions that bottom half of my screen doesn't work. I have tried reinstalling it multiple times.

I have the same issue.

Just fixed mine try changing your display resolution to what it has then restarting the game.

I have an issue, where at day 29(dunno if the day is relevant) I can cook ignots and put them on my anvil, but then when I try to hammer them, nothing happens. I;ve tried with copper, adamantium, and titanium in sizes of 1, 2 and 3 ignots, all with the same problem. I am sure it occurs with all ignot types, I just haven't bothered purchasing all the other ignots.


Any help?

Developer

Hey Beartastic,

That is a new issue. The day shouldnt play a role in the issue. The issue might be on my end and Ill look for a solution. I apoligize for the inconvenience.

Thank you.

(+1)

I figured out a temporary workaround, if if you hammer an ignot while it is on the forge, it will turn into a short blade, and then you can resume putting ingots of the anvil and hammering as usual.

Hope that helps!

I started playing on the 0.63 version and the workaround for me so far has been to put the ingots on the shelf for a while until I make a few more weapons and if I try the ingot again later it works. Though there's no consistent time or number of weapons between the bug and it working again it seems...

ShopSim.exe has stopped working how to fix?? ls help me

Developer

Hey ShadowIsTheBEst,

Did you download the game with the App or browser? What is your computer specs? What version of the game did you download?

1.I downloaded with itch

2.my pc specs : i7 8gb ram nvidia gtx 1050 current resolution 1920x1080 Windows 7 64 bit

3.I downloaded the 32bit version

(Edited 1 time)

with your specs its better to use 64bit.

32bit can only support 4gb of ram.

also I highly recommend using the itch app to install the game as it gives you prerequisite files for the engine on install

in my game it says : "DX11 feature level 10.0 is required to run the engine" WHAT I DO ???

(+1)

if you did not install with the itch app I recommend this as it will give you the prerequisite files needed to run the engine.

if that does not fix it or you already installed using the app you can try updating your DirectX via the windows update manager

(Edited 1 time)

dont worked D: i installed with app and when i try to update DX11 it says its updated !

(Edited 1 time)

Hmm. what are your system specs and did you get 32 or 64 bit version?

also be sure your video card drivers are up to date as well

how to download 32 or 64 bit?

my computer is 32-bits,windows 7 professional and i get the 32-bit version,and im sure my drivers is updated

how do I update the game?

(Edited 1 time)

using the itch app right click on the installed game and choose "check for update"

if you are not using the app you will have to delete the folder and download the newest version

So, I was playing today, and all the ingots I've tried to use(the ones thar are more expensive than iron), turned into iron, but my money wasn't restored

I've found a way to """"fix""" it, save the game, and restart it, the money you spendt won't be restored, but the ores are going to be back to the normal

(+1)

also every time you use a new ingot on the anvil, use the z toggle and choose blunts or blades then put the heated ingot on the anvil, remove ingot from anvil - I drop them on the ground - then put it back on the anvil. this should reset the anvil allowing you to craft the correct item and material

Hey Dasius, I have a problem with my game. for some reason, my mouse doesn't work for it. If you could help me fix this problem or if you have any suggestions on how to make my mouse work that would be apprecieted

I've been having a problem whereI can't change things from a sword to a hammer. I've tried hitting it as many times as I could handle but it would just keep cycling through the different sword designs.

Press Z before starting to hammer it, will appear a circle with a hammer, a sword and a shield, you just have to click on the one you want to do

Metal that I just hammered is getting stuck in the air.

Figured this would be a great place to share my Installation Tutorial! Hope this helps everyone having trouble installing :)


(+1)

Some people wont even pick up what i make. Why?

(Edited 1 time)

It won't let me sell a two or one handed sword. ( and yes, unless I should be using the hammer or a great blade/hammer to make a one or two handed sword for some reason, I made it correctly. )

Developer locked this topic