Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Bug Reports Sticky

A topic by Commodore Shawn created Jun 15, 2017 Views: 9,904 Replies: 341
Viewing posts 1 to 113

Did something break? Please tell me about it.

I don't know who mentioned it, but when you place a road over a mountain, and then remove the road, there is grass underneath.

But I think in the first place, we aren't meant to be able to build roads on mountains?

I can confirm the same thing happens to the coastline, removing the road turns it to grass 


Roads need a little rework, currently placing a road erases whatever was beneath it, hence why everything turns to grass.

Not building roads on mountains makes sense, maybe with a different type of work designation that could flatten the mountain (to make a pass, or allow for building a mine)

Got a couple crashes as my troops (20) when into combat against a large Maskling force (50ish?)

1.2.4 may have fixed this I'm not sure 

Migrants still idle when they Haven even reached the settlement 


I saw a crash in 1.2.4 around fighting masklings, still trying to chase it down.

Migrants idle when they reach the settlement's influence range (the distance at which you can construct buildings). That influence range is based on population, and can get pretty big. Those idle migrants will stop idling as soon as they're assigned a task.

the migrant groups were outside the settlement range, they were idling in the masklings camp where they spawn (unless they overlapped)

Also sometimes migrants will get stuck travelling to a structure that is just on the other side of something ex: carry bricks to a wall but they walk up to the tower just in front of it instead of going around through the gate

Does that make sense? I often have to delete the structure, and retry but it can happen again, it's almost like I'm guessing if this can be built or not in this place E. Happens almost always with walls in corners that sorta thing


It's possible that a settlement's influence range expanded to a maskling camp, there's no cap on it currently.

As a performance optimization citizens will "give up" if they can't reach a destination or get closer to a destination after a thousand calculations or so. What's happening there is the citizens are getting "stuck" in a spot too far from a door. 

The migrants get attacked bugg and game crashes is fixed but there are some new.

1: if a pig is on top of a construcktion site they will stay there, no villager can reach them and the only way to get them away is to destroy and rebuild the building.

2: Maskling camps. Maskling camps have a large bugg, In a old post I read that you could deconstruct maskling camps in the inspect menu, I tried and it actually works, the masklings decontruckted thier tent wich then became construcktion grounds, they attempted to rebuild the tents, which they couldn`t and since then I never got an attack from that camp (I also don`t know if it got rebuild, but the hammering noise stopped.)

3: in the Settlemend info menu you can tell them to store, for example 600 food...... doesn`t work, same with mudbrick and wheat. Why doesn`t it work, that`s because if you tell them "store mudbrick, food or wheat" they start farming mudbrick or wheat, but not the needed amount but way more, with mudbrick for example I told them to store 600, they went to produce mudbrick, alot of mudbrick and when the brickworks was full they finially started moving the brick to the storhouses, not ending up with 600 stored but with 2200+. Another wierd think is is that storehouses have 40 spaces but I have storehouses with not 40 stored items but almost 250 items per storehouse.


Made a note of those, thanks!

Can the grass green be changed? It's destroying my eyes and preventing me for playing a long time.


Huh, I've never heard of that before. What would be an improvement? Lighter? Darker?

Actually funny too :p

But everything is possible :)

For the future, can the music not play when we minimize the game? Just a minor detail

(1 edit)

I also saw that when the game is minimized and I right click in another program, that the game turns into inspection mode


I know that used to be a problem, but I'm not seeing that behavior in 1.2.5.

Developer (1 edit)

I'll see what I can do with that.

Edit: though the game is still running when minimized, muting the game would remove audio cues that you're under attack.

(1 edit)

The settlers get stuck on the road and are stuck in "traveling to farm" mode even though they are next to it. (almost all my settlers are stuck trying to enter the farms)


They could be trying to travel to a different farm, but are unable to reach it. Citizens cannot walk over farms at present.

(1 edit)

Ah ok, i'll try to remove some farms and see if it works(it did, thanks)

Sometimes my Trade Wagons, when they are close together (say 3 of them moving on a route at once) if they path at the shoreline they glitch out onto the water. Also they can sometimes get through walls? atleast in one particular case at one of my settlements.

Developer (1 edit)

The Trade wagon displays as a 3x3 tiles, but in actuallity it only occuplies a 1 tile space. What you're seeing is probably the wagon overlapping onto the water.

There's an issue in 1.2.5 where pathing can ignore structures in some edge cases. I have a fix in 1.3, but I could release it early if it really bugs you.

Edit: Masklings shouldn't ignore the walls, so don't worry about your defenses being useless.


no hot fix required! They're just some real strong pigs

so I'm not sure if this has been said or come up before but I have seem to have spam clicked houses so they half overlap each other. So I can effectively have 2 houses in a 2by3 area.


Made a note of it, thanks.

I currently have 2 Settlements one with about 200 and one with 50-100 People and 1 migranting group + 5 Wargroups.

Crashes got a little bit more frequent after 2 hours of play (had 3-5) but now I have constant immediate crashes whenever I load the game.


That's unfortunate, are you on the latest version? There have been  several world load fixes since 1.2.0

Yes I'm on the latest Version.

I don't think the problem is necessarily the world load since it crashed before that.  Would providing you with the save help you with fixing this bug?


It would

I tried it and it's the same fatal error as I described before. But since the 1.2.5 I didn't encounter this


Thanks, I'll take a look.


Thanks to that save file I've got a fix. An odd little edge case around training warriors and me being sloppy when cleaning up after training is complete.

Fix will be in1.2.6, which will be out within the hour.

(1 edit)

Units sometimes go through buildings (tested with warbands and migrants). I started this game yesterday and they didn't do this, they only began doing it after the game had been saved and loaded.

gif of this happening: (I don't think it is related to the gate being close to where they did it,  I've seen it happen with a lot of other buildings)


There's a known issue around pathing calculations sometimes missing structures. It's fixed for 1.3. I can put out the fix early if it's epecially bothersome. Importantly, it wont affect Masklings, they'll still stop to attack instead of walking through walls.

Oh don't worry about it, it's not bothersome at all, just wanted to let you know in case no one reported it before.

Also, I've seen a group of migrants getting stuck for some reason since my last post, but I haven't been able to replicate it yet

(1 edit)

I broke another save. Thanks for "fixing" the first one btw.

This one was created in 1.2.5 but I copied it to 1.2.6 originally it worked and I could close and reload it without a problem but now at the end I closed the entire application and then tried to reload and it just shows fatal error. Got up to over a thousand people this time.


When someone is hurt you can see the "!" in the grey area around the screen.


Savefile fix is in 1.2.7 Looks like world generation was running during the saving process, resulting in a corrupted world. A preventative measure will be in 1.3. The would should load correctly, now though. On a side note, that world will be great for my performance profiling work. Thanks!

That graphics glitch is already fixed in 1.3

Hi Commodore,

now I broke my save, after the lags occurred and so on it somehow broke through saving or something.

Can you take a look, what went wrong in this save?

Hope it helps you for bugfixing :) 


I'm not seeing any problems loading in 1.2.7 (brand new this morning). Could be that this world had the same problem asTwonky's world. If it doesn't load for you in 1.2.7 please let me know.

oh have not updated yet, thx for the information.
I will try the update and let you know if it is working normal again

I have updated the game, the save is working again. Thx for the update!

Not exactly sure if its a bug or something you intended to have, but i've noticed that new immigrants are only going towards my first settlement


Immigrants are attracted to the settlement with the highest Wealth Per Capita value.

My first settlement has the least welth per captia value of 5 compared to my other 2 which are 7 and 11


What version are you on? Prior to 1.2.5 I think there was a bug where the priority was backwards.

Version 1.2.7

I had that problem too with a wealth of 32 and a wealth of 11 and they choose the 11 wealth settlement although those settlements were founded at a later date and the 32 wealth one was the second.

Developer (2 edits)

Curious, I'll take another look at the logic.

Edit: Do all of the settlements have 0% homelessness? Immigrants will only travel to settlements with sufficient housing. Or sufficient housing under construction.

Yes it did. It had enough for around 70-100 people I built the whole settlement with the starting 17 people.

I even send in a second migrant wave from the capital after a few Years and started importing food from other settlements because the 17/34 people couldn't support all the houses I had built. It took 3-4 Years for the first real migrants to show up.

You should actually still have the save with that settlement it was the last I uploaded the settlement between the 2 mountain areas. Btw. you said you wanted to use it for performance test. Were you able to fix some of the crashes happening every few minutes?


I do have the save, so I'll take a look. I just started the performance profiling, and I'll make sure to quash any crashes I see in the process. 

(3 edits)

In 1.3.1 World spawning can occur immeadiately beside a maskling camp - things do not go well for the migrants.


  • Also Maskling forces seem very large early, the first raid on several new worlds is upwards of 10.
  • Storage capacity can still be exceeded
  • Masklings sometime get stuck in water? unless they're grouping location is very close to the settlement? either way it casues my settlement to continually be in Alert mode
  • Roads dont seem to be constructed until every last thing in the construction queue has been completed 

I've made a note of them, thanks.

Are the masklings just sitting outside your settlement in shallow water (light blue)? Sounds like they're waiting for buddies to show up.

Yes they are! But its like directly beside my settlement, literally a couple pixels out of tower range.

I did settle directly next to fetile soil near the shallow water though so it may be coincidence

I was just not sure if the interaction was on purpose, since i lose a few villargers to continually alert mode.


I'll take a look at the "wait for buddies" behavior of the Masklings. Maybe have them wait further away, so as to not trigger an alert.

If a warband becomes too big, the info, split and merge menus gets covered with the list of warriors, which makes them hard or impossible to use.


I've made a note of it, thanks.

Found some new bugs. Maskling camps can spawn on rivers which is kinda weird. If you have a bunch of migrants and send them through a bunch of streets the may become stuck and completly unable to move. I had that situation happen twice in that settlement. Just make a new migrant group and send them north (You can just send them to join the city again and then form a new migrant group).

Another thing I noticed was that masklings camps can be built/spawn on top of each other.

Also the performance stat window in region map mode.

Gets only displayed on the unexplored area.

Some other things that I'm not sure about are.
Does the homeless counter round up?  Had no one showing up to one of my settlements until I built 1 more house and suddenly people came. Might have just been a coincidence.
And I think if you have skirmishers and archers in your army your army should stop/slow down at a range of 20 instead of 10.
Also the fast forward buttons could be linked up to + and - and a pause button right next to them would be nice i think

Apart from that though I currently have a 1000+ Population world that has only crashed once. So I'm pretty happy about that.

I've made a note of them. Thanks!

Hey! When a villager is repairing a wall, it shows in the inspect menu "a tribemember is inside" and they are litterally inside the wall repairing

Dunno if this is intended, manned walls might be a cool idea though

Manned walls was something I was going to suggest!


It's a side effect of the way citizens interact with buildings. I'd like to change how repairs are done generally, which would avoid the issue.

so I'm not sure if this is a bug per say, but everytime I load my world the notification for "a settlement requires copper but cannot produce it" displays makes the alert sound then goes again.


Made a note on it, thanks.

i cant da download any version except the 1.2.0 and when im playing it gets fatal error help me please


Why can't you download a newer version?

(4 edits)

I download it I start the game and when it starts is the version 1.2.0 but until then I did not see problem that version was cool  the problem is that When I started to get better more houses large population I click to see the information and gets fatal error, i already tried download again but of the same says that it will be corrected in the next update but I can, every time that I download is the 1.2.0 help 


1.2.0 has some bug and some performance problems. The current version is 1.3.2.

If you click the "Download Now" button, you should see a popup with payment options, right above the payment amount box there is a link: "No thanks, just take me to the downloads".  Click that, download "", and find where it was saved. Unzip and play.

Alternatively you can use the app which makes installing really easy. 

I have some issues with my copper mines. Somehow nobody is working in them. I placed them close and directly on copper ore areas.
But both ways are not working as planned. They have also free access from all sides.
Did I miss some requirements for the mine or have I encountered a bug?

ok my fault, I need to order copper throught the settlement info window, got it ^^


Citizens will also mine copper as it is needed. Currently copper is used to make Copper Statues, for several structure upgrades, and for spearmen and archers.

I can't play more than 5~10 minutes because it crashes without a specific reason.

Here is my save:


I'll take a look

Developer (1 edit) (+1)

I loaded the save and played for several minutes without crashes. It could be that whatever the problem was it has been fixed by the patch I'm working on. If the problem persists in 1.3.3 (due out today or tomorrow) let me known and I'll take another look.

Several of my civs have gotten stuck on the edge of rivers and oceans. It looks like they think the ocean is accessible terrain and is trying to cross it. I have also noticed it is always in areas where there is a small sea between two rivers.

Not necessarily a bug per se, but unbuilt structures (just placed by the player) seem to have just as much HP as a fully-built one. I abused this to instantly create a triple-layer of walls to defend against masklings. Pretty effective. Should probably be fixed. Most games have just-placed structures at 1hp for this kind of reason.


Made a note of it, thanks.

(1 edit)

Another one: the pigs have escaped their pasture and I have no idea how. Nobody seems intent on putting them back either.

Edit: The pigs mostly got re-gathered eventually, but one dude got stuck on a peninsula while gathering pigs (again), which seemingly stopped all pig-gathering business altogether, despite half a dozen empty pastures.


1.3 has an overallocation bug around pigs and tradehouses. When a group of pigs reaches the tradehouse, another batch of pigs is sent out. That's been fixed in 1.4.

There is currently a limit of 1 shepherd per settlement as well, which is why the stuck guy is preventing any other pig gathering. Could you send me the world so I could see how he's getting stuck?

After reloading the game it seems that he got unstuck somehow. He was at the tip of that peninsula while he was stuck. I don't recall having tradehouses when the pig escape happened but maybe I'm wrong.

On a 1440p monitor, the world doesn't fill the game window, I get black bars on the sides like mario 3. 

When I go to place roads, I'll click and hold with the mouse and then move the window with the arrow keys. I'd like them to be straight the whole way. But the game won't render anything new so I just scroll into oblivion.


Made a note of it, thanks!

If I place a road that is too long, workers only build the final stretch. So much better than before, though.

Something I noticed, you can see enemies through the FOW by simply inspecting the area they are at.

You can also use the "move to" cursor to detect coastline beneath the fog of war.

Pathing for trade carts gets pretty wonky. They'll follow the road one way and then take a detour across a mountain on the way back. I'll have them walk next to the road sometimes too, following it just not on it. It would be nice if trade carts (and other agents) had a stronger preference for roads, especially outside the city limits where it may be dangerous to wander.

(2 edits)

Trying the new export feature, it crashes my game consistently. I have a lot of people in four settlements, so that may be why. Graphical mods don't seem to influence the crashes. Panning through all the settlements seemed to help, as the game took longer to crash, so I suspect it's a matter of the world being too big. My settlements have overlapping  influence radii, I don't know if it changes anything.

Edit: I highly doubt it has an influence, but my world is called Eror the Plane of Chopping, not the most encouraging of names...


The crash happens when the image export is running?

Is Bronze Age "installed" in a directory that needs special permissions (such as Program Files)?

Yes, I click "export image", it sometimes run for a second or two, and then it gives me the regular "fatal error, bronze age has crashed menu/quit" message. It is in a subfolder of Documents, not Program Files. I'll try running it with admin, see if it changes anything.

PS: Nope, admin doesn't change anything. It creates a folder for it in the export folder ("Eror the plane of chopping turn 76858", number varies a bit), but it's empty.


Could you send me the world file so I can investigate further?

Here you go, savefile on dropbox.


Thanks. Got a fix for it.

Hey man, i cannot play this game on 1366x768 monitor. Things like work are missing.


As in parts of the screen are cut off? Would you mind posting a screenshot?

2.0 bug report time!

Everything is black when I preview or generate a map, it only shows the name of the region, can't play yet :(

Same problem here.

In the map preview is everything blue, but there i can see some black hexagons ...

Yeah same for me

I use a laptop with Intel HD graphics 520 btw, 2.80 GHz Intel i7 processor,  8 Gb RAM, with Windows 7 64-bit

It outright crashes on me.

So Twonky made a temporary fix for those of us eager to try stuff out! Check the comments here:


a) It's awesome that someone was able to put out a fix for the game while I was sleeping.

b) I think the bug is due to different cultures when loading the mod data. Do you use commas for decimal places where you live? That might explain why "0.75" is being interpreted as 75.

Here we use commas for decimal places, but that's only an issue with some microsoft software


Bronze Age is written in C#, which is developed by microsoft.

Okay, found a better fix than using Twonky's mod. This is for people who live in regions where commas are used for decimal place. Instructions are for Windows 7 but probably apply to different Windows.

Go to Control Panel -> Region and Language.

Change the Format to some type of English, or else it probably also works if you go to Additional Settings and change the Decimal symbol to "."


I'm not sure I'd call changing windows settings a better fix that Twonky's mod. Are there other issues the mod doesn't address?

I downloaded the new version but I cannot create a new world, everytime the progress bar completes ,,Picking region centers", the fatal error occurs. In the main menu there is a notification that some data files were not loaded. It happens all the time, restarting the game does not help. I have Windows 10.

Same over here, and I have Windows 7 Home Premium (32-bit OS)

(1 edit)

UPDATE: I tried moving the files around and I managed to find out that I made the most progress with the Komma's fix beacuse with the normal file in the game the fatal error occured but with the Komma's fix I could get trough the loading without any fatal errors but once I was in the starting point choosing menu I couldnt press the [Start] button, it just didnt allowed me to.

Cannot see anything, the whole map is black after loading or creating a new one.


That sounds like part of the "number conversion" bug, which should be fixed in 2.0.1

Can't create limestone mines for upgrading bakeries apparently.


Look for grey speckled ground. It will be in some of the biomes that have scattered mountains and trees.

I see it, but there is no way to interact with it to create limestone mines. Possibly a bug?


Possibly. Is your settlement in the same region, with another structure adjacent to it? If the hex isn't highlighted it could be in a neighboring region, which you can settle to build the mines.

I dunno, I settled pretty close to it.

(1 edit)

Cannot build over limestone deposits or near certain moutains


It looks like that the limestone may be in a different region. Try creating a settler and founding a new settlement next to the limestone.

It wont let me create settelers, I am having the same issue with deposits nearer me

I am constantly getting the fatal error screen on my world. I was invading a maskling base and when a was nearly done I was brought to the fatal error screen. Tried reloading the game multiple times with no luck. 

Developer (1 edit)

That's strange. I've taken a look through the reported errors and don't see anything that looks like what you describe. If you could send me the save file I'll take a look and see what's going on.


Thanks, I think I found the problem. Looks like a weird corner case around saving right as a unit died. I'll have a fix in 2.0.3, as a temporary workaround try changing (or disabling) the autosave interval from Settings in the main menu.

(1 edit)

Ok tyvm! As I was waiting for the response I made a bigger and better world. atleast you fixed a bug!

My city cannot create settlers, and are you supposed to be able to capture maskling capitals because i cannot do that either.


Settlers are spawned at the Administration Center (those tents near the left side), there's no empty space for them to spawn. If you remove one of the structures (like that brickworks) then you should be able to create settlers.

Capturing Maskling settlements is coming in the Conquest Update.

Ok, I feel kind of dumb because I have been dealing with things like that anyways, but thank you.


when place road and auto-save starting,  world crashes

FATAL Exception
   в Bronze.Common.GameState.Modals.AbstractProgressModal.HandleException(Exception exception)
   в Bronze.Common.GameState.Modals.AbstractProgressModal.Update(Single elapsedSeconds, InputState inputState, IAudioService audioService)
   в Bronze.Monogame.BronzeAgeGameBase.Update(GameTime gameTime)
Inner Exception Follows
Значение не может быть неопределенным.
Имя параметра: value
   в System.Xml.Linq.XAttribute..ctor(XName name, Object value)
   в Bronze.Common.Services.WorldSerializer.WriteNotifications(ReportStepProgress reportStepProgress)
   в Bronze.Common.Services.WorldSerializer.SaveWorld(ReportProgress report)
   в Bronze.Common.GameState.Modals.SaveProgressModal.<createworkaction>b__9_0(ReportProgress report)
   в Bronze.Common.GameState.Modals.AbstractProgressModal.<onload>b__16_4()</onload></createworkaction>

Happens to me too. first time the Auto save actually saved before world crash. next few times, not so much. Doesn't happen on old worlds that I migrate into 2.1 though. Strange.


Weird, I'll take a look.


Found the problem, it looks like it's due to the "Not enough housing for migrants" notification being present when saving the world. I'll have a fix in the next patch, in the mean-time you should be able to avoid the problem by adjusting the autosave interval, dismissing any notifications, and/or building more housing.

i just crashed from that

Developer (1 edit)

Curious, I'll take another look. Thanks for the update!

Edit: Got it! Same problem but in a slightly different area. I'll push a patch out tonight.

when i dismiss it, a hundred more need more housing notifications are thrown at me

managed to clear out 2 maskling vilages in quick succession, and i have 2 issues; first is what you see in pic1 i was going for a racial purity match and so once i got the first tribe under my belt i starting demolishing their roads (first).  This lead to whatever mess we see on top of some of these buildings.  The second is that since the whole tribe became commanded by me the second i destroyed their home base, i sent their 15-20 units into the adjacent village with my troops while doing that i decided to demilitarize them and destroyed their war huts.  After the war was over they came back to the ruins of their hut and just stood there.  Sadly i was spawned on an island so i can't send them on a suicide mission (not even into the ocean), so i think it would be great if there was a disband button on them, or maybe you could speed up the HP degeneration time on the base-less units (idk if that's been implemented yet, i've only heard about it). 

As a side thing, i was managing my second town when my troops took it and i had no idea until i saw all the masklings wearing my colors; so i thought it might be nice if once a totem is taken we get a menu screen like in civ where it gives us the option to raze, colonize, or maybe make the citizens into migrant slaves to be moved to another city.  You can kinda raze them by destroying the camp, thus killing all maskling slaves and turning the humans into migrants that you can use to resettle the area, but i'd like a simpler option. (PS - if ya need my save file, just ask)

When in speed 3 the gui becomes a bit unresponsive and buttons don't really work unless you click 100 times.

when it autosaves i get fatal error

You can't capture maskling camps in 2.2. Your Units walk up to them, and then stop and wait for orders. No matter how much you move them around they won't attack the Totem. Has anyone else experienced this?


That should be fixed in 2.2.1

Thanks Shawn.

(1 edit)

I can no longer capture maskling settlements. This seems to have started with 2.2.3, but reverting to 2.2.2 doesn't seem to resolve the issue. I tried to capture multiple settlements and had the same issue with all of them.

edit: reverting to 2.2.1 fixes the issue. I'll use that for now


Well, ain't that just annoyingly weird. I'll take a look, thanks


Found the problem, will have 2.2.4 out with a fix tonight

Awesome, thanks!

That did it, thanks!


So i lost my capital sometime in the middle of my game, i eventually brought up a secondary city, amassed a whole army, and reinvaded my capital.  The only problem is now, because that city was so far along, once i recaptured it, i started back at a level 1 palace and all my citizens were busy doing their own jobs.  

In the next update could you add some feature to make captured cities, well, able to grow?  Maybe just something simple like a check-box when you bring up the building management screen; checked indicates it can be worked by a citizen, unchecked means it can't.  That way i can redistribute my population to focus on building the city back up rather then having to destroy literally every building in the city just to free up enough citizens to be used.

I've had the same problem. It would be nice if we could disable structures and then reenable them later.


The ability to abandon and reclaim structures is already done for the next update. Abandoned structures won't drain or produce resources or infrastructure, and will slowly decay.

Cool, thanks

I get always a bug when i want to load a world of mine. The bug says:"Fatal Error. Bronze age encountered a fatal error. The exception has been reported, and we will try to fix the issue as soon as possible.  Check for updates, as the problem may have been fixed already.

The game autosaves regulary, so you should be able to resume playing without much lost progress."

what can i do to fix the problem?


In the Bronze Age directory there should be a file called "crash_log.txt". That will have details on what happened.

where is the directory?


Where ever you downloaded Bronze Age, if you installed it through the App there is a button in the bottom right (when looking at the Bronze Age page) called "Show local files" that will open the install directory.

I'm seeing some reported errors around trying to load a save file "Inhe The Island Of Hammering". They could be your errors, in that case you may be trying to load an old (pre-2.0) save file. You can check for it in the "saves" folder in the Bronze Age directory. If the file doesn't have an XML extension then it's an old format save file that sadly can't be opened in Bronze Age 2.0.

You could download Bronze Age Classic to play that save file, though.

ok thank you very much


Settlements with both land and sea trade will occasionally send a wagon out to drive from one side of a neighboring territory to the other, as if they are attempting to find a land route to the destination reached only by water. This happens whether the sea route goes to a settlement that shares a river for a border or if the land masses are separated by sea regions.


Thanks, I'll look into it.

Game crashes every time i click generate 


Try updating to the latest .Net version (4.7.1) That worked for one person with a similar problem. I'm also working on a fix on my end, but I don't know when it'll be done.

had the same problem to  but it works so do it

I installed the and when I run it, I just get a black screen. 
No menu, no crash message, just black screen.
Im using windows 7, any idea what can be the reason for this?

OK, installed latest .NET Framework 4.7.1 as somebody recommended, and it worked.
Issue solved.

When I open the game I cant play it. It only shows a black screen with static.

i had that problem but realized not all the files where in that folder after extracting it to the desktop so i had to extract it to a folder then it worked. also make sure your PC will allow the game to play i get a notification every time i start the game and i have to allow it to play

I ordered a unit to embark on a ship, the ship was unaccesible for him, but he still teleported into the ship. Now the unit is forever lost on that ship, because when I click to unload it, game stops for 2 seconds and does nothing. Demolishing the barracks didn't help either.

Also, when I demolished admin center while it was being damaged, this crash happened: 

Object reference not set to an instance of an object.
   at Bronze.Common.World.Behavior.UnitCaptureBehavior.AttackStructure(Structure structure)
   at Bronze.Common.World.Behavior.UnitCaptureBehavior.StepSimulation(SimulationContext context)
   at Bronze.Common.World.Data.Unit.StepSimulation(SimulationContext context)
   at Bronze.Common.Gameplay.WorldSimulator.StepSimulation(Single elapsedSeconds)
   at Bronze.Common.GameState.States.GameplayState.Update(Single elapsedSeconds, InputState inputState, IAudioService audioService, Boolean inForeground)
   at Bronze.Monogame.BronzeAgeGameBase.Update(GameTime gameTime)


Well that's unfortunate. I'll look into it, but that ship and unit may be stuck. If you sail the ship near some Masklings they might do you a favor and kill it for you.

I told my ships to trade but instead of trading they go around in circles.


Are they going around in circles near borders between regions? (the white lines). That may be a bug in pathing optimization.

i downloaded the .net thingy but the game still wont open, i've tried using the admin mode and the compatibility version, but for some reason nothing seems to work

you need to download and install net. 4 7.1


There should be a text file in the Bronze Age folder named "crash_log.txt". Is there anything in that file?

Not really sure where to make suggestions at or if there is a place to have conversations about the game like a discord group or something but its a great game.

was wondering if there was another way to boost moral for the city other then building brewery's if you don't find a place with wine.

also is there a way to find resources after already discovered them maybe like icons.

is there a way to create outpost or another type of building to keep territories lit up or atleast make it to where if you have a settlement on the section it'll stay lit?

you can  build a monument too boost morale


There's a couple suggestions threads, and feel free to make your own as well. I've thought about making a discord group, but I'm not sure I have the time to manage that as well as the game.

As znuffy said you can build monuments. When fully upgraded they're a very efficient source of morale. If you have patches of fertile soil you can also build gardens.

Resources show up on the zoomed out map, but I like the idea of a "find a resource" window. Stellaris has an "expansion planner", and that sort of thing could work well in Bronze Age.

Towers are a good candidate for keeping vision throughout your territory.  They can also slow down attackers that pass through.


If you start upgrading your town center, but something else uses the materials before the town center can finish being built, there's a very good chance that you won't be able to finish building it, because resource buildings will stop producing.

First time I ran into this bug I was upgrading my town center. Hit upgrade, then it shipped off some bronze, used the rest somewhere else then got stuck. I had to abandon the province and re-settle.

Second time, same thing but this time with mud bricks.

Might be a good idea to add a 'cancel upgrade' button, or to immediately reserve the materials for the upgrade.


I'll see what I can do. Probably cancelable upgrades, but also have the structure keep operating while being upgraded. That way the whole settlement doesn't shut down.

Deleted post

I've noticed a small bug, quite possibly to do with path finding. It seems if a admin building is not accessible by land (blocked by buildings/obstacles), and you try to settle settlers in that region, the computer will freeze up for a good minute or so, until the cursor is moved away from the region. Returning the cursor to the region will instantly freeze up the game again.


yep, sounds like a pathfinding bug, thanks

something i just noticed today that ships can not go under bridges if you build a bridge across a river any ships on trade route are cut off and glitch out as pathing no longer can find route is this a oversight or is bridges suppose to do that?


Bridges are supposed to block boats

ok thanks for the heads up i will remove bridges also i need to reset all the trade routes as the boats are all suck now going back and forth in an area my next question is once a bridge is built does that permanently cut off that water way as even with the bridge gone ships wont travel over the shallows any more? 


The boats should be able to pass over the shallows once the bridges are gone. The route the boats need to take might be too difficult of a problem for the pathfinder to solve. It does a bit of guessing to save on performance.

Perhaps try relocating the trade ports so they have a clearer path.


why not just let boats go under bridges that would be a clever thing to add to the game with all the broken things you added recently  and give happiness back to monuments

(1 edit)

My game won't launch.

Yes I've downloaded the .net frame thing.

I've created a pastebin of the error report given by launcher. It's a bit long.
But I suspect what's on line 228 has something to do with it, involving my graphics card not recognizing hidef profile, or whatever?

If I can configure my game differently to not have this issue somehow, please let me know. Or whatever solution you can think of.

Developer (2 edits)

That looks like a change I'll have to make on my end. Doesn't seem to be a problem, though. I'll test it out and push out a patch shortly.

EDIT: Version 2.3.5 is out, which should address the issue.

Still doesn't work.
Now at the same place it says "Microsoft.Xna.Framework.Graphics.NoSuitableGraphicsDeviceException: Adapter 'NVIDIA GeForce GT 540M  ' does not support the Reach profile."
The full text output of the error file is here:
It seems that indiegames like this have issues with my graphics card quite often, is there some setting I can change on my side, either with my system or with game configs, that will make it easier? For this game, specifically? Am I supposed to conclude that my graphics card is too outdated to run specifically games with pixellated 2D graphics? I mean idk


Honestly I have no idea.

The problem was on my end.
Sorry about that.
For some complicated reason a program was masking my graphics card, using a bit of software that acts like a driver, which would confuse my system for some programs trying to use the graphics card. I uninstalled the program and I can now run the game.
I'm now having a lot of fun playing your game.


I'm glad you got it working. 

ok sorry for kind of butting in but do you know what software it is that you disabled? im trying to use what sounds like the same engine as this dev and im getting the same problem that my graphics card "does not support the reach profile" and this is the first lead ive found as to how to solve this

im having the same problem as the last guy i just get a black screen and i have no clue how to fix it ive tried everything and nothing seems to work


When this caravan crosses from land onto the bridge when carrying resources, game freezes for a second.


I'll take a look, thanks.

(1 edit)

Hey, I'm not sure if this is an actual bug or if I'm just dumb. The game doesn't have any sound  even though sound effects and music are on in the settings. Also, the UI is really small on my setup. I can't find a way to make it bigger in the settings, so I'm not sure if it's that small for everyone or if I'm just extra special. I'm no computer whiz so I could be missing something obvious, but if anyone could help I'd be grateful. Even with these problems I love the game. Keep up the good work!


That all sounds very odd. What's your setup?

There don't seem to be any masklings on my maps at all.


Yeah, I noticed that this morning when starting on diplomacy. They should be generating again in 2.4.2

Is bronze's new tin cost intended? It makes it much much more difficult to distribute enough to bronze a kingdom, and impossible to field a large bronze army/fleet.


Yes. In 2.3 it felt like once you had one Tin source that's all you ever needed. I could bring the cost back down a bit, though.

I had trouble distributing tin before, though I had many cities and they all had armies.

I think a decrease in tin needed in smelters back to 1 and a decrease in tin production in the mines would be good.

This way you can still distribute bronze in your kingdom by shipping tin and smelting it at the settlement where it arrives while at the same time tin is still more valuable than copper.

And that's pretty much what I'm doing for the next update on my Admin++ mod.

(1 edit)

I don't know if you fix these stuffs but in the mod TestMod a bug when using the human race the tower object is replaced by the ratpen


That's actually deliberate. TestMod is designed to demonstrate some things you can do in mods.

I understand

Heads up to folks: make sure the application is in a folder which doesn't have write permission problems, and make sure it is elevated to run as administrator. Had a persistent crash that almost made me give up entirely on this game. In the end, program files (x86) worked for me. The desktop, C:, etc. did NOT work. Cheers!

Developer (1 edit)

Downloading Bronze Age with the itch app will avoid any problems with permissions, and keep the game up to date as well.

(3 edits) (+1)

I have a bug with the latest version (2.4.4) of the game. Whenever I try to make a new trade route to a city or village the program freezes completely. I can't do anything. I may be the only one who has such a bug, who knows.

I happened to learn C programming language a little so my guess is a loop in a program which never ends. That would explain why the program can't proceed any further. But I'm just a newbie at this so I don't think my guess is correct :)

I have a crash log. Hopefully it'll help.


Note: Sea trade works fine. The bug appears in land trade.

Developer (1 edit) (+1)

It looks like it's failing to generate a trade route, and crashing every frame. I'll look into it, thanks.

Edit: yep, it appears to be failing to calculate an impossible trade route. I'll have a fix to more gracefully handle it out tonight. Thanks again for reporting the issue.

(2 edits)

I opened up the game, (newest update v) and i loaded a "huge" map with regular other default settings. And 1 minute or less into it it crashed with a "fatal error" message. 

happened twice again with smallest worlds possible.


Did you exit the game before trying again? There could some memory held on to by the previous world.

Yes and its still doing it whenever i create a world.

Love the game so far, got a few problems with the trade routes in 2.4.5, both of these were found on small worlds.

First I settled in an area where half the area was connected to a large continent and the other half was cut off and surrounded by sea, even though I had the mansion on the main landmass no land trade routes could connect to the settlement, which made my plans of having it be an incredibly safe trade hub disappear.

The next problem was on a sea trade route down a river, I notices the ships were being attacked when they moved alongside the mainland so I went to add way points so they stayed safe, I placed a point down right in front of the dock I was using and the route disappeared with my ships not trading with the settlement anymore, even deleting the trade route didn't fix the problem.


Did you try removing some waypoints? I have a hunch that the waypoint right next to the dock was confusing the pather. I'll take a look.

Yes I removed all my waypoints and the route never came back, tried placing new waypoints and deleting the route, nothing worked.

If I build something that blocks a trade route the traders just stop in front of it. I have to clear and rebuild the trade route to fix it. If an enemy blocks a trader they stop and won't start moving again on their own after the impeding unit moves or is destroyed. Cities with both land and sea  routes no longer have the issues I experienced before. Routes no longer seem to have problems when they cross many regions, though path finding across extreme distances is still problematic. Overall, trade feels much better, and these issues are manageable.

The enemy sighted notifications can very easily become overwhelming. I had to turn off effects sounds completely. Perhaps there is a solution where you could toggle off these warning for certain settlements, or maybe something more elegant.

Not really a bug, but it would be really nice if ranged units defaulted to skirmish stance, ships included.


Thanks for letting me know, I'll see what I can do.

Whenever i open 2.4.6 it only shows a blank screen


Have you installed the latest .net framework? That usually fixes that issue.

whenever i try to lanch the game it crashes

Bug: When reclaiming maxed upgraded limestone mine, all resources cap at 70 from 220 and the resources produced of all resources are dramatically lowered into the negatives. 

Pop: 87 idle: 7 after: pop 88

happiness before bug: 127 (100%) after: 21 (-24%)

food before bug: 64 (72%)  after: 4 (4%)

Housing before bug 115 after: 4

Storage before bug: 220 after: 70

Administration before bug: 0 After: -1

I'm guessing this happens because negative administration. 

(3 edits)

I found a bug in the masklings mod:

huge lag (the game stuck), when stealing from a building that not product anything that you can steal, Exemple: if i'm trying to steal from a road, when the unit reach the road the game suck. But if i will try to steal from a lumberyard anything is fine. i tried to redownload the game, hasn't effect anything.

Plz fix it so you can only steal from stone mines and lumberyards.


I'll take a look at it, thanks.

Hello there! I've just test your last update with the happiness rework mod, and i got a world with human settlement but no maskling. Did you change something to the spawn of opponent?


Masklings like a little more territory around them than villages. Could be that there just wasn't room in the world, especially on a contents map.

Yep that was the problem! was on a mediteranean map, i've just try on mesopotamia and everything was fine^^ thank for the help.

Realy like the happiness mod btw, i t give me more liberty for desining my city wich i realy like. What are you going to do with the happiness building if you implement it in the base game btw?


Only the brewery won't really have a role under the happiness rework. I'll probably just remove it.

Ugh i can't click the buttons, maybe you should add a scroll thing?

That's quite a lot of people selected...

I'm planning on exploring a new UI framework which should be more responsive for situations like this, in the mean time you can still order movement through hotkeys. They're the yellow letters on the buttons.

If possible, can you change the overlays menu to not merge with the tutorial/diplomacy/justice advisor buttons

Hi everyone, it seems that i cannot capture maskling settlements with my army. When im choosing Capture and i mouse click on the enemy - i assume - "town center" they do nothing... Help?


Did you declare war on the maskling tribe? Do they have a full set of walls?

Oh so I need to declare war now? Okay. No they did not have full walls around settlement. Thanks for answer

(1 edit)

BTW only spearmen can capture a settlement.

Random question which of the three map types (with small size type) are smallest? Im playing Mesopotamia small map its almost 1100 with 10 cities and over 600 people and settling another 3-4 cities, but unfortunately looks like my PC is not that good for long-run of the game. Also is there 64-bit version?

The performance are not the best in the game "Commodore Shawn" says that performance improvements need to be done with the game.

And map types are not, as much as i know, to change the size of the map. They only change the generation features. For example: Mesopotamia worlds generate with deserts and lakes instead of large oceans, Mediterranean generate ocean in the middle, a ring of land attach to the borders of the maps, and more rivers.


A continents map will have fewer things on it, due to all the open water. That will be your best bet for keeping performance from degrading.

Fatal Error on Autosave

Steps to reproduce: Literally the games crashes to Windows with a fatal error when I try and save/quit, or when auto save kicks in. I haven't been able to play any further than the end of the first Winter.

Windows 7 64-bit

Intel i5-4590 CPU @ 3.30 GHz

ATI Radeon HD 3400


Just to throw in some more info, Windows 7 is completely up to date. Most recent versions of DirectX, .NET, etc. etc.

All drivers are up to date.


This is likely caused by Bronze Age not having write permissions to the save folder (such as Bronze Age being placed in Program Files). You can either put bronze age somewhere else, or change folder permissions

The trade window bug ?!

First of all I'd like to thank you for the great work.

Now, it seems that the trade window doesn't have any scroll bar or any way to shift to other commodities.

I'm not sure if it is a bug or something wrong with my settings, I'm a totally clueless when it comes to programming or any ''PC STUFF'' T.T

I toke a screen shot if it will help.




That's a known issue at low resolutions. If you edit the trade route from the zoomed out map the settlement information won't be there, and you should have room for all of the items.

Thanks for the help :

when I tried to establish a trade route between two of my cities, my caravans beelined for the opposite corner of the map. In a different game, I recalled some of my millitary units and the same thing happened. The direct movement commands work fine. If it helps, in both cases my cities were fully surrounded by walls w/ accessable gatehouses.


That's bizarre. Does the problem persist after saving and reloading?

Ah ok, that seemed to work. Thanks!

(1 edit)

I do not know if is just me, I just download the latest update (not the classic) (I am new downloading) and it does not load, it just give me black screen for hours. PERHAPS I should download the classic first and then the second link.. Am I right?

The classic is a different game, try to redownload the game

yup, already saw it, however only the classic runs, the other stuck in a black screen for long time...


Strange, sounds like something isn't loading right. Look for a file called "crash_log" in the bronze age folder.

Okay found it, and, hehe I will translate it, since it is write in spanish, It starts with:

========== 10/07/2018 07:17:14 p. m. ==========
Exception No se puede cargar el archivo o ensamblado 'System.IO.FileSystem, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' ni una de sus dependencias. La definición del manifiesto del ensamblado no coincide con la referencia al ensamblado. (Excepción de HRESULT: 0x80131040)    
en Bronze.Common.Services.AiAnalyticsService.Initialize()    
en Bronze.Monogame.BronzeAgeGameBase.Initialize()

"(Unable to load the file or assembly 'System.IO.FileSystem, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' not one of its dependencies. The assembly manifest definition does not match the reference to the assembly. (Exception de HRESULT: 0x80131040)  
 in Bronze.Common.Services.AiAnalyticsService.Initialize()    
in Bronze.Monogame.BronzeAgeGameBase.Initialize() )"

and then there is like 12974 lines repeating the same:
========== 10/07/2018 07:18:09 p. m. ==========

Exception Referencia a objeto no establecida como instancia de un objeto.    en Bronze.Monogame.BronzeAgeGameBase.Update(GameTime gameTime)

"(Object reference not set to an instance of an object.)" 


Ah, could be an old .net framework issue. Try updating to the latest version of .net

oh, too bad.

Then I will wait till I can buy a new computer to install Windows 10 and then can use the newest .net, since by some reason my PC cannot be updated to 8.1 or 10. so my latest is 4.6 :P anyways the Classic is very entretainment.

ssoooo....traders, battleboats, chariots ( so far thats all i found ) dont ''recruit'' new units after the first ones die...and even if you rebuild the buildings the buildings just say ''not operational'' and it says the same thing when you build it in another city/village therefore making it impossible to continue traiding after an trader ambush...and theres no way to destroy towers...or order them to attack it making it impossible to destroy your enemy and continuing to endlessly kill eachothers traders ( well after he destroys my trader then it goes one way but before that ) and units...


If the buildings are "not operational", you're probably missing input items. Are any of your item stockpiles 0 or negative? From the sounds of it, you might not have enough wood.

Unlike a typical RTS, in Bronze Age units don't just have an upfront cost. They are a constant drain on resources.

You should be able to attack towers if you declare war on the enemy tribe. By default Masklings are just "hostile", which allows you to kill units, but not structures.

(1 edit)

OOOOOOOOOOOOHHHHHHhhhh...ok let me have a look....yeah somehow im low in wood :D... and how exactly do lumbermills work? do you place them directly on a tree tile or next to? i know it says to place it on a tree tile but does another one have to be next to it for it to work? do they run out eventually?

(1 edit)

The lumberyard can be placed only on 'trees' hexes, and not require any other additional structure to work.

ok thanks...i thought they stoped working for a sec...

(1 edit)

I found a 'problem' and i'm not sure if it's a bug.

AI does not trad back, i mean the AI is set trades but the caravans or rafts not travel to take the resources.

Can also happen when the trade building is get abandoned or deconstructed. 


The AI should be sending traders. Could be related to a trade pathing bug I'm looking into.

Thanks for the heads up.

(1 edit) (+1)

I saw this a few times lately, as well the game is LAGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGGY. i can't play it, only 1/2 FPS, but i'm sure you going to improve the performance on the game.

The crashes happen mostly (as i remember) when deconstructing/upgrading a building(s) with negative amount of idlers.

OK!!! I think this time i have a bug! after a while of playing my trade/transport ships started to have a ghost unit taking up space ( after a normaly functional first naval invasion it started to do this ) and later they stoped even unloading units they float up to land but dont unload units ( after a reload it worked again but left a ghost unit behind...usually a skirmisher) after like 20 mins of this happening my save game i cant reload the world...

also i think it might be because of the skirmishers because my previous world i didnt build skirmisher barracks and the game didnt crash or bug with the boats


Curious. I'll take a look at it. Thanks, and sorry about the broken world. If you send me a link to it, it would help with debugging. And I could likely fix whatever is broken in it.

heh...ok...the next day ( today ) i wanted to send you a screenshot of the error and the game is working again (dont know for how long)...the error was very similar to the one that eyalonsky had...maybe even the same one. I will send a screenshot if it does the error again but for now it works

Game won't load D: Just a black screen when I launch it

Try reload/reinstall/reboot the game/computer

Still nothing. Rebooted several times, reinstalled it about 4 and nothing happens when you reload it

So In that case: I'm really sorry I can't help you. only Shawn can.


Did you update to the latest .Net framework? There's a link in the installation instructions.

Also, anything in crash_log.txt? It can be found in the bronze age folder.

It's always the simple things that work. I reinstalled .Net and it worked! Thanks a bunch!

The game opens but only as an eternal black screen. Can someone tell me how to fix it?



Look up

i think i know what cause lag.
When you have more then 11 'known' tribes.
known means that you have a diplomacy with them.

uhh this tribe non stop spams me with this notification. They constantly keeps coming at a rate its hard to even save and quit the game. I have no idea what triggered this. This is my best world so far because i have bad problems with happiness and administration. So I don't want to lose it if it comes down to that.


I think it could be failing to clear trade routes when ending trade relations.

Try removing any trade routes to that tribe.

I never had any trade routes with the any tribe. I was making and trying to make a trade route with a different tribe. But I got this glitch before i could do anything. 

You think I could edit the game save to fix it possibly?


(1 edit)

Well you can completely delete the tribe/delete the tribe knowledge
i assume this will fix it


If you can host the save file somewhere, I can try and figure out exactly what's going on and put out a patch.

alright I uploaded here:!QGRFDSzY!xKed8eDun4kYsz_gseuZEkY7uCuSmSrqhzZsse_EIy8  

Oh yeah I accidentally clicked on your profile and you have a space age version of this game? I gotta check this out!


Excellent, found the problem and I'll have a fix out shortly.


Nice glad to help! Once the new update/patch comes out is my world going to be playable again?


if you update to the latest version it should be playable now

(5 edits)

I don't know whether these where mentioned before as I didn't read the whole topic, but I found some inconveniances (just started playing today).

1. When building a tower, it has range of view before being built, so I can order it to be built, then stop and it is ultra-quick scouting.

2. The game is auto-saving even if paused for a long time, so it basically saves even though nothing could change in the game.

3. Everytime I receive infomation about productivity boosts, it boosts 0%.

4. When unit is set to explore, it will stop when all land tiles of region are visible. But there might be some blackened squares around which a priori are not known whether they are land or water, so theoretically they should check them too.

5. I have a feeling that bakeries produce food even if there is a slight shortage of wheat, e.g. having 1 farm producing 5 wheat and 1 bakery seems to constantly supply population of 9 (4 initial + 5). I am not too sure about this one though.

I like the idea for the game, but I think it requires too much micromanagement - I need to click each building several times to upgrade or to build (for bigger towns it is really boring), building roads between settlements take a lot of actions etc.

  1. Yeah, that behavior isn't ideal. I'll likely change it at some point, but I don't see it as that high a priority.
  2. Is that a problem? Things can change when the game is paused, you can change trade routes and order new construction.
  3. I think that's a rounding error, I'm looking into it.
  4. I think this is due to a limitation of the pathfinding system, but I'll look into it.
  5. I'll look into it.

Thanks for playing, and thanks for the feedback.

(1 edit)

Thanks for developing this interesting game!
2. You are right, sorry for this one. To be honest I don't like the autosave system as it is, because it interrupts the play, but I don't see any workaround here - I guess it is not possible to make it in the background?

6. I was wondering about one of the annoying things mentioned - to order a construction I need free population. Maybe it would be possible to change this mechanics so that player could construct a queue of buildings to build when there is workforce present (e.g. for building longer roads or wall sections)? What do you think about it?

but you can disable auto saving in the settings


2. Right now saving has to pause the game, so that world state doesn't change mid saving. I don't really see that changing in the future.

6. Yes, I'd love a system like that. It's in the plans, but will likely be awhile.

After playing the newest version for a bit, i've noticed these random slow-downs mid-way through my playtime.  It isn't even near the autosave time, it just randomly happens for 15-30 seconds then the game resumes as normal.  Has anybody else noticed this?

(1 edit)

Yes this is probably because too many of ai units in the map

But I'm just guessing


Wanted to say I recently found this game and have been enjoying it quite a bit. However I have not been able to progress anymore because trading is not working for me. The trade carts seem to completely refuse to trade half of the time. I have tried to figure out why this is happening for multiple hours on end but I just can't get it to work.

First issue I ran into was my trade carts refusing to import more than once from my allied AI's settlement. I tried increasing the trade limit trough diplomatics, rebuilding the tradedepot, using waypoints, deleting and reissueing the trade route and clearing the road, but nothing seems to work.

After that I just tried to make due with what I had and finding the resources myself, but then I ran into another, even more confusing problem. My trade carts had been exchanging recources between my own settlements for a long time, but all of a sudden all of the trade carts from ALL of my settlements suddenly all stopped what they were doing and started just going west on the map. They were still 'trading for x settlement' and whenever I called them back and reissued the trading again, they just went west again. Again I tried everything from rebuilding the tradedepots + carts and reissueing the routes but nothing worked. 

As a result of this my settlements all started to starve and rebel because they were lacking recources(I had seperate settlements for seperate things).

I hope this is information is of any use, I love the concept of the game and I'd like to see it keep progressing.

Game won't start... At all, not a black screen or anything, it just won't start.

Try reinstalling the game


Also try installing the latest .net framework.

I did both, Still nothing... Unless you have to do some special process for the .NET Framework or something.


There is a file created in the folder with the bronze age executable, crash_log, when an error occurs. Anything in that file?

Where did you put the game? Is it somewhere with special permissions requirements? Like Program Files?

I can't find crash_log, is it in the starting folder when you click on the extracted file? Also it is in downloads, so no there should be no problem with permissions. Maybe it has something to do with my graphics card? I bought a refurbished dell optiplex 755 which has decent specs but an abismal graphics card and I am unable to play some games due to it, I have obtained a new graphics card that should work for my computer and will tell you if anything changes.

Okay... The problem turned out to be my graphics card.

Deleted 1 year ago

i was previously being raided, and i have about 4 settlements if that helps.

not in a war though

you can be raided if you are hostile towards an ai
its allow limited hostile actions

(2 edits)

So I'm playing the latest version of Bronze Age and I essentially wiped out as Shontu tribe -- which gave me three Shontu regions. Now, they don't supply the Humitte armies that make up most of my land, so the only reasonable way was to abandon them and immediately resettle them with Humittes.

Unfortunately, abandoning them caused my units to just sit there and not do anything until I saved and reloaded -- and the same problem occurred when I abandoned-and-resettled a second region (the first had a settlement, the second had a walled village).

On a side note, if you take all of a Shontu force's land but don't wipe out all their units, the game thinks they're still active, despite them having no land and 0 population (it doesn't even recognize the people wandering with their oxen!)

EDIT: Speaking of bugs, there's no way to promote citizens or nobles into leadership. As a result,  my dynasty has nine adults, four children/babies, and eighteen regions... which means half the nation has to go without a governor.


Not having enough governors to go around is by design. I'm working on a provinces feature in 3.1, which will allow you can group several regions together under a governor.

I'll look into those bugs, thanks.

(1 edit)

Sometimes the RNG puts settlements (and other starting constructions) in rather..... sub-optimal locations. I just conquered their neighbor, and now two-province Ashisor is about to lose the shortest war in the history of Bronze Age (EDIT: it took 17 seconds). In addition, one of their provinces has exactly two non-mountain tiles, so it's about as useful as a submarine screen door.

Bonus fact: five-province Bonechopper Tribe (just west of Ashisor) is completely split in two by mountains (quite possibly from another wonky start), so if when I attack the two eastern provinces, the three western provinces are completely unable to assist.

(2 edits)

Speaking of bug reports, if the window is too small (in  my case, windowed on a 1920x1080 monitor) the settlement list and army list can overlap the lower-left panel. More seriously, on 50x50 maps, zoomed-out tiles can glitch. Yes, I have a mod here (which simply adds a new map), but I've seen both of these in entirely vanilla gameplay .

EDIT: I should also add that a town view of a town in a desert still uses the same exact tileset as a grasslands settlement, even if there's no sign of grass being anywhere nearby.

Developer (1 edit)

Do you see those black artifacts on the city map as well? If so, try disabling Optimized Tile Drawing in the settings menu.

The desert issue is known, as that biome ( and swamps) haven't been fully fleshed out yet.

(1 edit)

I've only seen them on the world map -- and only on 50x50 maps.

LATE EDIT: I should add that unchecking Optimize Tile Drawing works, but also really slows down large cities (to the point where hovering over a business in my capital causes 2-7 seconds of lag, depending on building);  I'm sure some of this is from drawing in a city with 356 people and 32 nobles, but it also means that I will not be expanding my capital any further!

And speaking of minor bugs, the game resets all settlements to 100% satisfaction on load.

Unfortunately, we have a big bug to deal with: of my four savegames, two of them are corrupt and unloadable. IIRC both of them are on 50x50 maps (one on basemod's Valley map, one either on Valley map or a shrunken version of basemod's Cradle map), which may  be related to the problem; after all, they're the same maps which had graphical issues if optimized tile drawing was off.

I recommend allowing multiple saves for a game. Sure, losing three years of gameplay may suck, but permanently losing a save is worse.


I wonder if that is related to a bug in save loading that I just fixed in the beta branch.

I'll push it to production tomorrow, and you just might get your worlds back. Backup saves is a good idea to implement, too.


Please try loading those saves in the latest version,

Unfortunately neither of the broken saves load in the new version. Should I upload copies of them so you can look at them? I can also upload a copy of my custom map (even though it's just Cradle set to 50x50) if you want.


Sure, thanks

The saves:

The map:

Yes, there's only one map despite the filename; ideally I'll make and add more maps, but I'll have to study what we have now to make maps that work. 

(2 edits)

Bug report 1: The AI thinks building a trade yard is a high priority, even over removing ruins. Furthermore, building trade yards seems to be a higher priority in 3.1.0 than in 3.0.0. As a result, the AI can wind up being ruins collectors:

Bug report 2: The AI is poor at waging war. In the above screenshot's game, even as a ghoul unit was creating ruins, the white-outline force sent a single levy unit to try and defeat their northernmost province's lion nest. They're also more than willing to send  a clearly insufficient force to attack a ghoul unit (levy only, equal or inferior numbers).

EDIT: Just after that image I took the empty land northeast of white-outline (carpe diem!) and exchanged maps with the blue-purple just northwest of white outline... who has four more ghoul units causing problems. Therefore...

Bug report 3: As of 3.1.0, the AI cannot handle ghouls.

LATE EDIT: I've seen that the AI obsessions vary. Sometimes they really want trade posts, sometimes they really want farms, but on multiple occasions I've seen an AI build the same building over and over in the same territory.

I'm getting some really rocky performance on the latest version. It's so bad that I'm having difficulty pausing. Save

Minor bug report: I tend to give every city a small guard (blame the Civilization series), so my army count quickly gets bigger than expected. Unfortunately, the general list flows out of the box.

Fortunately, simply expanding the box will fix that.


I'll take care of it, thanks 

(1 edit)

Bad news: Optimized Tile Drawing isn't fully bugfree.

EDIT: Also, if you have a large info panel (in my case it's very obvious on the nobles' Manor House, although it's barely visible on the above image), the map appears over the info panel's background but beneath everything on the info panel.


If I close my eyes does that mean the problem goes away?

Thanks, I'll look into it.. again.

thank you for finding this

It oftens seems impossible to get tools to resource camps.

Sometimes the tools arrive after a while, sometimes they don't. It seems to happen more when the tools have to come in by trade (I'm pretty sure they do come in by trade). What makes it really bad (and which is IMHO quite unnecessary) is that a resource camp seems to just shut down while it waits for the new tools, rather than at least work at the level of the best tools available (e.g. stone tools which are available by default). Can we please just have such camps at least running at stone tool levels while it waits for tools?

The combination of these facts make this one a real economy-wrecker. I had a case where I finally get hold of a single tin mine. Okay, I start creating bronze tools in the very same province, which luckily is a city... I set the tin mine to bronze tools. However, turns out my serfs just sort of aren't feeling it that year, or any year, and the mine just sits there waiting for its bronze tools whenever I set it to bronze tools. So whenever I even try, it shuts down the entire production chain leading up to my bronze tools! I mean, really...

This persists when I disable any other demands for bronze tools, and make sure there's available workers, so it isn't even a priority issue, I'd imagine.


Yeah, I've seen that too. I'll take a look.

By the way, how exactly does attrition work? It seems attrition persists even if the units end up in a region where I have the surplus resources that ought to cover their supply. I think - not entirely sure - I get scenarios where some supply resource ended up negative because of city growth, but the army just keeps starving when that is fixed, leading to stuff like an army of nobles just starving to death on my capital tile that's pouring over with resources.


There are issues with delivering items from within a city to armies camped outside. I believe it's related to haulers needing to physically move items to the edge of the city map.
Do you use warehouses?

Well, as I mentioned in the other thread, I am unsure how warehouses actually work. I can see how they offer extra room for storage, but I'm not sure how they directly or indirectly are supposed to influence how things are run. Like, is it for some reason more plausible that resources will be distributed to demands if there's a warehouse? How does it work?
Also, I guess it's interesting that some worker actually has to move the goods physically to the map edge.
About that (I guess it's a different topic altogether): to what extent are good moved around physically in settlements like you see the wheelbarrow guys if you actually check in a city screen? Is this actually done that way in all settlements including computer ones? I also seem to run into performance issues (basically FPS death on quite a new computer) when I get to a later game with bigger cities and computer factions being very busy. Including when on overworld view. Is it actually actively rendering all the particular good transports moving over the settlement maps of all the settlements in the world or something? I can see how that would cause fps death.


Warehouses do two things: they store items, and they increase delivery range. Most structures can only deliver items to 10 tiles away or so. Warehouses have a practically unlimited delivery range.

The wheelbarrow people technically exist for each city (not villages) in the world. Their overhead is incredibly small, though, as it's essentially moving along a number line. I believe that the current performance drag is down to logic running on individual structures, but I'll look into that more after tactical combat.


Units consume a certain amount of supplies, and require deliveries of items to restore supplies. When they've run out of supplies, they start suffering damage.

The root problem, I believe, is that for some reason the items aren't getting delivered.

So the guy you least want to hear from finally got out to testing out 3.2 and, well, the graphics are still not 100%; when fully zoomed out, the visible part is shifted up by four pixels. Sorry. :(

I fear I'm running out of graphics-issue-related flavor text (but hopefully we'll finally squash that last graphical issue!).


Interesting, that part seems more easily fixable, at least. I've been pretty burned out lately, but I'll see if I can take a look next week.

Thanks for playing and reporting issues. Better an issue reported than one not reported.

(1 edit)

If you need to take a break, take a break; we don't want a talented developer to burn out, especially when they're 100% of the staff!

I've actually thought of modding Bronze Age, but I'd have to juggle it with the other projects I work on.

Speaking of bug reports, I found a rare one.

See the eight-province red-yellow maskling tribe? The correct answer is "no", as that's actually two tribes with the same culture, same primary color, and same secondary color. They even have similar names (three-province Bloodcrusher Clan in the east, five-province Bloodcutter Folk in the west).

Yes, the odds of a match like this are very low, but obviously it can happen! ;)

(3 edits)

Since today is the day for bug reporting:

  • In the zoomed-out view, the brown coast is also four pixels too high; it's less apparent, but you can see it in the fog mismatch pic above.
  • The subwindows List Armies and List Settlements (of the upper-left window) both have overlap issues, both with the upper-left and lower-left window. This is more apparent while hovering over the button that opens them.
  • The subwindow Economy (of the upper-left window) lets you scroll to the right until all the provinces are scrolled off. Fortunately, all it does is look odd (and suggest there are more provinces when there aren't).

Also, I noticed some AI issues. This is not an outright bug, but while observing the AI play itself (Preview map) the AI made four errors: two minor, one major, and one catastrophic.

  • It assumed a two unit army should attack a unit enemy army.... even if the one unit is 100% health and the two units are 5% and 15% HP.
  • It kept moving an army that was starving and low HP, causing a couple units to die. This was post-battle, mind you, so the army was simply moving back to its capital (and therefore lost a couple units for nothing).
  • It failed to deal with cults, so three out of four cults managed to overthrow the province (I think the fourth was actually prevented..... by bandits overthrowing the province, seeing as it was a new force but the ghul cult vanished, aside form a ghul unit wandering around).
  • It failed to deal with whatever splits apart forces (running out of heirs, maybe?). The strongest force (~15 territories) spectacularly imploded into five different forces.

EDIT: There's one more graphical bug (which is probably easily fixable): when scrolling downwards, it takes too long for the next row of tiles to be drawn; as a result, there's a black bar on the bottom before they show up, whether zoomed in, zoomed out, or city view. The only exception is buildings in city view (including roads and under-construction buildings); they show up fine.

EDIT 2: I found another bug; after viewing the AI play itself, if you try loading a previous game, the cult viewing mode will not show any cult data. Oddly enough, the other viewing modes (standard, diplomacy, and happiness) are fine.

I'm having a lot of problems with lag and fps drop, which is very strange because in the first 7-10 minutes of game everything is normal so suddenly the game becomes unplayable due to the fps, I even tried to run the game on the grapichs card video but it doesn't seem to matter??


The game is primarily CPU bound, instead of GPU bound. Try playing on one of the smaller maps, like middle land or river valleys.

it work, but i get another bug, the sinal from whem an enemy is atackin/enemy spoted/combat is started, wont stop playing, it looks like a nuclear alarm and is preaty cool i guess, but how do i stop? 


If memory serves there's an option to change the sensitivity of those warnings.

well i try but it wont stop, but i lost the word anyway, also i said before it worked on smaller word but after 1-4h on game the lag came back, its something to do with the CPU bound again? with its it will be changed in the future??


Unfortunately I've stopped work on Bronze Age, see this dev log for details

I understand ADHD too, so I'm grateful that you made so much effort to answer me even with the project stopped, I think it's time to migrate to broze age tribe them

another bug that boders me, i can create any word without starting A FUCKING WAR i set the hostility to low and still it feels like the USA join the same time i started attackin me, how im supouse to stop a sieg whem i dont have 1 man to build an army? im doing somethin wrong?? 


Huh, I remember people complaining about the AI not being aggressive enough. I wonder if I did something silly and flipped the effect of hostility. Try with maximum hostility, see if the experience is different.