🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Feedback, Bugs 'n' Stuff Sticky

A topic by Denki created 35 days ago Views: 8,777 Replies: 790
Viewing posts 1 to 200 of 305 · Next page · Last page
Developer(+2)

Hello! Thank you so much for playing. And thank you, too, for all the feedback. Our apologies for any inconvenience caused by any bugs you encounter (one of the few downsides to such early access). We'd like to recommend using our Discord channels for communication. The best thing about Discord is you don't need an account to join in, it's a doddle to use and we can keep tabs on everything in one place.

Thank you again.

Aaron and Gary

Hello.

<font>I found bug. When you take pickaxe from your automaton when he is mining... Well he will create infinite tower of ore and stone.</font>

(Edited 1 time)

Yeah, I did that too by accident and I have 10 robots moving it all into a storage thing for 2 hour and I still cannot see the top and the storage thing got filledover the 1000 limit it is now over 20 thousand

it will have to go up to 9,223,372,036,854,775,807 (no joke) until NOTHING is left

:O

Developer

Woah! not seen that one before. Nice find. Added to the bug list. 

(+2)

Trump would be proud of that tower!

ahahahahha so true xD

(+2)

Hi! Ive found a bug. whenever I went to get water from the sea or the pond. it would make my character freeze up, and I couldn't move him. It would make me have to either restart or load. I really want to feed my people! D:

Same here.

same

(+1)

You, can Just grab water from the cow  dump(poop) . I accidentally  discovered that. Just grab a bucket and right click the poop. BOOM !! You have water . You can also automate your workers getting water from it .

thanks

Developer(+1)

Ah yes, we've had a few people ask about this bug. It will be fixed in Monday's version. Sorry about that

Hi! :D
If i accidentally right click on a tree, the character drop the tool behind the tree, it would be nice an other camre position to see behind stuffs.
:D

Same goes for bots that run out of power behind trees, it's near impossible to get to them.

or just fix your brain and get a axe to cut down the tree

Thank you for enlightening me, oh Master.

np son

that happen to me

Hi, Think I found a bug. When taking a plank from inventory to hand slot, if that hand slot already has a plank in it, it duplicates the Plank icon and the icon persists after inventory is closed.

<font>Great game so far.</font>

Developer

@pepe333 yeah that's a know problem. It's on our to do list. Thanks!

Developer

@Manbot Thanks, yeah we've had a report of that before so it's in out bug list. Cheers!

Hey! I Found 2 Bugs with the game. 1. Whenever I send a bot to get water (from a cow, or from another bug I will talk about) they take the bucket, and get the water, but keep trying to get more water. I'm guessing this is because the bots are programmed to fill all the spots in their hotbar before they do their job, and they think milking a cow is like taking something out of a storage box or picking up something from a pile. and since buckets are different from other items, and since they don't stack, it confuses the A.I, meaning it cant get water. The Second bug is another bug involving water. When you take a empty bucket and try using it with another bucket, empty or full, it will fill the bucket. While that is convenient, I don't think its meant to be like that.

Developer(+1)

Ok the first bug should be fixed in the next uodate. The second one is new. Added to the bug list. Thanks

(+1)(-4)

You got a spelling error, Denki.

Developer(+3)

Denki can't splel

(+1)(-7)

Denki can't 'splel' even more. Please 'splel' more correctly.

(+1)(-5)

Who keeps giving me a -1?

(Edited 1 time) (+1)

I feel certain that he purposely did that spleling mistake.

(Edited 1 time)

It might be a bug, but I can't seem to drop tree seeds.

Edit: The way I found to "fix" this is just put in the seed in your inventory, I still can't seem to drop it after, but at least I can continue.

I don't think you're supposed to drop tree seeds. You have to place them either in general storage or a seedling tray to store them. The only way I know of dropping them without storage is to drop the seeds on cereal crop or in grass.

Developer

this is fixed in the next version. Thanks

(Edited 1 time)

hello, 

I am not sure if this is meant to be like this but if you pick up a log you can put it in your inventory And carry like 10 of them. ( you can do this with every item ) and since you can only carry one log in hot bar I don't think you are supposed to carry 10 in backpack. Like you can only carry 4 stones, you can carry 14 with inventory. Like I said not sure if supposed to be like this.

Thanks                                                 

For hopefully reading.  :)

(But at the beginning this can be very helpful and I like it but, not meant to be like that )

You cannot carry 40 stones. Each item you place in your inventory takes individual space . But however by that method you can carry 10 stones and can also be done for other item of same kind.

Yeah woops accidentally wrote 40 will fix

Nameste Denki, So I have found Two major bugs . It's a bit hard to explain but I will try my best .
1) YOU CAN DELETE ITEMS IN GAME. I was goofing around and found out that when you PRESS SPACE (CALL)  your worker , But before calling your worker you need to be about 4-5 blocks away from your worker. Then you need to right click your worker (this will make our character move towards the worker(to carry the worker) )before our character reaches the worker we need to Press Space and Perfectly time and click the worker again to access It's training menu .( IF it worked perfectly then our character will be carrying the worker and the workers menu will also be open) Then after that we need to PRESS THE TRADE BUTTON . You will see that IN YOUR Inventory is The worker as an item which we are calling (hard to understand: TRY in Game) So now we can move our items to the workers inventory and then we need to move the worker(item from our inventory) in to the workers inventory  . Then By closing the Trade menu . THE WORKER AS WELL AS OUR ITEMS WILL BE DELETED.

2)WORKER AS A HAT. I dont have any idea on how it happened ,But now my character has a Worker AS A HAT . I think it happened  when I was trying to delete the people from the game By the above method . The Worker Is LIKE A HAT , I am not carrying it as it doesn't show in my inventory and I can Pick up  other item while the Worker is In my head.

Thanks,
The Game Is EPIC . I hope to see the new update soon.

(sorry if I was unable to explain the bug well)

Developer

These sound similar to two bugs we already know about but are struggling to recreate, so thanks for this - hopefully your description of the first bug will help us fix it :)

im pritty sure thats not a bug, just time lord technology :p

something like that?

I have three bugs to talk about. One is when you spam left and or right click your character like teleports a block or two ahead. The second one is something I have only seen once. I automated tree planting and when one tree grew to full size my worker kept on putting seedlings at that one spot and then there was a tower of seedlings and a few open spots for trees to still be planted and it may have been caused by that worker wanting to plant in that spot but another worker took it and it felt like it didn't complete its job and kept on trying to get it to get in the spot. I don't know but I know that isn't supposed to happen that I know of. And the last one when a tree gets chopped down near a building the log sometimes gets stuck  in that building and nothing can pick it up well I saved and quit the game and came back the logs where repositioned in a different way and I could pick them up without moving. They went directly into my hotbar without me moving and I was like 5-6 blocks away from them. That be all I got for now that hasn't already been mentioned.

(Edited 1 time)

I think I found another bug or two. The fertilizer storage says it can contain 1000 fertilizer, but mine is going on 2100 stored fertilizer! Also fertilizer in the game is spelt fertiliser but I don't know if both are correct or what?  The second one has to deal with the Wooden Sickle it hasn't ran out of durability yet. My worker has had for a couple hours of just almost nonstop cutting down cereal crop hasn't broken yet. Made it  I used it some the  worker is using it now, is it a bug don't know just don't seem right to me for it to  not break like the other tools. Thats all for  now. Emphasis on the now.  (I would send you a screenshot of the  fertilizer but I don't know how)

(Edited 2 times)

Yeah, I've got a same bug with logs aswell, you can pick them up from the other side of the map instantly aswell.

'Clickspam runing' is fun :). I use it all the time.

And yes, you can store over 1k+ on 1k storages.

Storages with tools won't show current amount, maybe because the actual words on that tooltip are too long.

Would be nice to somehow show bots without any jobs. They got a light on their head so It might light on or something if they aren't programmed yet.

Builders who have anything in hands and need something else will just stay without building, like in case you put the flooring down and storage, you build flooring down with logs but they got a log in hands and won't build storage.

For this early game is still alot of fun. I've got about 150+ workers just to automate everything I want them to and it's really stable.

And boulders are quite OP, much faster to dig on them and they give stone and metal ore so I found ratio to 1 worker on boulder and 1 on metal digging sufficient enough tu supply my current needs.

Would be nice if collecting bots would put their loot into the closest storage instead the storage you programmed them to.

If you pick up worker, and when holding it you will train him - he will disappear

Developer

Added to the bug list. Awesome find!

For some reason when I go to fill my bucket he does the animation and then I can't move him anymore.

That is something other people have said and it happened to me. Wait for the new update or start new and also get water from the cows for now and not the water blocks or it will happen and yes cows give water when you left click on them.

(+1)

I found a bug where if You have a bot chopping a tree, and you stop him half way through cutting it down and get a bot or yourself To try and cut it down again it won't and the tree is invincible. Now I have half a tree stuck in the middle of my forestry. 

Great game btw

Developer(+1)

Thanks for the bug. Now logged.

And thanks!

(+2)

Hehe, 'logged'.

plz go to my thing

I try to gather water in a bucket, it shows the animation, however, I am frozen in place and the bucket is empty. Is there no water in the game?

PS I can still move the camera and look at different objects and buildings like normal.

Developer

Thank you, all, for these bugalugalugs. We swear that we will do our best to resolve as many as possible for Version 4.

Thank you for your great work! Keep on going :)

When I tried to pick up two workers the first worker is stuck on my head

Good game tho

Hi I think I found something  that may be a bug. I tried to automate axe and shovel production, I was able to put tools in storage, but when I tried to teach a bit to move tools from the bench to storage he would just grab an axe and then sit there and not put it in storage. I think this I because he wants to fill his inventory but can't because he can only hold one tool, which doesn't count as a filled inventory.

On a side note I think it would be cool if I could click on 12th workers programming box in game and modify it manually 

a way to fix that is Re-do the teaching and do it exacly how you want him to do it

so being that you want him to Pick up tools and put them in a storage box you would have to-

1. start teaching

2. Pick up the tool

3. put it in the storage

4.walk back to where you started

5. Repeat and Go!

well the problem is that once he picks up one tool he just sits there. He doesn't do anything but pick up one tool and wait for more. I think the problem is the check to see if his hands are full and he locks up on that

In V3, this works fine

I found a Bug. so what happens is i was holding a Worker/robot and i whistled to teach another to collect stuff mean while the other one on me head wasnt able to be selected and got stuck on my head... Fixable?

Developer

Not the first time we've heard this (or similar). Once we figure out how to make it happen, we should be able to fix it.

(Edited 2 times)

First of all, really nice game! It has a lot of potential.

I like how you teach the workers actions by doing it yourself but I'd rather prefer a proper menu for creating, viewing and editing action chains. I have trouble keeping track of the robots (custom colors, names and labels would help) and it seems more complex actions are impossible at the moment (carrying more than one tool from one place to another or supplying more than one workbench with materials).

I'm looking forward to new versions!

Deleted post

I didn't see a new version was out so my post refers to version 2. With version 3 it is indeed possible to create more complicated commands. Nice. And the menu for it is much closer to what I thought about.

Customizable colors is actually a good idea, say putting red on lumberjacks, and blue on rechargers! (These are just random examples)

Deleted post
Developer

OK! We do have a short video showing how to use the updated teaching, which hasn't gone up yet :)

What's your Repeat problem exactly?

i don't know how to use the repeat option when teaching the robot.

drag the repeat into the actions list, then drag whatever actions u want repeated between the double bars

thanks I have been try it and it work.

TYSM FOR THE REVISED PROGRAMMING, MY LUMBERBOT PICKS UP ONLY ONE AXE NOW

Will you ever add conveyor belts, spliters etc. ?

That might make it too much like Factorio though... :/

I don't think the 'until hands empty' command works when dropping metal into a general storage. also how do you make wheels???

Did you drag the commands into the repeat "mouth"?


The Wood router, previously known as the Gear router

i did drag into the 'mouth' like normal but and the code was right but it still wasn't moving on after the hands were empty

Is there some way you can screencap an image of the command? It might be because you didn't put a "forever" block 

(Edited 1 time)

did you put "repeat until hands full" for the picking up of iron? This all works fine for me. Also be sure to click the "forever" button!

I think I've experienced a similar problem, have you tried saving and restarting the game?

I'm having the same issue. I tried to get a bot to pick up seeds with "until full" and then plant them with "until empty" but it just kept doing the repeat command and not going to the next task on the list.  It just kept doing the first repeat command and stalling trying to up seeds with a already full hand.

The water bug is really serious, where you try to get some water with a bucket and your character freezes. Since this bug exists, does anyone know some ways to get water?

Cows, I would say milk them, but since its water, "water" them? lol

Developer

It is. Sorry about that. I think it's my fault it got broken again after Aaron fixed it. We'll update Version 3 with a fix soon.

Suggestion: Wait and If condidtionals for the bot logic, so you could do something along the lines of, if items under x amount, and also wait x time, before restarting loop, or wait x before looking for item on ground (since ive had it where my bots will grab an item from elsewhere cause they are looking for the item thats about to come out of the bench, and then it gets confused)

Developer

Yep, we have loads of plans for the bot teaching and scripting :D

:D

In inventory, when you're holding an item (holding LMB)and then rightclick over an item slot that's taken you'll make... something. I'm not sure how I can describe this. It's kinda annoying.

Also, I kinda like it, but if you want to walk faster just quickly alternate between left click and right click. Useful. But I guess it has to be posted.

My Crude worker bot is now a Basic worker bot. It was like that before the new update but I  load my save in the new update It has the new skin for the Crude worker bot which was a little frightening to me at first, but it still says Basic worker bot and it has the inventory of one and as I can tell acts completely the same as a Basic worker bot. How this happened don't know just came back to my save yesterday clicked on it and it said Basic worker bot. 

(Edited 3 times)

WOW! Saw a let's play from ColonelWill this morning and immediately downloaded the game. Didn't pay, because I don't have a credit card and live in the Netherlands.. Sorry. When you get to other payment methods I'll definitely support you though! Been playing the game from this morning till midnight, almost non-stop :P


Now to the part where I'm on topic lol. I found that for some reason, the loop command sometimes stops working! Didn't really find out why, but here are some conditions I tried:

- When feeding the villager people, I would let a bot first take food untill their hands were full, then distribute it to the nearest villager untill their hands were empty. For some reason it worked with one bot/area, but not with another. I tried using another bot on the same area, but that one had the same problem. 

- I had one bot plant trees, practically the same algorithm. First get their hands full of stuff, then distribute it. Again this bot would distribute untill his hands were empty and then get stuck in the "untill hands empty" loop. 

- The only thing that was the same that I could think of was that both bots were working to the right of the spawn. One in the forest beneath the water and the other in the empty field left of that forest. Really don't know if that has anything to do with it, but I'd rather tell you then not.

I really hope you can do something with this. I'm not used to posting bugs on a forum, so I'm not sure which info I should give to be helpful. If there is anything you would like me to test, or more information you want, just ask. Your game is AWESOME :D

EDIT: I'm playing on version 3 btw

EDIT 2: It seems it's not the repeat function that's the problem. I removed the repeats and let the planter bot just get one seed and than plant it and he still just did it once and then kept bouncing from "find nearest seed hole" through "move to seed hole" and to "plant", going back to "find nearest seed hole". It completely skips the part where it goes back to the seedling tray to refill.

Because I want to play more and already got to endgame, I'll just go bug fixing then lol. Probably more edits coming soon xD.

EDIT 3: Alrighty, some more testing got me some more information:

- It seems to only affect certain bots, if a bot is affected, no forever loops will work, it wil always get stuck in some action. At first I thought it was only with multiple actions or repeats in the loop, but that doesn't matter. A simple digging loop will also break (for instance, one broken bot kept digging in the same spot). I had 2 bots broken and tried to give them all jobs related to tree chopping. There was no job they would do succesfully.

- The bug I'm trying to find also makes trees unbreakable if a broken bot tries to chop a tree. This is not guaranteed, but it happened to me multiple times while trying to find my forever loop bug.

- Upon save/load, the bot will work again. I think the broken trees also dissapeared upon save/load, but not sure if some bot cut them down upon save/load. Now that I did this, I need to find another broken bot before I can continue my research. There might be an action while starting to teach a bot something that breaks it forever untill save/load, but I'm not sure.

Developer

You have been busy! Thanks for this. Added to... The List!

i think I found a bug when I am using a basic workbot. When it work after the first repeat it canceled out everycommand underneathit.

found a bug it's the basic workeebot don't work well

Developer

Ooh! OK. Please elaborate.

how do I fix that

Describe the problem in more than three words.

Preferably, by describing what you are doing and what you expect would happen, and what is happening instead.

(Edited 1 time)

My bots won't exit repeat loop or i'm just doing it wrong?!

Until bot has some tool like axe or shovel everything is OK.

forever {   
 repeat until hands full     { find nearest pine tree ; move to pine tree;  use held item }   
move to general storage
take from general storage
}

tool breaks = infinite loop


edit:

this loop:

forever {   
move to general storage 
take from general storage 
repeat until hands empty     { find nearest pine tree ; move to pine tree;  use held item }   
}

works like previous one should 

This is exactly the same problem I was having, read my post! If you want to fix it, just save/load and your bot will be fine

Save/Load don't work for me

on the first one, it's on repeat untill full, which it should be on empty. I prefer the top script with it set to reapeat untill empty :)

(+2)

I'VE FOUND A WAY TO RECREATE THE BUG!! :D

I really don't know if it's the only way, but it's a way. At first, I teach a bot to get fertilizer once and plant it once. Then I add the repeat functions and let the program run once (without adding the forever loop). After the bot stops, I use teach again and add the forever loop to the program. If I let the bot run now, it get's one fertilizer (so it skips the first repeat loop) and plants one fertilizer. After planting the fertilizer, it get's stuck in the repeat function like the image above.

By using this set of action, I managed to break 4 bots in a row, so it's very reliable. Because of earlier testing I think it should work with any set of actions, not only with the fertilizer. I'm not sure if it only breaks with the forever function the way I did, but it's a reliable way to do it!

Good luck!

(Edited 1 time)

Lol immediately found another small bug. If you grab a cow when he's shitting, it stays upside down if you put it down again. Now I've got a cow grazing upside down lol. Probably fixes itself upon reload.

don't fix this please, infact fix the fact that they reorient once they flip again

Developer

Added to the bug list. Thanks

Hey Denki,

It would be nice if when you opened your inventory and shift-clicked on an item in your hot bar it would go into your inventory. Same as if you shift-clicked on something inventory it would go to hot bar. ( you could also make it right click instead of shift-click)

Great game! :)

hey Denki, 

Just something quick but could you make the crude workers not look like cardboard boxes that a two year old made.

Otherwise great game. I give it so far as of version 3 a 9.5/10

Developer

I like the new Crude Workerbots! :(
Gary

lol , there ok I guess you could keep them how they are it fine I am getting used to how they look. :)

Not a major bug but: People aren't normally stackable and will get upset if you try to stack them, making you drop the person you're holding where you stand. Standing on a person and trying to stack them will prove to be successful,  even if they are slightly upset about it for a moment.
Atleast it can't be exploited with huts even if they share the same position only one of them will be pleased.

You can also stack them if you let a bot put people in one spot. Had a stack of 20 people or something lol

You can still put them in your inventory...

I wanted to move my folks to another area but but when I deleted the huts and placed then in the new area I was not able to pick up the folk guys and move them to their new area. Now they are stuck were the old hut was. They act as if they are still at their hut so I can feed them just not move them.

Developer

:( Added to THE LIST.

Youcangetwaterfromastick

 myspaceisbroken:(

(+1)

use ctrl-c ctrl-v (copy and paste) on a space character

You're welcome :p

my worker was cutting down a tree and he stoped so i wend to cut it down and it would not cut

Suggestion: Can you make worker bots be able to grab and touch other worker bots (like refresh the battery). Also, can you make them place things in rows. (If you do It it will really help me automate the creation of workerbots!)

worker bots can recharge other worker bots, you just have to actually do the action in order to teach them to do that

it does work, as for automating production I reccomend using storage as a buffer, you're probably already storing poles and planks. my worker who makes others does this, take referring to crates and find referring to ground:

take plank
give to router
take four planks
give to factory
take four poles
give to factory
find gear
give to factory

Thanks

I've got one idle until I press "teach" then "GO". This way I wont have a hundred bots in one space, lagging my computer, he simply does it on command!

(Edited 1 time)

2 Glitches: (I have v3 saved in the v2 folder so I could keep the save {if there is a better way please post it)  The repeat command doesn't work; after the first time through the repeat command, they stop doing the commands.  Additionally sometimes when a worker put cereal into the windmill nothing comes out.

P.S. The the v3 update is great.  Keep up the great work : )

Feedback; I think the crude worker is a bit too rugged looking.  Maybe make it a bit squarer in the head or more natural looking by making it rounder.  Additionally, the squeaking on the bike is a bit annoying maybe it could be just when you start to move or removed in a metal version.   After some revision, I think it would great additions. : )

Help ?

maybe reduce the quality settings at the launch?

Nah,I tried all of settings.

Developer

This is a known bug and something I'll be looking at soon. What video card do you have?

Verry bad vc:NVIDIA GeForce 6150SE nForce 430

Yo Denki,

I have an idea: It would be cool if the folks didn't just sit there, like Mabye if you feed them and they are happy they could help out or something like that. Mabye if after a while they get hungry they would go back to there hut and request food. (Maybe the thing they could do is if you build a big fenced area with a gate they would once happy go in and maybe doing things with other folk such as playing a game. Or they could help you build.) Another idea is maybe sometimes the folk would go inside and look through a window in house and then when hungry come out. It's just an idea, sorry if a worded it weirdly.

Great, great game so far!! :)

But they're supposed to be the laziest beings in the universe! (Hence why they lay around instead of walking)

Deleted post

its not unplayable, make an axe by getting a stick and a stone then left click on the log to make 2 planks. Very inefficient but is required to start. And removing buildings and blueprints works perfectly fine for me.

you can only RMB and del in edit mode

Sorry for yet another post but for some reason after the update the cows keep eating and producing dung even when the grass is not fully grow causing me to get more dung then before.

(Edited 1 time)

that keeps happening for me too

i have to get bots to get rid of the giant piles that block a piece of my screen sometimes

apart from that its good for fertilizer

also i started a space program

http://prntscr.com/fxv7qf

Developer

This is a known bug but thanks for reporting (and the screen grab).

(Edited 3 times)

Repeat loops don't work (Version 3)

Example:

  • Forever


    • Repeat until hands full
      • Move to General Storage
      • Take from General Storage
    • Repeat until hands empty
      • Find nearest Tree Soil
      • Mode to Tree Soil
      • Use held item

Start : a bot with empty hands next to a Storage with wooden shovels in the middle of tree soils

=> the bot move to the storage, take the shovel and loops forever at the first repeat

If you remove the first repeat, the bot will loop forever at the second repeat even if its shovel break (and it'll walk around with a white and red circle on its head). The behaviour of the bug is like the condition is only tested at first.

The repeat loops and forever loops do work properly because I have been using them perfectly fine. Make sure things are inside the loops not under them. That might help.

°Forever

     °repeat until hands empty

          -Find tree soil

          -Move to tree soil

          -Use item

     (End of repeat)

     -Find nearest shovel

     -Move to shovel

     -Pick up shovel

(End of forever)




This is what my digger bot's script looks like.

Mr_Mobius_Your script didn't work. The bot has nothing in its hands (and inventory) and it is stuck in the first loop.


This works for me, but I have them grab it off of the ground instead. :/

(Edited 1 time)

Ok. Sometimes, save/load unlock the situation

Good, because I see nothing faulty with the script... good work!

(Edited 8 times)

TheRuinGuardian21, I wrote what I done ;) (Judy is the blue bot and it's stuck at the first loop with a shovel in its hands)


EDIT: I think I understand the issue. The "hands is full" just test if there are empty slots in hands, not if the bot could take more in hands (that is a mistake in my guess). If the bot cannot take another thing, then the hands must be consider as full.


EDIT2: For logs, there are still empty slot and the bot is not stuck with the "hands full" test. So maybe it's specific with tools.

One can only carry one tool in their hands, and it takes up one out of the bots 6 slots, so of course its hands are not full, hence why it keeps trying to take more tools.

(Edited 4 times)

Feedback:

Now with the repeat until loops you can program the bots better, but you can only choose from 2 options: until hands full or until hands empty.

I know there will come more options in the future and thats ok, but they will always repeat until a specific "thing" is true.

In short: the repeat until loops are going to be for specific things.  (less thinking,  only the options given)

My idea:  if you add repeat x times loops you can use it for various things. (more thinking, all the options you can make with this)

i have a pink clay ficer  ???????????????????????
what?????????????????????

Texture is reset when hover the mouse cursor on the pink

also i think have cartcs, weart and power/fourn for food is a good idea

seelding tadys sill cout even if not build

Translation: Seedling trays still count, even if they're not built.

ty i can't spell

XD No problem dude!

(+1)

Hi, please change the rule for Foundation operations. Don't record the exact one foundation, but just the type. Currently the bots are useless for bringing materials to building sites, as they will only do one building and then keep bringing materials to the same place. This would be especially useful in that I wouldn't have to build fences manually anymore.

yes! I second this. It's so lame I can't autobuild.

it worked in the earlier versions but not anymore

meaning they already did but removed it for some reason

I have a feeling the removal was an unintentional byproduct of the new scripting.

I know! I had to build a fence all by myself!

Developer(+1)

Yes this is definitely a pain to build. And yes it worked in the previous version but the change over to the new scripting system has stopped it. This is something we'll be adding back in soon.

(+1)

something wierd, clay furnaces are pink when I load a save, they return to normal once i scroll over them.

(+1)

Same here, Windows 64-bit version

Bug: You can't delete metal workstations. It just tries to delete the floor under it.

Well I deleted my metal workstation, what do you mean?

Idk, I've never been able to delete metal workstation. 

Developer

This will be fixed in version 4 on Monday. Thanks

i encountered a tiny bug

apparently my bot wanted to start a space program and started slowy glitching up into the sky

i would've taken a picture but the bot went off the screen.

Hello! I seem to have a wonky little thing where my little worker bots can never seem to find the tree hole they just dug. I thought it might be a too far away thing...but this happens even if the hole is right next to them. :(

If the bots are stuck on a 'look for [x]' section of their script, you should be able to see a red circle.

It only looks for [x] inside that circle, and not in a radius around themselves.

Cheynas, 

I can't seem to trigger the red circle that you mention, but it does seem to be that the "fix" is to just dig a few random holes until it likes one of them. So I've just got a few extra holes dug around and that seems to be preventing the issue. 


Thank you!

(Edited 1 time) (+1)

Hello, I love your game and i think it will come really far but,

sometimes items will appear under stuff,

I have only seen this once when i was recycling a robot,

a plank went under the arrow thing , path  whatever it is called , I could still reach it though.

Also, what does a metal pole do?

I have a feeling metal poles will be used for metal bots, along with metal gears

Bug: The general storage does not have a cap on the amount of items that can be put in them. it says out of 1000 but it still accepts items beyond the cap.

Bug: When certain items are put into the general storage (Like a wooden shovel), it does not show the amount stored. It just stops after the equal sign.

Bug? or Feature?: If you have multiple general storages they share an increased cap and share items. Is the cloud storage a feature? An example of this is if you make one general storage on one side of the map then another on the other side of the map and put on log into both of them. They both show 2/2000 logs. 

Bug: Max move distance. Idk if its intentional or not, but the character has a maximum range of movement and will not path any farther outside of that limit. I didn't test to see what the limit is but its really annoying when trying to move back and forth across different portions of my base. 

I been playing this game quite a lot and I love the idea of it. Hopefully it gets better and bigger!

Addedndum to bug #2:
If hovering over a storage with tools in it (that doesn't show quantity inside), it will suddenly start showing amount inside when that number changes (such as adding or removing a tool inside).

After that, it always shows the amount of tools inside.

Hey loving the game at the moment awesome concept, some feed back/suggestion 

Can you add a control to quick access items in inventory like a hotbar or the mouse wheel for times when im running around with 6 different tools and need to switch between them

Will Logic statements be added to bots the same as repeat and forever buttons like If, then, else, or, untill, i understand that is a big task but an easy one that would be the most help to start off would be or eg.. find plank and put in storage OR find poles put in storage.

(Edited 1 time)

Numbers on the keyboard would be optimal. I agree with you on both accounts!

Developer

Thanks! We'll be giving the entire UI an overhaul soon including the inventory so a quick bar will be investigated.

Yes we'll be adding lots of goodies to scripting like logic statements. 

I think I found a bug: sometimes when I remove something from a general storage the amount of the object stored remains the same, so I have access to infinite amounts of it.

why on mac i can't build anything

(-2)

this really ruins the games because every time i watch videos they build when i can t

(+2)

I've found that due to the new update, while it is awesome, you can no longer program bots to build structures. They simply go to the "foundation" you told them and back to a storage crate. Not going to the next foundation to build it. Please fix this!

Developer

I ran out of time for the last version so this will be added back in at some point. Thanks.

Looking forward to it!

Hello. First of al I want to say, GREAT WORK. I think even in this early stage you have done some great work, there is still some work but you're getting there ;p. Te game has a lot of fun aspects.  Also i'd like to ask if it is in any way possible to remove bushes? If not, I'd like to ask you to add a way to remove them (or place them somewhere else). Again great work.

(+1)

that depends on what bushed you mean, if its the ones that the cows eat then yeah I agree those need to be moveable or something. But there are the other type or bush things that can be removed with a shovel as can the mushrooms.

Thanks i was indeed talking about the bushes and mushrooms (stupid of me for not thinking of the shovel). And indeed the grass should be movable.

(Edited 1 time)

Here is another bug. You are able to place fences and maybe other objects touching the edge of the map, but you cannot put resources into them.

Developer

Added. Thanks!

I just encountered a wild bug. If there is only one boulder and you tell a bot to mine it, it'll mine it once then go afk.

(Edited 2 times)

The bots are a little buggy sometimes.. What worked for me is having him mine where 2 boulders are close to each other. After a quick save & load he began mining them both.

When I tried adding a bot they both went afk after mining 1 as you said.

(+2)
trees that fall on the seed farm wont be picked up by bots. when i manually pick up them from afar they teleport to my hand no matter the distance.
(Edited 1 time)

I get this bug with  storage buildings too

@Ledjlale Same this as both of you.

Developer

This is a known bug. Thanks!

Can anyone help or is this a bug

this as far as i can see shoul work

the bot will cut the trees until axe breaks then will go to the axe storage as it should

it will pick the axe up but just stay there, it will not return top begining   (am i missing somthing)


(+2)

Im not sure why it isn't working because it really should be. But you can just take the go to storage and pick up axe commands out of a repeat because its in a forever loop and the bots can only use one at a time. That should work no matter what cause it'll just pick up one axe.

(+1)

Save and close the game. Start and Load that usually fixes it.

(Edited 1 time)

removing the pickup axe bit from the repeat did work  thank you it was doing my head in :)  But the save and reload did not but thank you anyway.

I did Forever[RepeatUntilHandsEmpty(Find nearest PineTree,Move to Pine Tree,Use held item)Move to General Storage,Take from General Storage] and it worked for me.

(Edited 1 time)

Sometimes, a cereal crop cannot be farmed. Bots (and player) try to farm it but it will never disappear (and then they are trying forever)

Here is the save file. The player stand between buggy fields : save folder

Developer(+1)

Thanks for the save file. Added to the bug list

I encountered the same bug. Glad to know that someone else saw it too!

I had this bug on several tiles, I fixed my save myself (recycled workerbots dedicated to farming, and removed wheat crops in test.txt).

Not sure, a cow probably eat the wheat before workerbot take it. I see (in test.txt) several workerbots (dedicated to take wheat) had tasks on these tiles.

Possible bug (or me being dumb) Can't seem to delete the metal crafting bench.

You might be hovering your mouse over the wrong part of the metal craft bench, because for some reason, half of it isn't collidable.

Developer

This will be fixed in Monday's version

If I may make a suggestion...

While I think I saw here suggested already the ability to change the work area of a robot, I was thinking perhaps being able to assign a robot to a plot. i.e. the lumberjack, hauler, planter, digger, and gatherer of a tree farm are assigned to the plot of tree soil, instead of a radial area. (Even sweet would be both options.)

Either way, it is rather annoying, because it's easy to end up in a situation where you have trees being planted and chopped in an area, but no-one picking up the logs, or trees that could be planted and chopped in an area, but there's no holes to plant them in (see here). 

Developer

Yes we need to spend some time looking at a solution to this problem. We have a few ideas but we need to explore them. It will be fixed!

Sweet. Looking forward to more! 👍

(Edited 1 time)

Hey I found a bug that has probably been mentioned before but if you drop a plank in uncut cereal, it's hidden beneath it and is hard to see and difficult to pick up. Also, say you drop an axe or any tool on a tree, you have to cut that tree down before you can receive it again. Thanks! Awesome game!! 

Probably because the plank is smaller than the uncut cereal, same as poles. Also, I have dropped tons of axes in trees, causing a waste of resources until it's cut down.

Developer

Added. Thanks

There is a visual glitch where clay furnaces turn bright purple when you first get on the world but when you hover your mouse over it, it returns to normal textures

Same. :/

I have build everything and my map is 100% automated   everything working very well every one happy and fed on auto all tools being replaced when broken auto  and no real bugs for me    my only sugestion so far is to make them stop mining and cutting trees when there is a  self set amount in storage as  they stack up so high its abnormal   and i must have 2000 logs laying about  (such a good and clever game tho)

Developer(+1)

Thanks. We'll probably be added some branching conditions to the scripting system that check things like how many logs you have.

Hey I came across an issue where robots were a little buggy when programmed to plant cereal seeds. Sometimes they will plant it however it seems that most of the time they would just walk over to the tilled dirt and go back to pick up another seed without planting the first one. Idk if I did it wrong or if it is a bug.

Developer

This might be the 'repeat' scripting bug  that's affecting any sort of repeating. Hopefully this is fixed in Version 4 on Monday.

I found a bug where I can put anything on the flooring but then I can delete the flooring & things like sawmills & workbenches will stay there.<font></font>

Developer

This is a known bug, but thanks!

(Edited 2 times)

You can't highlight/click the right side of the metal workstation. Also when a cow comes to eats your cereal you just harvested, some of the cows stay on the cereal without eating it.

Developer

The workstation bug will be fixed in Monday's version. 

The cow bug I'm not sure about it. They have odd behaviour at the moment and won't be staying like that.

Thanks!

Hey Denki, when I go to click on the Autonauts.exe it will load for a little bit and then stop and say there should be a Autonauts_Date next to the folder. How do i fix this problem?

Developer

When you install the game there should be a Autonauts_Data folder inside where you've installed it. What method did you use to install?

Nevermind I got it to work. Thank you for trying to help

I found a bug, not sure if it is intentional or not, but I was programming a bot to pick up a pickaxe, and I got rid of the "find nearest pickaxe" command, and simply told it a location and then to pick up pickaxe. I clicked run on the script before dropping a pickaxe, and the bot picked me up! After that, there is nothing you can do except exit and start again. 

i think i found a bug i accdently buil a hut in the middle of my tree farm but he workers cant get the logs on the huts house so it just keeps sacking like crazy until i have to manually put them all down wich tkes forever

Well i have a problem a bot decide to pick me up and give me a lift but now im stuck. I can put my self in my own and other bots their inventory but cant give commands any so cant be dropped down. dont know what to do about this help please?

Maybe try putting yourself into your inventory and then drop yourself by clicking right click

tried it dint work

(+1)

Nice demo. After poking around a bit, I was missing Factorio-style circuit conditions for the bots. Like if pole < 50 then do this and if plank < 50 then do that. 1000 seems like such a wasteful amount to build up to, but I suppose at this stage it's more of a little detail than a critical necessity.

I botched charcoal production somehow (I'm still not sure how exactly, probably clicked a few too many times when doing the script) and went off to do stuff and after a while I came back to see 228 logs in what was supposed to be the charcoal warehouse. Is there an easy way to empty it out? I guess I could build another storage next to it, but this was sort of a surprise log storage that might be useful too, if it wasn't in the location it currently resides at.

Perhaps the general storage could rename itself after an item has been put inside. Then in the scripts you would see commands like "Move to xyz storage" instead of everything being a general storage. That would make debugging easier at a glance as well.

Developer

Circuit conditions will be added at some point along with a load of useful scripting stuff.

If you delete the Log Storage and rebuild a new Generic Storage it will be fine. Any logs inside the old Storage will be kept. Alternatively you could teach a worker to take them out for you.

Yes we'll be updating the entire UI including the Storage rollovers at some point.

There is a bug where the furnace (charcoal maker) turns bright pink when after you just loaded your game. But when you move your cusor above it it returns to normal texture.

Developer

Added. Thanks

I found 2 bugs

1. You can give a bot to himself making him disappear. You can do this by pressing space and then clicking on the bot to make the menu on the left pop up then click on the bot to pick him up and trade.

2. You cant delete a metal workbench for some reason.

Developer

Both of those will be fixed in Version 4 on Monday. Thanks

(Edited 1 time)

Another bug i found just now is that bots get stuck in gates what happened to me was a bot in the cow pen is out of charge 2 bots come and charge it but 1 gets stuck in the gate and the other bot was waiting for the 1st bot to go trough the gate i stopped the first bot and i was able to pick it up remotely(just like the tree inside of a building bug)

Edit: I have 2 bots that charge others so they charge eachother

Developer

Thanks. Added

I think I've found (one) cause of the save-button-not-working bug: feeding a worker into the recycler while the worker is holding something

as soon as I do that, the game will no longer save

Developer

Exellent! Thanks for that. Added

Denki I love the game but my game is broken the dirt is black pls resolve and response

Developer

Thanks. This is a known issue and will hopefully be fixed in Version 4 on Monday

i dowlanded it on 32 bits

is your computer 32 bit or 64 bit

If you click fast the location you want to go to you will go there faster by teleporting short distances

Developer

This will be fixed in Version 4 on Monday

Glitch: when my robot digs holes they can dig under simple flooring that has dirt under it. Which means they can plant trees from under my base.

Developer

Thanks. Added

thx so much 

(Edited 1 time)

Sometimes when I tell a robot to pickup 4 planks(because of how much the crude bench saw can make at one time) the robot tries to get 6 and  it stops them from doing anything untill you give them 6.

Did you make it untill hands full if yes then bots have 6 hand slots not 4 like the player

It was without repeat until hands full

then maybe restart your game but idk it should work

I gathered all the folks but 1 bot cant keep up with feeding them all so i kind of failed because another bot will try to feed the same folks and drop the food instead

Denki my computer is on 32 bits but if u remember me im the guy where the game dirt is black and the clay and metal de portements too pls resolve it for me pls man

I<3TheGame

Developer

This will hopefully be fixed in Version 4 on Monday. Let me know how it goes.

Denki pls resolve my bug my game dirts is black and the clay water too pls resolve

I love the game P.S My computer 32bit i dowlanded on 32bit

He arleady said he would try to fix this bug in version 4 on monday

i found a bug where a worker bot picked me up and i had to reset because i can't do anything can you plese fix that so worker bots can't pickup players

How did you do that

This happened to me too. I programmed it to pick up planks, and build foundations (fence). I was probably standing on the pile of planks, and might have had a plank in my hand.

Hello! Great game! I think I found a bug, though.

I have the following setup:


The first General Storage contains planks, the second poles, and the Basic Workbench is set up to create wooden axes. Works like a charm. Andy chops wood until his axe breaks. Since his hands are then empty, he goes to the Storages, grabs the components, crafts the new axe, and picks it up. Awesome.

I'd like Andy to just keep doing this, so I want to embed this whole setup within a 'Forever' loop. That's when it all goes wonky, though. I've tried programming Andy in several different 'orders', but none seem to work the way I'd like. Adding a single chopping action and then going to create the axe works. (It doesn't work out, because Andy has his hands full of axe and can't get the planks or poles to create the new axe, but he seems to go through the motions correctly). Then adding the inner loop of 'Repeat until hands empty' again doesn't work: the inner loop seems to be ignored then.

For now I just poke Andy and tell him to 'Go!' again when he's waiting at the workbench with his new axe... am I expecting too much?


I did the thing on your screenshot for a shovel bot and looped it forever and it worked but i dont know why your program has issues

Not sure if bug or feature, but a bot ordered to 'Find Nearest Tree Soil' will ignore Tree Soils adjecent to a Tree Seed Hole.

I assume this is a feature to make sure the bots don't 'paint themselves into a corner' with trees...

The seedling tray seems useless, as you can just plant tree seeds in a tree seed hole. This is unless the seedlings that have been in a tray grow faster, but I haven't noticed that.

General storage seems fairly useless as well, as it seems possible to stack infinite items on the ground.

Also general storage limits are not actually enforced.

huge towers block vision

Sorry if this has been mentioned before, but I seem to be having a problem with cereal crops. I have these 2 patches of crop that my bot keeps using the scythe on and they won't go away, and that makes my other bots not do anything because they are waiting for the bot to finish his job. Saving and reloading seems to break things further, because the golden cereal crop turns into the low quality crop, and the bot keeps trying to work on the same 2 squares. Both squares will not turn into bale cereal, so the bot continues to switch back and forth.

I think this was mentioned and hopefully it will be fixed in version 4

Bug found,Crude worker bots will teleport around the player and won't do anything

How?

(+1)

Feature request: start menu if there are saves, and multiple save slots. I enjoy playing the game as do both of my kids (9 and 11 years old, great game to improve coding smarts!), but without the save slots I now have three copies of Autonauts on my laptop ;)

Developer

Yep this is definitely something we'll be adding soon. Thanks!

:( Actually, I just found out my solution doesn't work. Even though I have 3 copies of the game installed in 3 seperate directories, the save game is somehow shared between the three copies. One very upset 9 year old found out his daddy 'purposely' (not) overwrote his save game. All the more urgency for multiple save slots, please!

Developer

Sure. In the mean time you can 'manage' your own saves by keeping copies of the save file. You'll find Test.txt in the C:\Users\Aaron\AppData\LocalLow\Denki\Autonauts folder (on PC)

Works great, thank you!

Developer

Also please bear in mind this is a super early version of the game and is far from stable or complete. We've put it up on Itch to get people's feedback on features. It shouldn't really be treated as a whole game yet.

Totally aware of that! Thanks for your help and your hard work!

Developer(+2)

I can confirm Version 4 on Monday will have multiple save files! I'm so easily persuaded :)

Thanks!

No wonder he's sad. His feet got wet. (Probably not supposed to spawn there).

Developer

Yes I've seen that one before. Very odd. I'll add it to the bug list.

Went through the past few days of bugs. Most of my bugs have been noted by others. But there's a few that I didn't see mentioned.

1) Rapidly inserting items into the recycler makes them invisibly stack in front of it. The bots notice them and can pick them up and restore them.  Or saving and loading will restore them.

1b) Placing a bot that is holding items into the recycler permanently deletes the items he is holding.

2) I saw a post about cereal crops that get stuck. But I have it happen with trees as well, didn't see anyone mention this. Can't interact with it. Saving and Loading causes the stuck trees to become invisible. I'm not sure how to reproduce this but it seems to happen when you or the bot doesn't finish harvesting the tree. (I did get some buggy behavior trying to recreate this one, telling the bot to stop chopping the tree when he is in the middle and trying to pick him up. He would get caught in a loop chopping the tree until you tell him to stop.) I saw this in occur in a YouTube let's play of it, so it's probably pretty common, I can get you the video and time stamp if interested.

3) Quasi-bug: some weird scripting stuff that's not intuitive. For instance if you teach to get something from a general storage, it has 2 commands, move to general storage, take from general storage. In reality it seems to be "move to selected general storage", "take from selected general storage" as you can't mix and match.  In contrast something like a stick seems to be "select nearest stick", "go to selected item", "pick up selected item" The gui doesn't communicate this at all and took me a bit to troubleshoot what was going on. It seems to work better if you don't move commands around much.

4) Minor bug, if you pick up the bot while teaching him it messes up the gui, you can't place loops. Though the bot continues receiving instructions.

5) The bots don't make a check after selecting an item that the items still exist or is nearby when they get there (at least with some commands). For instance if they are to chop a plank into poles. If you pick up the plank they selected and walk off, they get turned into poles anyway (where the plank was before you picked it up) and you are left with an invisible plank in your hand that you need to drop (can be used to duplicate items). If you chop the plank first, they get stuck into a infinite chopping nothing loop. Amusingly, the axe continues the chopping animation even when taken from the bot.

That's all I can think of right now. Pretty fun little game, excited to see what you do with it. And looking forward to seeing some of the updates that you have mentioned, explicit work areas, more conditional statements, etc.  I also find myself wanting more ways to input instructions, maybe choose from a list. Or copy and paste instructions into and out of a notebook or something would be nice. 

Anyway, hope that's helpful and good luck!

Developer

Excellent work! 

1) This is new. Added.

1b) This is known thanks.

2) This is known thanks.

3) Yeah the clarity of the scripting isn't great. However this is just the very first attempt to get things going and we'll be refining as we go.

4) This will be fixed in Version 4 on Monday.

5) This is new though we have a related bug already noted. Added

Thanks for these!

I''m not sure what's causing it, but for some of my basic workbots they have started not listening to repeat commands.  I could switch workbots and the same set of commands would work, but they wouldn't realize their hands were full and continue to repeat. They have now started to glitchingly jump back an action and run even without a repeat or forever bracket.

Developer

Thanks for reporting. Hopefully this will be fixed in Monday's build.

Hope I'm not being too pushy with the feature requests, just see it as feedback and do with it what you will ;)

The 'red circle' that shows the bot's working terrain apparently is centered around the location of the first item you interacted with when you were teaching the bot (i.e. if you're teaching it to chop wood, it will only chop wood in a certain radius around the location of the tree you chopped to show the bot how). It would be nice to have more control over this; for instance by clicking on the 'Find nearest x' entry in the learning dialog, and then clicking the position on the map you'd like to be the center of the bot's working area. Not too hard to fix this up when you're working with inanimate objects (e.g. just drop a log where you want the center to be, then show the bot how to pick it up and bring it to the storage), but I found it very tricky to set the working area I wanted for my bot-recharger-bot. Then again, maybe that's how you want it ;)

On a related issue: the 'Find nearest x' has the bot go to the 'x' nearest to the center of its 'red circle'. Sometimes this makes for very counterintuitive behavior, where for example a bot ignores a tree that's right next to the one he just chopped down, to walk to the other end of its 'red circle' work area where a tree is a fraction closer to the center. Reading 'Find nearest x' I would find it more logical for the bot to find the 'x' closest to its current location (while still within the red circle, to prevent it wandering off too far).

Perhaps this could be added as behavior for higher tier bots; it'll make them 'smarter'.

Developer

No problem.

Yes we have plans for a much more flexible working radius system.

Yep I was aware of the odd Go To Nearest behaviour. As usual we get something working first just to get people using it then we go back and refine.

I found a bug where my bots won't  dig the bulders

they do if u do it correctly

How do I do it correctly?

(+1)

Cows are eating nothing and emiting waste!!!!

I would like aesthetic features ; flowers, paths, road, wall and door, etc.

I reach the limit of dung potential ^^

https://www.reddit.com/r/Autonauts/comments/6p3o25/welcome_to_dungtown/

woah nice building skillz

(Edited 1 time)

 I made a new save now that i knew what i was doing, i made a robot and programmed it to go grab logs and put them in the storage and... it picked me up http://prntscr.com/fzdlrv if i go to trade it says hes holding 'autonaut' i can place 'autonaut' in my inventory and my character just disappears until i place it back http://prntscr.com/fzdmtd . weirdiest thing ever

 Also i would suggest adding like if/or/and functions/options for functions to higher tier bots :D 

(Edited 2 times)

If i remove this comment it removes my previous one for some reason so i wont :)

(Edited 1 time)

Some of this is probably a bit repetitive, but stuff I'd like to see in the game:

  • Show the cost of items before laying them down.
  • I think a "left click action / right click cancel" approach would work well. I like the way Oxygen Not Included does it.
  • Have a way to show the "tech tree."
  • Maybe a bit more feedback as to why a robot is failing.
  • Have a way to cancel construction of a building in progress.

EDIT: It would be nice to set a limit on general storage containers, so my bots aren't doing things like creating dozens of axes.

sd

I don't really know if this has already been suggested sorry if so. But have you considered adding wildlife (Pigs/Boars, deer, bears and such) and hunting tools (spear=meat, bows= hides-->leather...). With these new resources there are options for new machinery aswell (meat grinder, tanning rack ...) the leather and hides could be used for when you have added seasons (i saw you were planning on adding them) to keep the residents warm and happy :) during winter. Great game already BTW looking forward to see your additions.

This game has potential. My biggest problem at the moment is it is failing to save my progress.


Found a bug in version 4 (incorrect recpies) in the clay furnace the recipe for charcoal is 1 charcoal and the recipe for metal is 1 metal.

Developer

This is fixed. Just update again and all will be good :)

Awesome,  is there anyway to know what the current sub-version you are on compared to the most resent, its difficult to know if theres any updates .

Developer

No, we need to start doing that.

Developer

Though if you use the Itch app it will tell you if it needs to be updated

Version 4 Bug: If you use the dragging feature when building things like fencing, you can still build blueprints in the deep water that you can't walk in.

Developer

Thanks for the info. This is a known bug and will be fixed in the next Version 5 on Monday.

After a bit more playing, I definitely want to have a way to set a more specific "work area" for each bot. Is there currently a way to reset the work area of existing bots?

Idk if this is a bug or if its intended, but I noticed that the crude shovel for example can dig 20 blocks of clay or tree soil but it seems to be able to dig infinite bushes and mushrooms. Like I said, Idk if this is on purpose or not but I figured I should bring it up.

Developer

Yeah this isn't a bug, it's just not implemented yet. Well spotted. Added thanks

One feature I would love to see and I think many others would love to see would be if the game could load up your last saved game automatically on startup. Its not something too important but its a little convienence thing that I think a lot of people would love if its not too difficult to get working.

Developer

Good idea. Added.

Possible bug: When you hover your mouse over tiles with name plates and blueprints/buildings with nameplate things, then you move your cursor over the name plate. you sometimes can't move your camera around. Its not very consistent to put your cursor over the nameplate though.

Developer

This is a known bug. Thanks!

(Edited 1 time)

Hey Denki! Love the game and not sure if this a bug or not but sometimes I hit the save button in order to get rid of a bot being stuck on my head after picking him up and pressing space (Pretty Sure that's not supposed to happen) but it loads to a state I was in ages ago even though I just hit the save button.  This is in Version 3 not sure if you fixed it already.

Developer

I think version 4 will fix that problem. Give it a try !

I will when I get Itch.io app down on my pc

(Edited 1 time)

Hey Denki! Just wondering if there were any plans to allow Bots to recycle one another? Like having a Basic Workerbot recycle Crude Workerbots and so on and so forth? Or maybe a copy/paste feature for programming as an ease of Life thing? Im sure im not the only one who'd love that feature!

(+1)

When trying to place a blueprint (simple flooring, for example), it won't let you do it if your character is in the way. This is weird, as once you have placed it, you can walk right through it.

(Edited 1 time)

Idk if other people are experiencing this issue but sometimes when the bots are doing things (picking things up, chopping trees, digging holes, planting trees, etc), they walk a really long distance to get to their next job even though there are closer jobs for them to do. This doesn't happen all the time and they tend to ignore things right next to them I noticed. Makes things really ineffiecent imo.

Developer(+1)

Yep this will be improved as we go.

(Edited 1 time)
These five fences to the left of me are nearly unbuidable if the flooring im standing on is a blueprint. If you remove some of the blue prints of the fences you can end up building some of them, but not all of them in the end. I found that the only way I can build the last fence (or any of them if I don't mess with it) is if I either delete the blue print of the flooring im on or build the flooring. By far one of the most peculier bugs I've found. (EDIT): I think I might have figured it out. When the player stands on a blueprint of the flooring, he usually refuses to build anything. He almost always tries to pathfind off of the blueprint of the flooring in order to place items into another blueprint adjacent to the flooring.. 

Some problems or bugs with clay pots (probably related) :

1/ If we had stack of several clay pots (with or without another things), we can hover and highlight bottom pot only.

2/ If we leave one or several clay pots on bush, we can't click them any more (but workerbot can find and take them).

3/ If we leave something on a tile, and leave one or several clay pots on top, we can't click clay pot any more (but we can highlight and click another things into the stack which are under or on top of clay pots).

I would like create new city named "Westclaytown" :oP

Developer

Great thanks for that. These will be fixed in Version 5 on Monday

(Edited 1 time)

Hello, i found a bug. Sometimes weed grows on the cereal crops, and that makes a tile impossible to harvest, or do anything. i can use scythe on it, but it doesn't do anything. And 1 more-when i tell workers to seed a tile with an item on it they go to that tile, come back, and get stuck.

You can remove the weed with a shovel.

What r metal gear and metal pole for?

I have a theory that they will be used for better bots.

1 more thing-can u let us make an ocean bridge with simple flooring? it would be great!

I beg of you please change the sound of a furnace while it's not doing anything. It feels as if my earphones are rubbing against each other and is really weird.

so somehow, my regular worker happened to pick me up and I can't get him to drop me. I tried trading with him and put myself in my inventory which bugged the game out super hard so I can't even play it any,ore. When I load it just takes me to the edge of the map and leaves me there stuck in a softlock

Developer

Oh dear. What version are you using?

im using the latest version at this time.

Developer

What's the version number?

version 4

Developer

Ok I'm not able to make it happen but if you get it again see if you can spot what the worker was doing at the time. Thanks

well I told the worker to go pick up a crude worker and put it in the recycling machine and set that on repeat. I happened to have a crude worker in my hands at the time to go and recycle it myself but the worker picked me up and I couldn't get him to put me down. I traded with him, put myself in my own hands and my character sprite dissappeared, so I saved then loaded and that was when the game broke

Developer

Ok thanks. I've added your description to our bug list and I'll look into it.

Thanks my man

(-1)

love your game just wish maybe it could be a little hard I would suggest the next update might have attackers and maybe they could have babies not sure where you want to go with this but I think this is the next big thing I LOOOOOOOOOOOOOOOOOVE AIs

(Edited 2 times)

Hi,


i'm new here so please be patient with me.

I programmed a robot to shovel a tree seed hole, put down the shovel, take a seed, plant it, take the shovel and repeat.

Sometimes it stucks at finding nearest tree seed hole although it has dugged one before.

Version 4


Edit: I can make Crude Gear and Metal Gear but the Recycler needs a "Gear"? Found it within the wood router - it's a bit confusing.

Love this game already, BladesAndRazors

I wouldn't recommend having one bot do plantign and shoveling. As you noticed it bugs out (a lot) and its super ineffiecent. You lose a lot of through put doing it that way. I recommend having one bot chopping trees, one bot shoveling holes, one bot picking up acorns and putting them in seedling tray, one bot taking seedlings out of tray ind putting into hole, one bot to pick up logs and store them, and one bot to auto recharge the others. Thats a fairly effeicent farm to get going then you can add bots where needed to increase production.

if you're holding a bot and attempt to reprogram a different bot you lose the bot you're holding but it stays above your head. 

Developer

Which version are you using? I think that was fixed in version 4

(Edited 1 time)

Hey When i play autonauts the whole ground is black except for top like grass cereal crops tree mushroom and etc the building tool is fine but the Whole ground is just all black version 3'Brad' i am playing on 32Bit pc k reply K?. GianM145, over.

Developer

Yep this is a known bug but I can't make it happen on my machine so I'm finding it difficult to fix.

Hello so i am wondering i got a bot stuck ontop of me how do i get it off my head

Developer

Right clicking not working? What version are you using?

When you open the teach menu of a robot while holding another robot the robot you were holding will become glitched and you will not be able to drop it, forcing you to reload the save and loosing the robot you were holding
Also, for some reason I passed the 1k limit of the general storage (at least for poles)

Developer

Which version are you using? This happened in Version 3 but should have been fixed in Version 4.

I had that problem in version 3 but once version 4 rolled around it stopped happening, always try to stay with the most recent update.

So after I laid out my huts I wanted to move some around but when I deleted a hut with a folk in it the hut got deleted but I still couldn't move the folk. My bot still fed him even though he wasn't attributing to the overall folk/happiness count.

Developer

That's a known bug thanks.

(Edited 1 time) (+2)

A couple of things I noticed farming:

1) Weeding is done with a shovel. I'd expect the hoe to be used for that, but that tool doesn't seem to have a function, while shovels are used for both digging tree holes and weeding.

2) In the above screenshot Gary is the bot indicated with the white square. While there is a last weed within his red circle work area, he's not able to find it, apparently.

3) Once fertilizer is applied to Weeded Soil, it turns into Soil. No matter how much you plant and harvest from that Soil, it stays Soil, apparently having infinite nutrients and never needing more Fertilizer. So right now we will never need more Fertilizer than there are 'farming plots'. (Hence the bored fertilizer carrier near the windmill). Suggestion: change 'Weeded Soil' to 'Barren Soil', and have Soil turn to Barren Soil after a couple of harvests.

4) When Cereal is fully grown and harvested with the scythe, but not yet picked up, 'seeder' bots will see this plot as Soil again, and try to plant a seed there. The game won't let them until the cereal is picked up, and they will stall. It would be great if they would try to 'Find Soil' that is not blocked by a cereal instead.

5) While technically not wrong, the term 'Cereal' is usually used for processed grains (breakfast cereal, 'cornflakes'). Most people will probably call the stuff that grows on the farm 'Wheat'. I'd also call the 'Cereal Seeder' a 'Wheat Thresher'. A hand tool to do that work is called a 'Flail'.

6) (Not just farming) Storages of the same kind share a resource pool. This allows for a very convenient transport system, instantly teleporting goods from one end of the island to the other by putting resources into one storage and taking it out of another. This just seems like 'spooky action at a distance' to me, though  ;)

Developer

Great work. Thanks!

No problem!

Lol my entire automation would fall apart if magic storage was taken away

While using a shovel, the screen wips up/down. 

What are the options for the teach screen? in example: can I make a step optional ( for example: 10 seconds no pickaxe available, skip to another step / break loop ?

(+1)

can i make request in here..?
==> adding "copy&paste"  function in bot can be awesome

and is this bug or not?

the function on this 2 bot is "shared"..

Developer

Nope that just happens sometimes. Thanks

It's just the names. There aren't many names to start off with so some bots have the same name, but you can program both of them differently.

(Edited 1 time)

missing graphic of wooden bucket when i pick up from tall "pile up" object

Developer

So you had a big pile of buckets, took one out and it's not visible? Can you do normal things with it like pick up/drop/fill?

nope nothing i cant do with it, or even destroy it..

but the texture reappear after switching it to inventory and take back to main hand, but the problem still same, still cant destroy it.

i didn't try anything else though, because i restart the game before saveing it ,sorry.

Developer(+1)

Yep copy/paste is on our to-do list. Thanks.

Hey,

is there a way to show and change the working radius of the workerbots?

Developer(+2)

Not yet but we're working on that.

(Edited 1 time)

Hello,

here is a List of Bugs i have encountered in Version 4:

  • Storage Limits dont work: Bots will ignore the maximum Storage. So you cant create Bottlenecks e.g. limited Stick production.
  • Workerbots dropping Folk (via "drop all") houses them outdoors: You cant pick them up anymore and they start to request Food.
  • Scooters: Bots dont seem to utilize Scooters. And should they really work in water?
  • inaccessible Items: Building close to a Forest often results in Logs and Acorn dropping inside the Building and become inaccessible, stacking over time.

Suggestion i got:

  • Storage: Keep the Type, after the last Item was removed, to decrease Micromanagement.
  • Gate: Maybe add a Player-Only Gate to restrict Bots to a Fenced Area. (it can be quite a Task to fix Farmers)
  • Repeat: The Option to repeat X times would be nice.

Keep up the Good Work

Developer

Great, thanks for those.

My suggestion for limiting production is to just grossly over produce like say have them make something like 1000 poles let them go a little past and them turn off the bot that makes the poles until it dips below 1000

(+1)

Hey there!

Been fooling around for a couple of hours now (and yesterday, until 3am, it is so addictive to watch the army of little dudes destroy collect and replant a forest over and over again) and noticed a few things, most of them have already been mentioned by other but I will voice them as well:

  • Identification / possibility to name or identify stations and storage
  • A possibility to copy commands (and use the above locations or names for easy adaptation)
  • If the above can work, some sort of standard command book where you can store some of the copied commands for later use
  • Read inventory amount and and make a yes or no condition to continue (if product 'x' below 10 continue script, else wait)
  • Next to the "repeat" option a basic "if then else" construction (combined with the above)
  • Set waypoint that will be the centre of the workrange
  • A way to lock inventory type in the crates, so when the last one is taken it will not reset to nothing
  • Possibility to customize individual or groups of bots for easy identification

A small bug I found, when a bot runs out of charge when standing in a gate, the bot programmed to recharge it will not do it. It is possible to manually charge them. Also other bots will not be able to use the gate.


Keep up the good work! Can't wait to see what is next!

Developer

Great stuff! Thanks for all that.

I found a bug: When you put water into a clay furnace to make bread but then cancel the process, the furnace no longer allows you to use it. If you right click it you drop the items where you are standing. 

Also, I was curious if there was a way to delete structures? I tried most of the tools and can't find a way.

Awesome game by the way.

Developer

That bug should be fixed in Version 5 on Monday.

Also you delete structures by pressing the Delete key in Edit mode.

Thanks!

I noticed something strange with 'charger bots'. I use two bots per section of the map to recharge other bots, so they can charge each other if they run out of battery themselves. I've noticed that when one 'charger bot' runs up to a bot that's out of battery, the other 'charger bot' will stand still, waiting, until the first one has charged the bot that was out of battery. Then the 'charger bot' that was standing still will run up to the bot that was just charged, as well. It looks as if a bot running out of battery flags all 'charger bots' that have it within its working area, and then they take turns trying to charge, while obviously only the first one needs to.

Developer

Yeah I've seen that one before. Thanks

I'd like to suggest the spawn rate of tree seeds to be lowered, or some additional use for them created. Perhaps they can be fed to a 'Piglet', who also needs water (some higher amount of each) to turn into a 'Pig', after which you can slaughter them at a 'Butcher Block', using a 'Cleaver', resulting in 'Bacon', which the Folk will love (let's face it, who doesn't love bacon?)

Developer

Don't worry we'll come up with a use for them. We will try to make sure everything has more than one use.

you should have a small tutorial in the game

If you need help with any part of the game Autonauts FAQ should have you answer and if not them just out your question up and someone should respond fairly quickly

(Edited 1 time)

I had a bug where a weed & cereal grew at the same time. The bot was trying to harvest the cereal; but could not due to the weed.  I tried to harvest the weed or cereal and could not. 

BTW, this game is Pre-Pre-Pre Awesome!

Developer

Great find. Thanks!

I agree with "this game is Pre-Pre-Pre Awesome!" :3

Any chance we can have Bots pull out items from the back for a Storage Box as well?

(Edited 1 time)

would be good if you can use if statement for when dropping of items (Container has more then x, Container has less then x) container is the last used before the command? ;) that way i can tell my bot to only do 10 gears and not 1000 ;)

Also an shortcut key to move selected item from a robot to person storage/hand

Could we get the little red ball on top of the Bots head to shire bright red when 'working' and dark red when 'not working' or no power?

Developer(+1)

Yep we'll be improving working and teaching feedback soon. Thanks

A quick recommendation; There should be a way to get rid of any unwanted or excess materials. 

Also, this game is incredibly satisfying once players begin to automate.

Developer

Yep that's a good idea. Thanks

The command to "do this until the storage is full" doesn't seem to work for me. When I use that option it just keeps resetting--unless it's only supposed to do it if there's nothing in the storage?

Developer

Yeah it's not very clear at the moment what to do. It should do what's inside the yellow Repeat container until the Storage you've selected is full. Have you selected a Storage? (do this by clicking the small round button left of "Until Storage full")

I have everything in the repeat box and I have clicked a storage. I thought maybe forever command was messing it up but it still won't work. So this is how I have my bot set up who collects logs and puts them in storage : repeat until storage is full (all commands are in the yellow area) Find nearest log, move to log, pick up log, move to general storage, and add to storage. I also tried having him pick up logs until hands were full and in separate repeat box until storage is full . Everything works just fine until it gets to the add to storage part, also using it the old way of just adding to storage works. 

Ahh just reloaded and I see the little button you spoke of. It is working correctly now, other then the fact that he picks up 2 logs and only puts one in before going to get another.

Am I the only one where the cows don't eat grass in version 5?

Developer(+1)

When you see the "!" above their heads that means the need to be milked with a bucket :)

ok thanks

It seems that bots are no longer able to deposit materials into storage, so far it seems to be effecting everything ( Don't have any cereal things so not sure about that) my forestry are quickly descending into madness because the bots (and the player) can't put anything into storage and they get stuck at the storage because they can't put anything into storage so they can;t complete their loop

Developer

Oh dear, I've not seen that yet. Can you send me your level file please?

(+1)

I am so happy you guys are updating this game all the time and I think it would be an even more cool game if you had to eat and maybe there were some basic berry bushes you could farm :) thanks guys LOVE the game

Developer

Thanks!

no problem also I would like to mention a couple of bugs in version 5 "drew" when I saved and then loaded the cow lost all of his fatness or milkyness not sure what you want to call it and the seeds (not seedlings) vanished out of the seedling tray but other then that I think its good :)

Developer

Ah yes they're known bugs. I'm not saving those new things properly. Thanks!

np and I want to say that you guys are great devs you talk to your players to make a better game and you are updating a lot

Developer

Thanks!

Bots get stuck on planted cereal crops when attempting to detect weeded soil. kinda gets in the way of making a autofarm

Developer

Argh not good! Can you send me your level file please?

how i do dat?

Developer

If you're on PC go to a folder that looks like this C:\Users\Aaron\AppData\LocalLow\Denki\Autonauts and you'll find your levels. You may have to make your hidden folders visible in order to get to that location.

Same error here. If u order a bot to plant seeds He get stucked. 

make it so pressing backspace in edit mode can delete buildings. plz think about people with the reduced keyboards on laptops

Developer

Ah good suggestion! Added

(Edited 1 time)

Can you add ability to limit storage capacity per type ether in config or slider ingame from 1-x containers * 1000 that way i dont need a robot to do 3000 shovels and only 10 ;) or set tools to 10pcs/ box and the rest keeps 1000. 

works better now that the limit is 100 instead of 1000 xD but if you find time and if you want that add it but i am happy with max 100pcs per box 

Dear dev, i have been enjoying you gone for the past couple of days and i may have found a bug.

i came across it when i fenched off  my tree farm the bots in side needed to be charged by the other bots but i noticed that the bots on the outside recharged them selfs after they ran out.

so to test i loaded a new world and fenced in a bot that was programed to recharge other bots and sure and well the bots outside started to recharge them self. i also found that if you fenced of your seld you could recharge them remotely.

hope this is enough information and ill besure to look for other bugs so i can halp the game to be at its best for everyone.

Developer

Great thanks for that. Yes there's a bug in the route finding which affects Workers and Cows. Thanks!

I had a fenced off area with 1 gate with bots going in and out all the time, a recharge bot was pretty close to these bots, what happened was that the bot ran out of charge right as it got to the gate, opening it and making it impassable for anything else but not occupying it so it could be recharged, not actually sure if this was a bug but an interesting edge case anyway. simply adding a second gate fixed this.

Developer

Yes this is a known bug but it's a bit annoying. Thanks

There seems to be a bug where bots sometimes skip or repeat items in their to-do-lists and then get stuck when they can't complete the next ones.

This is most notable for me with a bot that I have set to make metal:
repeat:
    go to ore storage
    take ore
    go to furnace
    place item
    go to charcoal storage
    take charcoal
    go to furnace
    place item
end repeat
I often come by and he sits there, trying to put another ore into the furnace when in fact it would require only charcoal.This bot is the only one who accesses the furnace (no other bot and I don't use it manually).

The same thing happened when I tried to have bots first produce, then store wares (bring two logs to a furnace, then bring the charcoal to storage/ cut up a log and bring the planks to storage/ ...) - they just seem to jump around in their instructions sometimes. These ones I managed to fix by strictly restricting bots to one task (one bot puts logs into the furnace, the other takes the charcoal away), but that seems uneconomic and doesn't work well for smelting metal as the two bots who want to put in coal and ore often block each other.

So far I have not been able to observe this happening on-screen, so I can't pinpoint any possible reasons (i.e. running out of juice mid-action or being blocked by another bot traversing their target or something), but I'll keep an eye out.

Developer

Oh dear. Which version are you running?

v5

Developer

Can you send me your level file please? Preferably with the player next to the bot in questions. Thanks

Sure thing:
http://s000.tinyupload.com/index.php?file_id=06172969144112492196
(Didn't find a way to attach files here and you haven't listed an email I could find)
The bot in question is Dave, right above the player.

Developer

hmmmmmm. that's going to be difficult to catch. I left it running for about 10 minutes and everything seemed to behave fine but like you say it just happens at some point. I'll add it to the bug list but I can't really fix in until I've got a method of testing it so if you come across one please let me know. Thanks.

It seems to be in the interactions with other bots (i.e. them standing in the way, I guess), as this does not happen when I put him into his own little area with nothing but the two required storages, the furnace and fences all around...
Will try to find a minimal setup where the problem occurs.

(Also, I can now confirm that bots that are unreachable for the recharge bots get charged remotely^^)

Okay, it seems to be definitely related to other bots blocking their way:
I've now got a setup where he skipped the step of actually walking to the furnace and jumped straight to trying to insert the item!
http://s000.tinyupload.com/index.php?file_id=72337184487671410134

Developer

Ah that's a good clue. So being blocked causes the Move To to be ignored. Great that's all I need. Thanks so much for the help!

(Edited 1 time)

Need a way to destroy anything (we obtain too many stone or seed with new gameplay). I submit two new building below.

  • Incinerator: destroy anything which can burn (log, wood plank or pole, seed, wood tools, dung too, etc)
  • Breaker: destroy anything

I submit that these building take very long time to destroy something, most longer time for the breaker.

NB: and pleaaaaaaaaaseeeee, need aesthetics things (flowers, small tree, etc)

(Edited 1 time)

Why have them take a long time to remove excess items from the world? Unless you are making something in the process like concrete.

Although I did just have an idea for excess stone...stone floors.  NO wait! Stone bridges, so we can reach the other islands :D

would LOVE to reach another players island. 

(Edited 1 time)

•BUG: My workers have a problem where the ones planting seeds target the first soil, even if there are already crops on it, then they stand there until the harvester comes along and removes it so they can plant. 

•QUESTION: No rush, but about how long till we have sound control?

•STATEMENT: Also, for those of you who have "Straw tower problems" I also have an excess supply of straw "in tower form" towering over my base. So to move it out of my base I placed a box on the far side of the map and have a worker dumping it into a tower over there :D

Developer

Bug : Added. Thanks

Question : Soon :)

Statement : or you can feed to to the cows!

Thanks!

Latest update looks great! No more infinite storage, so the bots won't spend all resources making infinite of something I don't need.

That seems to be the major stuff out of the way, I'm looking forward to new content now :).

(Edited 1 time)

Repeat until not full would be good to change to empty or added. Because repeat untill not full only works from full(100) to (99) and want to go lower before creating more planks

(Edited 1 time)

I actually use repeat until not full to tie lumber production to both log and seed storage by putting two empty until not full in the main loop. If I were to nest until full loops, it would only ever check the innermost, so I could only control the amountof one item, not both.

Love the game. 

I have two bugs regarding the buckets. First recycling the bucket gets my player stuck in place in front of the recycler and I have to save/reload to be able to move. For the second thing, I'm not sure if it is a bug, but buckets seem to be the only thing that I can't store in general storage. This is rather annoying as the way I set up most of my tool worker bots is to fetch a tool from a chest when it breaks. Do buckets not break?

Developer

The first bug is known and will be fixed in the next version.

The second is new. Thanks

Buckets don't break yet but they will at some point.

Thanks!

(Edited 1 time)

Don't know if this has been reported yet(edit. it has, but still adding details), but... I just update to Version 5, and I'm trying to use upgraded bots to plant my cereal, but they mistake full grown plants for tilled soil and try to plant in them.  The seed is not consumed. 

Developer

Yep that should be fixed in the next version. Thanks!

Just trying to help. :) 

Developer

Great, we need all the help we can get! Thanks!

Not sure if this has been suggested or not yet, but if in stead of Q just putting away the item in the hand if it could also bring back the last used item that would be amazing.

Developer

Good idea. Thanks!

(Edited 1 time)

When I recycle a robot when it's holding something it just makes the object disappear, the robot comes out in its components, but the object itself is gone.

EDIT: A queue for machines so you don't have to wait for it to complete the project,  you could just feed tons of materials into it so you don't have to wait, so you can leave and do something else.

Developer(+1)

The first one is a known bug thanks.

The second one, yeah i'd like that too. It would be handy. Thanks

When you drop a tool it won't ever break for example:" teaching a bot to pick up nearest tool do something with the tool and then drop the tool again. the bot will never break the tool.

Developer

Good find. Thanks!

(Edited 2 times)

Bug report for version 5, wearing a HAT (by placing in the inventary) and taking it off (by placing it in your hands) destroys the hat, tested with the Top hat and the Plumber's hat.

When milking cows, if you have more than one bot milking, and they get in each other's way one of them skips a instruction and gets stuck.

Maybe a repeat until bucket full / bucket empty?

Every once in a while bots that are feeding folk will attempt to feed the same target, as a result dropping food on the ground.

Developer

Hat bug: yep that's a known bug but it only happens if you use the Inventory screen. If you use 'Q' and ',' to stow and recall the hat it works fine. This will be fixed in Version 6 on Monday.

Milking bug : yes this seems to be affecting all scripting and not just milking. Thanks

Repeat bucket : we'll be adding loads more instructions as we go.

Feeding bug : I've had this reported once before so I'll have a look into it. Thanks

(Edited 1 time)

Just found a tiny bug/behavior. I had a storage crate placed down but added no materials to it, so it stayed as a ghost. at one point I had a worker bot run out of battery inside the ghost block. Recharge bots will NOT path find to the bot and will not recharge it. Reminds me of the problem where bots run out of battery in a gate.

WiseMack, I actually had a nice bug with my worker bots and milking cows. They both were just waiting at the milk depot, and as soon as a cow was ready to milk they both went to the same cow and started at the same time, and both got milk. Both DID get placed in storage so for a while I was getting 2 buckets of milk out of each cow.... although after reloading the world I have the same problem you do, I liked getting 2 buckets of milk per cow lol.

Edit: Just made a second milk storage so each bot has its own, and one will still eventually be sitting in front of the milk storage with an empty bucket trying to add. So the problem is happening when they meet at the cow not the storage.

Developer

Yep the 'stuck inside blueprint' is a known bug. Thanks

Two milks for one! great! Thanks for that. Added

(Edited 1 time)

i am using the linux version.

when selecting a save, the only notice that you have selected it is the noise. add visual identification. same is with selecting a file to load. also text when making a label for a save does not appear. it would probably be a good idea to have that be shown for this specific purpose.

Developer

Good ideas. Thanks

had a weird bug that if u pick up a cow as hes being milked the cow will glitch out and dissapear and reapear as u move, its weird but i could put him back down and he would be fine after that.

Developer

Woah. That's a new one. Added. Thanks

I found a few bugs that have already been reported...but I just wanted to say how great this game is!  I've really enjoyed the past few days of playing and hope to stay involved as you progress.  Keep up the great work!!!

I think I found a bug in the Linux version. When I try to save it tells me to make a file, I can make one but when I type nothing shows in the text box. 

Developer

Oh dear. So you've clicked the text box first?

Yes, it is working with new release. Thank you! :)

*** BUG ****    I am on a mac. I tried to change a key bind before you start the game for invintory to open with one of the side buttons of an aftermarket mouse. It dinged at me and no matter what I pressed I could not get out of the  menu or assign a hotkey. I had to force close it.

Hello, I have yet to know if this is because of the new update or not, but I noticed that wooden tools seem to take less time than metal ones to do work. Is this a glitch?

Developer

Quite right. No one has spotted that yet, well done :) Thanks!

wuuttt...you tricky :P well most of us are in Metal Tools :)) 

Developer

I should point out this only applies to axes. The other tools should all be the same speed (for now)

you can currently plant on weeds, which turns them into cereal crops on top of weeded soil, but the weed model itself never goes away.  This causes weeds to accumulate in tiles.  

Developer

Grea, thanks. This will be fixed in Version 6 on Monday.

*BUG*
Interrupting or a robot stopping mid way through a chopping job, bugs the tree out so it can't be chop down fully.

Developer

Yep this is a known bug. Thanks for reporting though :)

(Edited 1 time)

*Question*
If I press Q to stow an item while teaching a robot, it doesn't stow the item, is there another way of making them? Or do I have to make them drop the item and pick it up again?

Developer

In version 5 no, but version 6 will have this ability. Thanks!

Alright, sounds good.

maybe bug ,when robot cant find folk without hat he  drops him on ground 

Developer

Great, thanks :)

again bug , folk respawn on deep water :P

Bug report, hopefully not a duplicate:  If two bots are waiting to remove an item from storage that is currently empty, when a single item is added to storage both bots will act as if they took the item, but only one of them actually gets an item.  This usually causes the next operation to fail for the bot that didn't get the item.  Took me a while to figure out what was happening, but it's easy to re-create now that I know what to look for.  I built a simple save file as an example if you want it.

Now to the accolades... this is such a super game so far!  I truly can't wait to see where this goes!  Thx!

Eric

Developer

Thanks for that. Having that save file would be handy if you can send it over? Thanks!

No problem... how do I get the file to you?

Developer

On PC you'll find all the save files in C:\Users\<your name>\AppData\LocalLow\Denki\Autonauts

You can use something like Dropbox or Google drive to send me the file.

Thanks

Here you go: https://drive.google.com/file/d/0B-I6kLClypHPcC15dnlZV1JIVjA/view?usp=sharing

Developer

Great example! Thanks for setting that up. I'll add it to the bug list.

(+1)

AMAZING GAME, BRILLIANT WORK, SORRY FOR CAPS BUT ITS REALLY GOOD, I ONLY GAVE 90P COS THATS ALL I HAVE BUT WILL GIVE MORE

Is there a way to donate again?

Developer

Yep, Paypal is back up and working again. Thanks!

Viewing posts 1 to 200 of 305 · Next page · Last page