Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

What are some funny bugs you had?

A topic by Le Don created Aug 05, 2019 Views: 186 Replies: 23
Viewing posts 1 to 19
(1 edit)

Hey guys, I would like to know if you have some funny bugs or glitches, that happened during the development. Or maybe something else, that happend.


I had one strange problem: I have robots that shoots laser beams to the player. But strangely they would only shoot in the left direction, but not on their right side. I doesn't made sense, it took me a while to understand why. And when I did, it was quite hilarious. You see, the robots can hit other robots and when they do, the laser beam disappears. And because the robots have their center x-/y-coordinate on their upper left corner (as per GM2 default), they would hit a robot, when they shoot on the right side - they would hit themself.



And sorry for the self-promotion, but it would be great, if you could check out and rate my game here (the graphics are way different now):

https://itch.io/jam/gmtk-2019/rate/462513

Submitted(+1)

At some point of making my first roguelike, I've screwed with Lua tables and got some pest infestation lol:

(+1)

That looks insane :D

Submitted

This is CQD trying to highlight letters in 'Hello':

Tried to highlight 'E'

Tried to highlight 'L'

Tried to highlight the other 'L'


I was close to losing it...

That's hilarious ^^.

Submitted

At some point during development I accidentally duplicated my tilemap. While this did not change the look of my game at first glance, it introduced a bunch of weird bugs as everything in the game existed twice now. You could walk over a key, pick it up and walk away and there would be still one key lying on the ground. You could unlock a path with that key, but the barrier would remain visible. And after that, one of the two player characters (who originally where in the exact same spot) could walk over the barrier, but the other could not. Scratched my head about this for like 5 minutes, before figuring it out.


My game: https://njamster.itch.io/wonkey (playable in browser, not mobile friendly)

(+3)

That's certainly a bug that goes against the only one rule.

Submitted (1 edit)

Literally the last minute:

Build finished with the result ‘failed’

One minute later:

Thank god there is a extra hour!

Psst. Play my game:

https://c0derp1glet.itch.io/go-go-go

Submitted

The funniest bug i ran into was changing the spawn rate of the flies in my game to around 15 per second(I intended 1 every 15 seconds). The speed of the enemies are determined by the spawn rate so this made then insanely fast as well. 

Each fly has a sound that plays so all of the sudden my game went from  relatively calm sounds of bugs cruising into frame to this game crashing onslaught of high pitch noises screaming accross the stage. It actually made me laugh out loud. 

It's working much better now: Blind as a Bat

Submitted

When the door knocked me off level = D Try it https://itch.io/jam/gmtk-2019/rate/462518

Submitted

Animations wouldn't stop sometimes for some reason even though thier condition was false,  https://fruitsam.itch.io

Submitted

My game ran perfectly in Unity, but in an actual build several controls stopped responding.

Turns out I hid some key functions in an "Assert()" command, which were apparently removed in the final build...

Submitted

For My game you need to spawn a brick to help you solve puzzles and the bug allows you to do this while mid air which means players can spam/exploit this to basically fly.

Submitted (1 edit)

Initially we wanted the plane to just lean over as a visual indicator when you were turning (not fully roll), but a bug made in the execution made it so the plane would lean when your pressed left, and rolled furiously when you pressed right. The bug added a lot of added challenge, because you could then only yaw left and roll left, and was crazy-fun as hell. We really considered keeping it, but it was dramatically motion-sickness inducing, it also made our physics overhaul do crazy things like rolling the plane would make gravity go up. Figuring out what we were doing wrong to get leaning stabilized was taking too long, so we cut the whole idea of leaning the plane and later found another cool visual indicator as the smoke billowed behind the plane at high speeds.

The other bug was that the terrain which worked well in downloadable Unity builds freaks out in WebGL (it's just too big). We kept it in both because one mate worked hard on it, and people have mostly looked past the buggy-terrain for the fun gameplay.

https://itch.io/jam/gmtk-2019/rate/463076

Submitted

The funniest bug was the falling walls in our top down shooter :D

It was an easy fix tho and the game looks now a lot better than in the GIF.

It's funny to look back.

Wow, One Shot Gladiator, right? It lloks way different.

(1 edit)

Unfortunately definitely didn't have time to make a GIF of it but there was a point where the zombies ran away from the player!
https://itch.io/jam/gmtk-2019/rate/461633

(+1)

Awesome, that's hilarious!

Submitted

My game is a puzzle platformer called Broken Robot where you can only press each button once. In it I had a glitch where any stage that had a spring on it would make the player just stuck floating in the air, even if you didn't touch the spring. I had to change some stuff around and got it all working in the end.

https://itch.io/jam/gmtk-2019/rate/462219

Submitted

I forgot to clean any text that mentioned saving from the game, i cut it last minute to avoid bugs, but left in lies telling the player it was saving, so very sad, I've done a lot of work trying to mitigate the repercussions of that. 

the other bug i had was i left default text in when the player examines nothing, obviously an immersion breaker.

https://newkryptonite.itch.io/the-lonly

Sooo... Just got a new laptop about a week ago and installed Blender 2.79. Didn't realize Blender 2.8 was JUST released before the jam. Me doing all the modeling, programmer kept asking me what version of Blender he needed to open into Unity (I like importing the .blend direct) and instead if actually checking I said "Just download the latest version off the website!" 

Little did I know 2.8 had gone live and was the most major update in 10 years. Since we were mismatched it broke many of the  animations I had already imported into test scenes in Unity. Thankfully we figured out what was going on quick and rolled back to an older version of Blender on his system. I hardly recognize the Blender 2.8 UI! Have another thing to get up to speed on now ...

I have to say the Blender - Unity collaboration is great, and Unity Collab is also amazing.

Submitted

For some reason our main character kept vibrating while standing still until he was covering almost the whole height of the screen, it was pretty rad.

Submitted

So, after an hour or so of work I finished my mighty final boss for our game!  Curious to see it in action, I hit play...

https://drive.google.com/open?id=1udvQH_UXeQA3nSUBzhVL8DNsCwAbWJ2f

Submitted

My game procedurally generates the environment from simple images with low transparency drawn with additive blending. It does this by filling in a pair of lists of visuals to draw (one for foreground and one for background). Each element of these lists contains the position and an indication which entry in the list of sprites to use.

During generation, the tree sprites and their reflections can be flipped, in which case the expression for which sprite gets a possible +1 added to both, using a variable to make sure the reflection matches. Due to having named the variable too similarly, though, I initially added the constant for the position of the reflected tree sprite. Normally, this would result in trying to draw a non-existent sprite, which silently fails. However, because I made and included far more art than the jam build uses, this effect happened:


(also shown in pic: the result of my having both forgotten to manually set the anchor, aka sprite origin, for the oar and forgotten to make sure it's applied in all the right spots. In this build it rotated all the way around the boat from that distance.)