đŸ€‘ Indie game store🙌 Free games😂 Fun games😹 Horror games
đŸ‘· Game development🎹 Assets📚 Comics
🎉 Sales🎁 Bundles

Bug reports Sticky

A topic by Benjamin Soulé created 1 year ago Views: 1,683 Replies: 107
Viewing posts 1 to 60
Developer (Edited 1 time)

Please post any bug reports here

in the start-screen <CLICK TO START> is unclickable for me...

I even tried clicking somehow next to it, but that didn't work out either...

  • I'm using Windows 10
Developer

I put a new version online, can you try with this one ?

I downloaded the new version from itch.io and tried it...

...same problem... still unclickable!

I have the same problem.

I'm also on Windows 10 on a Surface Pro 3 (a touchable screen device).

The fact is that the game is in touch mode, it's not clicking, it's tapping the screen which works... it would be good for both (clicking and tapping) to work.

Yes, that's the reason!

I was a Thinkpad Yoga 260...

touch worked for me! :D

Developer

I uploaded a 0.81 version with some new change for the click detection problem. Please tell me if it solves anything for you.

(Edited 1 time) (+1)

Using a potion will leave the slot it was in permanently black, even if another item tries to take it's place;

Also it's possible to get stuck in a room without a key;

Developer

The potion will be fixed in next patch. For the door I generate 2x keys and 1x chest on each floors which means a player only endanger himself if he opens 2x chests on the same floor and the previosu keys got lost. I'm not sure about what to do about this, any suggestions ?

About the lost keys, I suggest that, if a key disappears and would endanger the floor (more doors + chests than keys), another one should generate.

Leveling up over 10 (while playing on Easy Mode, at least) freezes the game just when I'm collecting the final coins. Happened twice up till now. It can be unfrozen by no input whatsoever.

(Edited 1 time)

Same here.

I also found a bug where you can use the grapple on Archeos, which also freezes the game.

And is it intended for you to lose characters you've unlocked after you die with them?

Developer

v0.8 ( which is online now ) should prevent the lvl10 bug from happening

I will check archeos interraction with grapple for next version.

When a non-adventurer character die, he goes back to jail.

Are we ever meant to have multiple party members like in the preview gif?

Developer

If you free another team member in your group you can select them before opening the dungeon door.

I also somehoe don't get it there is an x under the other team members if you want to select more than one

how?

Developer

I forgot that next difficulty level must be unlocked to increase team size. ( 1 > 2 > 3 )

This is far too messy right now. I need to make it more readable. I think about allowing 2x members team on the free version and extend to 3x members for version premium.

(Edited 1 time) (+1)

The game is stuck when the last key is inside a fairy and you don't have items to kill it. Also some kind of exploit is if you have an armor and you have slimes and a fairy, you can click on it until the dungeon is full of slimes, the downside is its boring and takes long to do.


Also are planing to add a fullscreen couch mode? ;D

agree

(Edited 1 time)

Awesome game! Really liked the concept and the pixel art!

Reporting some issues:

After playing various times, I noticed a message on the corner saying "Grid.hx:102: testCol Fail!". Don't know when it happened, but I hope it can be of any use. Also, the image of the Bull in the card shows as some kind of red paper imp, not the Bull I suppose it should show.

http://i.imgur.com/dg0J9gt.png (Here's a screenshot don't know how to embed a picture, sorry :P)

Trying to click a single fairy while having the burning sword equipped causes her to both flee and get burned, and causes the game to freeze.

(Edited 1 time)

Using the swap wand on Archeos and then on another ennemy causes the game to freeze. I wanted to do a Swap + Hammer combo to get rid of him. It would be interesting to also test if using the hammer on archeos to bring him down or kill him freezes the game too.

Thank you for this great game!

(Edited 4 times)

I, uh, don't know how to pick up a key. Clicking it doesn't seem to do anything. (Nevermind, keys seem to autouse on the same screen. Could be made clearer!)

(Windows 7) Also when I died and was brought back to the title screen the window was the same size but the playable screen shrunk considerably until I hit the window size buttons a couple times. This happens in both Fullscreen and Windows mode.

Evil Roots can stick on ceilings without nearby monsters to cause their fall.

The turn indicator disappears when you switch to fullscreen.

(Edited 1 time)

same here :)

screenshot

Trying to swap a monster to an empty tile freezes the game. Also swapping it with itself leaves a visual effect on it and uses up the item, while I think it should just cancel the use.

I used the switching rod thingy on a monster who was next to an empty place and clicked on the empty square. The game didn't seem to know whwat ti make of it and seemed to basically stop working. Seemed like it was waiting for me to click somewhere for the other switching target, but woudln't accept any options.

I'm not sure if this is intentional, but the ranger seems to have many turns sometimes before the next party member's turn. I think it has to do with the extra arrows he gets?

(Edited 2 times) (+1)

The Goblin description has a typo. It should say every sword counts for 1/2 damage, not one. It also fails to mention that goblins lose their sword when there's fighting nearby.

Another oddity in the descriptions is the use of an imperative verb instead of third person singular, for instance shouldn't "Scrounger - Steal nearby items" be "Scrounger - Steals nearby items" as the description refers to the monster and not you? Some of the descriptions also become a bit nicer when reworded from the viewpoint of the monster: "Fairy - Flee on a free square if you attack a single one." becomes "Fairy - Flees onto a free square if attacked alone."

Not quite a bug, but one small feature that I find distracting is the blinking items. If the items need highlighting a small up and down movement animation or a uniform scaling animation would suffice without concealing the items half the time.

Developer (Edited 1 time)

I'm really interested in typo reports because my english is below average. If you think that some texts are unclear or written in bad english. dont hesitate to send other reports.

(Edited 2 times)

The scale of the game resets to 2x after death. edit: in 0.82.

Now in 0.83 it resets to 1x

(Edited 3 times)

The description of item `Mallet` is:

kill the most bottom Enemy in a column

But it does kill the door (if it is the bottom most thing in that column), make it impossible to advance

(0.82)

(Edited 1 time)

When the hero upgrades, falling dead enemies freeze in mid air, and I can not interact with the game.

Developer

The pause on level up is actually something I wanted. I'm actually quite surprised people thinks it's a bug ( you're not the first one ) Maybe I will remove it later.

Well I know it is not a bug, but I feel strange that I cannot perform any action. Maybe slow motion is better than freeze.

Are unlocked heroes supposed to stay unlocked?

Yes they are.

Hm! I unlocked the archer and they've dissappeared (.82), I'll try and unlock on .84 and see if I can reproduce

If you use a bow to kill a monster, it doesn't trigger `if it is killed alone` event.

Developer (Edited 1 time)

This is intentional. I will reword it : " Burns nearby monsters if attacked alone. Resist fire. " Does it sounds ok ?

(Edited 1 time)

try changing "attacked" to "punched" or "melee attacked" (sounds strange though)?

If I click on a equipable item when my inventory is full, I cannot cancel it but to drop an item.

The new party system is great. The guaranteed prison levels really work. The new hero spawns with mere three health though, which in later levels means they pretty much die a few turns later.

Here are some other issues:

The fire rod cannot target an empty space (for instance a gap between two groups of monsters)

The floor shouldn't automatically change when there are no more monsters present as there might still be some treasure laying around. The floor should only advance if there are just doors and chests left with no keys.

The "Choose a spell" text gets stuck to the left panel if you cancel the spell selection by clicking outside of the spellbook.

The potions are a good idea, but there are a few problems with the implementation:
- Stolen potions are not shown as an icon on the Scrounger, while other items are.
- There should be a way to drink potions on the spot. It's really annoying to have to drop a multi-use item just to use a single-use item.

And here's the major one:
The hero turn counter can get stuck meaning you only get to use one hero even if you have two or three in your party. Usually this happens only for a few turns, but once I had my knight frozen for dozens of turns until my adventurer died at which point the knight got a turn again. Later, in the same run, I rescued a new adventurer at which point he got stuck and I only got to use the knight. As far as I know this didn't happen in 0.82.

I had two bugs (but after playing a lot!):

when I restart in fullscreen mode, I heard the sound of menu title but don't see anything, and click does nothing...

After killing four or five munchers, the game freeze...

(I don't know if it is usefull, but here is a screen: https://framadrive.org/index.php/s/159LkKmxbQX5B81 )

(Windows 7)

Developer

The muncher freeze is fixed in 0.841 ( available on the download page )

In the latest version a entered with an archer, got a knight and at some point I don't know what happened but it never switched back to the knight until the archer died.

Some other tries some other bugs (or things I found strange):

- If there is a potion (maybe other objects?) when you use "relocate", potion disappears.

- It's frustrating to go directly to the next level if you kill all the monster: I waited to kill them all before open chest and eat, I lost all...

- I got a turtle behind an evil root (but I don't know why...)

- The green balls around the boss stay on the game over screen (I lost against the boss...Arg...)

- The rules of switching between characters isn't clear for me, even after a lot of tries...

By the way, Cool game!

Developer

" If there is a potion (maybe other objects?) when you use "relocate", potion disappears. "

I can't reproduce this one. Is there other specific conditions for loosing an item with relocate ?

Arf, I was thinking that was simple, I haven't observed more of that. In my memory, it was on the top of the screen, there were empty spaces on the "relocate" area... I had two guys, I think... No more memories... I will try to reproduce it...

why is the name of current release

tower-of-archeos-v0.841-window.zip

do you mean "windows"?

Hi, I can't reproduce relocate "bug", maybe we stole my potion and I didn't notice it... For now, I always do screen shots... Here some remarks:

- When you rescue the archer, you can use infinite quiver at this floor (you have a negative count)

- When a character attacks an hydra, his protect objects protect everyone (on the other hand, the objects on a "passive" character have no effect)

- I have got a freeze after remove the third shield of the boss by killing a blob and when a Zombi start to eat a Gargoyle...

(here are the three screens: https://framadrive.org/index.php/s/w0boNEWQkAig1Fr )

And not a bug, but a simple remark: Isn't it unfair that when you kill a gargoyle with a special object, the others become statues but when you kil a monster near a gargoyle statue with a special object, the statue don't become a normal gargoyle?

Developer

Mmmh for the gargoyle I would like them to turn to stone only on a classic attack. I need to change their code so they behave this way.

Developer

I made a quick fix ( v0.851 ) for archer, hydra and shield boss bugs. thx for fast and detailed reports !

Via combination of nagas and lots of meat i got to the end of stage with locked door, key dropped but door stayed locked. I recommend you to auto-unlock doors when stage complete.

screenshot

P.S. God, such a good game.

After Archeos uses his three-bubble shield attack, and I break all of the bubbles, the game field freezes and I can no longer highlight or click on any monsters or items in my inventory. The menu buttons still work, for some reason, and animations still play. This has happened both times I've gotten to Archeos and has made him impossible to defeat...

Developer

This should be fixed in 0.581 version which is available now.

If you encounter this bug in 0.581 please let me now.

In the newest version I started the game with the knight, I was cleaning level 3 from the rats and in one moment the game stopped working (sound worked but graphics got stuck mid rat death animation).

In the version 0,83 I was able to skip Archeos fight by opening the door with a key - but game crashed on level 13 after I tried to use the bow (Main hero Archer, with Knight and Adventurer).

I think that the knight should have an abillity to quickly kill all monsters with 0,5 health - it's quite irritating to spam the rats and bats.

Otherwise, I love this game and I'm waiting for more updates :).

After selecting someone with the Winrod, I click someone else (not nearby, I wanted cancelled), it killed monsters but considering the Winrod as used (I don't know if it is clear...)

And I discover the mermaid's effect on the Vampires and it changed my strategy, very clever...

Developer

...and one more fix for the windrod ! I think it should be ok now.

Yeah mermaid "heal" a lot of stuff... Maybe you haven't found all of them :)

Sorry, one more bug with the winrod:

- I select it, changed my mind (damn ghosts!), and select the bow. The winrod become used and the selected character stay selected (screen here , we don't see the selected area in second picture because of blibnking, but it was still here). Maybe it's better to just cancel winrod when we click at a wrong area.

- Something that is not a bug but is strange to me: when we finish a floor, poisonned heart aren't heal even we have all our hearts and the ointment...

- (and an other thing with the ointment: if we had all the heart "poisoned" and kill an other spider, ointement don't heal the first heart, but maybe a "negative heart"...)

-The display after restart bug is still here: screen . Maybe it's because I had two screen, this what I see in my left screen, on the right one, I don't see anything until I press escape...

Developer

Can you confirm all of this happen on 0.91 ?

Oh, my bad, I use Itch app and so was thinking I always had the last version. But I launch it, and the screen show me it's the 0.851...

In fact, I discover that you now have a paying version, so the app failed to download it (it didn't switch to free version, and didn't display anything to signify the change, no clue for me to guess...)

Sorry about that.

Developer

No I'm the one to blame, Itch.io have a special process to update files and I erase/upload instead of using it. Need to learn how to do it correctly

Two fishes spawn from the rod when the golem rolls down to an empty column and later is killed. And sometimes the fish shows up later than it should (1-2 turns) with 1 hero.

It's after 2 a.m. and I've spent last 3 hours playing with my boyfriend. We managed to get Adventurer to 10 and Thief to 9 in one game. 3rd hero door didn't spawn (intended or not?). Archeos fight is too random in our opinion - he teleported to the top and was surrounded by cobwebs and stone gargoyles. IMO his skills should be less random, more predictable (the whole game is awesome strategy-wise, and he is just luck dependant). Didn't manage to kill the guy this time because of his teleports :(.

I reaaaallly hope for some local (1computer) multiplayer/co-op mode, it would be so great!

Waiting for updates :). Cheers

Developer

Yeah I'm not quite satisfied myslef with the archeos fight right now. I think that more monster refill would make it more enjoyable.

The fish problem is fixed in v0.9

Hey there! The game is great, and you're truly on to something special.

I'm here to report a visual bug with Fullscreen. Every time I die in a run and return to the title screen, it looks like this -

Some things that would be worthy to note is that I'm on Windows 10 and my resolution is 1366 x 768.

Developer (Edited 1 time)

It should be fixed in v0.9

New version, insane difficulty, Archeos only casts freeze spell (7-8 times in a row). I cleared all the monsters and he couldn't be killed because he didn't spawn new ones.

Screen: http://oi64.tinypic.com/2lc30jl.jpg

Developer

It's fixed now in 0.91. ( How could you unlock insane difficulty with bugged archeos ? )

It was bugged on Insane, I finished hard mode normally on previous version and played insane on new one.

(Edited 1 time)

I got a bug with the Doppelgangers. I had two groups of Demons with a group of Doppelgangers between them. I turned the Doppelgangers into Demons, but they were still a separate group. Only when I caused them to move they became a single group.

Edit: just managed to somehow freeze the game with the PriestÂŽs Banish spell. The cursors only showed for one enemy type and the game got stuck when I clicked another one.

Hi. I've downloaded the game 2 days ago (so it might not be the freshest version?) and I found a weird bug:
After having attacked three doppelganger, they turned into harpies but kept forming a group by themselves (not mixing with the harpies nearby). This screenshot might help to understand the problem : https://gyazo.com/9b6852cfb01f5c3348bc09b7bd35d2cf
(Insane difficulty)

It was fixed the next turn : https://gyazo.com/cdce84514efbda7b34061ea4b14a3a04

Developer

Can you confirm you had this bug with 0.92 ( Version number is showed on title screen )

Nope. 0.91.
I'll download the new one and tell you if this bug still occurs

If you clean a floor without unlocking the door (by using magic by example) you can gather up to 3 key but no way to open the door...

By the way, 38 hours of playing the game, best investment since a long time ! :)

When fighying archeos a harpy can transport him in a single box as he normally occupies 4. This causes bugs ...

Same problem here but he occupy 2 square.

"Occupy Archeos !"

J'ai ouvert 2 fois l'onglet paramÚtres et le deuxiÚme écran veut plus partir, il répond pas... c'est un peu perturbant de jouer avec en plein milieu des monstres ^-^'

Et en faisant un relocate, archeos semble passer à travers un monstre mais je ne sais pas si c'est dû au bug précédent ou pas ?

(Edited 1 time)

Et alors du coup, j'ai cliqué sur replay, et là PAF ! Niveau 1 Archeos qui se pointe pour continuer le combat! ^^

EDIT : Et il ne prend pas les dégùts bien sûr ! :P

Suite au problÚme avec les harpies, j'ai encore relancé le jeu, et Archeos s'est encore pointé au niveau 1...

Bug avec le Ring do Destruction : mon deuxiÚme héros (aventurier) joue, Archeos réplique en enlevant le R fo Destruction de mon troisiÚme héros.

Le jeu reste bloqué sur l'aventurier qui ne plus taper.

EDIT : en fait en ouvrant et fermant les paramĂštres, on revient Ă  la normale.

Combo SirĂšnes / vampires : quand les sirĂšnes meurent, elles les transforment directement en chauve souris ! :)

Pareil pour les Tortues. En fait elles ne régénÚrent pas les créatures, elles altÚrent leur état, sans hiérarchie d'état.

Developer

Les vampires qui redeviennent des chauve souris, c'est voulu. Les tortues devraient retrouver leur carapace, c'est le cas ?

Les tortues sans carapaces oui, mais celles avec deviennent sans carapaces !

Ouvrir le menu hiscores et rester bloqué ?

(Edited 1 time)

Had a scenario yesterday with only Ice qubes left and a locked door, I guss the key was in one of the 3 monsters in the Ice blocks.. Maybe make it posible to crack single cubes open.. maybe just free the monster as a downside

(Edited 1 time)


If you press esc while in the shop, the shop menue gets stuck over the game field

same issue here - got the 'swap item' arrows and settings dialog stuck on the screen.

https://s32.postimg.org/kxedertv9/2016_07_02_23_54_37_Download_Tower_of_Archeos_by.png

http://imgur.com/H1YaZLp

Ice cubes over door, keeping it locked, when you end up with out any destructive item, the game is stuck here and no one cant do a move.

The door is still bocked sometimes, even if there are no monsters around

Typos :

The king is thankfull to your party and decide to gift you with this land -> The king is thankful to your party and decides to gift you with this land

quests availables -> quests available

In the final fight with Archeos, a character dies (Archer in the 3rd slot). The victory text is :

"You defeated the evil Archeos !
null
The king is thankfull blabla"

Bugs/others :

Maybe it's just me, but I can't make sense of the quest system. Sometimes, it awards me a task that is not even in my list. Sometimes, I think it displayed the award message for a different task that the one I solved, but when I checked the auest tab, the good one was darkened. By the way, having uncomplete quests bright and completed quests dark seems weird. I think the standard is the opposite. An example that comes to mind is the Achievement system in WoW, and you can believe Blizzard know their business.

- the Torch kills a monster in ice without melting it ??

- view high scores : no back button ?? no way to go back to the main menu

- Sandals still seem quite useless, or even detrimental (more higher level enemies)

If you get the compass on floor 9, Archeos won't appear on 10

Summary: Two adjacent bats burned infinitely by Fire Sword

Scenario:

  1. I think my Archer was attacking a lone spider on top of the two bats, using a lit flaming sword.
  2. To the bats' right was a pile of at least 7 spiderwebs.
  3. Both bats were transformed vampires, but I don't remember if any doppelganger transformations also took place.
Steps:
  1. I attacked the spider, which killed it, then caught the bats on fire.
  2. The fire burned the bats, then the spider webs to their right, but then the bats never stopped burning (I waited 20 seconds or so, it showed no sign of stopping).
  3. I took a screenshot and closed the game.
Observed on OSX, full version 0.96
Developer

Ok this was a tricky one. These bats were once doppelganger ( with fire immune ) then change to vampires ( with fire weakness ) and then changed to bat. None of this fire status were reseted on each monster type change resulting in a very rare case of immune & weak to fire bat. It will be corrected on next version ( probably the final one :D )

Nice detailed report, I could find the bug in no time thanks to it !

Hooray! Glad I could help.

The game is awesome, by the way. My BF and I are both hooked. :)

Getting crashes in the Mac version! Running it on OSX el Capitan. Crashes after about 2 minutes every time I run it-- sometimes during the character select screen at the base of the tower, sometimes in the game proper.

In the very first scene where the character runs through the forest, and in the character select screen, the character's sprite also flickers and there are some weird vertical black lines that flicker as well.

I may be able to record this with video later today if you need me to.

Developer

I had a similar bug report for OSX el Capitan this morning.

Do you know what is your adobe air version ?

There's not an easy way to figure out, and I'm unfamiliar with Macs, but I have found an adobe air installer through Finder that is version 23.

Developer

I tried to work on this but it seems I'm unable to make the game works on last OSX version : El Capitan.

As a result I removed the mac version on steam and itch.io, please contact me on benjamin.soule [at] gmail [dot] com for a refund.

no need! I also have a PC and I've been able to play it just fine on that machine!

version 0.96

on the first level, i attacked a solitary fairy to move it. instead it disappeared and a coin purse appeared. i clicked on the coin purse and received the gold. the golem above then rolled into the space, then the fairy reappeared in the same spot, on top of the golem. i could then select the golems as a group around that golem, or the fairy itself, but not the golem behind the fairy.

https://s10.postimg.org/mg7vjxnft/fairy.png

Hi there! Awesome Game but... after the latest update, the screen will stay black after selecting a hero. Also, no sound. Windows 10. Ran fine before that update...

(Edited 1 time)

I have the Steam version of the game.  Using the mouse hover over a pot or money source doesn't show correctly how far the gold bar will advance.  Also when advancing to the next level, the gold counter shows that it starts with some gold in there sometimes, but the first match starts it back at zero.

It seems now impossible to unlock priest nor assassin... Does unocking system has changed ?

Archeros is gone after summoning explosive stones from the top left corner ! No way to finish the tower...


I used the Wizard's "Inferno" spell on the zombie just to the right of Archeos' head. There was a brief flame effect, but no creatures on the row were burned. Now, I'm unable to take any action at all - no attack or spells... no menu, anything. Neither mouse nor keys will affect any in-game action anymore. I can make the game window full screen or windowed, and that's it.

(Edited 2 times)

doesn't look like you care about this game anymore, but in case someday you do:

*sometimes the gold/experience bar doesn't clear after attaining a new level - you have to get more gold on your next turn in order to clear it

*a solitary frozen wolf does the same damage as (an unfrozen) wolf in a pack.

*if a prisoner/dungeon door is picked up by a harpy, the percentage left to clear to free the prisoner disappears when it is placed down

*happened once: completed game with thief, but it showed the assassin in the high score screen instead