Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Tailor Tales

Romance hot guys and create your own clothes. · By Celianna

Bug report! Sticky Locked

A topic by Celianna created May 22, 2017 Views: 3,499 Replies: 154
This topic was locked by Celianna 71 days ago

Bug report for 1.4 will be closed due to the fact all bugs have been records and fixed in version 1.5.

Viewing posts 1 to 49
Developer(+1)

Use this thread to report a bug!

Please provide screenshots if you can, and detailing what you did right before it happened, thank you!

My game kinda just froze on the opening. 
I clicked new game since that was my only option and even if I select yes or no on the question it's just stuck on the "now loading" screen.

Developer (1 edit)

Alright, let me try something out. I'm going to upload a version that's larger in filesize, but it should hopefully run. You're not the only one getting stuck on the loading screen.

I'll send you a new download link shortly! :)

Okay, I created a new version,try this one. Please let me know if this one works!

Developer

Beta 1.0 has been pulled due to reports of people not being able to get past the loading screen.

I'm very sorry for the inconvenience, I will try to fix this ASAP and get a working version out to everyone. Beta 0.2 is back up instead.

I really hope you fix it soon :)
I've been waiting for the update because I've been itching to play it. I love the game! Good luck fixing everything. Cheering for you :) 

Developer

I've found the issue and my programmer is trying to fix it (it has to do with the encryption), so hopefully you can get to play a working version soon. But first I will test it on one person, and if it works for them, I'll upload the fix :)

Developer

Tailor Tales beta 1.0 has been fixed, it should now be playable again!

(1 edit)

I've been unable to design any bottoms. it just shows her jeans/shorts as invisible and when i saved it hoping it was just a graphical error- i put the jeans on and they were invisible, it didn't even show the underwear, just skin. 

Edit: I'm on mac and noticed that you had some things may not work for mac. I also read through the development log, there are no voices either on my game. I haven't noticed any blinking either? There may be other issues but ill report back if i notice anything else.

Developer

As for not hearing voices, I will assume, you have heard zero general sound effects as well? I.e door opening, windchimes, footsteps, glass breaking etc. Your SFX sounds may be set to 0% so you don't hear them :) go to your sound options in the Settings menu, and set the volume of the SFX higher so you can hear them. Let me know if this was the issue!

As for no blinking ... that unfortunately, I do not know the cause of. I will have to see if this is something all Mac users experience, or only you to determine whether it's a bug in the game itself, or your Mac is not running it properly.

Hello! I know that the Mac version is still kind of iffy, but also not sure if it's just for Mac, however when I try to make a new game, it won't let me overwrite so I had to click continue which took me to the character customization page. I went on to customizing my character but then an "UnknownError" popped up.

Developer

You mean when you first started the game it wouldn't let you create a new game? I think this may have to do with Mac's permissions with overwriting files,  Can you try out this solution, to run the game like that, and see if it allows you to overwrite the file? If not, please go to the game's folder, browse to \Game.app\Contents\Resources\app.nw\save and delete both file1 files.

That should hopefully fix it!

It worked! I was able to create a new game now, but after I customized my character, this pops up.

Developer

Yeah it's trying to rewrite an image, and it doesn't have the permission to do so. I can't help much on this (don't own a Mac!) - except perhaps you can google some ways to allow this app permission or to bypass them on Mac? It definitely has to do with file permission though.

I had this problem too but found a way to make it work: right click on the game and choose show contents, then go to the file MacOS, click on the thing called nwjs and your game will pop up along with another window, but you should be able to save this time.

Developer

Thank you to everyone mentioning the emperor's new clothes bug! Will be fixed in the next upload; you can design pants again.

Hi! Encountered a bug about the avatar creation at the start while on the Mac version! Not sure what to do. "Error EROFS: read-only file-system, open '/private/var..../pictures/joselina_avatar.png"

Developer

Yeah someone else got it on the Mac as well. It has to do with permissions. Could you try out this suggestion, or turn off Gatekeeper/add Tailor Tales to the exceptions. Let me know if it works. I suggest googling the issue yourself as well, as the app needs permission to write files. I'm sorry I'm not much of help, since I don't own a Mac myself to test it!

I actually tried all of it and it didn't work.  :( I even used terminal haha but I think it might be because Sierra's pretty strict because I already exempted and let it run to "Everywhere" for app restrictions

Developer (1 edit)

Oh darn, that's too bad. Then you kind of run out of options. What OS build do you have? Then I can warn others before they download.

I have heard of another player trying Wine and it worked on there :)

Alternatively, you could locate the file in \Game.app\Contents\Resources\app.nw\img\pictures and delete the file joselina_avatar.png. This should allow you to get past the beginning screen and let you read the story. You're not able to use the option "Outfit"  in the main menu though, as you'll get the same error as before (though feel free to try).

I'm having a problem with my game crashing the whole time and then i need to start the game again... Are there any plans for an autosave feature? I really don't want to keep restarting, and I'd created so many clothing items...

Developer

I'm sorry you seem to have issues with the game. Can you tell me how much RAM you have and what processor you have? This seems like the game might be too much for your computer to handle. Also, when does it crash? Are you designing clothes, or reading the story?

I will try and see what I can do about an autosave, but I cannot autosave while you're designing clothing, that's not possible. I would only be able to autosave whilst you're in the menu, or reading the story.

At the moment, I can only tell you to not have any other programs running in the background as you play Tailor Tales, especially not having a browser open or anything, as that takes a lot of memory.

I'm not at my laptop atm but I can tell you it's a terrible quality of laptop, it's really old. It doesn't crash while I'm designing, it crashes while I'm in the story. The first was when the police showed up, the second was in the cafĂ©. I usually don't have anything else running when I play games but I'll try again later. Thank you. 

Developer (1 edit)

Ok, I know what's causing you to crash. It's pretty simple: the special effects. The special effects loop continuously until you progress further into the story when it turns itself off (in your case, the police sirens and the blinking of the CGs). During that time, it will continuously refresh, and therefor an older laptop such as yours wouldn't be able to handle the processing.

I will see about the option of turning them off :)

I will assume you crash straight away if you try out Dimitri's story and it starts to rain?

I haven't tried his story yet, I'll see when I play again, I'll choose his story instead, but thanks for the helpful suggestion! 

(4 edits)

I started the new version and this was the first thing I get. I can not continue past this point. This happens when continuing and starting a New Game. Same state after redownloading.

Developer (3 edits)

Sorry this happened right as you start the game, I will try and find a solution.

Did you delete the old file completely, if you ever downloaded Tailor Tales before? You have to delete them, not replace them, and this should be in a clean folder.

Edit: I figured out the cause, it's a loading thing. I will try to fix it, in the meantime, you can hit F5 to refresh after running into the error, until you finally get it to work.

Second edit: got a fix for it. For those that already downloaded the game, instead of downloading the entire thing again, you can download this small text file, then find your www > data folder, and replace it with the one in there. Also, delete all files in your save folder. This should fix it.

(2 edits)

The game not always shows heroine's name correctly [shows the default name]. Spotted in Dimitri route [when they are having dinner], in Neil's when Angela speaks [dunno where exactly] and when you have to make dresses for events. //the older ones I think? Tho I might be wrong - and if I am, I'm really sorry, I did read it at 2.00am so my eyes might have deceived me.

Also - sometimes when you buy something, everything else disappears. If you leave shops and go there again it fixes, tho. 

Developer

Dimitri's already fixed, as for Neil, I'll need more info on that, I can't scan 25+ chapters D: was it in the newer ones? Like chapter 20+, or the older ones below chapter 20?

You make a good point on the dresses though! I'll replace it.

Developer

If anyone got the "uncaught syntax error" bug after trying to finish a client, please re-download the game. It's a small error in my part, I apologize.

my game crashes right after i press yes or no to have i played it before it will go through the instructions on how to play and then right after it will crash no matter what i press yes or no and on either route.

Developer (1 edit)

Does the game close/stop responding, or does it give you an error? Does it load the main menu screen, or does it crash before that? Can you see the save screen, or have you never gotten that far?

the game closes. It loads the main menu. It loads the whole screen but before you can even move or do anything the screen will go black and then close.

Developer

Alright it seems to crash right when the save screen opens.

I've removed that part of the game so that it doesn't force you to save anymore. Please delete your old folder and download the current version :) let me know if you still crash.

(1 edit)

I downloaded the new one and it now usually crashes after the second how to play screen has loaded. i did once get further but i triedto save it after the main menu had loaded because it fixed if i had the problem before in previous betas but it crashed and said type error.

Developer (1 edit)

Alright, do you think you can get me a screenshot of that type error?

As for crashing before that, I ... honestly don't think I can help you with this :( I think your computer's specs are too low to be able to run Tailor Tales (especially since you said you sometimes managed to get further without crashing). Can you tell me your specs? RAM, processor etc.

its an intel(R) core(TM) i3-2330M CPU@2.20GHZ proccessor

and the installed RAM is 4GB

ill see if i can screenshot it

its cool i figured it out its just my laptop thats iffy i tried it with a bigger ram and diffrent proccessor and it worked

sorry for any inconvinence i caused.

Developer

No, I'm happy you can play it though! It does seem that Tailor Tales requires some minimum hardware to be able to play without crashing. I'll have to keep that in mind that people with an older PC/laptop may not be able to play.

(1 edit)

I'm really enjoying the new version! I love the client requests and earning money but while I was in the shop (not for the first time) my game froze then crashed. Then I just tried playing it again thinking that things crash all the time. I got this after clicking continue, I was shocked I could because I had forgotten to save my last game...

So I started a new game because I hadn't saved and I thought that was the issue but I got a black screen. The music was still playing, along with the guys voices, but the screen was just black.

And now after re-downloading and still getting the black screen, I am posting this. My computer hates me

Update: I restarted my computer (it had an update) and it works fine now....

Developer

Well, continuing when not saving the game results in the black screen - an known issue that shouldn't bother people because they're supposed to save at least once, hah. There is no auto save option, but I'm looking into that for in the future.

Seems the type error occurs only due to PC issues, so it's hard to determine what exactly is causing it. I think it's mostly due to your specs not being high enough (Tailor Tales seems to require 1GB of RAM at least). Probably best to play Tailor Tales with a freshly restarted computer with no other programs open to avoid the crashing.

I keep having a problem with some looks, where I'll hae it perfect, but then it says 'Nope. Wrong.'



I'm playing on a Mac, with the latest edition [only downloaded it a few days ago.]

Developer

How many times have you experienced this bug, and how much tailoring exp have you earned?

I'm aware of the issue, but thought I had it fixed when I released this version. Apparently not, hah. That's what beta tester are for :)

If you come across the issue again, delete the client. I'll work on a fix.

It's happened 3-4 times so far. Almost always on skirts, although once was a dress. Knowing it's a bug helps me not get frustrated. ^^ I'm sure it still annoys you, but I hope it helps.

Developer

Yeah it's something I thought I had fixed (I tried it out over 200 times to see if it still persisted but I didn't see it anymore), but I guess I was wrong. Sorry about the bug, as I said, just delete the client if you can't finish it. At least it doesn't occur all that often.

My programmer is re-doing the client system now, since we can't seem to replicate the bug.

Thank you for reporting :)

Hello, I am playing your demo and having a blast so far (so much content!). Admittedly it seems I am stuck on one obligatory design and I'm not sure if it's my eyes (with tiny patterns sometimes it's hard to pick the right colour) or if it's a bug. It's navy dress with white gloves and white pattern.  Not sure if anything else is hiding. Comparison photo underneath. 


Developer

Check the sparkles pattern on the skirt - it should be default colour, it should not be white! :)

The sparkles are already white.

Ooh, thank you so much. I have forgotten that patterns have default colours. I'll excuse myself since it was 5 am =D 

Developer

No problem, I can see why this would get confusing. I'll keep it in mind in the future. Anyways, have fun playing again!

Hi! I faced a bug when I clicked on the third CG for Neil in the CGs menu. It said something about not finding the width null, sorry I forgot. >.<

And when I opened the game to bring the error again to screenshot it nothing happened! I have no idea why it happened the first time.

Developer

It's ok, I know why it happened. It's a core bug within the engine, opening/closing pictures too fast causes it. I'll try to add some extra wait times to avoid it for the next update. You may never get it, or sometimes run into it, just like how it happened with you :p

(2 edits)

First of all - I really enjoyed the game so far! Great job! I did encounter some bugs though (or rather, one bug and two minor things)

1st picture: Often when I tried clicking "finished" on orders it didn't work. It would always be when working on dresses and trying to finish from the skirt section as showed in the screenshot. Not a game-wrecking bug, but I encountered it very often as I always worked on the skirt last, haha.

2nd picture: Poor guy is decapitated :(

3rd picture: "Typo" (or are do you).


Developer

1. Alright, this is very important to clarify for me right now:

- Are you able to click the Finished button, at which point the window will pop up saying that there are still some things missing?
- Or can you not click the Finished button at all?

The former is a noted bug I'm aware of and will be fixed in 1.4, and the latter is a bug that should not be re-occurring at all, so it's important to know which bug you're encountering!

Thank you for the other two screenshots :)

The latter. When clicking "finished" nothing happens at all. If I switch back to shirt it suddenly works fine.

Developer

Alright, thank you. You're playing 1.3.1, right?

Sorry for getting back so late - but yes I was.

(2 edits)

So, I got a number of things. First, I really enjoyed the game, normally I don't do the dress-up thing but I rather liked the amount of customization put into it (minus the shoulder ruffles. I just don't like those for some reason, but to each their own).  Though, there's a number of grammatical errors that I really hope you get around to fixing. This is probably going to be rather long, but I played through the whole thing and tried to do everything to try and give you the best feedback possible.

Bugs I found (I am using Windows):

Supposedly perfect dresses are "not what the client wants." I had bought everything from the store I believe. General problem causes (I tested a lot):

-- sometimes a skirt/dress will ask for baby doll, but on a few skirt types baby doll will not show up (such as on the short knife-pleated screenshot--it was apparently looking for a black baby doll which I found eventually. Another was in gray.)
--the tiny details are difficult to determine correct color for, a zoom option could probably fix this
--I looked through, and on the primarily brown and green dress for example (unfortunately I screenshot on the sleeves tab) 4 of the 6 available hemlines (shirts) didn't work (all dresses--the hemlines are there, just layered incorrectly)
--occasionally there would be something under a different layer (see above)
--I had one client where they had asked for a design on their clothes nearly the exact same color as the main piece in the glitter pattern and I couldn't see it so I was clicking blindly until I figured it out.
--Clients who ask for short sleeves/small sleeves with patterns killed me, because more often than not the pattern would be in the cut off portion or just hard to notice due to the close color (most notably the snowflakes). I feel like a solution to several of these problems would be an ability to see requests for specific pieces/layers at a time. But I also don't know how to program a game so maybe that's not a viable option.

I could not design a pair of pants with a single rose. The rose didn't show, so I deleted them. They were gone. I made a dress. Screenshot of what happened. Note the tab.
--Furthermore, with the same pants issue, I kept having a problem making dresses. I don't remember how I fixed it, I think it was save and quit maybe, but I did. Still, every time I made a dress, my deleted pants came up. Plus side--the pants worked. Downside--my dresses that should have been there did not. This screenshot was done with a design dress-->make dress on the blank slate dress.

Not really a bug per se, but when I try to put details (like roses) on dresses, I have a certain layer goal on where I think they should show up. I discovered that there were a lot of layers. That caused that rose problem you see on the next dress. I feel like if there was any way to have something telling you which layer you were on it would help.

Overall there seems to be a layering issue with clothes, such as if you put a skirt with the flowy overlay hemline (I forgot what it was called it's getting late you'll know with the screenshot) with a shirt, the shirt unceremoniously takes over. Also, shoes. I like having pants with boots, but I don't think the pants layer should go over the boot layer at the least. I like my pants tucked into my boot. I have a few example of layer issues.

About the store purchases, when you buy either A) all of the items from a page or B) all of the items from a section, the rest of the items disappear. Sometimes A, always B. I noticed someone else say this, but I thought it said that they were on Mac, so I figured I'd put it here. Going out of the store and back in was a solution.

Angela's dress--she asked for gold dress. I made gold dress. She comes in to receive red dress. Effort is drained down toilet.
--Angela side note--I don't have a screenshot, but when Angela is drunk/her cheeks are red and her eyes are closed, it's kinda creepy because the red isn't blended into her eyelid area and she sorta looks like a demon.
--Another Angela side note. There's this one area of inconsistency (I don't remember what chapter number it is, but it's this next screenshot) where Angela says "...your really cool aunt will beat them up for you!" where the entire rest of the time she is explicitly his cousin.

Then there's a sort of funny hour-minute thing going on in the last one. I didn't know the hours stretched so long! (It says, "you have played for 5 hours and 289 minutes" --this was after I finished Neil's current route)


*Edit* Until I can figure out how to upload a picture, no screenshots. I chose to upload through here, it told me to choose my file, it said "uploading" and then there were no pictures. I don't know what to do about that.

I figured it out :)This one was sort of funny until I realized that my dress was irrecoverable that the pants stole the spot of.  I deleted these pants several times. Kept taking a dress spot. As seen here:Sorry, should've just screenshot the boots but that didn't happen. Pants also cover the shoes a wee bit, though I feel like that's less of a problem. This wouldn't be except I normally put pants inside of boots and also you see the boots hiding out behind MC legs.

Sorry there are so many, but I figured it was more helpful to put up screenshots.

Developer

Hi there! It would also help explaining what you did because it's not so obvious in each screenshot :p

The pants taking in the spot of a dress is definitely a bug - did this happen when you deleted an item? At least, that's what I think happened; you deleted a dress, and these random pants showed up instead. Did you ever close the game without saving?

Overlaying errors however is just something we all have to live with. If shoes overlapped pants, it would still look weird because not all shoes perfectly overlap the width of the pants, and vice versa. if you want something skintight and tucked into shoes, go with legging instead, since they're below shoes :)

And if you want the skirt to overlap the top, you're going to have to turn it into a dress instead - otherwise tops will always overlap skirts.

You definitely earned quite a bit of money!

Yeah, sorry.

I made those pants, but they didn't work properly in the pants tab. So I deleted them. Then I went to make a dress, and when I went to the dress tab, that weird mishmash is what happened. At that point I had saved but I hadn't played for so long that I had ever closed the game yet.

The first screenshot was me getting an error over and over again that the dress was incorrect. By sheer luck I tried the baby doll and it didn't show up on the skirt and I thought, "Oh dear." So then I started putting colors on the baby doll and clicking "finish" until it worked with a black baby doll and I got my funds.

The next one was a design that was also not being accepted, so I went looking to find things that might not be showing up. As all hemlines seem to be viable options to clients, I went to check there and 4 of the 6 types (line, ruffles, scallop, big ruffles) are not able to be seen. I was not about to go through the whole slew of color and hemline combinations for that one, so I deleted the client.

Well, I can understand having overlay problems, and I appreciate the tips. Though, I would still like there to be a little more in-game forgiveness on how the layering works--like on the thumbnail for that weird rosy skirt thing I did, it shows all of the roses on top but that isn't the case with one of the rose details especially (and I really thought I had treated all of my details equally with just as many layer-clicks). I made that particular skirt at least four times just because I was determined to figure out the layering thing. I then gave up and succeeded on a much better work with the power of luck. Maybe if there were a way to edit garments?

And yeah, I did make a bit of money, ha. There were some really interesting designs that came up that I wanted to do, and then some more, and then things spiralled out of control. Also I really liked having enough money to just binge a few chapters at a time but also wanted to have a bit more challenge, so I bought out the store while I was at it :p

Sorry also if I seemed snarky/blunt about the overlay thing, I'm just one of those people who get focused on details.

Developer

When you say the pants didn't work properly, what do you mean?It's definitely happening because you deleted some bottoms though, that's for sure. You can't delete the weird pants/dress combo either? The more info you can give me on what you did and what happened helps me out a ton! Then I can re-create the bug and find a fix for it :)

Clients not accepting outfits that match perfectly is a well known bug and will be fixed in the next update. If you come across an impossible client, just delete them.

Oh right, the babydoll item was a test, I should not have added it to the game haha. It doesn't have a graphic for the other skirts, so it may show up invisible on some clients if you own it. Although I'm confused about the layering issue you mentioned. What were you trying to achieve with the details?

Editing garments is not a feasible option, sorry :( once the design is finished, it saves it into a single image and all of its data is lost. Saving the data for each garment would just crash your RAM. I may have made the system a bit too complex, haha.

Well, the pants issue was that I used the rose detail (I think I only had a couple of details at the time, the teardrop one and that rose) and it did not show up, so I deleted the pants. After that, they were gone. I think I tried to make them three times, and I deleted each one. So I gave up on that. Then I made a dress, and the pants showed up there instead and as the weird combo, also with the rose detail showing up, oddly enough. I did delete that as well, but the combo then showed up as a different dress that I made. Deleted that, too.  At this point, I hadn't closed the game at all yet. Defeated, I saved and quit, and when I came back later, everything was working fine, rose detail included.

I see, the babydoll thing makes sense. Deleting all impossible clients is a can-do.

As for the details, I was just trying to get them to show up on the skirt (or pants, from earlier). They showed up completely fine in the thumbnail, and I thought I had moved them all to the foremost layer (I used the buttons that seem to move from straight from the first to the last layer), as they looked fine in the design as well, but you can see in the screenshot that one of the roses is missing due to being on a different layer, and the big rose is under the shirt. Since the second is probably because shirts override skirts, I'll just readjust for that one, but the medium rose missing is a little irritating, since that was about my fourth attempt to get all of the details to work. I still don't know if that answers your question. As a side note, I did eventually succeed with a different dress, so it does work fine, it's just hard to tell if the details are actually on a layer that leaves them visible sometimes.

Oh, I see. Not feasible at all then. How many layers are there to a skirt or a dress, then? Just on the basic level. I think even knowing that would be helpful. Or maybe if there was a sound effect to the layer buttons? Because right now there isn't any, and I think that would help, even if there was just one to tell if you had hit the foremost or last layer, or if the buttons faded out when you couldn't move in one direction any more. I don't know if either of those options are feasible either, but it seems that it would be simpler than crashing RAM. Ah well, everything is a learning process :)

(1 edit)

Hi, 

For some reason on the mac the game crashes (for me at least) immediately after you try to save your character's look. I'm not sure if it's just me or something else entirely. Here's what the notification looks like: 

Developer

Yep, a noted bug - Mac doesn't want you to overwrite files, which is what's happening here.

Someone else did this to get around it:

 

I had this problem too but found a way to make it work: right click on
the game and choose show contents, then go to the file MacOS, click on
the thing called nwjs and your game will pop up along with another
window, but you should be able to save this time.

Thanks so much! Sorry about the repetition. I really appreciate your quick response!!

Developer

I'm going to assume it worked then? :D

Yep, sorry for being vague haha. Thanks!

This solution worked for me, too!  Thanks so much!

(2 edits)

Hiya! Really enjoying this game so far, it's rather addicting :'D

My problem is that I can't seem to change my outfit after finishing Neil's 11th chapter (welp, I reckon that I'd need to change my outfit for the next chapter, since I have to design my own ball gown) and as I've looked into the respective folder, that CLTH_00010.png is missing from it, so it's probably either a missing file or a coding error which originally meant to say CLTH_00011.png ('coz that one exists).

Does any of you guys maybe have an idea on how to fix this (playing the latest Windows Beta version, btw)

Thanks a lot everyone~!

Edit: I managed to fix it by renaming CLTH_00011.png into CLTH_00010.png !:D Leaving this here for everyone who might face the same issue. Have a lovely day everyone!^^

Developer

It's not actually a bug - it seems you've created an item (#10), then deleted it, but never saved the game after deleting it. The game is now trying to find the image for item #10, but it doesn't exist, hence the error.


Luckily the next update should force an autosave after you create a design so that this kind of issue doesn't crop up anymore :)

Hi!

I'm playing beta 1.3.1 on a Mac.

I have 4 dresses in my character's outfit wardrobe, so 3 on the first page, 1 on the second page. If I click the top-left item on the second page, and then go back to the first page and click on an item on that page, a trashcan delete icon appears on the top-left "remove outfit" space.  See below:

Similarly, if I click the top-right item on the first page, and then go to the second page and click on the item on that page, a trashcan icon appears in the top-right empty space on the second page. See below:


Same thing happens if I click the bottom-left item on the first page, a trashcan appears on the empty bottom-left space, and same again for the bottom-right and the bottom-right empty space.

On my previous save game, I clicked on the trashcan in the empty space, and an error appeared. I couldn't click anywhere so I quit the game. When I restarted the game, returned to the outfit wardrobe, and tried to change my outfit, another error appeared. I ended up starting the game again from scratch by uninstalling and reinstalling. Unfortunately I don't have screenshots of the errors, but from memory I think they were the same error as the above poster's error ("Failed to Load: img/.....").

I hope my explanation is okay! 

Developer

Thank you, these are very detailed! I've replicated the bug and am looking for a fix now :)

No problem! Thanks for all your hard work ^^

okay yeah, i left a comment earlier but deleted it to try the game again. cx

so i'm doing the client clothing and i'm pretty sure i've got it down but it's not letting me proceed? i'm not sure if you'd call it a bug or not.


unless i'm using the wrong material or the wrong colors?

Developer (4 edits)

Haha yep, someone else mentioned it and I was working on a fix! Seems the data got corrupted, so you can download the fix here. Drop and replace that file in your Tailor Tales > www > Data folder and it should work again! You do not need to create a new game for this to work. I apologize for a sloppy release </3

Edit: turns out, you DO need to create a new game. Your previous save file has the corrupted data stored unfortunately. Thankfully this was right at the beginning of the update haha. Go to your www > save folder and delete all files in there to start a new game.

by new game do you mean we have to start all the way from chapter 1??

Developer

No. Delete all files in your www > save folder to start a new game with the current update and the downloaded fix (or just re-download the game from itch.io and delete your old one if you want to be sure). I apologize for the error.

got it. thank you so much for your help and hard work ! really love your game!

Developer

Thanks! Let me know if this fix works :)

I'm having the exact same error, but for the pink flower dress in Neil's passionate ending. I am for sure the dress is right but it wont let me proceed. I downloaded the link and attached it to my game, deleted my save files and it still won't work for me for some reason?

Developer

That's unfortunate. It's time to delete your  Tailor Tales 1.4 folder and re-download from itch.io again as that version should work.

.

Got this error when Mc fell on top of Neil

Developer

Thanks! Reload and try again, this can sometimes happen due to a core bug in the engine itself.

(2 edits)

I reloaded several times to try again, but it still happens.  I play it through the itch.io game manager

Developer

It's unfortunately not an error I can fix right now, but I do have some ideas how to circumvent it in the future. If you come across it, try pressing F5 so that the game reloads without closing the game, it should hopefully skip it this time. Make sure you're not running anything else either that slows down your RAM.

Alright, thanks

Hello there! 

I really like the game, and I couldn't wait to see Neil's ending...Unfortunately I can't seem to achieve one of the client's request, but I think that my model is the same.  (I apologize in advance if it's me that made a mistake with the model ^^ )


I saw that someone ran into the same issue and that you told this person to delete the folder and download the game again. But I've just downloaded it, so it should work if you uploaded the fixed version...

So I hope that you can find how to fix this ( I will be patient to see what's next in Neil's route x) )

Developer

Very peculiar as that bug should be fixed. Perhaps my newest update to itch.io got mixed up and the bug is back again.

Are you a returning beta player and have you just started the game? Or have you been playing this version for a while?

I'm a returning beta player, I've played the version 1.3 and I was on Neil's passionate route. So here, I just started the game, choose returning beta player, and I encounter the problem almost right away.

Developer

Alright, try redownloading it again, let me know if it works this time or not. I uploaded another version.

It seems to work, once I started the game I was on Dimitri's route, so I change it and get to the chapter 26 of Neil's. I didn't seem to encounter the same client's request for now. I'll keep on playing and let you know if the problem comes back ;)

Developer

Well that's because you went from Dimitri to Neil, so you skipped the clients requests for chapter 26 entirely, it doesn't tell me whether it's fixed or not :(

Ho :s sorry, the game started automatically on his route and I couldn't find a way to start on Nail's route :s I jumped from Dimitri to Neil by choosing the chapter 25 so I thought that I would have the request again :s

Developer

Oops, my bad, seems this version got uploaded with a save file I forgot to delete. If you wanted to restart, all you'd have to do is go to your WWW > Save folder and delete all of those files in there. But that's if you want to start over, you don't need to.

(1 edit)

Hi again, sorry for the late reply! 

So I just tried it, and I worked, I managed to achieve the client request :) 

I'm trying to figure out why this isn't working :/ I wanna hurry and move on to my next chapter but I have to finish this clients design. It keeps saying "That's not what the client wants, some things are missing still!" I'm not missing anything T_T Please fix it :/ This happens on other clients designs too but I delete them .-.
Developer

Oh something definitely broke there. Does the pattern move away from the skirt when you cancel and re-accept the client? And it doesn't let you finish, right?

Did you do anything special before accepting that client? How many times would you say that the random clients wouldn't accept your request, despite matching it perfectly?

Do you think you can upload your save file so I can check it out? The file should be located in your Tailor Tales > www > save folder and called "file1.rpgsave" if you could upload that to for example dropbox and send me the link, that'd be great!

So I'm not entirely sure that this was because of your game, but I think there's a good chance.  I think it caused my video driver to crash.  I can't be sure because my computer seems not to have logged it, but it froze up mid sentence and then the entire screen went black before starting back up again.  The game is still a black screen but otherwise my computer is working fine again.

I was playing Dimitri's route, Chapter 2.  MC had just got ditched by Alex and they were sitting on the sofa talking about Dimitri's birthday.  MC was in the middle of the line where she wonders if she did something wrong.

I just replayed the scene without issue.  If it happens again I will update.

I'm sorry, I wish I had more info or was more certain, but it was alarming enough that I at least wanted to give you a maybe report.

Developer

That seems to be unfortunately hardware related, Tailor Tales is quite taxing. Can you tell me your computer specs, how much RAM you have etc.?

(1 edit)

i7-4790K CPU @ 4.00GHz, 16GB RAM, x64, R9 270x 4GB

My first guess was out of date drivers, but that wasn't the case.  Maybe the video card itself?  That I have a SSD?  It's a gaming desktop but getting a bit dated.  I haven't had the error happen again though.  I'm checking the performance now, but it doesn't seem at all taxed.

Hi! First of all, I love this game half to death. As soon as I found this bug I panicked. I'm playing Neils story and read through the whole story except the 28th chapter on the passionate route. When I try to click the continue button, the screen fades to white for a second and makes a sound but doesn't move onto the story. Am I missing something I need to do? 

Developer

Thanks for playing Neil's ending! Chapter 28 is the epilogue and not yet added to the game, therefor you can't continue :)

Ah okay, thank you for letting me know! I'm glad there wasn't anything wrong.

Hi there! I downloaded the 1.3 version of the game on a mac, but now it's updated to 1.4 I get an error message whenever I start the game up, reading 'error, failed to load: img/pictures/BG_boutique_floor_01.png and I cannot progress beyond that!

Developer

Hi there! Please delete 1.3 and treat 1.4 as another stand-alone version, do not attempt to import your save file or merge the two versions together.

Does the error still occur with a clean download?

Uninstalled and installed the game again, it works perfecly now! Thank you for the quick reply! 

(also Dimitri is honestly too cute I'm not sure my heart can take it!)

I was trying to save the avatar from making it in the very beginning and it gave me this

Developer

Hi there! This seems to be an issue with your Mac version. Try out this solution:

For Mac users, if you encounter an error when you try to create a
character at the beginning of the game, please follow these steps:
- Locate the folder Tailor Tales\Game.app\Contents\MacOS
- Open up the game by clicking the file  "nwjs". This should open the
debug window as well, simply minimize it and play the game as normal!

I was trying to start up the game and it immediately crashed. It only did this once and now it won't even get past a black screen. Previous versions have worked for me so I don't know what I'm doing wrong. Thanks! Sometimes I also get this (picture attached to this post). Ps. I have unpacked it and I've even tried running it as an administrator. I've also reinstalled it about 5 times.  I didn't change anything in the files!

Developer (1 edit)

You're the first one to run into this issue, so something has to be different on your side, I just don't know what, unfortunately. If previous versions worked, then this version should work as well.

You don't happen to own RPG Maker MV, right? :P

Alright I did some searching and it seems the cause is your graphics card. Apparently, if you switch to onboard graphics, it'll fix the problem. So try the instructions on this webpage.

(2 edits)

Thank you for replying so quickly! I actually tried to start the game today and viola , it suddenly worked and it's been working pretty smoothly for a little over 2 hours (in exception to one crash). 

I do not nor have I ever owned RPG Maker MV. Thank you for the research on my graphics card, this actually might have prevented me from playing other games as well. If I ever encounter the issue stated before I will consult the advice you gave me. 

Have a nice day and keep up the great work! I can't wait for the rest of Dimitri's route and the release of Caine's :D

Developer

Ah, bugs that fix themselves! Hope you enjoy playing, and if you run into that error again, try the graphics card thing :)

Hey there! So, before going to do chapter 5 in Dimitri's route, there is an important client, Rose, that needs to be done and I can't seem to complete it because the pattern isn't in the exact same place despite having the correct colors. Normally when this happens with other clients, I just delete them.  I'm guessing this is another bug unless there's some way to adjust the position of the pattern?

Developer

It's not that you can switch the colour of the pattern around, it's simply, you have the wrong colour for the pattern AND the design itself ;)

Switch them around, red for the pattern, black for the pants itself. If you ever find yourself in a situation where your design isn't accepted, it's probably because you need to switch the pattern colour with the design colour!

Oh... well now I just feel silly making a big deal about something so simple and minor.

Developer

Haha it's fine, you're not the only one to run into this issue. I shall make it more clear in the future that you need to watch out for striped patterns like these.

i know this thread is to report bugs but i didn't really have any problem with the game other than the fact that's not finished. :( Don't mean to cause any offence it's just that i'm so addicted to this game that i cannot wait for the next update. just wondering how the progress is going. i fully support and appreciate the game. i just think that it is so unique the way that you have the whole clothes making thing integrated into the story. Can't wait to see the rest of Neil's as well as the next route update. Though i am rather impatient take your time, (quality over quantity always ;)), I hope everything is well and i also hope you know how much i appreciate this game. 

Sincerely

A fan 

Developer

Haha you can just post in the feedback thread :P

There's been a considerable amount of progress! Unfortunately, nothing's been made public, only my closed beta testers can play what I have available right now. The public version has Dimitri's route up until chapter 7, but the closed beta has up until chapter 18, so there's quite a bit of content!

If you want to stay up to date and fangirl with other fans,join the Discord, I like to post spoilers lol.

Tailor Tales keeps crashing a little after opening it. I don't if its the laptop i'm on (windows 10 RCA tablet, may i add if it helps), but it is really getting on my nerves. if you have any free time, may you please tell me how to fix it, or give me a link of a fixed version, please and thank you!

Developer

Can you give me the specs of your computer, or tablet? LIke how much RAM it has, video card, processor etc.

Because honestly, I don't think your current specs are able to handle Tailor Tales if it's frequently crashing. It'd be nice to know what specs you have so I can tell people the minimum requirements to play the game without any problems.

The crashing stopped, so I don't need help anymore. But thank you for taking your time to reply and try to help me, even if you came a little too late. I appreciate what you do! I hope you get the best of luck these future days, goodbye!

(P.S the crashing stopped because I waited one second after the dialogue stopped and waited for me to continue.)

Developer

So the crashing happened because you were speeding through text, is that it?

Outfits created in free mode don't seem to  be saving anymore. Everytime I go to my outfits (dress) tab a floor length white skirt with a single scallop sleeve will be there instead. 

Developer

Hi there! When reporting bugs it's very important you list what steps you've done before leading up to the bug. A description of a dress isn't much information. Are you saying that no matter how many dresses you create, they don't show up in "Outfits"?


However, it sounds to me like an issue with deleting a dress/creating one to replace it and it's showing the old one. It has to do with exiting the game without saving. This issue is fixed in 1.5 (not yet public) but not in 1.4, so please remember to save before you exit the game :)

I'm in the newest version 1.4 And I can't change my characters clothing it just shows me this error

I've tried re-downloading the game and adding my files again and this is what happens. But If I start a new file it's fine...  personally I would like to know if there is a way to fix it, if not that's fine.  

Developer

Hey there! This is something that is fixed in 1.5, but not in 1.4. What happened is that you deleted a piece of clothing, didn't save and exited out of the game. When you tried to start it up again, the game tried to find the image file for the clothes you made before (since you didn't save after deleting it). What happens is the error above; it can't find the image file because it was deleted.

What you can do yourself is go to the folder it mentions and duplicate one of the images in there and rename it to the one that's missing. So it should be called "CLTH_00004.png" and then try to run the game again. Remember to save your game :)

Thank you! And I will remember to save from now on. 

I tried playing the game but received this error after the customization of the MC. I'm using Mac. 

Developer

Hi there! This seems to be an issue with your Mac version. Try out this solution:

For Mac users, if you encounter an error when you try to create a character at the beginning of the game, please follow these steps: - Locate the folder Tailor Tales\Game.app\Contents\MacOS - Open up the game by clicking the file  "nwjs". This should open the debug window as well, simply minimize it and play the game as normal!

There something wrong with the Save data, can you please check Saving  data?

Developer

Can you take a screenshot of the error you're getting?

Most likely it says it can't load a certain graphic, right?  Here's what I said to another person with the same error:


Hey there! This is something that is fixed in 1.5, but not in 1.4. What happened is that you deleted a piece of clothing, didn't save and exited out of the game. When you tried to start it up again, the game tried to find the image file for the clothes you made before (since you didn't save after deleting it). What happens is the error above; it can't find the image file because it was deleted.

What you can do yourself is go to the folder it mentions and duplicate one of the images in there and rename it to the one that's missing. So it should be called "Name of the missing image it fails to load" and then try to run the game again. Remember to save your game :)

here are some of the screenshot when i try save & load data it become like this

Developer

Do you remember what you were doing right before saving? Any details will be helpful to me.

Right now I can't fix your save file - you will have to start a new game unfortunately.

At first the loading data were Okay when I try to save Dimitri chp 7

 it suddenly pop out 

I don't know how it pop out but I very annoy that's I have to repeat again and again. at first the loading data were okay again but its still pop out again after I start to load with Neil Chp2


Developer

Alright, so if I get this right, after the end of each chapter when it asks you to save/load, you click load, and that's when you get the error?

You do not get this error when you boot the game up and play as usual?

Yes!! that's the one main problem!! Even if I did boot up again and again, I still had start from very beginning again after i try save Neil chp14 and getting tired from start all over  (TT~TT)

Developer

At the moment, I can't fix it for you (version 1.5 will not have this issue), however since it seems to happen after you finish a chapter and save, my suggestion would be to only save in the main menu settings instead. So at the end of a chapter, when it asks you to save/load, click cancel. Then, when you're in the main menu, open the settings and save there instead. That should work.

Okay.... I will try your suggest

I'm 99% sure that this problem just comes from the fact that I have to run the game on Wine, however when I'm designing clothes, the only patterns I see are whatever the first client I clicked on requested.

For example,  I clicked on this client's request, and now all the other request I click on won't have any patterns.

Like this, which if I go back to the main menu and then open the client list again, I can actually see what they want.

Similarly, if I clicked on Ginny's request first and then Melissa's, the top of her dress would have a gray checkered pattern as well.


Again, this is most likely because I have to run the game on Wine, however I was wondering if you had any ideas as to what might specifically be causing this?

I don't know if this is the correct thread to point this out, especially since I doubt it's a problem that applies to anyone not running it with Wine,  however I don't know what the proper thread would be.

Sorry for the bother!

Developer

That definitely seems to be an issue stemming from Wine, something about the masking class having issues displaying properly when it's being emulated. So you get masking issues like the pattern not showing up, or showing completely.

Mac versions I already do not support - an emulated version on Wine even less so. Sorry, it just doesn't work properly like that. A legitimate Windows PC would be your best bet to play, otherwise this will stay an issue.

First, I want to congratulate you for creating such a cute and amazing game! Second, I'm having a problem, I'm playing on windows (version 1.4), and I finished Dimitri's route (so far so far, Chapter 7), so I want to start another route, Aiden's, but when I click to start a new route (either from Aiden or any other character) nothing happens, I only hear a little noise, but it continues in Dimitri's save, I always save my game manually, and never exclude any pieces of clothing - I read some saying have problem with that . I dont know what else to do... Can you help me? (ps .: also no error message or anything of the type appears).

Developer

Hey there! Only Neil and Dimitri are available at the moment. Caine will be the next bachelor to be released, that's why you can't play him right now :)

I clicked the download link next to the Windows symbol, then hit 'save' and 'open' when it popped up at the bottom of my screen. I tried clicking open several times, even from my files. It says it's only partially downloaded and whenever I try to click 'open', the screen flickers and sometimes it'll open a blank page tab.

Developer

Are you trying to download Tailor Tales onto a tablet?

I can't change to a new character's route! I finishes Neil's story and wanted to move on, but every time I try to choose somebody else and come back out of the menu it is stuck on Neil chapter 28. Help??

Developer

That's because only one other character besides Neil is available, which is Dimitri. And currently, only his first 7 chapters are available.

The other characters aren't released yet :)

You can get early access to Dimitri's most updated route (which is at chapters 1 - 23 at the moment), through the Patreon.

Hi, I've loved this game so far but I'm having a bit of trouble with the save.  I've had to restart twice now and maybe it's my fault for the first time?  The first time when it would ask me if I wanted to save after a chapter I would click yes and I thought that would be fine but when I came back the next day to play it, it didn't give me the option to load to my last save so I just restarted which kinda sucked.  So I instead tried to save through the setting button and closed out the game to see if that would work but when I reopened it, it just showed the screen where you first start and asked me if I've already played the beta version and I have to go through everything again.  Thank you in advanced for your help! 

Developer

Make sure you unzip your game before playing. You cannot save if it's still in the zip folder.

So I just take it out the folder?

Developer

When you downloaded the game, you downloaded a ZIP file. Right click it and select something that looks like 'extract' or 'unzip'. Then choose your destination folder and the game will be unzipped. Then you can finally save :)

You can also simply download the game through the Itch app and not have to worry about extracting it yourself!

Oh ok, thank you very much and sorry for the small inconvenience!

Hi! I'm super excited for this game but ii kinda experienced the bug on the scene where you fall on Neil (in boutique) where he tripped.  i restarted the game 4 times but it would be the same. i'm using windows 8.1 btw . Hope you can figure it this out because i Really wants to play this game T^T

Developer

Hi there! Sorry you're encountering an unknown bug.

Tailor Tales will get another update in December or January and all bugs will be fixed.

Because of that, all bug reports are outdated and already fixed, that is why I'm closing this thread right now. if you're experiencing any bugs at the moment, please be patient until the next update.

You can get early access to Tailor Tales' most current update (bug free) on the Patreon here: https://www.patreon.com/celianna

Developer locked this topic