Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

How to get your game running in the itch app Sticky

A topic by Amos created Dec 17, 2015 Views: 13,468 Replies: 53
Viewing posts 1 to 28
(5 edits) (+9)

This post used to contain specific advice, but we now have a fully-fledged guide instead!


All of my games are working! Great job on the itch app, it works wonderfully.

Will we eventually be able to search for (and install) any of the 20,000+ games on with just the app? Or will it always just be purchased games, games in a playlist, or staff picked games?

I'm guessing that it'll have a in-itch browser.


Sure. Just leave me the time to do it right :)

In the meantime, collections are the easiest way — shop on site, play in app.


Yup! all my games work beautifully! Good going! :D

wait how do i change which exe it opens? construct 2 exported all my games with a direct x installer, and that's what itch always launches :(

(1 edit) (+1)

Until manifest support is in, there's no way to override it.

That said, for known installers like DirectX, there's easy ways to detect that, I'll push that in a version soon —

Can you link me to your game? If it's a rather typical Construct 2 export, I can make sure it runs well :)

thanks for responding!

the games that are affected are, and

also, that last one is a bundle of more than one game... so is there any way i can have itch show multiple launch buttons for the multiple executables? doesn't really matter since the games are shit, but it would be a cool feature anyway

Edited first reply to include link to manifest issue, which I think answers that question — sorry, I meant to include it in the first place :)

okay thanks for the help!

one last thing, what about browser games? itch tries to download them but just says they're 'broken'


Web games are also planned —

Supporting them is a lot easier than native games, so I left that as a goodie for later :) But it's coming, no worries.


thanks again

also great work with itch. it's already looking really promising, and when it does work (which is most of the time) it's a hell of a lot more convenient and easy than manual downloads :)

Well... i have a few games on and i want to test it out, but turns out Windows XP is not supported so i can't install the app.. *sad*
so i guess the Itch app can't be run in windows XP anytime soon?

P.S don't ask why i'm still using Windows XP!

Oh don't worry, I'm not going to ask :) But no, the app requires Windows 7 or higher, because it's based on electron, which doesn't support anything older.

Appears my game iGrow Game came up as broken once trying to download and install.

My game has separate packages for 32-bit and 64-bit Linux distributions. Currently Itch app always installs the 32-bit version, even on 64-bit Linux.

Does the Itch app simply install the first Linux package it sees or is there some logic to determine the correct one?

There is no special 32/64-bit logic for now, I opted against adding heuristics for that and rather, wait for backend support instead to properly tag builds.


I made a package for Linux according to itch guidelines, i.e. two versions of executable (x64, x86) and a `launch` bash script which selects a version and sets appropriate LD_LIBRARY_PATH and things. However it's not easy for some users to run it: the problem is that they don't use itch app, they download & unpack .zip manually, and they don't or cannot use command line. So they cannot run the script in Ubuntu: double click just opens it in text editor, despite that it has executable permission. And I don't even see any way to run a bash script in Ubuntu's graphical shell, without touching command line. There's no 'run' context menu command or something like this. I don't want to force users to use command line, what else I can do? :)

Yep, that's the way most Linux distributions behave and it's been annoying third-party developers for years now :(

The only option that I know of is to provide a .desktop file, which will appear as a shortcut and is double-clickable to launch the game. Absolute/relative paths may be an issue there though :(

(1 edit)

Thanks for reminding me about .desktop files! Indeed relative paths seem to be not working at all, but there's a workaround (thanks to this SO answer), use %k in Exec line of .desktop file to get path to .desktop file itself, and than extract directory name:

Exec=bash -c "$(dirname %k)/launch"

.desktop file is also better than bare bash script because it may be displayed with custom icon, and even localized name.

UPDATE about icon: looks like relative-path icon is not possible. This time really :(

(1 edit)

I have a simple prototype game using luxe engine, html export ( that won't launch in the itch app. It says WebGL is required to run. Game runs fine in Safari (I'm on macOS 10.12.1), so it looks like the browser the app uses doesn't have WebGL yet? Any ideas on how to fix this?

//edit - I realized this is because WebGL doesn't work on Chrome on my computer, and I think the itch app uses Chrome somehow. I guess it's up to the end user to get WebGL working on their computer then?


That's right, the itch app uses the same engine as Chrome/Chromium - which is usually pretty good at getting WebGL running, at least on Windows/macOS, I'm surprised it doesn't seem to work with your system, maybe it's a bug on their end?

We keep in sync with Electron, which keeps in sync with Chromium, regularly, so if it gets fixed upstream, itch will get the fix as well!

how can i open a file game

I have a WebGL game made with Unity that run on a Chrome browser - but not on app.

Can you post a link to your game?


Is the issue that it doesn't install? Games in draft are not yet supported by the itch app, see - the problem will go away as soon as you publish the game.


Actually, I didn't bothered hitting the install button. Since it's a WebGL game, I thought that it would run on the app in the same fashion as the browser by displaying a rectangle with the game. =P

Now that the game is installed, it's working normally.

How do I select more than one file for download on the app?

Currently I have a demo and full price version (in draft). The app gives me a choice but it doesn't allow me to select both and / or I don't know how to select both. Then after installing the one there is no way I can get back to a place where I can select the other again - I have to uninstall whichever one I chose to be given the choice again.

Since my demo is different to my main game I foresee people will want both - the demo is a 1 hour game in itself. And I want to tell them how to do that in my download instructions, but I can't figure out if that's possible or how to do that myself. Is it possible?

Deleted 4 years ago

I guess that you will have to speak to the dev and it's not an issue on the platform app.

(1 edit)

how do i do that?

(1 edit)

Hi. It seems .exe files which require admin rights dont work. I always get an error when I try to launch it (reported on github already a while ago for app "Antares"). Is it possible to change/fix this? Other .exe files work fine, it seems its the admin thing (exe has a shield icon). :-/


I replied on the github issue directly.

Thanks! :)


(1 edit)

I have the .exe and dll and data files zip up into a folder and uploaded it and it still says that there is nothing available for download but the download will work for the app. Is there something I am missing?

Joseph, that's probably why :)


Our latest game, built in Clickteam Fusion 2.5, is having trouble launching from the itch app. The setup file we're distributing is built with the in-engine Install Creator, which I guess isn't recognized by the itch app yet. Is there a way to make the itch app extract certain files contained in a ZIP to other directories, say, a subdirectory in AppData, or am I looking at changing my setup file into an InnoSetup executable?

ClickTeam's Install Creator is not supported (and won't be) because it doesn't allow silent installs.

I heavily recommend using butler to upload your game - the itch docs have everything you need to get started:

I have a WebGL games made with Unity that run on a Chrome browser - but not on app.


It seems to work fine in the beta:

Can you confirm it does for you too?

You can download the beta here:

Thanks. It is working fine with beta.

Hi! Is it possible to add already downloaded games to the app? If it is, how do I do it? 
I don't want to lose my progress in the games but having them automatically updated sounds great... :)

It's not possible at the moment.

You can try asking the dev where the save-games are and then download the game via the desktop application again and transfer your save games over, then uninstall the existing non-itch install.


I ended up doing that in the end so everything is fine now. Thanks for your suggestion! ^^

Hello; I'd like to request that devs uploading games to itch be automatically linked to the QuickStart Guide so that they can support their games in the desktop application.  Having to poke each and every dev to do so is a bit troublesome on my end.

If it were me, I'd go so far as to making it mandatory (like how Steam makes compatibility with their client be mandatory for sale), however I understand itch likes to suggest rather than strong-arm so that's up to how admins wanna do it.

(2 edits)

I have a game a just recently put up on itch. It is a webgl and currently restricted at the moment until I have more build to show to public. But I cannot run the game in the browser view window or even from the itch app. I built my game in Unity as well, just want to give as much information as possible.

From the itch app, the game is just stuck frozen loading and in the view page, the game screen is to zoomed in so i cannot navigate my menu system to start anything. Is there anything I need to change in the upload settings to get this fixed? I have a couple images to show the issues I am having to help.

I can add images if needed to help show the issues that are happening.

If anyone can help me with one or both of these problems I would be greatly appreciate it!

Is it necessary to use the butler tool to make your game working on the app?


No, back when I still used to upload zips manually I tried downloading my games in the app to check if they worked. They worked just fine.

than i don't understand what I'm doing wrong.. :| (none of my games work in the app)

but thx for letting me know! :)


You did not tag the platform for your files and as such the application cannot figure out which file to download.

(1 edit)

wow YOUR RIGHT!!!!! ;D
thx a LOT arekku I already gived up on this one, but now I can do this for all my games! :)

thx again arekku! :)