Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Issues and Questions Sticky

A topic by The Haunted PS1 created Mar 24, 2021 Views: 5,432 Replies: 91
Viewing posts 1 to 40
Developer (2 edits) (+2)

This topic is for issues you encounter in the Demo Disc, and also any questions you have about the disc.
There is also dedicated topics for Comments and Videos so any comments and videos posted in this topic will likely be deleted. If you want to have a longer form discussion about the Disc we suggest starting your own topic.

Before you ask any questions here please check it's not already asked and read our FAQ here

FAQ:

Q: Does this run on an actual Playstation 1?

A: No these games are all built on and for modern hardware. The demo disc will be a downloadable game for Windows PC's and not a physical disc. Unfortunately due to the high development and testing requirements of releasing 25 separate executables on windows we also will not be able to release for Mac or Linux.

Q: Will there ever be a Physical Release of Demo Disc 2020 or 2021?

A: No. While we have received a lot of messages over the last year about people enthusiastic to help us do a physical release of the first demo disc, we have thought long and hard about it and decided that no matter what a physical release would involve money which would inherently conflict with the goals of the HPS1 remaining a free community run for the love of low-fi 3D games. However this year we are looking at providing digital materials for dedicated fans to produce their own DIY physical copies. 

Q: Are all of the demos for full games?

A: While we cannot guarantee all of the games will make it to a full release, they are all currently intended to be full releases eventually.

Q: Do all the demos have PS1 inspired graphics and are they all horror games?

A: Not Quite. Despite the name the HPS1 is a community where we try to accept all low-fi and retro art directions. As such not every game has to be 3D or have the particular visual quirks of any specific hardware. In a similar way we do not require the games to have a strict horror theme, instead they can be atmospheric, have a slight unnerving twist or even just feel so of the era that we can't resist loving them and wanting them in the collection.

Q: Was this a game Jam?

A: No, this isn't a game jam, while some of the projects may have been in development for short periods of time, there are also many that are just neat vertical slices of longer term passion projects from members of our community.

Q: Who is involved in the creation of the Demo Disc 2021?

A: There are at least 44 members of our community involved in the production of the disc and the demos they are all credited in the disc itself and as many as possible are credited in this Twitter thread.

tMod asks if I want to install a C++ runtime; I click yes and it lets me install some Unreal prerequisites, which I can do, but it still just asks me the same thing when I launch it the next time. Game itself won't launch. (I installed a C++ redistributable manually and the same thing happens.)

Developer

just updated a fix on my page to test and later push to the demo disc download https://tobyme.itch.io/tmod

Developer

hey any way i can contact you to track down this issue better cause i havent been able to reproduce it

How do I restart the game from scratch? Like Skelly's dialogue and everything?

Developer

You can find your saved data at AppData>LocalLow>The Haunted PS1>HauntedDemoDisc2021

(+1)

How about when the game is installed through the itch desktop app? I have it installed there since the game can automatically update that way, and also wanna start from scratch to show it off to folks.

(+1)

Nevermind, found it! This is for Windows 10: The itch desktop app seems to have its own folder under your Users folder. Go in there, then use the AppData>LocalLow>The Haunted PS1>HauntedDemoDisc2021 path.

The experience of launching the games didn't really work the first time I tried it, I interacted with one of the games and thought it was going to take me straight in, but the game just froze and i didnt understand what to do, and I realize now that the launcher simply failed to open up and take over for the new game. I had to alt-f4 the "lobby" game and then it worked the 2nd time.

Developer

Sorry the experience didn't go as smooth as intended. I will pass this post on to the launcher devs and they may reach out to ask for more details if they need them.

(1 edit) (+1)

playing peebs with a controller from freeplay opens up other demos when you're playing. alt tabbed and i had 30 different demos open. should mention this happened multiple times. had to restart because things just kept opening. happened 2 different times

(1 edit) (+1)

I keep getting this error message while trying to start "Agony of a Dying MMO"


(I checked. The data folder IS there and it has the exact name. I have no idea why it keeps getting this message.)


A few other weird things as well, the dev is uncredited and all sources of him are wiped from the collection. His itch.io page for the game that I had to go find seems to be locked with a password as well... wtf?

Developer(+1)

We are experiencing issues with agony of a dying mmo currently, we will look into this as soon as possible

Thanks! Lmk if you can whenever you guys get it all sorted so I can play it, can't wait!

(+1)

Darn, I heard so much about it and its what got my attention peaked for this compilation....which led me to find some AMAZING demos of games I never saw coming. Still, its the only game I didn't get running out of all the games.

(+1)

Same. Got the demo pack specifically to play Agony. Can't  run it and can't even find much about the developer because their .io is behind a password and their twitter isn't public.

(+1)

same :( I really want to try it!

(+1)

Ditto, thats the sole reason I got the Demo Disk
At least I know that i'm not the only one with this issue, hopefully they patch it soo

(+1)

I'm hoping thats the reason its locked behind a password. Not some backlash with people that cant chill. I've seen some of the comments on some of the tweets about the game and made me want to make up my own mind on it.

Developer

It should be fixed in the latest update

Still broken

Runs fine, for me at least. Looking forward to playing it.

Is there a way to download individual games without downloading the whole 4 gb file?

Developer

Some of the demoes are available separately. We can look into maintaining a list of the separate downloads but right now we aren't providing this.

is the lorns lure demo a new demo for this demo disc or is it the same demo as before?

(+1)

It's the same, more or less. Play it again tho!

just a note: on the demo disc 2021 itch.io page the link for 'agony of a dying mmo' goes to google.com

and now the 'agony of a dying mmo' link takes me to https://hauntedps1.itch.io/demodisc2021

this may just be an issue on my end.

I'm having the same problem. i was seeking more info on the game but it is behind a password protected page.

i was just wondering what happened here?

So many comments hating on the game despite the recommendations...and now i'm here unable to even play the game due to an error. :(

Developer

The error should be patched out in the latest update

When I try to launch Walk it launches in a small window that I can't resize instead of full-screen, any fixes?

Developer

try pressing Alt+Enter or F11 for fullscreen

Tried but it didn't work

same issue here, alt ent and f11 dont work either 

(1 edit)

I been trying to install this game since yesterday but it always failed from "network error" it says. it's probably because it's 4 GB so it not easy to install it on a computer it did work on my laptop but I want the play on my computer and it takes so long to install it ok bye

Developer

If you have it on your laptop maybe you could transfer it with a usb stick or external hard drive if you have access.

When I tried to launch Toree3d it launched 10 copies of it, and once in game it launched 8 copies of [echo stasis]. Maybe this demo disc really is haunted haha.

Developer

Were you using freeplay mode?

Yes I was playing in Freeplay

The book on the ground floor isn't opening for me

for me tmod doesnt work 

Developer

hey peter, im sorry it doesent work, what kind of issue are you experiencing? Does it simply not open?

yeah it pops up with some thing saying about a engine problem

I have an issue with An Outcry.

I have pressed every single key on my keyboard, but when I press either of my ALT keys, the game automatically quits.

Hey, dev for An Outcry here. I have two ideas you could try to fix the issue you're experiencing:

1. Do you have a controller connected? Controllers might interfere with the keyboard controls of the game- If all else fails, the game is also playable with a controller.

2. There is a rare bug with the engine the game is made in where keys "stick" on the keyboard, interfering with any other keystrokes due to input being dropped. The developers of the engine are aware of this bug, and have offered a fix for it here:

https://steamcommunity.com/app/362870/discussions/0/541907867763056737/

Here's an official troubleshooting topic for this issue. I'm hoping it helps!

It actually worked, thank you.

I got really far along in The Chameleon, but when I tried punching the electrical box covered in electricity, I died (yeah, it wasn't a great idea, but I wasn't sure what to do, haha). When I had died previously, the game reset me to a checkpoint just fine, but this time I'm stuck on a black screen. I can use my abilities and watch my energy bar go down and hear the sound effects of them and my environment, but I can't see anything besides the UI overlay, and I can't seem to punch either. I tried opening the menu to swap the graphics settings around, but it didn't help.

Super fun game though, I had a ton of fun!

tMod is still giving me the "Would you like to install Microsoft Visual C++, etc." in order to play through both the HPS1DD and the individual download on the developer's (tm's) itch.io page. I really want to play it because it looks awesome and my friends keep telling me great things!!

Developer

hey, im really sorry you havent been able to play. Is the popup installation giving you errors or does it simply not install? Have you also tried restarting your computer after installing the first time?

don't be sorry! the popup installation is primarily giving me errors, it has only asked if I wanted to actually download the C++ stuffs once and I declined bc i didn't know if it was necessary or just some fluke. i can try to recreate the problem and download it and then restart my laptop if you think that'll work!

Developer (1 edit)

Oh its a regular prerequisite installation, you should install it to play, otherwise idk if its a real issue at all. Let me know if you do retry!

Would it be alright to ask for a list of content warnings for the games? I love horror games, but I'm a bit sensitive and would appreciate some warnings, just so I know which games are okay for me.

Developer(+2)

every game has a question mark next to it, which includes the content warnings!

(+1)

okay, thank you!

I am using a ps4 controller connected with USB but all the games that have support have the camera spinning like crazy. Help?

Developer

Have you tried unplugging it and replugging it? A lot of controllers get drift when the connection isn't 100% perfect

Same problem here, seems like the buttons get remapped wonky and camera X is mapped to L2 trigger. 

(+1)

Janitor Bleeds will not open for me.  This screen keeps appearing, and no matter what I try, it has not loaded.

Same for me on all the games I've tried :/

(1 edit) (+1)

Not a fix, but if you really want to try it (I really liked it) and it doesn't work for you no matter what, they've also got a demo on Steam.

Thank you! I'll have to check it out.

Anything in any of these which would would break Twitch's TOS or is it safe to stream?

Developer

These should all be safe to stream. Heed the content warnings in regards to whether the game might be a good fit for your stream or not. 

(2 edits)

Fiend's Isle crashes whenever I try to get past the controls screen. (I apologize for all my questions!)

Developer(+1)

I saw one other person with this problem, but I'm not sure what's causing it. Could you let me know what version of Windows you are running? Also you can try the stand alone version here: https://iwilliams.itch.io/fiends-isle-demo

I have Windows 10 Pro, version 2004. I downloaded the standalone version as well, but it also crashed.

Developer

If you're willing to help test, I just uploaded a debug version on my itch page that will give you a console that should show the error when it crashes. It would be really helpful if you could grab a screenshot of any errors showing up in that console!
Go to my page and grabfiends_isle[windows]_v0_6_6_DEBUG.zip

  • Playing Mummy Sandbox, my camera was stuck in a constant rotation. Thought this was some bizarre intentional game design before I looked up other people playing it, haha. Played with a mouse and not through Freeplay, for context
  • Lorn's Lure end-level tally screen disappears way too fast to be read.
  • Not so sure on this one but what triggers the music in The Chameleon? I think I heard maybe two pieces of music in my entire playthrough, and when I watched someone else's vidoe they had stuff playing I never heard.

Hello, when I play the game "Walk", it can't be fullscreen, what should I do?

when i try open it,, it says 

Failed to load PlayerSettings (internal index #0).

Most likely data file is corrupted, or built with mismatching

editor and platform support versions.

(1 edit)

Trying to avoid spoilers, so I'll post my problem in a comment below, hopefully help people skip it if they want to go in unspoiled. (Never posted here before, please let me know if spoiler tags work.)

S
P
O
I
L
E
R
S

I can't get the secret game that launches off of the computer in the bar to work. It loads, but all I get is a black screen. I can hear my foot steps moving around, but that's it. A friend who's watched a Lets Play of the game told me that that's not what's meant to happen, that I'm supposed to start the game in a lit up room. Am I missing something, or is this a bug?

Same thing happened to me. Would really appreciate some help on this one, I'd like to see what's going on in the secret game

Adding a 3rd to this. I encountered the same issue when playing. 

I think we've been abandoned on this one, unless an update cleared it up. It'd be nice to know if it's downloadable outside the demo disc itself. Hard to find that out without knowing the name.

When will the discord open back up to new members? I know the Twitter said 1-2 weeks but it’s a little over that now.

I downloaded the demo disc and ,though I haven't opened every game yet, the games that I've opened from the opening screen so far seem to work fine. But Walk doesn't seem to open? Every time I try to open the game it gives me the, 'switch to another tab screen' but the game never actually opens. Like I said, the other games that I've tried have given me no issue. I downloaded the demo disc specifically for my interest in walk so Its kind of ironic that its the only game I cant play haha. Have other people had this issue before? and more importantly, is there any way I can fix this? Other then that the disc is great! Very fun and well done!

(1 edit)

I'm using ps4 controller with usb to try to play the game but the controller has mapped weird on both of the two games I've played. The camera wildly spins to the right because I think the right camera control is mapped weird and all the buttons are a bit off (Square is select, R2 is pause etc). I had similar issues before on some games I bought through steam but I was able to fix that by setting steam to recognize my controller. I checked if I could do the same thing through the itch app and I can't find an option to.

THIS POST CONTAINS SPOILERS

Whenever I try to launch the "video" from the password-locked computer my game transitions to a pure black screen. If I click the wsad keys I can hear my character moving around; I tried looking for an exit that might trigger a loading sequence and restore the visuals, but no dice.. If anybody could help me fix this problem, I'd greatly appreciate it.

Same problem as a few others, Walk launches as a small window sadly and alt+enter or F11 don't work sadly :(

Hi, how are you??? I have a problem installing the "demo disk", but every time I get a message that says "the version of this file is not compatible with the version of Windows you are running. Check your computer's system information to see if you need a x86 32-bit or x64 64-bit version of the program and then contact the vendor " Please if you could help me I would really appreciate it as I really want to be able to play these great demos.

it means that you don’t have the right architecture to run it. You’re probably on an older system that is x86.

Ahhh ok 

 thank you very much for answering
 Greetings.

Hey everyone! First ... great project;) I think its super cool!

Can you somehow establish contact with the dev teams?

I am an environment artist myself and would like to offer help and participate on projects like these.

 Cheers 

Nico


btw. i hope this is the right way for questions like these^^

Why was this Game is Built  4GB whyy i just want to an demo of toree 3D  :(

(1 edit)

Protagoras Bleeds looked very cool and when I went to download the application to play the game, the game showed the launch screen, but then put me back in the hallway with the soda machine. 

Has anybody actually had an issue fixed in here? Anyway, I launched Walk and like the others I can't make it go full screen, but worse than that I can't get the menu to respond to any input at all. WSAD, Arrow keys, numpad, mouse, nothing works except the Enter key which makes me exit because Exit is highlighted by default. Wish this was available in some form outside of the demo disc launcher.

It’s been brought up before but Walk does not launch in full screen and neither F11 nor alt+enter seem to work. Has there been a fix to this yet?

I tried playing with a PS5 controller and there doesn’t seem to be a way to crouch. I tried clicking in the left stick like it says on the control page but nothing happens. 

(1 edit)

I launched the game and no sound is playing. So i reinstalled it, and there's still no sound in the menu or any of the games.

I wonder these amazing demos are made by which game engine, for I really want to make my game like these,. That s so coool!

(+1)(-2)

hello, these are made in Microsoft Excel ™... thank you for playing