Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

bug reports Sticky

A topic by loren schmidt created Feb 04, 2016 Views: 2,139 Replies: 44
Viewing posts 1 to 22

this is a thread for letting me know about any bugs you encounter while using dungeon decorator v. 0

i'll do my best to fix everything i can!

Developer (3 edits) (+1)


  • mouse input issues in firefox
  • smoothing issues in firefox
known bugs:
  • irregular solidity behavior when switching tiles with wasd
  • game hangs when platformer character touches edge of world
  • loading games breaks sometimes in safari (caused by = in datauri)
  • editor becomes tiny on hitting fullscreen button on
  • irregular spawning rules for nongravitational player character

if i run into another room with the little pal on the rightmost screen the game freezes :(((((((((((((


thanks! i think there's an edge wrapping issue with the platformer character. i'll investigate...

(1 edit)

I am unclear on if these are intended behavior, but they were confusing.

  • the itch page scrolls down when I press spacebar to jump. I don't know if you can cancel the event in an iframe or not.
  • a little thing about how wasd/e/q works would be nice?
  • I couldn't tell what was happening with the diamond, it seemed to cause me to spawn in the next room over
  • hard to tell the difference between collidable and uncollidable all black cells.

Feature requests:

  • helpfile, please :)
  • the scrolling in the embedded version is a problem- most of the player character controls also scroll the page! i'm not sure yet if there's a way to fix that on itch, but here is a clean version which should auto-resize and solve the problem. folks are welcome to use this offsite version instead:
  • it's true, i think wasd / q / e (and f) could stand to be explained more fully somewhere. possibly the in-game help file is a decent place for this, or a series of video tutorials.
  • the diamond is a second, nongravitational player character. thanks for the heads up- it seems there are some spawn rules which don't correctly handle having two types of player characters. i've added it to the list and will fix it!
  • solidity can currently be set manually per-tile. you can check solidity by holding shift. it seems there is a bug where switching tiles with wasd ignores the defaults, which can result in some surprising solid / nonsolid tiles. i'll put that at the top of the list.
  • i agree about the need for a help feature + more documentation!

thanks so much for all the helpful feedback. sorry about the bugs! i'll work hard to get this shipshape for the release of v. 1

when loading a saved game image and then going fullscreen, the editor becomes... tiny? not an issue if i go fullscreen and then upload the image.


oh wow, that's exotic! i'll check it out. what browser are you using?

chrome on a mac- i think it was a problem with the embedded version on, so it might be a bug on their end? either way it's not an issue with the full screen one on your website.

A few things:

  • At some point I lost the ability to save my level, not sure what caused it but now the save button does nothing.
  • Like @jonbro said, the diamond is very confusing.
  • I really don't like how the player teleports to seemingly random locations while editing. Happens most frequently when changing rooms from the map.
  • This level that I was working on is kind of a mess because a diamond I put somewhere is causing the player to sometimes become a flying enemy thing. I'd try to fix it but the save button isn't working, so there's no point (save you levels offline frequently!)
Besides that though, the editor is great so far! Really love the tile set.

Also for anyone reading, here are some useful shortcuts:

  • Shift highlights tiles with collisions
  • G toggles the grid
  • Z and X rotate tiles
  • Ctrl picks a tile
  • L does something awesome.

thanks so much for the bug reports. that's very helpful

  • i'll look into the save button issue. i've seen this myself, but don't have a way of consistently reproducing it yet. i'm sure it will be come apparent- in the meantime, it would be helpful if anyone happens to discover a way of reproducing this.
  • agreed- sorry about that! i have some work to do there.
  • thanks. the teleporting player is definitely confusing. that was originally a feature to ensure there was a playable character present at all times- it's making player characters at a random location when it doesn't detect one. i think i need to move to a more consistent solution though. i'm considering making right click spawn a temporary player character, which would possibly make the random spawns redundant. (all suggestions welcome)
  • yes, while things are solidifying it's definitely a good idea to save your files frequently! also for reference, if you want to remove a diamond or a platformer player character, you can use the x next to them. it deletes entities. (here's a version of that file with the diamond removed: )

i'm glad you're enjoying the tool! it's been fun seeing what you make with it.

"making right click spawn a temporary player character" this would be perfect. I think letting you playtest as you edit without having to press any other button is really good and making that feature as user friendly as possible should be an end-goal of sort.

Also just for clarification, is the diamond a separate player entity like what you had in your game? For some reason I was thinking it was some sort of 'interact' tool which let you do more advanced things, but I guess not. Since you can't really have the platformer player and the diamond character at the same time, it would make sense to have it as a toggleable button that lets you switch the player from one type to the other instead of two separate buttons. That way users will understand what the diamond is immediately and not get confused like me and others have been.


yes, the diamond is a separate type of player character.

the toggle idea is good- i'll see if i can work that into my plans. my current thinking is that eventually the rest of that palette will be filled with other types of entities, such as particle emitters, various characters, switches, doors, and the like. the plan is for all of them to be optionally player controlled.

(1 edit)

L for light WSDA to navigate on tile textures, X Rotate tile, Ctrl picks a tile, G toggles grid, shift+clic to edit colision layer (pink is path and not colider)

To save, I did it a lot coz its buggy and I needed to refresh page several times (it worked better on chrome). Clic on save icon, rigth clic on image and save it(its your map!) Then you can load it by clicking on top left corner and send your file.

There is no icons for some props like water drops, enemyes key stuff.
I didn't get how to put messages.


If player go on border map its freezes. Careful to leak. Save before cliquing on enlarge screen or click on it when start to make map coz sometimes the game re-sizes strange and canot save/edit or recover it, need to refresh and lose your data.

I can't seem to get the save function to work in Safari. The "copy to clipboard" text isn't clickable the way it is in Chrome, and the image doesn't seem to appear in the blue box. Let me know if there are more details I could pass along!

Purely look and feel but the screen transition effect feels too slow sometimes. This is especially obvious if you drop down a long pit through multiple rooms, not much time to see the next one before you're out. Maybe pause the game execution until the effect is partially over?


agreed about that transition. yes, i think perhaps that could be addressed via some combination of forced pause and perhaps making the region around the player always transparent? (also the eventual plan is to have multiple transitions available and let folks pick.)

I mentioned this on Twitter because I hadn't yet seen the link to this board, but loading games doesn't work reliably in Firefox because loadDataURL assumes data: URLs load synchronously, which is only the case in Chrome: .

If you wrap the rest of that function in image.onload = function() { ...} that should make it work reliably cross-browser.

(1 edit)

currently having an issue with the save system - maybe because there's been some new tiles between the version on vacuumflowers and the one on itchio? - i'm building with itchio's

(left one is original, right one is loaded - same results from url and image)

here's the saved picture if it helps:

specs: windows 10, chrome


i have a lead on a fix for this. i think it may be (at least in part) due to incorrect handling of tile rotation- possibly it ends up with rotation values outside of the 0-4 range (which is fine internally, but won't save correctly). i'm looking into this right now actually, and i'll upload the fix tonight. i sincerely hope that will address all of the save corruption issues. that's such a tragic bug; by far the worst bug on the list. fixing that is my highest priority right now.

it seems like hitting the "X" to clear the scene doesn't account for sprite rotations? i uploaded an image directly then hit the X to clear it and this happened

(1 edit)

of course uploading images directly probably does a lot of weird stuff, it just seems like X should clear it completely no matter what. (by "image" i mean an image i made outside of the program, not an image made by the program)


oh thank you- the clear function predated the tile rotation and didn't reset it! i'll fix that.

woot woot! Making progress. Took me a while to figure out what was going on here, so yeah... maybe I'll help contribute to those docs. : D

The biggest challenges for me were understanding player placement, that there is no "goal" marker, what in the world that key is (do I even understand it now?), and why my player couldn't move anywhere ... that owing to the empty blocked tile. : P

Also, I'm guessing signs just don't work yet? Otherwise, add that to the list of things I don't understand.

Work in progress that'll have ya traverse back up the waterfall is here.

Oh, and I guess it wasn't clear to me how to get to the playable version of my game as the creator... figured out I had to just click to share it and open that URL in a new tab myself.

Also, I think a button for triggering the load from the uploaded file would be wise. The magic load right now is jarring, and it then didn't seem to let me reload from a saved image once I'd edited the loaded level.

Oh, and since I'm posting in the bug thread, I should add that touching the bottom of the map through a non-blocking tile wraps you around to the top screen in the map even if it is blocking. Had that happen with the pool at the bottom of my waterfall before I changed it to the linked version.


thanks so much for your feedback. i'll try to make these things more intuitive over the next few releases. in the mean time, i'll try to clarify:

the keys are a partially implemented feature- they will be a multifunction key / collectible in the next release.

there's currently a bug which can cause tiles to be solid (or nonsolid) which shouldn't be by default. i'm working on a fix, but in the mean time, should this happen, you can fix tile solidity by holding the shift key and clicking.

you're correct- signs aren't implemented yet (but will be in v. 1, later this week!)

(your game is coming along nicely, by the way)

I saved and now I can't load again: top row loads fine, but below is a mess.

One time I got:
IndexSizeError: Index or size is negative or greater than the allowed amount save_load.js:232:0

Another time:
TypeError: tile is undefined

save file is:

You can also see it in the player version: link


this is a new bug- thanks so much for reporting it.

i get your "first row only" error 100% of the time on my end, which bodes well for finding a fix quickly. thanks for the file! i'm looking into it.

Wow, not sure what happened, but it appears that when I started to rotate tiles on my later maps, the tiles went CRAZY. : P

What's funny is the blocking vs. non-blocking elements seem to persist, but it's obvious once you start climbing back up from the fall down the waterfall things go awry. Current version here.

Again, not sure if this is due to rotation or what, but this dungeon looked like this screenshot before I tried it in the player. : P


thank you for the info and the links! someone else seemed to have the same issue and suspected the same thing as you earlier. i have a hunch it is due to rotation- that would make sense. i'm terribly sorry, this is such a tragic bug. i'm working on a fix right now, and i'll upload it tonight. hopefully that will be the end of the tile garbling bugs.

Occasionally, I see what should appear in the "empty" tiles in the tileset. (I know I can select and place them to see some of the future sprites and such, but in the editor they appear empty while in the player they actually show up as they should.) Is this intentional? Just an issue of version management?

For that matter, it would be nice to see in the interface what version I'm looking at, including ensuring I'm seeing the correct images somehow. : D


thanks for your response. agreed- for a while i was planning to incorporate new tiles as i added them, but i've decided to keep versions separate so as not to mangle people's creations. so i've reverted the version at to the original tileset, and the next version will be at a separate url.

it will always be possible to take your save files from an older editor and open them in a new one (and then manually tweak whatever is necessary due to changes between versions)

i hope that makes dealing with a pre-beta tool more pleasant and predictable.


i've fixed several bugs (including the nasty tile garbling bug) and i've rolled out a new version at which incorporates these fixes!

(3 edits)

Thanks to everyone for reporting their issues and your work on resolving (or trying to resolve) them, Loren. I seem to have encountered a bug where if I load a map no avatar is generated. I'll try loading other maps and see if it's a consistent issue. I'm using Firefox 44.0. ...update: It appears to be a consistent issue.

Also, is there any difference between and These are the URLs I'm going to to make my test maps and getting no avatar when loading them to play.

I should perhaps also note that the map is smaller on those URLs than it is here (maybe two or three times smaller) -- -- although the smoothness/responsiveness is better. Is the relative smallness intentional?


thanks for letting me know about the avatar issue. did you place a player when you were in the editor, or were you playing using the one automatically placed?

re: differences-

yes, i've been updating the version at quite frequently, and i've been updating the one here on only when i have more major builds.

thanks again for the bug report!


hello folks- i've been fixing various bugs, such as the focus issues, tile garbling, etc., and i'm working on a fix for the bug where part of the map doesn't load. i'll be uploading a build shortly (to both itch and my own site) which contains all of these fixes. i'll post here as soon as i upload!

Glad to hear about these fixes. You're really putting so much work in on this. In regards to part of themap not loading, will this mean I can load a previously broken map?


if it's the bug where only the upper part of the map loads, my hope and suspicion is that it'll load correctly after the fix. the bug is likely caused by a tile with weird data in it which somehow breaks the rest of the load process. if so, once i add a proper error handler for that it will be able to read past the erroneous tile with no issues.


i'm pleased to report that i found a fix for the partial map load error! if you had a map in progress which was affected by this issue, your map file will now work with the editor here:

and the player works as well.

(2 edits)

Hi Loren!

So I loaded a map, worked for a bit on it then hit fullscreen and it looks like the attached image : [ Checked the console and there aren't any errors. This is Win10 on chrome.

I know this is an older tool, but I was having trouble saving and loading. Is there an issue, or am I just having trouble figuring it out?