Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Forum Bugs & Glitches Sticky

A topic by Gorbles created Dec 01, 2015 Views: 2,564 Replies: 29
Viewing posts 1 to 20
(5 edits) (+1)

Hopefully a helpful thread!

All issues encountered in Firefox Developer Edition (44.0a2 (2015-11-22)) or reported by other users (see posts for browser reference as a rule).

  1. Clicking HTML source in any post editor and back out auto-selects a bunch of text on the page and you can't click onto something else.
  2. [FIXED] Editing a post and completing the Edit redirects you to the beginning of the thread, wherever you were in it.
  3. [FIXED] Missing word in subforum rules.
  4. Cursor vanishing occasionally.
  5. Cursor redirecting to start of reply box occasionally.

Will update with more, as I find 'em (and cross them off whenever people sort them out or correct me) :)


Thanks, I updated the topic title to mention the forum specifically. We'll try to get fixes out soon.


i've stickied this thread for the purpose of using it as a general bug report thread. i or the other mods can update the OP with bugs as they're reported or as time goes on.


There's a word missing in the rules of the Devlogs forum:

If your has a visual component, screenshots are mandatory

fixed, thanks


I think the fix is broken ^_^

If project your has a visual component, screenshots are mandatory

lol nice, well thanks for checking my fix :)

Sometimes when I write a post my cursor will vanish and I can' type anymore. If I click back into the field I can type for a few seconds and it will vanish again. The only fix appears to be refreshing the page.

Happens for me on: Firefox 42.0 across 2 machines. Have not tested in other browsers.


It has happened to me too, on Firefox 42.0 . I don't know what triggers this bug.


Can confirm this is still a thing. Firefox 51.0.1 (64-bit) on Windows 7.

(3 edits)

Cursor issue, not sure if it's my browser or something I hit on the keyboard but every now and again my cursor keeps on getting sent back to the start of the reply box. I'm not hitting Home or Page Up or anything like that.


Updated OP.

Something I just saw, made a post.

"You post has been posted."

I'm not sure if that's exactly how it reads, all I could remember was that it read "you post" instead of "your post"

Pls fix? pretty please? It's just a bit too weord. XP

By no means is this a high priority recommendation, but when a thread only has one post in it, it reads "1 posts."

It's not a big deal, but it'll feel cleaner if it starts saying "1 post" or "1 view" and then switching to plural words when there are multiple of said issue.

For some reason i cannot see the second page (or any page after the first) of the Devlogs subforum. Every other subforum that has more than one page works fine, but when i clock on the devlogs' "Next page" link i get a "There was an error with your request".

I am using Firefox 42 if that helps. The URL the forum tries to open via that link when it fails for me is ""

(1 edit)

Same error with FF 42.0 on ArchLinux

(1 edit)

Firefox Developer Edition, works for me (C&P'd that link into my browser). Could be a session-based issue, have you tried flushing your cache / deleting cookies?

FWIW it seems to be fixed now (i didn't do the cache/cookie deletion thing because i didn't want to lose existing sessions in other sites).

Very likely session-based. I do wish Firefox let us delete stuff for individual domains, Chrome's control over that kinda stuff is much better :(

In the devlog section, you can now set completion progress but 40% is missing

hi, hopefully this is the right place. But I had uploaded a my game.. and after a few days uploaded a new build yesterday.
-some users have reported that this new zip gives an error, and
-the file size is reported to be only around 3mb, whereas
-a file of around 48mb has been uploaded
I've tried downloading the file myself and it works as expected (I get a full 48mb download). Is this an error with the itch servers?
is there something that I can do on my end?

In the devlog section, is it possible to update the completion progress % ?

am I missing something or it is not possible to jump to the last page/post?

Every time I exit the game and go back into it, all of my pre-crafted weapons are disassembled right where they are. The pieces just fall off, as well as the crystals always reset.

I don't know what version of the game I'm in because I checked the sign that is supposed to say the version number but its just blank so that's another thing, I could be checking the wrong place but from my understanding it isn't there.

If there is any information needed from my end just let me know what I can do to help.

(2 edits)

Also, forgot about this till I started playing, there is a small chance of objects glitching into the floor, sometimes walls, when I break open a delivery box. Is it possible to make it so that objects have designated spawn positions inside of the box rather then spawn everthing into one point and spew items everywhere?

There is also a glitch with the displays, when I have great swords, great hammers, or pole arms in my displays the customers always enter the shop, make the order, and if it is one of the weapons I listed, they will go outside and up the stair case to the top of the shop as if they are trying to pick up the weapon through the roof. Seems like they can't reach it for some reason.

This is slightly different then the last, some items on the display work perfectly fine, usually the lower items like one handed swords and daggers, but other times they customers don't recognize the items on the wall or on the table top in front of them. The only way to get them to buy those items is to take it away from the customer and then present it to them.

Lastly (this isn't really a glitch but something I think was missed), There isn't a one handed hammer display in the shop. There are two different pole arm variations above the door and one of each weapon on the wall, great sword, great hammer, one handed sword, and dagger.

(Also the dagger display won't hold any items, the rack be on no collide from Gmod.)

(1 edit)


Dear Developerteam,

I´m using Assetforge for Unity 5.6. Everytime I import a new object with

a texture, there will be automatically added a folder with textures.

But after importing another object the names of the textures which will

be importet to the project are still the same. So in this way the

existing Texture will be overwritten and the old objects will have

another texture. I think it would be cool if you give the user the

chance to name the texture he is creating. Or you have another Idea .

 I love AssetForge it´s a great Idea and perfekt way for programmers to

lower there work for graphics and texturing.

I hope I was able to help making this programm better

I'm expiriencing crashes all the time after maybe 20-30 mins of playing 

(1 edit)

coming across the same issue with several games and I don't know how to fix it. It seems I'm not the only one either.  I keep getting game crashes and the only error in the log is that it can't find the manifest. 
no '.itch.toml' file in top-level directory

Any idea how to fix this? I'm on Windows 10 CU but I can't seem to get past this issue.  The games having this issue simply won't load. They crash upon launch and apparently that is the cause, but I don't know how to fix it.

there is a bug that when surfing the sale list, it can't show anymore photos of the games below.

Really good game but it keeps crashing and my Norton Security keeps deleting it every time i download the new one  

Cursor redirecting to start of reply box occasionally.
Will update with more, as I find 'em (and cross them off whenever people sort them out or correct me) :)

I swear number 2. happened to me in the past many times but number 4 never.

Anyway thanks for great summary of glitches. I've had some other specific issues i thought it had to do with my hardware, will post them later.