πŸ€‘ Indie game storeπŸ™Œ Free gamesπŸ˜‚ Fun games😨 Horror games
πŸ‘· Game development🎨 AssetsπŸ“š Comics
πŸŽ‰ Sales🎁 Bundles

Known Bugs Locked

A topic by Cairn4 created 351 days ago Views: 2,815 Replies: 80
This topic was locked by Cairn4 95 days ago:
If you think you've found a bug, please post a new topic!
Viewing posts 1 to 34
Developer (Edited 15 times) (+1)

Here is a few known issues that currently exist in MewnBase. If you happen to find a bug, feel free to add it to this thread.

Non-Responsive (blank screen) when running the game on OSX on some machine
There's a couple things you can try - Try seeing if the mewnbase-java.zip version works for you. I've also heard that running the game through the Itch desktop client usually seems to work. Trying to figure this one out.

macOS: Can't command-tab out of game if toggling full-screen mode via the main menu button.
But using the native full-screen button on the title bar, then command-tab seems to work fine.

Bases that span across 3 more more chunks
Bases that go across 3 or more chunks will behave unexpectedly and won't keep good track of their air / power supplies, since the modules in the chunks farthest away from you will get unloaded.

Suit power stays off and HUD invisible even though the player is in a powered base
Suit power and HUD should get recharged / made visible after you re-enter a powered base. This issue seems to happen if you loose power and re-enter a base at roughly the same time.

Scrolling with the mouse wheel in the console window breaks inventory scrolling
Currently you'd need to save and quit and reload to get scrolling to work again.

World generation at negative coordinates doesn't work
Tiles don't line up, things get all wonky.

(Edited 1 time)

Strange behaivor by Closing the Storage Module

Its almost impossible to press the Closing Button by the Storage Box

Dont Use the fullscreen Mode under play

If Game is fullscreen mode(Max Button under windows), the menΓΌ looks really wired.

Developer

Thanks!

The Storage Module menu had a widget overlapping with the X button, preventing it from being clicked. I've got that fixed, and will be released in a hotfix update asap.

Full-screen is another whole can of worms that I'm still trying to figure out at the moment. Resizing the game window also has performance issues with the fog and lighting that I need to solve.

(Edited 1 time) (+1)

btw. its possible to enter the Vehicle?


and No Problem :) I search for more Bugs if i found any.

And. i love the game. i play this at morning before i go to work with a cup of tea :'D

Developer

The Enter key is the default for entering/exiting the vehicle, and Spacebar does the drift/power-slide (because, it's super fun to drift around craters).

And. i love the game.

Thanks! Really glad you like it :)

What if i have the game bought and get a new computer, will i have to buy it again becuase im getting a new computer soon

Developer

Nope, if you're logged into itch.io with the same account you bought the game with, then on the MoonBase store page you should see a "You own this game" message at the top along with a "Download" button.

Or you can use the download link that was included in the itch.io confirmation email you got when you purchased the game.

(+2)

K thanks for the help, im telling some of my friends to look at the game so i can support it more. Its a really fun game.

Developer

Thanks for the support! :D

(Edited 1 time) (+1)

I found a little bug. If you open a menu(like crafting or smeltng) while you're walking, your character will continiue to move.

Developer(+1)

Good catch! :)

Developer(+1)

Fixed!

The game is crashing if you place the greenhouse after placing the water tank. The model doesnt load and when you try and pick it back up the game crashes.

Developer(+1)

Woah, thanks for posting this. Was able to reproduce the issue pretty easily, I'll try and get a fix update posted soon!

when you place a green house next to another green house the game crashes/freezes, I'm playing on mac

Developer

Thanks for posting this. Looks like the same issue that Flockhammer posted above - has to do with the new greenhouse trying to update it's "has water" state before the sprites for it have actually been added. Will fix soon!

Developer(+1)

Just posted build v0.28.2 that hopefully fixes the greenhouse crash issues. Please let me know if the crash/freeze still happens - or if there are any other greenhouse-related bugs that I've inadvertently introduced! XD

Everything is looking good now! no crash! love the game keep up the great work!!!

Both win and win32 versions are being detected by windows anti malware as having a trojan and I cant even extract it to play.

Trojan: Win32/Peals.A!cl

Developer

Hi phillmckraken,

I just downloaded both the win and win32 MewnBase builds from the game's itch.io page, and scanned them both with Windows Defender on multiple Windows machines, each with updated virus definitions, and nothing was flagged as having malware.

Try using the Itch Desktop App and downloading the game through there and see if it still gets flagged for you?

If anyone else with a Windows machine could give the zip files a scan and let me know if they come up clean or infected, would be greatly appreciated.

Using the itch app seems to work fine.

It was really odd. Using windows 10 with latest windows defender. malware bytes is fine with it, but defender keeps deleting them all before I can even extract them manually.

Working good now, thanks!

Developer

Super weird! :O Glad that it's at least working for you through the app.

I'll try and keep an eye on it and see if I can get some friends to run it through their anti-virus stuff as well to triple check!

Cheers

(Edited 2 times)

Black screen on starting game in OS X Sierra 10.12.1 and turns unresponsive after 2 minutes. Version 0.28.2

Developer

Hmmm, that's a new one :/ Thanks for letting me know.

I'll dust off my Mac Mini tomorrow and try it out. Are you hearing any sound/music playing? And do you happen to know what type of video card is in your machine?

No, no sound/music. Here's the use-case:
I right click on "MewnBase" then click Open (To get past the silly Apple message since its not installed from their appstore)
Then the window shows up with a black screen. After a few seconds I get the loading umbrella of doom icon that spins for what I'm guessing is indefinitely.

Specs
CPU: 2.53 GHz Intel Core i5
Mem: 8 GB 1067 MHz DDR3
NVIDIA GeForce GT 330M 512 MB
Intel HD Graphics 288 MB

(Edited 1 time)

It looks like its just the OS X java application wrapper that doesn't work. The jar version works fine on OS X so far.

How the hell do u farm I put the seed in the green house and my green house soul turns into a blonde color and the 2 light squares are red plz help me out

Developer

To get greenhouse plants to grow, you gotta have a water supply module attached to your base somewhere, and then put ice in them. If the base has water, you'll see it in the base stats and the soil will turn darker.

tanks btw love ur gam

Developer

Thanks! I just realized that the Water Supply module description in the Workbench still says that it "doesn't do anything" ^_^ So I'll be sure to fix that soon haha

is there also a way to get seeds othe than getting them from plants outside

Just in case it wasn't clear:

https://itch.io/t/52281/expedition-to-origin-adven...

The notable event in that story is: if you travel far enough to reach the negative chunks (or zero coordinates even) then the terrain generation spazzes out.

Developer(+1)

Thanks! You know... for some reason I thought I had that issue up in the top known-bug post. But yeah, the terrain noise-generator doesn't like negative coordinates at the moment. Need to fix that :)

I've also been considering making it so that worlds are actually finite in size (still big!) but that they'd loop around if you traveled far enough in both x and y directions. But that would introduce a whole 'nother can of worms; technically, and gameplay-wise.

(+1)

If you're using something like Perlin Noise for the terrain generator, there are a number of ways for converting a basic noise field into a tiling noise field.

The simplest IMO would be to blend the value for the current coordinates with a copy shifted over by one and work using modulo math.

F'(0) = 1 * F(0) + 0 * F(-1)

F'(0.25) = 0.75 * F(0.25) + 0.25 * F(-0.75)

F'(0.66) = 0.34 * F(0.66) + 0.66 * F(-0.34)

F'(1) = 0 * F(1) + 1 * F(0) // Matches with F'(0) = tileable!


That will keep the planet from having seams at the poles, and you just have to take care with the math when the player is near the pole and looking over.


If the worlds are reasonably large, that shouldn't be a problem for gameplay since even 16 bit coordinates would make a circumnavigation in the buggy an epic week long RL marathon if you don't stop for anything and have more gigs of ram than you can shake a stick at.

Smaller worlds would need the plants to regrow at least, and probably a new drilling rig setup to get more water.

I still think he should make it easier to get seeds I finding it hard and only a chance of getting a seed 1 out of 20 plants in my worl

(+1)

According to the resource_tiles.json, there could be up to an average of 3 seeds per 10 plant tiles dug up. A little less than 1 seed per 5 plants harvested in that case.

If the listed drop chances are sequential and independent rather than cumulative, it could also be a 1 : 18.9 ratio which is close to your number there.


A crafting reaction to turn one plant into one (or more) seeds could be good.

That would let you maintain the farms by saving half your production to use as seed stock for the next harvest.

The main problem would then be the finite supply of water/ice.

With the release of the new version, I have taken on a 6-day scientific marathon foot trek across over 60 chunks to collect plants in the hopes of gathering a statistically significant sample.

I achieved 154 plants and 30 seeds. This looks very much like the ideal 5:1 ratio holds up.

well then okay I just seem to not get many seeds when gatherin

Found a few things:

Oxygenbank spans across bases

When you build two seperate bases the oxygen level is shared among all of those bases.

Unpowered tiles flicker

Don't know if it's supposed to be the case but yeah, base parts, or better, entire bases that are seperate from each other, flicker if they are not powered and it's quite annoying.

Developer

If there's any sort of module (battery, solar panels, etc) that goes between two habitat modules, then they all get considered as being the same "base" that shares a single supply of oxygen etc. If your bases are way far apart, and nothing is connecting them, and they're still sharing oxygen levels, that's definitely a bug.

Unpowered tiles flickering: I haven't seen this yet. Any chance you could post a screenshot of the base? Is it huge? You're not just talking about the lightning icon on them I'm assuming but like... the color flashing constantly or something? O_o;

Ok, then the oxygen thing ain't a bug.

Here I have two screens so you have an idea of what my base looked like when the problem occured, just imagine less energy production to create the fact that some tiles lacked energy and started flickering. And yes, I mean really flicker, the spotlights even made their turn on/off sound, it was very weird.

imgur link with screens *click*

Developer

Think I was able to get the flickering to happen: http://imgur.com/a/xcAu9

Happens when amount of energy being produced is too close to the amount being consumed each tick/update -> frames per second variation / delta time inconsistencies -> flickering.

Going to have to think about how best to tackle that. Thanks again!

A few bugs I found:

If you quit to menu while there is an oxygen leak in your base, and reload the save, you get the audio for the air leaking, even when far from the base.

Also found that if I quit while there were uncleaned solar panels, then when I reloaded clicking on them would bring up the 'energy generation/ usage menu' instead of cleaning it. (Picking up the solar panels and deploying them again was an easy solution)

Not sure if this is a bug, but when you pick up a water tank with water in it, all the water (/ ice) is lost.


Love the game and I look forwards to future updates!

Developer

Thanks! I just got the airleak sound issue fixed! Going to see if I can figure out what's going on with the solar panels next... I've definitely seen that happen at least once before.

As for loosing water when you pickup the supply tanks... that's something I kind of just hadn't really considered. What should probably happen, is that it should try and auto-transfer the water into any other water storage tanks attached to your base - then whatever doesn't fit would just be lost. Not sure I want it to all just get dropped back in the form of ice (or as a whole ton of water bottles)... but I'm open to suggestions! Empty water bottles / buckets that you can fill from it?

Hi, i want to translate MewnBase into Russian, but when attempting to add the Russian symbols in the file, the game just broke. I found solution this problem(rewrote the font file and replaced the font image), but game began to look so *MewnBase on Russian*. What to do for a game read Russian symbols on char level?

Developer

Right, the bitmap font I'm using now doesn't currently support the required characters for Russian (or any languages that require accents frankly). But if you had replaced both the font image + font data file, then started replacing the actual strings, would've assumed it would "just work".

I need to figure out a good/organized way of enlisting player help for translating the game - but for now would you mind emailing me your current font png, data file, and i18n/moonbase.properties (or mewnbase.properties) files so that I can take a look at what might be wrong? cairn4games@gmail.com

I have a big base and alot of air leaks so more often than not when i return from my resource hunts my base is always like out of oxygen but i came back plugged up all the leaks and no oxygen was coming out of the air cleaners i used an osygen tank to make sure i just wasn't using it to fast but still no oxygen at all please fix this glitch because it is hard to keep going past day 101 on survival mode without any oxygen in the base

Was your oxygen going down or just not going up?

That sounds very similar to what I found over here with oxygen levels getting stuck in certain situations (https://itch.io/post/94395)

Stepping outside for just a second should unstick things for you in the short term if it is related.

(Edited 1 time)

hey, first of all - great game so far - just saw it on the youtube channel of "BaronVonLetsPlay" :)

just run into a "bug" when i was trying to get to fullscreen - running win 10 - mewnbase-win.zip 0.30

im using two 4K Monitors an the game got stretched heres an img : Image

witch would much of a problem if i only had four monitors ;)


btw not an big issue for me, im more a windowed guy anyway, but you know :D

Developer

Solution: clearly you just need 2 more monitors ;)

Seriously though, that's interesting... not the same behavior as my dual-monitor win10 machine - might be a video-card specific treatment? When you play other games full-screen do the games see your computer as having two individual 4k screens? or one massive 8192x2160 display? (drool, ha!)

Extra strange because the game generally has a viewport area that's 16:9 - so I'm surprised that even though it's spread across two monitors... that you didn't get black bars on the left right sides.

Anyways, I'm definitely going to be adding a proper Options menu at some point with some resolution settings. Hopefully that'll address these kind of issues.

Thanks!

Thanks for the quick reply. - yeah i thought so 8192x4320 is the way to go. :)

I'm using a AMD Radeon R9 390 from Asus ROG - and in other games its working - so yeah they see it as two individual screens. Also its what i have set in my settings in Win.

Nope, checked again no blackbars whatsoever. If its of any help, just say so an i can send you my total hardware specs or any debugging stuff from console.

Yeah keep up the great work, i'm looking forward to it.

P.S.: cool intro music!

P.P.S.: i have been running in some trouble at the tutorial - at the point where i should eat i produced around 4 food, so when i ate one unit of it for the tutorial that told me to do so nothing happend - same task - i had to eat all of the units witch i produced earlier. I think there is a hard count of 2 or so instead of minus one... just a guess :)

Greetings from Switzerland

Developer

Hi again!

I've just started messing around with some full-screen options to let people switch the resolution etc. Next I just have to get a basic Options screen setup for it.

I really dig the intro music too! But I can't take any credit for it - it was made by cynicmusic.com - http://opengameart.org/content/enchanted-tiki-86

Managed to fix that tutorial food crafting/eating bug. Think I had changed the drop-rate for plants a while back, and hadn't considered that player could actually queue up multiple Food items at the workbench (and causing the issue you described). Thanks for pointing it out!

Cheers

Hi, I found a couple of bugs: :)

1. Sometimes when right clicking on food it eats 2 food instead or 1. The number goes down by 2 and two messages are displayed saying that I ate food. Once this happens it keeps happening until I quit and reload the game. I've had this bug start happening on two separate occasions but I'm not sure what caused it. The first time it was just after I alt+tabbed out and came back so might be related to that, but the second time it just started happening for no reason.

2. After playing for a while (maybe 2-3 hours?) the game suddenly slowed down and the framerate dropped a lot. This came and went every 5 seconds or so, sometimes running really slowly, sometimes running fine. After a while I quit and reloaded and it was fine. Haven't been able to reproduce it.

Developer

Hi Mloren!

Huh, that double-food eating one I've never seen before. Tried looking briefly into it tonight, but nothing stood out to me yet. Will keep an eye out for it.

As for the slowdowns, I honestly haven't played a single session that long in recent memory. First thought is that it might be due to chunk-loading/unloading. But if it was coming and going frequently, might be something that just isn't optimized yet (or that I'm doing very inefficiently :P).

I had another go at reproducing the double-food bug and I think I found the cause:

I have a save with 14 food and I tried loading it, eating all the food, quitting and reloading and repeating. It seemed really inconsistent at first, sometimes happening and sometimes not, but I think I found a way that causes the bug almost every time. I think it has to do with whether the mouse has moved between clicks!

1. Have at least 10 food so you have enough to try a few times.

2. Move the mouse over the food item in the inventory.

3. Lift your mouse off the table so you can't move it at all.

4. Left click to select food.

5. Right click to eat food. It will probably eat only 1.

6. Right click again to eat food, it should eat 2-3.

This never seems to happen if the mouse has moved in between steps 5 and 6.

Hope that helps

(Edited 1 time)

No .dll file in windows versions. Java version does not turn on

Developer

What .dll does it say it's missing? First I've heard of an issue like this.

Are you running it via a zip download, or through the itch desktop app?

The java / .jar version requires that you already have at least Java 7+ installed on your machine (https://www.java.com/en/download/)

Another suggestion: If it's crashing on launch, make sure your video card supports OpenGL, and that your video card drivers are up to date.

msvcr100.dll

Developer

Most search results suggests your computer is missing "Microsoft Visual C++ 2010 Service Pack 1", might want to try installing this and see if it helps: https://www.microsoft.com/en-us/download/details.a...

found a bug with the smelter, if u click on it to collect, while your inventory is full, the game crashes. (harvesting from planters, and workbench give me inventory is full message)

otherwise a fun game little game, hope to return someday when the game are a bit more fleshed out, keep the good work up :)

(playing on win10)

Developer

Oooo thanks for catching that one. Was easy to figure out, got it fixed on my end. Will release it in a point-update soon.

Thanks again!

Hello seems like trying to change the controls make the game crash

Developer

Hmmm were you trying to use the control mapping popup? During a game (Pause -> Options -> Controls), or from the Main Menu -> More -> Options -> Controls?

If after changing some settings the game keeps crashing you can always delete your moonbase_settings.json preference file to have it reset.

(Edited 1 time)

I wanted to change the controls in the main menu on my W10 but it crash everytime I try . I don't have the problem on Linux

Quick update : I can change the control in-game after a few test i can change them in the main menu after rebinding them directly in-game

Developer (Edited 1 time)

Ah ha! I was able to reproduce this bug, and I now know why it's happening. Thanks for bringing it to my attention :)

(+1)

Yeh i have the same problem on mac. Every Time i try to change the controls through the main menu the game crashs. But if i change it after lunching the game it's working.

Developer

This issue should now be fixed in v0.32

Hello, id'ont know if it's me or a real bug but when un put an airlock on the right side of any module i can get inside of the airlock but after i can't go anywhere on my base.

Developer

Half bug, half bad design: try rotating the airlock after selecting it form your inventory bar but before building it (default mapped to the R key)

placing furnace between 2 solar panels resulted to quit game, right clicking allowed to pick up but it was weird, yeah i know i shouldnt place there now, but still

If an auto-airlock is leaking, and you walk into it, the automatic action will repair the leak rather than open/close the door.

This is handy, but probably not intended :D

The automatic airlock is a great upgrade, and I like that it takes a normal airlock as a crafting component.

I've already had the chance for it to save my life as I stumble back to base with the suit at zero O2 remaining.

I have a random issues with the game. I have 3 monitors and when I close the game all monitors go black and I can't do anything about it. I tried the usual key combinations like ALT+TAB, CTRL+ALT+DEL and CTRL+SHIFT+ESC, nothing worked. The only thing I could do is push the power button of my PC to initiate a shutdown.

Win10

Geforce 780GT

1920x1080 Fullscreen

Developer

Blah, that's no good. Sorry about that.

Did this crash happen to you multiple times? I've never seen the game crash and hangup my entire computer before (with multiple monitors). When you run the game in fullscreen mode, was it filling up a single monitor, and just showing your desktop as usual on the others screens?

Another random question, are you using the NVIDIA "Surround" mode for multiple displays?

i am using the left monitor as my main and that's where the game runs.

The black screen happens when I try to exit the game or when I disable the full-screen mode in-game (1920x1080 resolution - native).

If I run it in windowed mode it's fine.

The weird thing is that it doesn't always happen when I disable the fullscreen mode ether.


I don't have a good explanation for it. I am using an nvidia card with latest drivers but I don't use the surround mode.


Not sure if it helps but I use HDMI for my left and right monitor and the middle one uses an VGA cable.

I will do some further testing today but it's painful to restart the pc everytime it happens.

Is there something like a log that gets created or a way to enable it?

The game comes to the desktop when you change the resolution, the previous version of the game was not the problem Windows 7 64bit
Developer
Thanks for the post. I'm going to have to look through the screen-resolution code since the previous version to see if I unintentionally changed something... clearly something is messed up.
(Edited 1 time)

After further digging around and testing the game I can confirm that its somewhat easy to crash the game by changing through resolutions and toggling the fullscreen option.

I was also able to find a lot sources with people having issues in general that their monitors go black after quitting a game so dont worry about that one too much. Probably not your fault.
The only (unreliable) hint I found was to replace the d3d9.dll file. who knows where the bug actually is that causes this behavior.

One last thing...

Why is the list with possible resolutions so long and includes duplicates of the same resolution every once in a while?

Developer

Yeah, I gotta look more into it. If I can't figure out where I made a mistake or why it keeps crashing on resolution change, I might end up just removing the resolution options for a while (and just keep the fullscreen toggle), until I can get a better handle on it. We'll see.

The resolution list is all of the display modes that the game thinks your "primary" monitor supports. My guess is that if there's duplicates in the list, it might be because there are multiple color-depths or refresh rates available for the same resolution (and my list of buttons are just showing the resolution width and height). I'll add in the extra display mode info to the button list to see if that might be why.

How do I use the "Give this game as a gift" button?

Small Bug Report: If you have an air-leak in any module and remove the module without fixing it, the sound goes away, but not the air. After a while of playing I had a smoke wall near my base. I mainly put some air filters there, cuz the smoke fit the fans below visually.

Developer

Hey! Thanks for the bug report.

Are you saying if a module is leaking air, and you right click to pick it up - the airleak sound fx stops, but the visual air leak particles/fx persists? I couldn't get it that to happen in the latest version v0.33.1, is that the version you're playing? (Although I was cheating to trigger the airleak disaster, so it's totally possible it could still happen in that version somehow).

Hey :D
Yeah it's the same version, however upon reloading it seems to have disappeared.
I'm not sure if it's just a glitch that happens from time to time or something, but it stayed there until I reloaded.
The process was: I had a module that leaked air unattached (forgot this part) from the rest of my base and instead of fixing the air i right clicked the module to remove it, which it did, but the animation of air flowing was there still, no sound though.

Deleted post
Developer

Nope, still busy working on stuff. Just been taking a while to get it ready to publish as a build.

Developer locked this topic