Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Bug Report Thread Sticky

A topic by Two_succubi created Mar 09, 2018 Views: 21,111 Replies: 231
Viewing posts 1 to 111
Developer(+3)

Please post your bug reports here.

Preferably include: 

  1. Game version
  2. Bug description
  3. (if complex)Way to replicate it

Crashes with corruption 750 wearing no clothes, opening the laptop.

CheatEngine for corruption 750, was not frozen. 

Developer

Thank you for the report but game is in its really early stage so max corrupsion is like 100...

(+1)

Once I buy the skirt for work, I can't change into it at work

Developer(+1)

Fixed it and reaploaded a new version.

Deleted post
Deleted post

Hi! Great game, just a few bugs - 

If you change her into underwear or make her naked before she goes to sleep (even if you change her back into pajamas), the next morning she will say she can't go out like that, even though she is wearing her day clothes.

After installing the new Patreon update, when I go to load a game it will not allow me to click anything or hit esc. This has been tried on both Windows versions. Occasionally, the background behind the main character will go entirely gray and I cannot do anything.

Developer (1 edit)

Thank you for bug report!

1) It's all because you are changing underwear pattern. It's not the same with PJ, underwear is like a common outfit to go outside.

2) When did you download this version? Try to redownload the new version, I hope that will help. 

I just downloaded the latest Free version of this game in the last 3 or 4 days. Periodically it'll flash black screen and minimize. When you enlarge it full screen again it'll Start Screen with Load/Save.

(3 edits)

It 's hard to find your posting here, if you reply to a 1 year old topic. Looks like you clicked the wrong reply button. What version you have downloaded?  win32, win64, mac, linux, android. Looks like your system has some problems on gfx or some other programms on your system force HOS to minimize. Try options in HOS and toogle fullscreen off. Win 10 has also some nasty problems with dual monitoring and some grafic cards on fullscreen mode. So if your system is a dual monitor you can also try to reduce it temporary to one monitor before starting HOS.

i am having a problem with the saves, they wont load so i lose all my progress. then the game crashes a lot and i'm not sure whether its my computer, the games programming or the games engine but i don't care as much about it if the periodic saves work

Developer

Please send me your saves so I can check it. You can find saves in :

C:\Users\your_user\AppData\Roaming\Godot\app_userdata\High School of Succubus\saves

And send in to my email : twosuccubus@gmail.com

Noticed that during play if I change to sleepwear and try to leave the house in the morning, a dialogue box appears and it locks up.  Couldn't find a version number on the title screen, file name, or file info (just had the version number of Godot) but it's the most recent build up on itch. 

Developer

Ty for bug report and yes we should probably include version in every build ty ^^

is the succubus coming to dream still not implement on the the public build?

Developer

It is in public build now ^^ version 1.5

but i cant get the  dream  even tho the corruption was well over 320

Developer

Redownload the new version. In game go to sleep and at the other night event should happen.

Maybe i should try that solution thanks

Deleted post
(1 edit)

Found a bug when you try to go out with any of the sleepwear or forget to go back to "regular clothing" from underwear the game gets the text window but no text and it all freezes so you cant do anything. Latest version for public download.

i have the bottle of wine but game is keep saying u need to buy one and there is no way that i can delete that wine so i buy new one

Stuck on 350 corruption on latest public update.

Developer

It's supposed to be like that. Corruption will be increasing every version. 

(1 edit)

The dosen't Work at all. When I start the .exe the Window opens and remain Empty. Version 1.5 win64 Public.
*edit.   Got it my graphic card was just garbage (Radeon HD4550). With my new GTX1060 everything works fine.

I have the wine but it tells me I still need to buy it, yet I can't purchase it.

Developer

Fixed please redownload the new version!

I'm using the most recent update and the game still won't let me buy the wine bottle the second time

Developer

I just test it and it's fine to me. Please redownload the game again and go to the shop (hotfixed it yesterday). If it wouldn't help please send you savefile you can find it in: C:\Users\your_user\AppData\Roaming\Godot\app_userdata\High School of Succubus\saves

And send in to my email : twosuccubus@gmail.com

For some reason, I can't get past corruption 375, even after buying the available toy, purchasing the new work uniform, and having the uniform changed to a mini skirt and unbutton blouse. There has also been no avaible events for a long time. I have the most recent version.

Developer

Probably you got em all for now ^^ Game is still developing, and we are adding 3 events every update. You can see changelogs and events in out patreon announces.

HOS1.6

Can't press back button (shown in screenshot) in cafe wardrobe. Button doesn't work when pants or the new shorter skirt is selected. It works if the longer skirt is selected, but then after you press it and the pants are selected it doesn't work again. 

HOS1.6

You can't buy wine for the second or the third time. But reloading the game's autosave you can again buy it.

HOS1.6

Reloading game and opening autosave removes all bought items (swimsuit, egg...)

Developer

Fixed swimsuit and sex shop bigs but wine seems to be working for me, please redownload the new version.

When is the next update plzz?

Developer

29th ^^

(1 edit)

I can't buy some things... Once the update will be done, I will be able to buy?

(1 edit)

When in the cafe and pressing the doors for work options, there is two "serve tables" but the second one (from top) still acts as it should (help with dishes). And when you are home, press the drawers besides the bed and then eggtoy nothing happens.

(1 edit)

It is true I have no open GL 2.1 but is it really necessary to play it?  :(

Developer

Probably because of the game engine...

@Two_succubi   

Hi there! I happened to trigger a bug and I thought I should report it.  So : In the 10 aug. version (i guess), when the "event" with Viki going to the gloryhole, if you click the log box too fast, the story will kinda loop itself for a few times and you should see her body as it is in the stall,but in the auditorium.  My mouse has a triple-click button and i clicked it for a few times, but I think you may replicate it with a normal mouse as well.  In the worst case, just use a macro or something.  I can't wait to see a full-ish development of the game :) Best wishes and keep up the good work!

Developer

Thank you, we will try to fix that but that might be just an engine bug...

I cant get past corruption 430, It keeps saying + corruption, but it doesn't go up in the stats.

Version 1.9

Developer

430 is the maximum corruption for this version. We had to do it to not ruin the corruptions system completely we still need to work on that tho.

HOS 1.9

I heard about this game week ago i was playing it and really enjoying it and then i found few bugs 

1. I cant progress anymore even tho i have not finished the game. 
-I got to the point where i have 1000$ because i cant progress, the only think i do is go to Cafe and make money, there is no events happening for like 4 weeks (game time)

 Screenshot: http://prntscr.com/kkixk5 

Screenshot: http://prntscr.com/kkixn9 

2. After some time of playing this game i cant buy nothing

 -The only thing it says is "Sorry that item is not in the game for now" even tho i have corruption and money

 Screenshot: http://prntscr.com/kkix3u 

Screenshot2: http://prntscr.com/kkixf8 

3.Saving problem 

Whenever i save the only thing it will load is latest event that happened, imagine doing event and after event was done i got some money then i loaded saved file it just loaded after event

 4.Corruption bug -My corruption exp is stuck at 430. 

Screenshot: http://prntscr.com/kkixtj

I can give u my save file if u want. Please fix these bugs please.

kokai, you should know that the game is currently under development, there is an update every two weeks and the game still isn't finished
1. You can't progress because you've run out of events - as I said, the game just isn't finished, be patient and wait for the updates
2. If it says "Sorry that item is not in the game for now", well, it means that the item is not in the game... the Girls didn't add events with the item, so, as I've mentioned before, you'll have to wait
3. Sorry I don't really get it, but I highly doubt there is a bug going on here
4. Corruption is stuck at 430 because it's the limit - Morgarith even informs you that you've reached the maximum of your corruption level available in this version of the game

Summing up - keep waiting for the updates and read everything carefully

Developer

Oh, thank you a lot... I missed this post >_>

I just downloaded the newest update 31.08 and I can't go to the beach for the event because when I go to put the swimsuit on she says she doesn't want to leave wearing that. I've tried all workarounds I can think of but nothing is working. It lets me try on the suit but I can't exit the wardrobe without the message. What can I do?

Developer

That event is in a beach bar, so you need new outfit with no bra and do the wet t-shirt event with Ash.

Thanks for replying! I didn't realize it was a new top and skirt instead of the bikini .

I've noticed there are multiple grammatical errors as well as spelling mistakes. I'm Fluent in the English language both written and verbally. If you would like me to fix these mistakes get in touch and we can work something out! 

Developer

That would really help, we are lacking on proofreaders... Sorry missed the message...

hey guys so im at 480 corruption and cant get anymore what do i do plz hel

here is a photo 

Developer

Every version has it's max corruption level so you can't get more till next update

thx for replying

may i know when the next update is?

Developer

In like 6 hours or so

and will i be able to continue from autosave point or start from fresh?

Developer

Yes, you can continue playing from your saves.

Thank you for both the replies

ok dose the game update it self

Developer

No, you need to download the new version from itch.io but your saves weill carry over!

ok thx 

hey if im not a patron can i still download it

Developer

There are 2 versions. public version in 1.11 and patron is 1.12.

ok

2 problems in 1.11

Opening laptop with max corruption freezes the game

When you get the 'flirty' customer at work the text duplicates

Also, if you're looking for a copy editor to clean up your text, msg me on discord and I'll help you out.

Discord ID Master Chris#3626

Developer

ohh.. thank you, btw the text duplicates when you get 2 slappes or just one?

It gets through the first slap then cycles back to him calling her over and asking for beer again. Looks like the sequence is just repeated.

Glitch in most recent version 5.10

On Windows computer, after sleeping all normally clickable objects can't be clicked. The game can however, be saved and if the new save example "Save2" is loaded it refreshes the game and makes clickables work again. It's a minor glitch, but it could get annoying for someone who just started the game. 

P.S The glitch occurs after sleeping regardless of the time you go to bed. Also sometimes clicking the phone fixes the glitch.

PPS When will the next update be after the 9/21 update? I'm looking forward to using more costumes than just the maid!

Developer

Fixed that bug, thank you... And the next update will be earlier 05.10 cuz of 26th Helloween special.

Hi, I'm playing ver 1.11 downloaded from itch.io and when Kelly wakes up in the morning I can't click anything in her room except for her cell phone. I have to click on her cell phone, the either try to open the photofap app or try to call someone who's highlighted, close the phone, and then I can leave the house/change clothes/any other clickable option in her room. Also, for some reason I'm unable to unlock any of the events at work except for the bonus pay event and the John peeping event. I've played the game online and I know there are one or two more events with John, and I should be able to change my work outfit to unbutton the top buttons. I'm also unable to get the Ashley wet t-shirt event. I'm done every other playable option in this game so I've just been going to lectures and to work every day hoping to unlock them but no luck so far.

If you have the skirt already, it sounds like you forgot to take your bra off. Those events are linked to going to work braless.

I managed to get the wet t-shirt event but I've had Kelly go around braless for a while now and for some reason I still can't unlock it. 

Developer

Hmm... If the chain of events starts when you go to the cafe without bra. The first one is John peeping on Kelly. And other events are triggered when you are in work dress with skirt and with no bra starting working (not washing dishes). 

And clickblock bug is fixed, please redownload the game.

I downloaded the new version and started a new game and the events happened so maybe it was just something i was doing wrong. Thanks for your help though!!

(1 edit)

I play the game through gamcore that's the only way I can play because I use a Chromebook and can't download things unfortunately. And i'm logged in on there which is supposed to save my progress because I've gotten really far and it will not load what do I do? It's currently at v 1.12

There are workarounds for running windows programs on a Chromebook. Google is your friend...

https://www.howtogeek.com/173353/how-to-run-windows-software-on-a-chromebook/

Great game.   Here are some issues I noticed using Windows version 1.12, dated October 6th.

1.  On Friday, at the cafe, you can collect payment, wait tables, collect payment, wait tables, collect payment, wait tables.   

2.  The wardrobe doesn't remember if you sleep naked.   To sleep naked you have to click sleepwear and then the left arrow each time, instead of just remembering that you sleep naked after the first sleepwear click.

3.  In the wardrobe, there is sometimes a display glitch where your skirt is displayed twice but offset to give a double vision effect.

I encountered a couple bugs on my latest play through.

1.) After the bonus became available at the cafe, I collected my pay with bonus, then served tables for a little bit, and when I went to leave, it alerted me that I had not collected my pay and I was able to collected more money (for the tables I served that day) and another bonus.

2.) In the cafe event with the customer who slaps my ass, there is a typo ("glass of bear" should be "glass of beer") and sometimes it loops after the event has ended and it repeats part of the event,

other than that, I saw some really obvious typos and grammatical errors but I didn't record when and where they were. I'll do another run through over the next couple days and make a list of all the typos and grammatical errors.

(1 edit)

Version latest as of posting this

After buying everything I can't do anything other than going out with John at the beach 

Is that a bug? 

EDIT: Can't raise corruption above 600 either

that's not a bug, it's the limit of what you can do. No further events have been programmed yet.

I am unable to open the game and I don't know why. I tried a demo of it on a site, really liked it, and downloaded it from the proper page. I can't get the game to work at all! Please help!

Developer

Please describe the problem? Did you download the game from itch.io? There was a bug that download link didn't show up, so if that's a problem just refresh the page.

Bug: can't use the vibe egg, could bring it for the dorm party, but not use it from drawer.

(bought the egg first and then the vibrator as second)

ver: HOS1.13-win64-public

Developer

Fixed. Today is update day so it will be fixed in a new version, thank you.

The cerrent update is 1.14 in the download but its not its 16,11 can you fix it?

Developer

Hello, 16.11 is a date of release, not the version.

(2 edits)

I can't change outfit. I bought new clothes to use, when i received a call from ash to go to beach bar i'm stuck at the succubus saying that i need to change outfit.


Version 1.14-win64-public

Developer

So you bought the new outfit (tank top and shirt) and it doesn't appear at the wardrobe? 

That's right...when i try to change outfit, it remais the same one.

Developer

Hm... Did it get disabled at the shop so you can't click on it? If so - reboot the game and try to wear it in the wardrobe if it's not working please send me your save file

C:\Users\you user\AppData\Roaming\Godot\app_userdata\High School of Succubus\saves on twosuccubus@gmail.com

The Halloween event won't trigger for me I have bought the Halloween costume but nothing happens.

Wait till Saturday and then the event will trigger automatically in the evening

Version 1.16

After buying the magic wand toy I wanted to try it, but it didn't show up in the toy drawer at home. Also, I can't select the egg toy anymore. 

Loved the new scene with Brenda, and having Ash as a co-worker will definitely make things more interesting at the cafe. I would really like to see more happening with Vikki though; also, how about an option to sneak a toy into the lectures, it would certainly make things less boring.

Developer

Three is no option to use magic wand yet. You can't click egg or it disappeared?

Other things like toys on lecture will be later as the story progress.

Can't click the egg, it seems to be blocked by the dildo cause when i hover my mouse over the egg it shows the dildo being highlighted instead, and clicking causes the dildo menu options to appear.

I cant download

hello when i first came to the nudist beach, i couldnt rewear my uniform , only wearing swimsuit. My wardrobe at home didnt have uniform either. So i got trapped in "i cant go out like this!(in swimsuit)"

I cannot change outfits to progress the halloween event OR the next costume event. She says "i dont want to go outside like that" even though im just trying to change clothes in my room.

I once got trapped in that, then i realized halloween costume is not for wearing out. If u have already bought that witchy constume, u r expected to wear it(automatically) in the dorm.

yeah I got same problem kind of the cat ears and tail and everytime I tried changing into it turns  back into the bikini the and won't let me out... 

Version 1.17-win64-public

After entering  the cafe by accident, I exited the cafe and went to the nude beach, and Kelly was initially shown in her work outfit before I switched to her bikini.  When I left the beach and went home she was still in her work outfit instead of her usual white tank top. On top of that the game seems to have "forgotten" some of my recent progress, I have the ability to buy the red lingerie again despite still having it, and magic wand isn't appearing in the store anymore, nor is the option to use it with the schoolgirl cosplay. Also the champagne bottle disappeared from the store. 

Not sure if it makes a difference but I had just completed all of the events so far when this issue occured.

i only see the icons of the game when i boot it up there are no backgrounds or picures i cant click on im play on 1.17 hos

Developer

32 or 64 version? Can you attach a screenshot of that bug?

Problem with Patron version 1.18. When I'm going to the beach, Ihave "Topless" button in changing room, but it doesn't work, just become dark when click. After that if I return to the town, Kelly wears her swimsuit with red panties underneath. Can send you my save file if needed.

Developer

We'll upload a new update soon. It will be fixed there I'm pretty sure.

I just recently got to the Halloween party part and everytime I tried changing into my Halloween costume it won't let me. 

More info I got  the Kat ears and butt plug tail. 

In the android version I can't get the phone to work.  It just opens the system menu.

1.19

If you calls viky's friend for the first time it starts nude beach scene.

It keeps crashing as the tutorial about the menu and all starts. (Android) it was in the last version (before the 9th March) im gonna try if its fixed i hope so tho :/ 

(1 edit)

The game is freezing aftrer bonus of my salary v1.19

(1 edit)

A couple of bugs (latest public version, 1.19):

Android: No way to access save/load/quit menu

Android and PC: Calling Ash after getting her number for the first time triggers the topless sunbathing with Vicky scene.  On android, I was not able to go to the beach or call Ash again, effectively locking the game. On PC: I was able to go to the beach and do the topless sunbathing scene, even though didn't have a swimsuit or nearly high enough corruption. After that scene, calling Ash again triggered the same dialogue, asking to go to the beach with Vicki, however, I wasn't able to actually access that scene on the beach again. Eventually I was able to go get Vicki's new swimsuit and triggered that mall scene, but after that, I was unable to call Ash again, go to the beach, or do anything with Vicki. In addition, I was already able to sit next to Vicki in lecture, see her pictures and raise her corruption, even though I hadn't technically met her (hadn't triggered the scene with Ash, don't have her #, etc.)

Now in the new version everytime i start new and call  Ashe she says she wanna go to the Beach again and then all is bugged i dont get Vicis number and cant cal ashe again

(1 edit)

When I come into the boss's office , the game crash , the dialogs are stopping , I can't do anything :/ 

* And they talk to me about Den , even if I haven't play that part yet

When Brenda demands your pants, it freezes up, ive tried reloading and re-installing.

i had the sam problem just switch to the white panties

(1 edit)

On the version Published Mar 09. 2018

Viki corruption is stucked on 240, doesn't metter what you do

v 1.19 for android

The game froze after the bonus conversation with the boss, and kelly's corruption is stucked on 50, don't matter what I do. I also can't use the "FapApp", every time I try kelly says she wants to check the new shop (????)

Hi, nice game, tho got stuck on Kelly's corruption lvl 1 at 1000, Viki's corruption does not raise, stays at 240. At the Central shop I can't buy Bikkini and the Red Dress (Red Dress says is not yet in the game). The rest is kinda working fine :) can anyone help with this somehow ?

:) I kept playing, some library events poped up, Steve got increasing his corruption and Kelly passed to corruption lvl 2

(1 edit)

V1.19 

Now really got stuck. Kelly's corruption lvl 2-50/1000, Viki 240, Steve 100. Bought everything from shops except the bikkini and red dress now can only increase the money (atm 1025) I have saved the game

In the version of the day 29.03 I get stuck on the scene where I have to give Brenda my panties

First off,  love this game great job you guys/gals are putting in, keep up the good work.  I've come across what I assume is a glitch unless im just missing what I need to do to activate it.   Playing on andriod,  after first encountering john at the beach bar.  The beach bar is still highlighted pink but i've never been able to return to the bar after that first visit she says she doesnt want to go alone but no one is highlighted in my phone to contact so im not sure how to trigger the event.  

Bug Report - File will be deleted in 30 days here. Spoiler alarm.

https://ufile.io/0przj

file can't be installed, latest version, Android APK

HOS 19 and 20 

I can´t start the Game i try many Different ways but without succses 

Thank you for you time and thanks for the good game 

(1 edit)

I am stuck when you ask boss for a raise he says you have to earn a favor and then it freezes current  patreon version for android 

me too, i'm stuck here

yea that exactly  it

Developer

Try to use red/white panties.

i just downloaded this game but im not getting any sound is that normal?

New version, 1.21, deleted ALL my Save Data! I had gotten to over 1000 corruption with main character! I'm not sure what exactly caused the data to be deleted all I know is the save data is gone.

Developer

What platform are you playing?

Windows 10... side note I think I know what might've actually happened; I recently did a system reset to defragment and clean up my computer a couple of weeks back, the saves might've been deleted when I did that. Oops! I got a little caught up in the moment and accidentally blamed the game at first, Sorry...

(2 edits)

v1.21 x64 

I will describe the steps to the bug : any day --> go to school -->at the question: 'What we gonna do today?' do nothing (after PE) --> Ash  tells you to go at library --> you ask Steve to hold the ladder --> after the phrase : 'Wha... Me? Oh... I w-will...' the game freezes and Steve dissapear, but the phrase remains 

Developer

Switch to white or red penties if it's freezing

good. then we were 2 people who got it

i really hope they could fix like that so player could go around in black undies

(13 edits)

V1.21 for android

Game freezes in class at college when I ask Viki for more photos. The conversation goes through but at the end when it says Viki's corruption increased, the game freezes. The game is now unplayable. I can't seem to continue the storyline.

Also, I'm told to buy a new more revealing swimsuit at the mall but when I do, Kelly says she can't imagine herself wearing it.

You need Kelly Corruption 100 on Level 2 first to buy the second swimsuit. For Reaching Level 2 Corruption you need to finish her personal event "No panties library flashing."

Cool. But I'm stuck at corruption 1000 because I can't continue the story because the game freezes when I view Viki's dirty pics. So until the game is fixed, I can't continue playing. Thanks for the heads up though.

(1 edit)

You could try a restart or an older save. I played 2 times on win version and don´t got stucked. My tip for a new play is to go not so fast on corruption. Corruption increases so fast only by events, no need to boost that more at home with tools or porn. Perhaps there is also a problem when you go to fast on corruption? There is also the possibilty that steve library scene 2 is before scene 1, depending on your answer on viki. This could also be a reason to trigger your stucking?  Could be also wise, to wait for next update first.

1. Version 1.21 on android

2.The game softlocks (you can't do anything but the animations for buttons still works) if you go to the library  after Brenda taking away your panties during the lecture and before having option to take of panties for certain places

Bug Report (Spoiler) - File will be deleted in 30 days here.

https://ufile.io/un9c38f3

v 1.21

  • Can't change into or even see new $130 school skirt in wardrobe.
  • could buy halloween outfit, but couldn't ever actually wear it. Was even in wardrobe, but couldn't put it on.
    • Couldn't fulfill Halloween event as a consequence. Kept telling me to put the costume on and I couldn't
  • bought $10 wine before asked, and Ash made me buy it again, before I could come to the dorms
  • Wouldn't let me buy flesh dildo, even tho I had high enough corruption; could buy the vibrating egg, tho, even though it had a higher corruption level. Had high enough corruption for both, so I was confused why I was able to buy one but not the other.

May not be bugs, but are issues:

  • No tab for clothes other than sleepwear, costumes and underwear. Able to see swimsuit and other clothes but only if you click sleepwear tab twice
  • None of the NPC's corruption changes, even tho they are clearly engaging in corrupt events with you
  • Really needs more than 1 save choice --  and only autosave at that.

Discomfort with fetishes that aren't mentioned: tentacle porn was totally unexpected and killed my boner. Fortunately, I have a rapid auto-clicker that allows me to quickly skip past this unerotic scene.


Just ran across this game and it shows a lot of promise. Would be willing to support but not sure if it's still in development.

I had the same issue in not being able to see the new 130 uniform. After a while it finally appeared though. Not sure why. Either from unlocking a progress thing or randomly having certain clothes on. So no idea why but it resolved itself after a while.

However, I'm still stuck at a point where I'm looking at Viki's photos in class and the game freezes at the end and I have to restart the game. So I can't continue the game and I haven't seen anyone respond to my bug report so not sure if it is still in development.

There is some point Ash is calling you for the beach party. For this party you need the skirt, but you can buy it before when reaching 450 corruption. Perhaps the missing beach party event will make the  skirt unavaible in wardrobe?

Stucking on Viki´s photo´s? There are some events triggered behind Viki´s photo's. Some are only if you choose see pic yes, other are only if you choose see viki pic no. Perhaps you can avoid the stuck by chossing looking pic's no? Mostly stucking at this stage is wearing no pants starting library events or wearing black pants when Branda take your pants.

(1 edit)

I keep saying no because saying yes freezes the game but then I go weeks without new events being triggered. I've given up lol (for the record, Brenda has long since taken and returned my panties).

Dildo is 500 Corruption not 200 as showed, need to be fixed.

There are 3 partys Ash wants you to buy Wine. Looks like current Wine stack(flag) is reseted for each party then.

Halloweenparty you can only start by clicking on dorm building. You can't put on costume manual. If you have it and click the dorm on saturday afternoon, Kelly put the costumes automatically on in girl's room at the dorm.

New skirt should be switchable on wardrobe, if you bought it, this should be also showed in wardrobe. Have you checked the shopping mall again, if the skirt is still buyable there?

Wardrobe is a little confusion, tabs have different functions, some are switches only others are more like checkboxes. Play a little more with the tabs. The middle tab has a costume on/off logic. With costume off triggerd you can't switch costumes.

Yeah, NPC corruption changes should be more on events. But this is a new step to change the NPC´s corruption, most events are finished before this step. This should be fixed in future, i hope.

Save system is one of the best i have seen in such genre. You can easy change the name for new saves. Switch between your saves by simply clicking on it. And save system also remembers your last name. So you can easy save/reload. Only the autosave behavior going to your last save name is thinkable about.

I downloaded the 1.21 version to android and whenever I click new game to start playing the app crashes. It happens all the time and I already tried to download again

Game version:  Current public release re-downloaded yesterday May 9, 2019

Bug description:  Multiple possibly interconnected.

  1. Started a new game while playing a game in which I had been given the shorter skirt and told to open my top in the bosses office...  Started new game went to work had on short skirt and open top, got bigger tips than wearing regular pants or long skirt.
  2. Continued to play until I was invited to the beach bar with Ash where I need a new outfit.  I had already bought a new outfit but couldn't change into it even though I had over 550 corruption.  Multiple attempts on multiple days.
  3.  Caused game to freeze by trying to open  the book in the top left corner while waiting for another event to activate (was loading slowly and I wanted to see how much corruption I was up to).

(if complex)Way to replicate it:  Pretty sure the way to replicate this is in the descriptions.

(1 edit)

There is a problem with "the new game" option in game, when you have loaded a save before and use the "exit/start new game" ingame option. Then you have not a new game, you have only a new intro sequence and continue on the loaded game states before. If you want to start a real new game, you need to hardreset the game-engine (close and restart the game). Using the softrestart leads to uncontrolled behavior. I think all your reported bugs could be such uncontrolled behavior.

1 is cheating ;-), if you do such things, game engine knocks back. :-P

2 and 3 could be uncontrolled behavior of softrestart

Bug Report (Spoiler) - File will be deleted in 30 days here.

https://ufile.io/1xnprk14

May 9, 2019

Bug description:  If you don't buy the vibrator (I was 16  corruption shy of buying the egg toy when I could afford it) you will still pull out the vibrator when using the egg toy even though you don't own it.

Now the developer have a second guy, they don´t like. Not only me. I put this in my next bug report. ;-)

hello i have a bug report. my game crashes when i get send to the library for the 2 books after a college lesson. it starts after the lesson with an auto conversation with ashley once im in the library it just freezes when youre supposed to go up the ladder.

What panties you are wearing? Have you tried other panties?

version1.22  It wont let me load my saved data it shows my saves are in the load section but when i actually click load it just doesn't work for me 

On which OS you play? (Win32/Win64/Linux/Mac/Android)

Can you start a new game and after finishing the tutorial make a test save and reload this test save?

I play on win 64 and i will go try to do that now 

so i can load the new save when i make the new game but still cant for the old save

(5 edits)

That was my suspicion. Could be something with the access rights? You can try to start the application with administrator rights. Right click the Hos.exe and use "start as administrator". You can also try to find the restrictions on the savefiles.

C:\Users\your_user\AppData\Roaming\Godot\app_userdata\High School of Succubus\saves

Rightclick save folder or a special save file -> use option -> security -> (and optional) extendend

At my system the whole folder is allowed for system, admin and my username. My savefiles in this folder have the same settings.

I also tested an older save from version before on my own. I have no problems to load this older version. So looks like no bug in HOS coding?

Edit: But could be also a problem, when loading savefiles from older versions, as i said in other postings here. You can´t control it. How old are you savefiles, was it one version before, two version before and so on... There is a limit and also a risk of stucking or crashes when you load saves from versions before.

Hey. I am playing on the .22 Android Version.

Bug: When I get to the part where you tell her to change her hair style in tutorial the game crashes.

(And I think should add that I tried the .21 Android Version as well and it did the same thing)

(+1)

Version 1.23 Android.

Game keeps crashing when I press New Game. 

Bug Report (Spoiler) - File will be deleted in 30 days here.

https://ufile.io/gvmjo6jn

Why i have the feeling you didn't look in my reports? I stop my reports for now. Looks like you didn´t have the time or priority to fix reported bugs (at least some of them). I will watch your game from a little more distance now. If you need and want it, i can come back. Anyway nice artwork.

(+1)

Hi, T

1. HOS1.23-win64-public

2. The picture app on the phone doesn't seem to be working anymore...

This is less of a bug than a slight logical fallacy, but I've found that after PE if I click on the door to PE again it says "There's no PE today, so there's no reason to go in there" or something like that. Version 1.23. I just found it a bit weird.

Latest android version. Miss Devis tells Kelly to come back on Saturday (second time) but I forgot to go to the college on that second Saturday. Instead I worked in the cafe all day. No reminder to go to the college so by the time I was done at the cafe it was night time. I tried to go home and it tells me I should go to college as requested. But when I try to go to the college, it says it's too late.

So can't go home because it says I need to go to the college but can't go to the college because it's too late.

Luckily, I hadn't saved a new file and simply quit the game and loaded an older save and went to the college before it was too late but the game should have taken this scenario into account because otherwise, you end up in an endless loop.

The linux packaging doesn't describe its dependencies. It contains a 32-bit binary and on modern 64-bit systems getting the dependencies set up right is hard.

I'm on version 1.25 on 64-bit Windows 10. After I meet Becca on the beach, the game freezes up on the line "Hm...She really is an interesting one. I need to add her into the Lustonomicon." I tried exiting and reloading, but the same thing happens every time.

I am having the same problem. Same version and specs

Save before entering the beach. Open savefile with texteditor.

On Windows save path is -> C:\Users\your_user\AppData\Roaming\Godot\app_userdata\High School of Succubus\saves

Search for "beccareveal". Change it to "beccareveal":true. Save the savefile. Load this in Game. This skips the Becca scene. Next Becca call you can trigger by multiply entering and leaving buildings, it has some random trigger.

How do I fix it on android? 

(2 edits)

Android has internal and external storage. Internal Storage normaly only the app who is writing and reading the data has access. So you need to find a way to make the storage external for applications or you need to find a way to get access to the internal storage.

But also think about the problem, if you manage to change this storing behavior you old save files before in internal storage could still not accessable. Perhaps its possible to access the savefile in internal storage?

https://itch.io/t/431925/android-save-file

If i press New Game he crash

Im stuck in 1000 corruption on lvl 1 and cant seem to pass to lvl 2, ive triend everything i could find to fix it, from redownloading to starting a new save and it just doesnt work, i really like this games and i wanted to keep going but until i can fix this i wont be able to progress.

I cant find the version number but its the latest thats in itch.io

Hope you can help.

https://itch.io/t/498780/how-to-reach-level-2-corruption-with-kelly

Game version 1.25 I believe? After I finished the exam scene on saturday and went to work, there's an that's preventing me from going home to sleep, saying that I still had to take the exam and when I click the school, it says that I needed to go home.

This is a stucking bug. If you manage to reach night without doing the second part of the exam, you have no chance to go on.

If you have an older savefile you can easy reload from there.

Or you can save, open this in texteditor, search for "daytime" and change it to "daytime":3 (or1,2), then save this again and reload in game.

You find the saves in windows here.

C:\Users\your_user\AppData\Roaming\Godot\app_userdata\High School of Succubus\saves

the game stops allowing actions after meeting becca on the beach , i can hide the dialogue but i cant no do anything past that beside close the game.

Fixed it myself. Found prev version, 1.23 and played only beach event on my save. Than bought the dress, slept and voila! Run on newest ver and works fine ;)

Good job. Yeah this bug is new. You can fix it by using an older version to pass the bug. But scroll up some postings above. You can also fix it with a texteditor.

thank you for the help guys =)

Is there a fix for the becca beach bug on mac, without needing to use the previous version of the game?

edit save file.

linux/mac : ~/.godot/app_userdata/high school of succubus/saves or ~/.local/share/godot/app_userdata/high school of succubus/saves

use simple text editor or use hossaveed

Search for "beccareveal". Change it to "beccareveal":true

Can't play on android.When i click new game, game is shutdown. What should i do.

(1 edit)

Before i write nonsense here i tested HOS on Nox App Player on my Win 10 System.  This player emulates an android system. I have no problems with starting a new game in HOS. I could also do the complete tutorial without any problems. So this is definitly a problem of your android system. Have you read this?

https://itch.io/t/499321/running-hos-on-android

For a fast test that your system can handle the godot engine, you can try the first link there to test other godot based games.

Next step is to find your android version and your GLES-Version. Without more information about your system i can't help anymore at this stage.

My android system 6.0 and i tried godot-engine it's barely worked.GLES 3.1.Should work normally.

(3 edits)

Ok, that´s strange. This must be enough envirement to handle the gfx of HOS. Let´s make some more tests.

So you can start HOS and game shut down when you click New Game.

What happens when you click Load Game, Options, Credits, Quit?

I have also looked on my NoxAppPlayer Test Envirement, what seetings is there for my installed HOS Application. But didn´t find any useful information for now. My installed HOS App has no extensional rights like accessing external storage or so.

At the moment it looks like, there is a special condition when you click new game, that´s trigger this shut down behavior on you app. So our next step to identify this behavior is to find a way to avoid the newgame process or to find the reason what deals this shutdown.

If you can click load game we can try to find a way to start your HOS with a savefile.

Luckily you have Android 6.0, so you have an integrated file browser.

https://www.cnet.com/how-to/how-to-access-android-6-0-marshmallows-file-manager/

My Noxplayer is simulating Android 5.0. I need to search first a filebrowser app.

Why we do this. It'looks like your system has no problems with the gfx, so my next suspect is, that we have problems with file access or permissions?

Before i continue here, i need to know if you can click load game without a shut down.

I can click Options, Load Game, Credits and Quit there is no problem with that. But when i click New Game freezing and shutdown the game. I have no problem with permission. My all permissions enable. So i can click Load Game but no have any save game.

Ok, i need to find first a way to access HOS savefiles on android. No one has managed this before here in forum. Perhaps we make it? Need a filemanager app first for my android test envirement.

Ah damn you said it's barely worked. My english is sometimes not the best. What you mean with barely? Slow.

Do you have performance problems? Could this be you have to less cpu power or to less working memory?

If you google "godot performance problems on android" you are not alone.

It means worked but in the range of 10-20 fps. I tried Cubiventure(https://khairul169.itch.io/cubiventure)

In memory usage by apps "org.godotengine.highschoolofsuccubus maximum usage 758 MB". My last free space 587 MB. That's problem, right ?

(3 edits)

Yeah this could be the problem. Lack of memory mostly no coders handle this. So you have mostly a crash without any message from the application or system or you get some other error messages which makes no sense. Can you temporarily shut down other apps to free some memory?

(1 edit)

I did but using so much memory not enough.

I have no High School of Succubus files. I looked Android/data.

(4 edits)

I think i found the special situation.

When starting a New Game in HOS it takes some time bevor starting.

On my second test envirement with Memu emulator i had a popup meanwhile that the application don´t answer anymore. But i could continue only by negate the popup.

What if your system shut down the app, because the system means the app is crashed, but app is still working?

Starting new game process on my win envirement and on my android envirement takes about 7 seconds. Is your shutdown earlier? It could also be that your envirement need more then 7 seconds before start a new game. I try to work on a save file i could send you. Have your system a kind of automated shutdown for apps which working to long without answer?

Edit : Yeah i had another some seconds no reaction part during the intro, i mean i read here in bug report where players got stucked.

Have your system a kind of automated shutdown for apps which working to long without answer?

:I don't think so. If it was so, I would know. 

Starting new game process on my win envirement and on my android envirement takes about 7 seconds. Is your shutdown earlier?

:It takes almost 16 seconds.

I spend some more time trying to find my Android savefiles. But thats´s tricky on Android. You need to root your system first to have full access on filesystem. Rooting Android is a security risk, you also loose your warranty, some other apps could deny their work and updates could be more work to do. There is also a way without rooting by using the ADB (Android debug bridge) and control the Android from another computer. But i have noticed, when i start from a savegame it takes same time to start, so it´s no different here, if you start a new game or try to load a new game.

(3 edits)

There is an  "android app not responding timeout" of 5 seconds.

https://developer.android.com/training/articles/perf-anr.html

This is also a problem of coding, if you run timeexpensive code inside codeareas handling the gfx, like building a window and so on. The whole window build process is waiting for this timeexpensive code and the system reacts at some point. This problem could be fixed if you separate the "build windows process" from the "timeexpensive code" using different threads (multithreading) and then let the window wait till the timeexpensive code is finished. Normaly you do something like "please wait ...". This is a problem of the modern programming. You can't put long running code in objects like a window without "separating" it.

Looks like your cpu is to slow to handle this problem fast enough? Can you stop some other running apps to give your cpu some help?

Thank you for all. I tried root long time ago but didn't work. I deleted software and i uploaded. Its not work. You said codes but i can't do this. Sorry for waste of time.

(2 edits)

This code problem is nothing we can do. You need access to source code and rewrite some mechanics to work multi thread there. I also can´t say, if this is common for godot engine based games or if this could be fixed in game coding part. Normaly it should be fixed in game coding, but its´s more then to change a trigger. You need to learn first the mechanic and syntax of multithreading in godot.

https://docs.godotengine.org/en/3.1/tutorials/threads/using_multiple_threads.htm...

There is also some special in the conservation between multiply threads, so it´s also some more work to wait (sleep) in one thread till the other thread is finished. This is something we can´t do. You can only try to speed up your system or try to find a way to stop a shutdown.

https://www.howtogeek.com/183004/why-android-phones-slow-down-over-time-and-how-...

Have you old version link?

I have old versions up to HOS.19, but i didn´t think this will help you. You can also try very old versions running in browers. But i think its the same. If you google "highschool of succubus" you find a lot of links to websites "hosting" old versions of hos in browser.

(8 edits)

What happens if you try to pause HOS before the shutdown.

I am new to android handling, but programmed in past some code on android. I know there are some states for the app like pausing and resuming.

https://stuff.mit.edu/afs/sipb/project/android/docs/training/basics/activity-lif...

Is it possible to start HOS then start a new game and pause and resume it without coding? I mean you start new game, pause it by switching to another app. What happens then? I think godot engine handles the pause and resume events correctly. Perhaps this will make the HOS-Code part paused. If HOS app is not shut down, when starting a new game and pause it, this could be a way to jump over the problem, by pausing and resuming the app. But this is only theoretically.

Edit : I have used the mechanic to start a new game on my test envirement without "the app is not working" message triggering.

Try this -> Start new game in HOS. Then fast click another app. I used the Filemanager. Now you can wait. I waited 10 seconds on my try, you need to wait longer i think. Then click HOS back to work. I was instantly in first tutorial scene. This means the HOS time consuming code can work in background and when its finished you can switch back to the app and the gfx build process then is no longer slowed down.

Cant buy Party Dress

Version 1.26

You need corruption 200 and level 2 and meet becca at the beach and wait for her two calls to allow buying the dress. If there is a bug to buy the dress in version 1.26 (i need to wait before this version goes public), you can "cheat" the dress by manipulate the savefile. Use texteditor or hossaveed. It´s :  items->partydress->true

where can i play the version 1.26 with out downloading it

public downloads are here, you need to wait 3 or 4 days, till 1.26 is public.

https://two-succubi.itch.io/hos

if you can´t wait, patreon downloads are here.

https://www.patreon.com/hosgame

playing this game in browser "without" download, is only limited possible, if you search for high school of sucubus you find some sites hosting older version of HOS in browser.

i see

what about the one on newgrounds

If you look credits in browserversion there, it´s 1.24, public download link there is 1.25. But you are right, the browserversion there is near latest public version.

can you make kelly reach level three in the one on new grounds

(1 edit)

You ask questions. In 1.24 and 1.25 Kelly's max corruption level is 2 and I didn't think in 1.26 it's different. Kelly's max corruption on 1.25 is 300/level2. I think it was 200/level2 the version before. Think of next Kelly Levelup about 1000/level2 or higher? So it could be about seven more updates before this happens. I didn´t believe this happens before chrismas this year. Perhaps if you write a letter to santa and declare him your wish, this could help. ;-)

Hi, I've been a  fan of your game for months, even the black screens and everything didn't bother me because I found a way of dealing with those. But today I went online to see if there was an update (I play online on a computer --- Not mac) and I was happy to see one; BUT then it was impossible to load my game cause it was gone ?? I spent months playing that and now my file just diseappeared ? What can I do ?

(2 edits)

I will try to understand you. You can't play this game "online"? I think you mean you play it in a browser, also because of the blackscreen bug? Perhaps it looks like online, but your browser downloads the game data to your computer and start the game also there. Savegame data in browsergames are mostly stored in cookies. The Cookies are also stored local on your computer. Each browser stores his cookies on there own way, so you can't access a cookies from another browser. The update you mean to play is not really an update. It´s the next standalone version of the game. So now you have your old cookies with all your savedata from your playtime with the older version and the new version with a new separate cookie at this point mostly empty, because you didn`t played and saved here.

You can try to find your old cookiedata in your browser. It´s in options and there in security. But if you wanna look deeper in cookies, you need special programms. Google for "browse cookies" or "edit cookies".

Anyway i need about 4 hours playing this game new from start to end. You can also switch to a non-browser version of this game. If you are not playing on android you have no problems with your savedata then.

So you have 3 options. Replay the game. Replay a non-browser version. Try to restore your cookiedata.

Hiya,

Windows 64

Bug: I cant get the cosplay event to trigger, i have Viki at 400 corruption, i have catwoman outfit.

Thanks.

I have tested  HOS 1.27-Public. Max corruption for Viki on that version is 360 corruption. I have also tested buying catwoman outfit before viki is talking about her new batgirl costume. I have no problems to trigger the cosplay event. When viki reach 210 this triggers the new swimsuit event for her, speaking after this again with viki in school triggers the batgirl dialog in school. Buying catwoman costume and call viki from kelly´s home starts the cosplayevent with viki. If you meaned 1.28-Patreon, because you said Viki is 400 corruption, i currently can´t say, if there is a bug or not to trigger the cosplay.

I would love to play but every time I got play it crashes the Android version of 1.27

(5 edits)

That´s like my computer don't start, can you help me? You give no info, except the HOS version you have tried. Android is a pain. There are so many different versions. If your environment is to low you can´t run HOS. See here to check for your basic environment like android version and gles version.

https://itch.io/t/499321/running-hos-on-android

If you have problems on starting a new game, there are more problems if your system is to to slow or have to less memory. Read this thread some days above, perhaps you can bypass the "crash" by forcing hos temporary to background.

(1 edit)

my Android is 8.1 Oreo and I have gles 3 so I'm not sure and backgrounding it doesn't seem to help either when I hit play it will freeze for about 8 seconds go to a black screen for about 3 seconds and then I'm back in my apps list

Have you tested other godot games?

https://itch.io/games/platform-android/tag-godot-engine

yes I tried two of them and they opened and ran fine

You can try a tool like cleanmaster to clean your phone, to free some memory and speed up your phone? 

https://play.google.com/store/apps/details?id=com.cleanmaster.mguard&hl=en

HOS has some bad time expensive coding without reacting to OS, so OS could shut down the HOS app to early . You can also try a  browserversion of hos.

https://www.newgrounds.com/portal/view/710878

tried both the cleaner didn't seem to have an afect and the newgrounds one is not able to be played on mobile

(4 edits)

You can't say "global", that the browser version is not able to be played on mobile. But that´s a general problem on android. Android should be primary a phone os, not a high end gaming device. I think HOS has 2 problems on android systems. Memory and Speed. I read some more about ANR (Application Not respond).

https://techterms.com/definition/anr

There is a different between a crash and an ANR on Android, how the OS handle this. I think in your situation it looks more like a memory problem and a real crash. HOS has so much Artwork. App has some hundreds MB data. I can´t say how godot and HOS handles the memory when you start the app. But depending on the time before the game starts, there is a lot of data shuffled to a current running memory process. Also later in game, for example when you start a new game or load a game, there is a lot of coding working and memory usage again i think.

Found also this topic about reasons on android game crashings.

https://techbeacon.com/app-dev-testing/top-6-reasons-mobile-apps-crash-how-best-...

So it could also be a problem with newer Android OS. But my personal number one is missing memory.

There is also the possibility to connect an android device to a computer and log the crashes, but that wouldn't help you i think, it would only lead to the crash reason and could help the developers?

ok I guess I'll just wait for mobile hotspot to renew for the month and download it on my computer

(1 edit)

I "tracked" the memory usage from HOS on my Win10 System.

Starting App will use near the 300 MB on memory like the app usage on file storage space. Starting a new game or load a game will boost the memory usage to near 2 GB. I have readed at somepoint that memory usage from HOS on android system is enhanced, but we have still a lot of usage there, need to test this on android enviroment.

Public 1.27 Windows

Bug: Trying to cosplay either the witch costume or cat costume, but neither changes the appearance of Kelly.  Corruption is near 600 already.

Thanks

You can´t put costumes on manually. If you put them on in wardrobe, Kelly is still in non costume clothes.

Witch costumes is only for heloween party and cat costume is for cosplay with viki. Kelly uses this costumes automatically, when you reach the scenes for this costumes.