Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Sipho

Design a creature and eat your way to the top of the food chain. · By Sipho, Dominas, DanTM

Bugs

A topic by Zhenyka created Aug 14, 2018 Views: 403 Replies: 54
Viewing posts 1 to 18

There are a couple of disgusting bugs I founded.

I use Linux. Played in browser.

Bug 1: Sometimes player siphonosomething start to move in random direction like if I pressed button.

Bugs in building:

Bug 2: Sometimes zooids replasing automatly to previous posicion after replasing.

Bug 3: Sometimes zooids do not spawn. But nutrion is taken away.

Bug 4: Sometimes zooids spawn in incorect position.

Bug 5: Sometimes zooids become like it is enemy dead zooids after plasing.

Its all I found yet.

Typos I found: 'founded.' to 'found.', 'posicion' to 'position', 'plasing.' to 'placing.', 'incorect' to 'incorrect', 'replasing.' to 'replacing.'.

I found a new bug- (windows, downloaded on the itch.io application) I pressed space to enter growth mode, took me to home screen (first bug) and when i clicked continue, it took me to a blank landscape. (second bug) Reloading hasnt worked, any other solutions?

Developer

Thanks for playing Sipho and reporting this issue!

Does this bug happen consistently? If I'm understanding correctly - in game, you've pressed space button which then took you to Main Menu?

And second bug is that after that happening, you start in an empty field?

Yes you are right. Its rare but happens sometimes. I play on windows and its downloaded. An empty field with background bubbles was all there was.

Developer(+2)

Good stuff, thanks for reporting!

Bug 1: We have noted that, but haven't found a way to consistently reproduce.

Bug 2: I'm not sure I understand the issue correctly, but there are some problems with Zooids that are to be regrown and moving existing zooids. Future versions should remove Zooid ghosts if existing Zooids get moved around.

Bug 3: I'm guessing that's issue with continuing the game. We have that fix.

Bug 4: Does that happen on continuing the game?

Bug 5: This one is interesting. Could you tell us more on how could we reproduce this bug?

(+1)

Bug 4: Yes.

Bug 5:  Im not sure. For example, I have a big creature, and I noticed that It is non-metric. I tried to replase zooid, but then it become black (In editor). Game thought that that zooids was disconected.

And what do you think about difficults? Will you add It? And new types?

Bug in my PC: I start up the .Zip file, then i get assfucked by 'Unitywebplayer.dll is nonexistent in your machine' or something along those lines.

When it clearly exists!

Maybe you still have a On-Browser version of the game. if you do, reply to me with the link!

I think i'm spamming. Or am i?

Developer(+1)

Hey, thanks for interest in playing Sipho!

Let's make sure you are able to. Have you extracted files from downloaded .zip?

(2 edits)

Oh i downloaded it yesterday and tried copying the Unity .dll

also this is what the error looks like

im on Windows 9, and BTW the error looks so real i tried to click it but nothing happened xD

(1 edit)

also i'm playing on the Demo

the Free Demo

Developer(+1)

Just to be sure, have you tried extracting all files from the zip? Like right click on the zip file and select "Extract ..."

(+1)

I have extracted EVERYTHING from the .zip into my desktop, and it works! Thanks

did anybody find a fix for the blacked-out screen for downloaded linux version? i really want to play the not-in-browser version! if anybody knows could you reply a step-by-step to this comment plz?

Developer

My suspicion would be that black screen is caused by unsupported image effects we use in the game. WebGL version has some effects turned off.

Developer

Could you provide us your player log when launching the game on Linux? It should be here `~/.config/unity3d/AllPartsConnected/Sipho/Player.log`

Ok so i looked around and im lost. i don't know where to go beyond this point. could you give me a turn-by-turn on where the player log is on this?

Developer

I don't have Linux machine to check, but it's probably not in the Data folder, but rather in your environment. So this:

~/.config/unity3d/AllPartsConnected/Sipho/Player.log

probably becomes this:

/home/trog/.config/unity3d/AllPartsConnected/Sipho/Player.log

I'm just going to give up and play in the browser only, i cant find anything called "player data" and using the search phrases just brings up an error message. maybe creating a feature that automatically pulls it up from the options menu would help make it easier to send you guys player data?

Developer

Hi!

I have uploaded two Linux builds similar to WebGL:

Sipho 0.91_Nofx Linux Universal Gamma.zip

Sipho 0.91_Nofx Linux Universal.zip

You can find them on main Sipho page. I couldn't figure out how to link them directly on itch. Would you be able to tell us which one works for you? They both have some image effects disabled like WebGL does. And Gamma one uses Gamma rendering (instead of Linear). Thanks!

(+1)

sure thing, ill try them out later today or tomorrow.

so neither of those seem to have worked. do i perhaps need to download some kind of unity engine software?

Developer

Thank you.

As a last resort I will make another build with no image effects. It's weird though as those builds use same features as WebGL, yet the latter works for you.

Developer

Hi,

Sorry forgot to ask, did you try going past Breed selection menu? I've forgotten to change effects in main menu, which could have still indicated unplayable build.

We've uploaded another build - Sipho 0.91_NoNoFX Linux Universal.zip which should have NO effects at all. Let us know if it works!

Developer

Hi,

Could you contact us through one of these sites:

https://twitter.com/sipho_game 

Dominas#6068 on Discord

Or by email: sipho@allpartsconnected.com

Itch doesn't have private message functionality, so that's why I'm writing here.

(1 edit)

Hello everyone, I found a peculiar bug in the Demo Day 22 Sipho edition. It can be reproduced like this: delete all creature parts, then put structure parts in a T shape as depicted on the image (don't put anything else but structure parts). If done right, creature structure in the editor will become distorted slightly and the grid will tilt a bit. Upon the exit from editor window something bizarre will occur: creature parts will move on their own, twisting and stretching the structure, likely "explode" and scatter parts across the map or get them stuck in walls or destroyed on spike debris.

Edit: notice how on the 3d image the top of the T shape takes less space than it should. That's the distortion we look for.


Developer(+2)

Thank you for the report!

It's a known issue in our soft body solver. It doesn't handle larger symmetric builds which we didn't expect it to surface in normal play conditions. I'm going to take a note it's a higher priority issue than we anticipated. Thanks again! 

I'm all-too-familiar with this bug, especially since 99% of my builds are symmetrical (even the one build that isn't mirror-symmetric is radially-symmetric instead).

The bug can also present itself in other forms as well: Any sign of the grid shifting, no matter how slight, is a sign that this bug is surfacing. Side effects include the inability to place zooids in areas that you usually could on the other mirrored half of a symmetrical siphonophore (i.e. the game is literally forcing asymmetry), and sudden distortion while placing zooids.

(1 edit)

Thanks for the answer) And now I have another bug for you.

My actions: start as sea creature; complete first level with 41 total nutrition by destroying some green blobs after the message "stage clear" (good job on the message and weakened whirlpools by the way, feels much better than forced whirlpools). As soon as i start second level (boss) I hit space to redesign my creature but instead I see title screen. I pick "continue" and instead of 1st boss I get into this abyssal empty level with nothing but darkness in all directions. Can't find player logs on windows, no idea where it is.

Edit: could not reproduce the bug by doing the same, might be a rare exception rather than stable error.

Developer

Nice report. Do you play in browser or in downloaded version? Do you click "Dive" using mouse or Enter key? Has this ever happened on first playthrough (in comparison to happening only after dying/manually starting new game)?

This is something that has been reported but has been very elusive to repeat, we are looking for more info to dig in. My first hunch tell me that it has something to do with UI because Space key is the one that activates selected UI element.

Thanks. I play downloaded dd24 version on windows, usually mouse-click on the dive button or let it fill up on its own; but always use spacebar to enter edit mode. The problem only happened once and it was a new game without tutorial, but not first playthrough. The whole void zone happened as I clicked continue after that bugged main menu exit. I hope this info helps.

Developer

Thank you for info. It will help us to dig it down.

At great speeds collision with walls may get you stuck within the wall. I think it should either bump you out or damage your parts which would be reasonable giving the fact player just ran into a wall at mach 1 speed.


PS: Dominas, the DD22 game version has disappeared from your profile and requires password to access now. If you hid it intentionally, does that mean we were not supposed to access and test it? If you feel that it's too close to complete product state to be a demo anymore, we will understand.

Developer

Thank you for another report!

We should fix those pushers not acting physically and then figure out if additional actions are required for collisions. Fun fact, spike used to get stuck in walls and that was super annoying. We changed collision mode to be more precise and that fixed it. I hope we won't have to do it for all Zooids though.

Re DD22: Please, feel free to continue testing! You have provided valuable reports, we highly appreciate that. DD22 was intended for a gamedev community to test and provide feedback on. 

Good day to you, devs and everyone. I'm back with bug reports, a minor one this time.

DD22 game version.

As I clear the first level, text appears: area clear. By design, no more food or enemies can be found, limiting my ability to grow on this level, However, if I go to menu and press quit, then continue, I will appear on the same level along with multiple food sources and at least 1 enemy around myself. I suppose these are generated on level load by default, even if technically the level should be finished. This potentially allows players to grow infinitely on first level by quitting to menu and back.

Expected behavior: I suppose the game should check conditions and start "area clear" sequence if needed on level load before spawning food and enemies.

Developer

Hey, nice catch! 

We haven't thought about this exploit. We have it already fixed locally. Thanks for the report!

Sometimes the background of the third boss can change when you quit and come back.

Example of the bug in action: This actually happened...

The walls are correct, but the background is the Azure Depths background.

i also  caught THIS on Rak'dun and Twisted narrows.

it may look normal but its many whirls glitched into 1

i think i took this picture on Rak'dun, Edit mode...

(1 edit)

Greetings everyone, it's me again! So I checked out newest testing branch version and it's great, graphical changes and level design improved, but... here I am at the cage boss and as I expected it spawns 2 minions that I easily defeat. Then it spawns 3. Then 4. Then there is a constant stream of a whole horde of minions all mobbing up on me and pushing me around. I am experienced player, I didn't fall, and it was a fun battle, but I imagine some players will be... puzzled, if they have to fight constantly increasing number of minions for what feels like 20 minutes. Was this intended? I remember people were arguing that cage boss was hard back when there were 2 minions, but here it's just a zerg-rush, they just don't stop. Boss used to absorb itself to spawn these little minions, but now it does so at a slower rate. This is cool for a hard mode, but new players gonna be massacred)

On the picture - this is just the beginning, there's gonna be more of them...


I'm not even sure this counts as a bug or just slight disbalance

Developer

Hey, welcome back!

We have increased spawn rate to make this boss less farmable and have a more of risk-reward thing while fighting it's minions. It might be too hard, but with certain tactics the boss is easy no matter what spawn rate it has. I'll keep an eye open for it's difficulty, although with upcoming changes to the game, we won't have to reduce the difficulty. Thank you!

Gonna catch them all! Too bad there is no achievement for collecting all the parts, but I'm pretty sure you didn't intend it to be possible for players to collect all of them. But here I am again...

 

Here's how I did it (testing branch version): I got to the last boss, and it's awesome, and it has all the parts and rotates to attack me with various strategies, and there are also 4 supporting mini-bosses that come to help the boss when it's in trouble, and you only finish the level once all 5 of them are dead, but zooid part drops from the main boss once it's dead and if I quit out to menu once I get it before killing mini-bosses, I can continue the level from start, with all the bosses alive. Even though it's hard, one can farm last boss for parts and quit out as long as they don't kill mini-bosses, as the game ending sequence does not activate. This can make free roaming level quite fun :D

Developer

Nice one!

At this point we can say you've earned it :D

We should fix this one together with possibility to skip boss rewards by jumping into whirlpool early. Thank you.

pretty sure this will count as a complaint but...

why is the price for the game so high i cant even buy it tho im not mad

Sometimes final boss is unresponsive until some unclear event triggers it. In this dormant state it regenerates any destroyed zooids instantly and indefinitely and doesn't have protective red shell on its primary zooid. This may happen more often when I sneak around and kill a few mini-bosses first. Perhaps it's something with boss ai, as it's quite complicated as I can see.

Developer

Thanks for the report!

It may be caused Frakir being unable to fully grow and still be in the "preparing for battle" state. I think I see a missing spike. Noted!

Back again, with something that's been copied from another bug report but in the windows demo.


'allow players to grow infinitely on the first level by quitting to menu and back.' my version of that sentence is:

'allow players to grow infinitely on the tutorial level by quitting to menu and back.' so yeah.....

Hah, someone has to be quite dedicated to level up this way... I don't even see how developers can fix this other than including map state into game save file.

Developer

Hey, thank you for the report!

I think tutorial shouldn't have game save at all. Iztacmizton is right, to fix this properly we're planning to fully save map's state at some point. That will also help to preserve anything that's been going on in upcoming Aquarium mode.

At the cage boss I ate all of his minions and grew rather large. On the next level the game started "zone cleared" after I ate just one enemy, and on the level after that "zone cleared"  sequence started immediately, spawning the very first  whirlpool right at my position. And I noticed that whirlpools only show the DIVE button when you move into them from outside. I was curious what will happen if I just wait in the whirlpool... In the old days it would just force me to dive, but thankfully these days are over. However, it just kept growing and then other whirlpools appeared and grew bigger, and then I thought "hey, how am I gonna dive without DIVE button? I need to enter it from outside, but it's whirlpool everywhere and I don't have my button..."

In other words, welcome to the second circle of Dante's Inferno.

Eventually I managed to find the last small patch of still water and the DIVE button appeared as I entered whirlpools again, but that was lucky.

Developer

Thank you for the report!

Growing whirlpools should still start displaying Dive button. We recently made these more robust, but it seems that was not enough, noted!

(2 edits)

The longer I play at free roam level the lower my fps drops, down to 1 frame per second. If I quit out to menu and continue, everything gets back to normal, for the time being, then fps gradually drops again. Perhaps there are some objects on the map that aren't properly disposed over time? Little green blobs maybe? It needs debugging to say for sure. Thanks in advance.

Edit: Remember the trick with final boss that allows player to get new zooid and quit out before completing boss fight as long as 1 minion is alive? Turns out it also works on cage boss. I kinda like this bug, though, having full zooid collection is fun. But you might see this the other way.

Also, when I click Play Again button after final boss - it doesn't do anything.

PS: Is this a good place to leave bug reports? I used to leave bug reports in this post so  that other players would see them to prevent duplicate reports, but now I notice there aren't many bug reports coming from other players, so would you like me to sent reports anywhere else?

Developer

Hey,

  • Noted that performance drops. We use "pooling" for objects, but that shouldn't cause any problems as objects get re-used. My hunch tells me that it might be copies sipho "blueprints".  We will look at it - it will have to be fixed for Aquarium any way. Knowing that you only need to quit to menu rather than whole game gives better clues.
  • Noted about 3rd boss. We shall fix that exploit for good.
  • Noted that "play again" button doesn't work.

Thank you for all these reports! We also use discussion forum on Steam, but we monitor both communities, so you can use whichever you prefer.