Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Problem during setup: Isar failed with code 1. [Resolved]

A topic by Darthsonix created Apr 30, 2018 Views: 973 Replies: 30
Viewing posts 1 to 22
(+6)

I keep on getting the error and I dont know how to fix it. 

(+1)

Yeah, same here. I'm on a Windows 10 laptop. 

SAME

Same problem on Linux Mint. Reinstalled package as well.

Yup. Same for me here, on Windows 10. Tried re-installing and still no luck.

(1 edit)

Guess the last push fucked something over? I'm getting the same error

(3 edits) (+1)

Same here. Noticed the new butler.7z is only 1kb and 7zip doesn't recognize it as an archive while trying to find a fix. Lsar is what Itch uses to extract 7z files, which is why it's also failing on the corrupt file and giving the error code.

Happening to me too. I'm on Windows 7 Enterprise. Is there an older version we can install in the meantime?

(1 edit)

its the login part that is the problem that's why whe get that not even getting the change to fill in login info or automatic login doesnt work ether goes strait away to code1
figured out what is the problem
its the Android part off this program which is not able to funktion under windows 10 or any windows appearently
aka the butler part whont or whill not be loaded

(2 edits) (+2)

Butler is a normal part of Itch, it can be used by creators to add their games or update them and is available for OSX, Linux, and Windows. There doesn't seem to be an Android version of butler, so not sure what you mean.

https://itch.io/docs/butler/

So how do you fix it?

(+3)

Right now it looks like we're just gonna be waiting on Itch to update the corrupt file, Itch won't use an older version of butler as a fallback for whatever reason.

Same Issue!

Same i hope it gets fixed soon

(1 edit) (+3)

BTW, for anyone just trying to access their game library you can manually launch the games from wherever they're installed since Itch doesn't use DRM.  In Windows the default is usually:  Users\[your username]\AppData\Roaming\itch\apps . You'll probably have to turn on the option to see hidden system files to get to the folder though. On Linux they should be in your .config/itch/apps or something like that (or maybe local? don't currently have a Linux system up).

(+3)

I just looked at the contents of the butler.7z file in a text editor, and i just contains some XML:

<?xml version='1.0' encoding='UTF-8'?><Error><Code>NoSuchKey</Code><Message>The specified key does not exist.</Message></Error>

Same problem!!

Well at least I'm not the only one :D

(+3)

Glad you could join us at the  

Isar failed with code 1



party

(+1)

lol Well I just hope its fixed soon I need my daily itch :D

(1 edit)

Hey, I have this problem too. I'm on Mac OSX 10.10.3. :(

Time for an Isar code party!

This is also happening on mac OS 10.12.6 Sierra. Before the error kept popping up, the itch app seemed to hang on downloading a butler update.

Happened on two Windows 10 computers I just tried opening the Itch.io app on.

(+7)

Found the fix guys:

https://itch.io/docs/butler/installing.html

Download the exe respective of your CPU architecture then copy that exe to:

%appdata%\itch\bin 

Where %appdata% is either your default %appdata% folder or your "C:\Users\<usernamehere>\AppData\Roaming" on Windows 10. Not sure about other OSes or other versions of Windows

Launch Itch, and it'll say the same error, click the refresh icon, it'll be all good

Thank you, Joshua. I didn't even have to refresh...the app worked immediately after adding the file to the folder.

Should have thought of that lol. Worked fine here, thanks!

Thanks so much! Worked like a charm! :D

Awesome! thanks!

Just tried it and it worked for me on Windows 10! Thanks!

Admin(+3)

Hi everyone,

The issue has been resolved - launching the app again will work as usual.

Thanks for posting a workaround, more details on the underlying issue can be read here for the curious.