Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Mr. Friendly

Randomly Generated Acts Of Kindness · By JP LeBreton

Known issues with current build Sticky

A topic by JP LeBreton created Mar 27, 2018 Views: 1,035 Replies: 32
Viewing posts 1 to 20
Developer (14 edits)

Overall Project Status: Alpha (ie mostly feature complete, still some bugs and missing assets)

There's no public bug tracker, so please feel free to reply to this thread with issues you find, things that seem like objective bugs rather than stuff that would merit further discussion (which you should start a new thread for).

What works:

  • 8 quest types + quest system that randomly makes unique quests available on each level
  • world interaction: view name & description of thing you're looking at, talk to monsters
  • 4 tools: "grabber", texture sampler, fishing rod, guardian vision
  • UI: quest screen, inventory + crafting screen, HUD, "detector gem", tallies on automap
  • works with all official IWAD (Ultimate Doom, Doom 2, Final Doom, Doom Complete) maps

What's missing:

  • Some menu and title art
  • Help screen
  • Player character sprite?
  • A few little easter eggs here and there

What's broken:

Developer unlocked this topic
(1 edit)

(edit: i was using wadsmush) i just played doom 2 from map 01 and finishing map 19. i did find a few errors:
-map 31 got a fishing quest, but the only liquid is a water ceiling i cannot fish on because the fishing beaver is floor-only

-map 32 keens and tag 666

-map 16 photo quest destination in the hidden teleport area where the monsters wait until they can hear you

-map 18 missing textures https://imgur.com/a/r66oD

-map 19 missing textures https://imgur.com/a/En8EH

-map07 ticks and traps crash on launch: https://imgur.com/a/Ww0gH

(also, not really a bug per se, but on map 06 a texture was selected by the quest. but that texture was a super obscure placement as the bottom of 3 different doors essentially obscuring the majority of the texture. so unless you dragged it into an editor and searched for the sector the quest was looking for you would not know where it was)

(thursday march 29th build) the only "bug" i could find wasn't even a bug, just in map 24 (the chasm) i was asked to find a texture which was a mid texture. and i can't select mid textures.

(1 edit)

Sorry I didn't see that "objective" bug reports were supposed to be posted to this thread - I'm going to merge my thread into this one. I believe I saw this on version #74846:

I was trying to craft but then I was unable to pick up items from my inventory screen. Then i got a vm abort. I'm not sure if I can reproduce it but here are some recent saves (I was using DOOM2.WAD) and a screenshot:

Developer

No worries! Thanks for the report. I added a few checks to this part of the code and haven't been able to repro it, let me know if you see it again.

(1 edit)

Getting this same problem on build 54. Rather constantly, in fact. Never on the first level but often within 3-4 stages. The inventory screen just does not respond to any clicks at all, and if you click to much you end up getting the "crash" a bit after you leave. Hovering functionality works fine though (item names and the glow around crafting spots).

Here's a save. Doom.wad.

Developer

Thanks! I just pushed an update (build 58) that totally refactors the crafting and related inventory code, so it should be more robust now. I can't repro the issue as described in the new build.

It looks like it's mostly fixed; I'm not getting it the majority of the time. I did run into one time though. It no longer ends in an out of bounds array access, no matter how much i tried to poke it, and unlike before while it stuck in the save file it didn't stick around when I reloaded from the beginning of the stage.

Here's the link. doom.wad again.

this should work right? https://imgur.com/a/jfs30

Developer

I started writing some dialog entries with that tag before I wrote the code to parse it properly, should be fixed now.

april 12th build. i don't know if this is a bug, it's fun, but it's super janky. feels really off. as a side little "haha" it's fine. but it just feels like i am destroying something beautiful by doing this in actual play.
Developer (2 edits)

A couple days ago I changed the Texture Sampler to swap its texture with what's being sampled, so most of the behavior you're seeing in that video is intended... you can certainly butcher a level's texturing with it but I wanted to try it out and see how fun it felt.

The bug there is that you were somehow able to sample the temp "no tex" texture multiple times and stamp it everywhere; my idea with the swapping mechanic was that you could never destroy or duplicate any given texture in the level more times than it originally appeared.

(2 edits)

To reproduce, with version 44 complete MAP31 in DOOM2.WAD with the Wandering Demon page finder mode turned on

UD e1m4: fishing out a dopefish for the quest, dropping it, picking it back up during diving placeholder animation played. it said i could return to the quest sender and the game crashed to console when checking inventory

Developer

Should be fixed now. Issue was stashing a fish while it was diving back into the water.

Minor spelling error (brough -> brought)


This journal page spawned a tad too close to some walls. Looks a bit silly.

Quests can end up on the boss in E3M8 (and presumably E2M8), making them uncompletable because talking to them ends the stage. Currently it's happening on E3M8 in level-based randomness mode.

Ran into another fun little quirk: you can be asked to get a switch texture that you can't get anymore, because you pulled the one-time switch with the texture and now it's another texture. The detector gem still points to the pulled switch, but grabbing the texture doesn't solve the quest. Tripped me up on Sever The Wicked; was asked to get the "skull switch on wood" texture in the "unpressed" state, but the only switch of that type is the one right next to the starting point and I already turned into the "pressed" texture right off the bat.

Finished up and found two more things going wrong in MAP30:

First, at least in Doom 2's map 30, if you talk to the one and only enemy and try to get his quest too quickly, GZDoom freezes and needs to be end-task'd. I think the point at which your are safe is when the first cube lands and spawns a demon; merely waking the boss brain isn't enough.

Second, if you pick up and throw the Wacky Wizard around somewhere before talking to the Wizard, this happens.

Developer

Thanks for the reports, Yoshi! I was able to fix all of them except one for Build 60, let me know if you still see them. The switch texture issue is a stumper.

Hello friend, i do not know if this should be posted here, but i have a few problems. The pages in level one didn't appear to spawn at all, meaning i couldn't finish the quest, and in level 2, i do not know how to lead the NPC to the location which he wants to visit. 

ok, yeah this is not a bug. the pages do indeed spawn. you just need to use the friendly-vision (bound to weapon 4) to see them. and you don't need to lead the NPC to the location he wants to visit. you just need to go there, stand in the right spot facing the right direction so it takes the picture and then tell him about it. once you tell him, the quest is over.

Slightly disappointed theres no gags if you try to run it alongside Brutal Doom, like HDoom has

Less goof: any plans for Heretic/Chex Quest/etc compatibility down the line? Obviously it would be a later development, but could be fun.

Developer

I have a trello card for Heretic/Hexen/Chex Quest support, it'd just be a matter of doing all the writing: https://trello.com/c/84fg3DQG Not sure when I'll get around to it though.

(1 edit)

So.. I tend to get this crash-to-console error when scrolling through weapons. Usually happens when you finish a level, enter the next one and scroll through your weapons

I'm currently running GZDoom 3.3.2, should I use a devbuild?


Developer

Good catch, should be fixed in the build that just went up.

HELP! it says 

Script error, "friendly.pk3:friendly_zscript/ui.txt" line 1763:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 36:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 36:
Invalid statement
Script error, "friendly.pk3:friendly_zscript/quests.txt" line 132:
Invalid statement when i run it in qzdoom or gzdoom

Developer

This seems to have started appearing with the most recent GZDoom, currently investigating.

Developer

This ended up being due to a bug in GZDoom itself, which has now been fixed. The next official release of GZDoom, whether it's 3.7.3 or 3.8, should contain this fix. If you don't want to wait until then you could try downgrading to an earlier version of GZDoom like 3.6.*

Developer

GZDoom 4.0 was just released, and fixes this: https://forum.zdoom.org/viewtopic.php?f=1&t=64188

So, enemies descriptions don't appear, and I don't know how to fix that :/

Developer

When you press spacebar, does a dialog box come up? NPCs don't have descriptions the way objects do, but you can interact with them to talk.