Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Paint of Persia

Paint of Persia is a rotoscoping pixel-art tool · By dunin

Bugs report

A topic by dunin created Jun 24, 2016 Views: 2,151 Replies: 59
Viewing posts 1 to 22

Please, post any bugs you encounter here...

(1 edit)


aight I don't even know what I'm reporting here but I start a new project 128x128 12 fps and All I get is these here windows no matter how long I wait for em to initialize. Windows 8 64 bit. (Upgrading to 10 as we speak to try use this dope looking tool though)


Hi, I upload a new version that records errors. Can you try with it and if you see an error.log file appear on the main folder, send me it...

(I have to confess that I only try the tool with windows 7 and windows 10... I... windows 8 scared me... But I will looking for it to do some tests...)

Hmmm I cannot get this working on mac:

if I run my nwjs project without the zipped Painted Of Persia it will just run the default start screen of nwjs so the setup seems legit. But if I add the zipped Paint of persia folder to as app.nw to Contens/Resources/app.nw. It will exit with this stacktrace:

I had to remove somethings because it was too long I've just added (...) where I've removed part of the call stack.

2016-06-25 08:45:29.725 nwjs[3177:224112] NSWindow warning: adding an unknown subview: <WebContentsViewCocoa: 0x7f91e9ce1360>. Break on NSLog to debug.

2016-06-25 08:45:29.727 nwjs[3177:224112] Call stack:


2016-06-25 08:45:29.920 nwjs[3177:224112] +[NSMenu menu]: unrecognized selector sent to class 0x7fff76e0e4a8

2016-06-25 08:45:29.921 nwjs[3177:224112] An uncaught exception was raised

2016-06-25 08:45:29.921 nwjs[3177:224112] +[NSMenu menu]: unrecognized selector sent to class 0x7fff76e0e4a8

2016-06-25 08:45:29.921 nwjs[3177:224112]


2016-06-25 08:45:29.922 nwjs[3177:224112] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '+[NSMenu menu]: unrecognized selector sent to class 0x7fff76e0e4a8'

*** First throw call stack:


libc++abi.dylib: terminating with uncaught exception of type NSException

Abort trap: 6


return natives.StartRequestSync(functionName,



Thank you to try this on mac!

I had coded something "just in case" for the mac menubar, but never tested it. It was a bad idea.

I upload a new version without this (you should have the default nwjs menubar, but this doesn't matter...)

Thx, I got it one step further with your fix. Now the app crashes when I created a new project, or click on "Quick Tour". It it related to the menu also "Item to be inserted into menu already is in another menu", some more details here:

2016-06-26 21:51:31.393 nwjs[4320:293985] *** Assertion failure in -[NSMenu insertItem:atIndex:], /Library/Caches/

2016-06-26 21:51:31.394 nwjs[4320:293985] An uncaught exception was raised

2016-06-26 21:51:31.394 nwjs[4320:293985] Item to be inserted into menu already is in another menu


Ok, I think to see where the problem is, I tried a quick fix and upload it...

Please disable shortcuts while the focus is away from the main screen, such as in the "Export" dialog.


Ah, it's a bug, normally shorcuts are disabled during export... What kind of export did you do?

That said, shortcuts are enabled even you don't have focus on app, maybe that's what you are talking?

I do this because when I used this tool, I did "Ctrl S" always even when I changed something on my browser... So I made this choice and let the possibility to disabled shorcuts on Edit menu... I don't sure it's the right choice, I wait feedback and will try to polish the shorcuts controls...


change the way that shortcuts works on the 0.2.1 version

Good job! it's working on mac now, thx :)



(WINDOWS 7 Pro x64) If you use the select tool, then you want to use the rectangle (or ellipse) tool it always draw dashed line and I can't figure out how to restore (program restart helps) you can even change the width of the dashed line which is very nice! but no option to get back to normal rectangle.

Also shortcuts seems very aggressive, I cannot even write comment here, because it swallows my U,E,I letters and the spaces


funny bug, thanks for report.

And yes, I have to change the way I implement shortcuts...

Hi, I would asking you, how I can change the theme? Unfortunatelly the transparency function doesn't work.



Right-click on the desktop then Personalize

Or Control Panel -> Apparence and Personalization -> Change the theme

Hi, nice tool!

On my Mac using, it steals the keys, when open. For instance, the space key is trapped.

The fill-tool fills the whole image, when clicked in the transparent area.



Hi and thanks!

bug 1: I'm working on rethink the shortcut implementation, the next build should fix it.

bug 2: I don't understand the second bugs? If your image is fully transparent, this is normal, if not, was it a completely close shape and it fill an other transparent area? or is it fill even allready draw area? Is there any error.log file in the app folder?


Bug2: Hm. Tried it a second time, just before answering. It works. So, please ignore this :-)



Ok, if it happens again, tell what the last tool you used before fill, maybe it's part of the problem...


It is possible I am doing something wrong, of course, but the window is never transparent here.

I am using Windows 7 (64 bit). I do have Visual Studio installed, so theoretically, it might be referencing debug runtime DLLs, but that seems unlikely. The video card is Intel 4 Series Express, which may be incompatible with the GLES library you are using, but I do not have enough to test that. It is not throwing an error, it believes it is running correctly and does not generate an error.log file.

Thank you for the cool idea, appreciate any help you might have in getting it to run here.

- d



If you don't show any bug report, the simple solution I think, and i hope that's the good one, is to change your theme (Control Panel -> Apparence and Personalization -> Change the theme) and don't choose a classic theme.

If it is not working, search if there is an error.log near the .exe.

If there is nothing, problem may be on nwjs. So we had to understand what do that, and let an issue on their github...


This is an awesome project. But Iam currently using Yosemie . Could you outline the steps that I must take to make it work on Mac ?

Thanks in Advance :D


Hi, I just posted a short tutorial here:

Hi, [Windows 7 x64]

  • Sometimes the undo function doesn't work until the program is restarted. This occurred once after I used the selection tool and accidentally right clicked and the selected image got stuck, I tried pressing CTRL+Z but it unfortunately did not work anymore.
  • After using it for a while (and minimizing twice if that helps), the transparency slider couldn't be click+dragged, but it worked if I clicked anywhere on the bar, if I did a click+drag, it gets stuck.
  • Sometimes the transparency slider and some windows are not responding (loading cursor) but the other windows work just fine.

Hi, thanks for report, try to correct the first two for the next version.

For the third, I don't show loading on non-responsive part (so you understand you can always move or resize window during a waiting part), but maybe it's a bad idea...

(1 edit)

Hi, I've been having some troubles with the tool. My main SO is windows 8.1, when I first started the tool the quick guide worked fine, but since then everytime I start it it shows the windows in white and just doesn't start. I tried using it in windows 7 in a virtual machine. There it starts without problem but the transparency doesn't work. I tried changing the theme but it didn't work either. I've triying everything this pass days, I'm despeared to use this great tool but I don't know what else to do. In the error file that it creates in windows 8 it says that it cannot charge the setting.json and when i try to force close it, it says that njws stopped working. Hope you can help. Please don't stop developing this tool, It has great possibilities.


Hi, that windows 8 bug is really annoying, I'm sorry, I have to investigate more on it...

Maybe if you want to help, you can download this version: that opens a console at start and send me ( dunin(at) ) what's this console show when the bug arrives...

Sure, I'll help you out. I think this tool has great possibilities. It would be my pleasure to help you as a tester. I'll pass to you the bugs and errors I encounter. I have tried it in windows 8 and 7 but I can try it in other OS's (except 10 because I can configure it right in the virtual box). Hope the tool grows in popularity ;)


Hi, I did some tests with a VM, the bug is really strange, I have to investigate more but for the moment I do a little fix that works (I hope) but the risk is to lose the saved swatches...

(1 edit)

Hi, i don't know if i'm doing something wrong, but my canvas size is always white, and i can't see what's behind it. I use the x32 version in my windows 7.

Help please



Did you try to change your theme?

Classic themes disable transparent windows...

Oh yeah! Works

Great job!

Hi! I love this program, but I cannot open any of my saved files! I get the same "cannot load so and so" error log no matter how i link the file. I'm just hoping the animation is not lost! Thanks!


Hi, sorry for that strange bug, I have to investigate...

But normally if you could save, animations aren't lost (check if save files aren't empty, you can open it with a text editor)

What are your configuration and the version you use? Did you use a sandbox?

And just to be sure I understand well: can you tell me exactly when you get the error, after browsing and choosing a file I guess?

Hi, Thank you for the quick reply! I had been using 0.3 on mac, placing the nwj in it's folder and it worked fine. I spent a few hours making an animation at 128x128. I Saved as, and exited. (no export as i wanted to finish later) Coming back the next day I have not been able to open recent, or open the file by searching for it. I'll click the file and nothing will happen, but I'll get an error log like this,

failed to load chrome-extension://dnlcphfbppfamdbgagjjeakmghplikll/Users/mstoneking1/Documents/baikin.ptop

or any path I place the saved ptop file in. I was able to open the file i animated in text edit and it definitely still has content!

Any help would be appreciated!


(Also, i must note that all versions of Ptop have ran on my mac, so I went to the older ones and they could not open the file as well. Perhaps my setup for saving is incorrect?)


Hi, I did a bug fix (v 0.3.1) that corrects this bug (test on OSX 10.10.5, but must work for all).

That's not the full support of mac spec (I want to set menu on the mac way and bundle an app...) but it is usable with nw.js, and you would be able to open your .ptop files!


I finished the mac port!


I see, I really have to look at mac specific aspects.

I will look at this asap.

Ok, thank you! I will donate money if it is resolved!

Please disable shortcuts when hexadecimal textbox is on focus.

Developer (2 edits)

Hi, thank for reporting, it's fixed on the new build.

rather weird, on Win 7 32- bit, the canvas is rather weird, most of the time, when i try to click on it, it just clicks on what's behind it, sometimes I can only click on a section of the canvas, it almost never works, Any suggestions?


Wow, really weird, I can't reproduce it. But sorry for the bug, I will try to fix it...

Can you give-me more precision:

  • if you open the Quick Guide (in the "?" section), do you see John Steed?
  • Is the bug already effective at open or is it a thing that arrived after you move the window or resize it? 
  • Can you send-me a screenshot with an indication of the area where canvas work and where it doesn't?

Hey ugh... I know this will sound really weird but sorry for the late reply ... ((IKR))
But for some reason, my new version of windows (which is exactly the same as before) fixed the problem, again, mega sorry for the 140 days gap lol, have a nice day/night sir

Hi, Colour palette suddenly started not loading properly (was fine to begin with). seems to only load half the palette and certian ares (mosty the right hand side) dont allow me to move the mouse, making impossible to select cerian colours or save any. have tried unistalling and reinstalling. 


Uh, strange. Maybe it's the file settings.json (that keeps the swatches) that's corrupted...

You can try to delete it (after send it to me (dunin(at) so I can debug the program). The location of the file depends on the OS and whether you use the itch application.

For example, on windows, it is C:\Users\yourUserName\AppData\Local\Paint Of Persia\User Data\Default\settings.json

Deleting settings.json did nothing. I completely wiped Paint of Persia including everything in Appdata and then re-installed it and that seemed to fix the problem for a bit, but then it started again. It seems that everytime i run the application the Colour palette gets smaller. after opening the application about 15 times the colour palette becomes unusable.

was it setting.json file that you wanted me to send?



setting.json was an idea, but if its deletion doesn't change anything, it's not that.

I suppose the bug happens even with a new project?

Which version do you use? I'm going to try a quick fix but I'm not sure that that solves the problem...

Making a new project doesnt make the bug worse, but closing the application and reopening does. I tried running and closing the application multiple times and the bug seems to effect all of the windows except scenario and the canvas (pic below).  im using


Hi, here is an attempt to fix it:

Can you try it and tell me if it solves the problem for the palette window or for all windows or for none?

If none, you can try to press f12 with the focus on the main window (the one with the menus) and see if there are any error messages in the console....

Yep that fixed the problem with all the windows

Thanks for the help :)



When I try to run this, it starts running and the window shows up in my taskbar, but none of the windows appear. If I mouse over the ptop.exe icon in the taskbar, the little window preview shows the file, edit, view menu, but that window is nowhere to be found. What's strange is that this worked fine an hour ago and yesterday, but all of a sudden it isn't working. I've tried downloading it again and downloading and running the 32 bit version with no luck.

Debug.log looks like this:

[0226/] range at 0x73ef35cc00000000, size 0x248 fully unreadable
[0226/] range at 0x73ef35ec00000000, size 0x248 fully unreadable
[0226/] range at 0x0, size 0x248 fully unreadable
[0226/] range at 0x1bd1277400000000, size 0x213 fully unreadable
[0226/] range at 0x1bd1279400000000, size 0x213 fully unreadable
[0226/] range at 0x0, size 0x213 fully unreadable

I'm running it on the latest version of windows 10.



I can't investigate for now, but you can try to delete the local folder (for windows: C:\Users\yourUserName\AppData\Local\Paint Of Persia\ ) and relaunch the program.

BUT save yours files before and C:\Users\yourUserName\AppData\Local\Paint Of Persia\User Data\Default\settings.json if you have palettes or anything you want to keep in program settings (replace the file after relaunch).

That fixed it! Not sure what the issue was, but as long as it works, that's all that matters for now. I don't really need color swatches so I can just delete that folder if it stops working again.



I drew something easy to try this out  (and the app as whole works perfectly) but for some reason I get an error when I try to export. I'm extremely dumb so it may just be me making a mistake, if that's the case then I'm really sorry for bothering you. I'm using the windows x64 version.

This is the debug.log

[0721/] range at 0x7f4819c600000000, size 0x82 fully unreadable
[0721/] range at 0x7f4819e600000000, size 0x82 fully unreadable
[0721/] range at 0x0, size 0x82 fully unreadable
[0721/] range at 0xb9ec19c600000000, size 0x86 fully unreadable
[0721/] range at 0xb9ec19e600000000, size 0x86 fully unreadable
[0721/] range at 0x0, size 0x86 fully unreadable



Your path seems weird.

The name box must be filled in with just the name of the files (pp). The path goes into the folder box.