Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Neofeud

Cyberpunk Adventure / Visual Novel · By silverspook

Report Bugs Here Sticky

A topic by silverspook created May 26, 2018 Views: 563 Replies: 24
Viewing posts 1 to 7
Developer

Thanks!

after talking with this red haired girl and trying to convice her I am not a policeman,

Error: DoDialog: all options have been turned off

appears and game crashes

Any chance you'll fix the incompatibility with the itch client? 

Developer(+1)

Hi there! Sorry if you had trouble running with the itch client.

I just did a test and it appears Neofeud will run in the Itch client, but you need to install the "Alternate Download" version of Neofeud when you are prompted to install. This is for running Neofeud on Windows.

Are you attempting to run Neofeud on Linux or Mac? If so I may have to investigate getting Neofeud to work for Mac/Linux properly on the new Itch Client.

If you're having another issue or error attempting to run Neofeud, let me know and I'll do my best!

Thanks for getting Neofeud!

-Chris

Do you mean "Neofeud Version 1.1 (alternate download)"? I disregarded that at first because it seems like 1.3 is the latest version of the game and the alternate download was just an optional old version. Oh and yes, I am using Windows.

I'll give the alternate download a try and report back. Does this mean it's not actually an old version?

Cheers for the help.

Just an update, the alternate download worked! I'm just curious if it really is a couple of versions behind or not.

Cheers!

Developer

As I recall, the 1.3 version has a couple of bug and typo fixes but no major changes. I would say that if you have no issues with playing Neofeud version 1.1, you should just stick with that build.

I hadn't realized the new Itch app wouldn't run version 1.3, but I'll look into figuring out what went wrong when I get a chance, thanks.

I noticed the itch client is complaining that the server isn't compatible with it, so I tried downloading from the site and I think I've figured out why  1.1 works and 1.3 doesn't. It seems you've hosted 1.3 on Google Drive and when I click the link it doesn't start a download, but rather takes me to a Google Drive page with a download button. 1.1 downloads directly and I think this is the reason it works fine. If you can rehost 1.3 in the way you've hosted 1.1 I think it should probably work.

Did you get a chance to look at it yet? I suspect it's a pretty easy fix, the problem seems to be the fact that the latest version is hosted on Google drive and Google likes to put a page inbetween the link and the actual download. If you hosted using the same method as the previous versions it should fix the problem.

Developer

Ok, I've added a file "Neofeud - Itch Client Version" that should work in the Itch Client. Maybe give it a try?

(1 edit)

No luck I'm afraid, still "This title is hosted on an incompatible third-party website.".

EDIT: Ok, this is kind of odd. Checking it out through the website, the "Itch client version" is still hosted on google drive and says it was uploaded around 2 years ago. The version entitled "Neofeud version 1.3" which was hosted on google drive before now says it was updated 2 days ago and is no longer hosted on google drive. Weirdly though, that version doesn't show up in the client, like maybe there's a flag set to stop it from appearing as an option on the client?

Is it possible that you got mixed up and the old non-working version 1.3 got renamed to "itch client version" and the new fixed one got named "version 1.3"? Given that one was modified 2 days ago and the other one was 2 years ago it seems like that's what might have happened. Assuming there are flags that say whether it's visible in the itch client or not, you probably just have to swap the flags.

Developer

Hm, there's no flag to hide in the Itch Client. I tried switching the files around and adjusting a few settings.  Try checking to see if the Itch Client Version works in client now?

That did the trick, thanks!

Hi,

Sorry to bug you again, but I've just discovered that the "Itch Client Version" is still 1.1 rather than 1.3. Any chance you could update it? 

Cheers,

SPf

Developer

In Itch the "Neofeud - Itch Client Version" launcher option is version 1.3 even though it doesn't say a version.

Hello, just finished the game, it was lovely.

As for the bugs/oversights (v. 1.3): first, in the throne room near the end of the game there's some objects in the bottom right corner, including Proto-J and a control panel, that probably shouldn't be here (when you use the panel, Karl actually goes to the panel on the left of the throne). Nothing game-breaking, but a bit untidy.
Second, in the credits it doesn't say who did the voice for the black woman in the slums that asks you to steal the electric power. Or did I miss it?

Thanks for the game, it may be a bit naive, but also makes you think about current situation in the world and whether it can be solved without magical all-powerful device.

I have a weird situation at Goertzel's lab: picked up the empty vial, used it on the painting, but the vial is still empty. However, when I try to get more blood it says 
"I don't need anymore of that blood" or something like that.

Developer

Hm, ok thanks for reporting and sorry about that!  

The vial of blood is added and often goes to page 2 of the inventory, if you haven't yet checked there.

If you still have issues here is a walkthrough of the entire game: https://www.youtube.com/watch?v=aJz-YbBpRi8&t=4859s

No worries :-) I'm aware of the walkthrough, but I'd rather not use it, as I'm reasonably sure I know what to do. You're probably right about page 2 of the inventory I'll check again. Thanks!

(+1)

Just reporting back that this was not a bug, but a result of me being a doofus. All good.

Crash on mac in social services call

Developer

Sorry about that, and thanks for reporting! Will look into it.

Just finished the game on steam, love it. In the past version of goertzel's lab you still have the option to exit the lab from the present lab, which will place you into the coastlandia capitol an crash the game.

Developer

Thanks for the kind feedback on Neofeud and playing the game! Also, thanks for reporting the bug!