Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Nina Aquila: Legal Eagle, Chapter II: "Broken Wings"

Fight for justice in Chapter II of this anime-themed graphic adventure game! · By Tanuki-sama Studios

Please report issues here! Sticky

A topic by Tanuki-sama Studios created Aug 22, 2019 Views: 399 Replies: 29
Viewing posts 1 to 9
Developer (3 edits)

If you encounter any issues, please post them below. If this thread is closed, that means a new version is out, so please download the new version and check out the sticky for that version.

Known issues

  • The evidence list is un-ordered - this should be fixed in a future build.
  • Screen flashes are numerous and make the game difficult to play for those who are photo-sensitive - we're going to look at adding a "turn off screen flashes" option; however, these often serve a structural purpose so this may not be possible. Investigation into this is ongoing.
  • Sequence break - On day 3, it's possible to get con passes too early, which can lead to you getting out of the world if you try to walk into the duel arena. This will be fixed in a future update. For now, the eventing is quite robust so if you walk back into the world, and just carry on to the safe room, you should be okay.
  • Ability to stand on a table in the cosplay area - This will be fixed in a future update.
  • Visual freezing bug - Occasionally the game will freeze; you can hear the game continue in the background, but the visuals have frozen. This is an intermittent bug which happens so rarely it's impossible to diagnose (we had one player experience it in the very first room of chapter I simply between two dialogue calls with nothing between). Keeping eyes open for an issue but the only solution we suggest is to save often; it's very unlikely to happen more than once in a playthrough.
  • Evidence bug - one of the testimonies on Day 2 could be resolved by presenting literally any piece of evidence (a debug flag was mistakenly set). This logic error has been fixed and will not be present in the next version.
  • Rope in courtroom is climbable - fixed in next version
  • Typos (fixed in next version):
    • "Do you even know what Marcus and Stella look like"
    • ... probably others :D I should be more studious with this

Hi! I just finished the game but it crashed around 3 times for me. Restarting the game fixed things until it would crash again after a while. 


Hi Mahout,

What kind of system are you on, and what did the crashes look like?

Were they the ones where you can hear the game going on in the background, but the visuals have frozen? If it is, can I say that you've been extraordinarily unlucky? In the 6 months of developing NALE 2, I've played hundreds of hours of it, and I've only seen that bug about 5 times in total.

Unfortunately that's an ongoing problem that I'm unable to fix. It seems to be a plugin issue, but it's intermittent - when it happens, it doesn't correspond to anything in the script. I've had it happen between two dialog boxes before, with nothing between them. People have asked about it on the MV forums but there has never been a concrete answer.

If I ever manage to hunt it down, I'll fix it, but it might be some time. Thanks for reporting it though, because any data I have to suggest how frequently it happens is useful!

Hi! I'm hoping it's just my system - I'm on a Windows PC (i7, 64 bit OS,  8GB Ram).  Basically what happened was that the game slowed down a bit, I think, similar to what you described but not for a long time, then it just closed.  I was a little wary about reporting it because it might just be my machine and compatibility issues.  But I messaged anyway just in case the info might help you.

I finished playing btw, and it was awesome. :)   


Thanks for the info, and it's great to hear you enjoyed it.

I've run into something that I think loosely matches what you described about Day 3; I've reached the Casino area, and talked to most of the people there, but attempting to walk down the back hallway leads to walking around in the black void surrounding the room. However, I'm pretty sure I got the con passes right when I was supposed to, on that same day. I'd be fine with using some kind of workaround if you could suggest one.


Hi, yeah, I can try to help you.

Can you explain what happened in the last cutscene before you observed the problem?

Have you visited the room with the safe?

I might not have a perfect memory. Basically, presented the attorney's ID to the event desk, got passes to go into the casino, made the guy get out of the way, and then I don't remember any significant cutscene upon entering the casino. I was able to talk to each of the people in the casino, and then went to the backmost area which has a hallway, but there was no trigger to enter a new area. Have not seen the room with a safe.

I may be able to retry the segment from an earlier save and give you some more detailed information, or hopefully get around the problem. Thanks for replying!

Okay, so I may have misunderstood. I think I remembered someone saying the safe room was at the back of the casino, so that's why I had been trying to get in there on day 3. On a reattempt, I spoke to the lobby receptionist and that triggered the cutscene with the safe room. Based on your description, I think I will be okay from here.


Thanks Katana314, just wanted to let you know that this will be fixed in the final version (I've already fixed it, but I'm holding some small fixes to push a bigger update, rather than lots of small updates).

Hi, sorry to disturb. I noticed you only released a windows version. I want to buy your game, but I only have a mac. Since you're using RPG maker, deploying the apple version is possible too right? Are you planning to do that? Thanks in advance.

Developer (1 edit)

Hi, no need to apologise! I want to have NALE on as many platforms as I can.

I would really like to release a Mac version, but unfortunately it's currently not possible. I develop on PC and don't own a Mac, and while you can deploy Mac builds from recent versions of RPG Maker MV on PC, if you do so, the user won't be able to save their game - you have to deploy via Mac to fix this:

Do you mind joining my discord? If you do, and message me, when I try and compile a Mac version in the future, I can get back to you. If you'll play through it and let me know if you have any problems, I'd be happy to give you the copy for free. The discord is here:

I intend to release a "final revision" of chapter 2 with a bunch of small bugfixes just before releasing chapter 3 later this year, and I may try to see if I can borrow a Mac machine from somewhere.

Oh I see, I see. I have created a few games via RPG Maker MV with Windows before, though my laptop lags A LOT, and when I deployed it with the Mac version, the save works just fine, but maybe your version is different, or it's different for PC... Anyway, I'll be happy to try out your game once it's released for Mac. I'll contact you via discord. 

Also, I've played the first NALE, and I just want to say that you did a really good job creating it! Tbh it's the best game utilising RPG maker I've played so far. You paced it out really well, and the plot and characters are interesting and hilarious. Keep up the good work! I'll be rooting for you!


Wow, thanks so much!

Hopefully we can produce a Mac version in the future.

Hello!  I love the game and I've already played Chapter 1.  What is the update on making it for Macs?  Is there anyway we can play it on our computers?  I'd love to know because I'd be very interested in playing the game!  It's a lot of fun, so thank so for also making it!


Hi, glad you loved Chapter 1 and thanks for reaching out! I've had a few Mac users get in touch, but because I really value that you guys cared enough to speak up, I want to give you a totally straight, honest answer.

Current status with the Mac version is "on hold", because I don't possess a Mac to develop, export and test on - Chapter 1 was weird in this regard because "it just worked first time"; it actually won't store your savegames on a Mac, but because C1 is only ~half an hour, that hasn't really been an issue.

Case 2 is orders of magnitude more complex in its implementation, so would require extensive testing and likely some bugfixing on a Mac machine (which is why I can't just ask someone else to export it; it'll require actual work from me to test and fix it up). I'm not certain that the Mode7 stuff will work, too, which might mean that on Mac, the game is slightly different.

However, when case 3 is finished, before releasing it, I want to release a "final" version of C2 which fixes all of the small bugs that players have reported, and will try and see if I can borrow a Mac from somewhere around that time, and maybe revisit this.

Sorry that this isn't the answer I know that you (and the other Mac players) would like; my desire would be to have NALE on every platform I can, for anyone who wants to play it - unfortunately that isn't always possible in the timescales I want.

Hello, I see that Mac is currently not supported for various understandable reasons, so I'm sure the answer is similar for linux support as well! Thank you Ethan for clearly putting so much effort into these games! I really enjoyed chapter 1. :)

What I'm wondering is if anyone who has more advanced troubleshooting abilities than me has figured out how to get it to run via Wine or some other method on ubuntu (20.04)? In case it helps others, I was able to handle the error below  by installing winbind (sudo apt install winbind): 

ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path.

However there are a couple others I will share here, in case anyone has any insight. Googling around didn't get me anywhere unfortunately, except to gather that this may be more broadly related to other RPG Maker games?


[8:9:0712/] WSALookupServiceBegin failed with: 8
[8:9:0712/] Lost UI shared context.
[97:128:0712/] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.
[84:85:0712/] ContextResult::kFatalFailure: fail_if_major_perf_caveat + swiftshader
[84:85:0712/] ContextResult::kFatalFailure: fail_if_major_perf_caveat + swiftshader

Thanks. <3

Developer (1 edit)

Thanks! All I can suggest is that you might want to pose this question on the official RPG Maker forums:

This sounds like the sort of question that I imagine someone has posed, at least I hope so.

If you get some concise instructions, then let me know - I can add them to the readme in an updated version.

(1 edit)

When you are meeting terry for the first time you can try to leave, which prompts you with "I should probably talk to Terry some more", but you can still leave the building. Working as intended?

I think I saw a word repeated twice in one of the casino's lobby dialogues on day 1 or 2. Can't remember who exactly but it would have been someone in the left part of the lobby, before the room with the three queues.

EDIT: Nevermind, I can't find it after replaying through the start of both the first and second days of the investigation. Maybe it was on the third?

In the final map (office surprise party) once the screen has zoomed-in the mouse click becomes misaligned : it selects the tile that woud have been there if the screen wasn't zoomed-in. For example if you click roughly 3 tiles away it selects the 4th tile away.


Argh! It is obvious that the panting sound effect we hear is a man's whereas it is supposed to be Nina's!

You could have made an effort to use a FEMALE panting sound effect, this is TERRIBLE to hear Nina panting like a man!


Thanks for the feedback; but I can assure you that the panting sound was recorded by a female voice actor.

Next time we look at refreshing assets, we'll consider revising it.

Was it the same voice actress who voiced Nina shouting "Hold it!" and "Objection!" in trials?


Admittedly no, it isn't the same person.

(1 edit) (-2)

Then it might be the reason why it sounds so off, because it isn't the same voice.

Not only that, after you answered it was a female voice, I focused more intently on it and I understood why this sound effect annoyed me so much, it is because it sounds forced, overacted, not natural at all, it has no credibility, I could picture the person forcing themselves to pant on a micro, I could not believe it genuinely expressed Nina's feelings.

Anyway, for the sake of consistency and quality, I think it would sound better if the same voice actress voices all sound effects for Nina instead of mixing sounds from different people, don't you think?


It absolutely would!

It'll go on the list of things to update when we do a refresh. Obviously we're limited in that by budget, but we can keep it in mind.


Glad that we agree. :-)

I mean, it isn't as if they voice all dialogues, they barely voice 2 words "Hold it!" and "Objection!", how much 2 words could cost?

Regarding Visual freezing bug: your statement that "it's very unlikely to happen more than once in a playthrough" seems a bit inaccurate.

I have been playing the game for two hours and it happened at least 10 times, I really have lost count.

It can happen at any time. Most frequently, the text box freezes and you can't continue a dialogue, you just need to start over.

Other times where it did occur: when beating Stella at the DFA battle, or just roaming around in the casino.

I am now saving the game at the end of each dialogue. I'll keep playing until the end because I really like everything about this game. I would have bought the Steam version too, but not with this sort of bugs.


Hey, we're really sorry to hear you're having this problem.

It took a lot of investigation, but we did actually manage to find the source of the problem, and it's related to how the game runs on certain hardware configurations.

We'd really like to make this up to you; could you contact us via email? Please message us at tanukisamastudios AT

Glad to report that the freezing bug has disappeared in the Steam version! Now I am playing without problems and enjoying the game very much!


That's great! It was really rare, but we did run into a few people who saw much more of it. We have to assume it's a hardware thing.

It was difficult to fix because it practically never happens on my development machine (like maybe once in ~10 playthroughs of the entire game).