Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Bug Reports Sticky

A topic by AR14 created Jun 30, 2016 Views: 4,151 Replies: 243
Viewing posts 41 to 74 of 74 · Previous page · First page

Looks like having more than one character file open, then saving one of them, leads to the software getting stuck. The loading icon plays normally, and it won't let me do anything.

Developer(+1)

Thanks for the info! We'll check it out and try to provide fixes ASAP.

Found that putting shorts over leggings results in this.

Developer(+1)

Hello! It looks like that is caused by tanktops instead of leggings. Tanktops are placed in a layer below other clothing (pants/t-shirts). To fix this problem, you can switch to the tucked variant of tanktops which are available. That being said, looks like we need to add tanktops that are placed in the same layer as t-shirts, so the untucked variant will properly show outside pants. Thank you for your information!

Ah, okay, my mistake. Thank you!

Heyo! Just encountered a weird one: For whatever reason, when I tried to export a PSD "without face," Mannequin was having none of it. It stayed on "0% exported" and just froze up. When I tried to force the program to close, though, I was able to export a full PSD after I got the "do you want to close without saving?" message (I told it no and the program was working fine again after that).

Developer

Thanks for the info, we'll check it out!

(1 edit)

Two things to report. (Current Pro Build)

First: I've found that searching for a particular item causes the window to shift its displayed content to the left. That leaves the left side cut off and the right side with a black space about one vertical scrollbar's width wide.

Second: the Raised and Upward Curve Eyebrow items share what appears to be the former item's graphic.

Developer(+1)

Hello! Thanks for your feedback. The search problem has been fixed in the current nightly build and will be there in the next stable build!

New one regarding Batch Export: I think exporting 144 images the second time onward takes longer than the first time. The only difference between all three batches is a change in pose. (First batch rendered with Akimbo pose, second batch with Crossed Arms pose, and Third (current) batch with Standby pose.)

Developer(+1)

Thanks for the info! We'll try to find out the underlying cause of this, and optimize the app accordingly.

With the Christmas DLC installed, itch sometimes opens that DLC folder instead of the actual application. Are there any plans to have a "/dlc" folder or the like to avoid this behavior?

Developer(+1)

Thanks for the info! Is this behavior happened when launching from itch.io desktop app? If yes, then we might need to consult this further with the itch.io team. We'll try to re-read their documentation first to see if there's something that we can do but has been missed.

That's right. There's a "mannequin" folder, and then a "mannequin 2" or "mannequin 3" folder depending on if anything else was installed, like the Nightly version or the DLC.

Discovered that the "Downward Slant (Neutral)" eyes are not affected by Eye Adjustments.

Altered values with Downward Slant eyes

Altered values with Downward Slant eyes
Same values, with Straight eyes
Same values, with Straight eyes
Developer(+1)

Is this from the stable build? If so, there's a high chance that the adjustment are not working for all face parts (not just the brow). A workaround to this problem is refreshing the preview canvas using the refresh button on the upper toolbar. This issue also has been fixed in the latest nightly build.

I believe so. I only have the stable build installed for now.


Turtleneck and V-neck Sweaters are glitching with flat-collar shirt.

Developer(+1)

We'll check it out for the v-neck part, but for turtleneck the solution should be removing the shirt as the shirt part is covered completely. Thanks again for your feedback!

(2 edits) (+1)

odd bug with some extra lines

You see the extra lines this show up in final render too and on any pose.


I don't think I'm doing anything wrong here

After mores testing this exist with all poses beside the default pose.

also just on the female models

(1 edit)

Found a really nasty incompatibility occurence. This character looks just fine as a PNG and SVG...


But when I try to open the exported SVG file with Affinity Designer (my current vector-graphic software), I get this:


I have no idea why this happens. The exported SVG file has everything, judging by both looking at the Layer window in Designer and viewing the SVG in a web browser (both Internet Explorer and Microsoft Edge). So this is a puzzling occurence (not to mention rather scary).

Developer (1 edit) (+1)

Yeah, that's unfortunately not something that we can fix. Various apps read SVG files differently from each other, so we can only maintain compatibility with Illustrator, Inkscape, and web browsers. Even with those two 'pro' apps (Inkscape and Illustrator), we have to tailor the output file to maintain the best output possible while accommodating each apps' quirks when reading SVGs.

Edit: We won't say that Affinity Design compatibility is out of the picture forever, it's just that now we haven't investigated the quirks of the app enough to find out what workarounds that we can use to make our SVG files imported correctly.

Thanks.

I am on a mac and when I open the app and attempt to create a new file or "open this sample" it says "Error opening file: Template file not found".

Developer(+2)

For the time being Mac users have to use the itch.io desktop app to install and run Mannequin. Sorry for the inconvenience!

whenever i open a menu (hairstyle menu for example) the menu won't load and basicly soft locks the software. i'm using the latest stable build and tried running both the zip file and the itch.io client. i'm using a windows 10 laptop with 6 gb of ram and a i3 processor

Developer

Hello. Sorry for this problem. Is this happening when opening an existing character file or happening every time (such as when creating a new character from the welcome page)?.

it's happening every-time

Developer

That's very strange indeed. We tried to reproduce this behavior in our test systems, but everything seems to be fine. Maybe you can try cleaning Mannequin's user preferences?

To do this, open C:\Users\[yourusername]\AppData\Roaming\Mannequin and then delete both user-preferences.json and user-preferences-dev.json (if this file also exists).

Let us know more if there's further problems.

Hi, I was able to use Mannequin perfectly fine until I saw there was an update. The actual app seems to open, but the window is completely blank.

I'm on windows, although I'm not sure what type...

Developer(+1)

Hello! We're really sorry for this problem. You can try reinstalling the app via the itch.io desktop app:


First, open Mannequin in your Library, and click the gear icon on the bottom right.


Then click the 'Manage' button of the version that you want to re-install.


Click the 'Re-install' button.

To make sure that your current app config is also good and not causing the crash/freeze, you can try deleting it by opening 'C:\Users\[your user name]\AppData\Roaming\Mannequin' and deleting the 'user-preferences.json' file.

Yay, it worked! Thank you!

(+1)

So im runing windows 10 x64 and after i've saved a character and reopend it to edit it, when i try to change something it just does this, 

as far as specs go i've got a gtx 960, 16 gb of ram, and amd Athlon X4 850k quad core CPU.

Developer(+1)

Hello. Sorry for this trouble! If you don't mind, would you be able to send the character file to our e-mail: hello@ar14.works ? It will help us analyze the cause faster to provide a fix. Thank you for your feedback and cooperation!

(+1)

Hello! I'm guessing this is how you're layering things, but I'm finding that the "untucked tank top" still ends up tucked in with most pants/skirts and such.

Developer(+1)

Yes, that's just how the layering works with the template structure. We're currently planning to add another template for tanktops that will be displayed over skirts and pants soon in the next update. Thanks for the feedback!

(+1)

Hello, thanks for your amazing software ! I have found three bugs. (I am using the last pro version with windows 10)

  • Missing arms when using the sailor uniform with long sleeves (see my picture)
  • The star necklace doesn't really look like a star (the girl in the picture is wearing it)
  • With some outfit parts like the knotted sailor uniform scarf, I need to restart the software to see the color changes
Developer

Hello. We're sorry for this problem. Thank you very much for informing it! We'll check it out to find the underlying problem and fix it ASAP.

(3 edits)


Got a bug report.  I'm running Ubuntu 18.04.4 and tried to run the demo free version.  However, there wasn't any .sh file to run so after looking up some posts I saw that you're supposed to run the "Mannequin" file.  It is listed as Exacute as program in the properties.  Alright, so I tried to execute it.  It came up with an error, "Could not display "mannequin"  There is no application installed for "shared library files." Do you want to search for an application to open this file?"  

Any suggestions on what's wrong?


About 20 minutes later:

After reading on the Itch.io app, which I didn't know even existed until now, in this community I tried using the app.  I was able to download the app and run it fine, so I tried downloading Mannequin through the app.  I remembered reading something about it being the preferred method of installing and running.  So, after installing it, wouldn't you know it ran just fine?  I'm a Linux only user now, I've ditched Windows for good, so apparently it will only run through the Itch.io app and not on it's own apart from the app??  Anyway, I really like it and plan to buy it once it's on sale on steam.  Happy it works because this is something that I really needed.  Wow just look at those colors of the demo girl would you?  LoL

Developer

Hello! Sorry for the confusion and glad that it cleared up for you. Just as an additional info, here is our reply to previous question regarding running on Linux: https://itch.io/t/692620/linux-help-mannequin

Using the itch.io desktop app is always the preferred way, though, since there is no self-updater built into Mannequin and we rely on itch.io platform (and Steam, when the corresponding version releases there) for managing updates.

Wonderful character there! Hopefully you'll find our 'Advanced' color option useful too; it will surely add more flexibility to match your entire game / artwork color style!

Do some outfits only have two colors being used in "Advanced Coloring"?

A lot of the new outfits are pretty flat looking as far as their shading, so I was trying to tweak the shadows and highlights to see if that couldn't help that a bit, and I noticed that the highlight just...doesn't seem to exist anywhere on this outfit- possibly for others as well?



Going through some other outfits to test it out, and it does seem like there either isn't a highlight color at all or the ability to change it isn't working for whatever reason. 

Developer

Yes, that is the current condition for most of the available clothing templates. We're currently working on adding highlight colors to all available clothing templates right now, which should be usable in the next big update.

Hi, I'm completely in love with your program, really great job! The only thing is I think I'm probably doing something wrong, as every time I export it as a png, the character image gets a little blurred on the edges. Any idea what it might be? And I remember seeing something about DLC's, but I can't seem to find it on itch.io. Would you tell me where to find it? Thanks for this amazing program!!

Developer

Hello! We're not sure about what kind of blur on the edges that you've mentioned. We've tested PNG export in the latest build and everything is as sharp as it's intended to be. Most of the strokes are designed to have a gradient color so this might be what's troubling you? If you wanted a more defined outer strokes, you can try the 'Outline' feature in the 'Art Style' sidebar.

As for the DLC, the only DLC available DLC for now is the Christmas Collection Test DLC (which is added just for initial testing on the DLC functionality, so the content is very sparse). It is available for download via the store page or from the itch.io desktop app. Please note that DLC and custom-made contents overall are only available for Pro users.

Hope this helps!

Thanks a lot, I figured it out and the characters are now exporting perfectly! I'll definitely check the DLC out! Again, very nice job with this software, can't wait to see what improvments will come next, and looking forward to see new DLCs with new options! 

I'm having trouble generating an All Layers PSD with the Windows Pro version when sprites have multiple different versions of each expression, outfit, or whatever. Whatever I do, whatever I click, the program hangs during PSD export and never finishes. It usually freezes at around 11-15% and never goes past it (I've even left it running all night, and my computer is not slow or weak). The sprites are never being exported at larger than 200%, and it freezes even at 100%.

Here's what I have tried:

  • Loading a default sprite (with only one face, hair, and clothing layer) and exporting All Layers or Without Face: Works fine.
  • Loading a sprite with multiple face, hair, and clothing layers and exporting All Layers or Without Face: Freezes, never finishes.
  • Loading a sprite with multiple face and clothing layers, but only one hair layer and exporting All Layers or Without Face: Freezes, never finishes.
  • Loading a sprite with multiple face layers and exporting Face Only: Freezes, never finishes.
  • Loading a sprite with multiple clothing layers and exporting Clothing Only: Works, but all the PSDs it generates are completely blank.

So I tried to isolate the problem by testing different combinations:

  • Create a new sprite and add a facial expression, exporting All Layers (1 layer): Works fine.
  • Same as before but add 9 facial expressions, exporting All Layers (10 total variants): Works fine.
  • Same as above but also add a second outfit variant, exporting All Layers (20 total variants): Works fine.
  • Same as above but add 9 outfit variants, exporting All Layers (100 total variants): Works fine.

This confused me as it apparently had nothing to do with the total number of layers, so I went and compared the difference between default sprites and the sprites I was using. Default sprites have Stroke On, Outline Off, and Backlight On. My sprites, by contrast, were Stroke On, Outline OnBacklight Off. On a whim, I turned Outline off and tried exporting my sprites to PSD, and now it works.

The tl;dr appears to be that exporting to PSD with Outline enabled causes some kind of hang in the process and it will never finish the first PSD. Doing a PNG batch export works with Outline on, but the PSD export does not seem to like that setting.

Developer

Thank you very much for your detailed description of the bug! With this kind of explanation is definitely easier for us to find out and fix the underlying problem. We'll look it up and provide a fix as soon as possible.

Noticed a visual bug with this shirt's color overlapping onto the pants below.

Similar issues, might be the same issue:


Shirt bleeds over into the pants. Seems to be an issue with this particular tucked shirt.


Dress Pants have an issue where there's a graphical glitch at the waist that seems to take the pant color. Doesn't always appear until the sprite is exported. I've tested it with other combinations of outfit items and it doesn't seem to matter though what other items are selected does matter to whether it displays in-engine.
Developer(+1)

Thank you for the info! This should already be fixed in the latest nightly build, but we're re-checking these items for a bit more assurance.

Speaking of the nightly, I found something there that doesn't seem to be happening in the official:


Necktie going through the Vest. Wasn't happening before.

Developer

Thanks for the report! We've fixed it and the next nightly builds will reflect the change.

Just found that these eyebrows and eyebrow shadows are misaligned. Not entirely sure how that happened, either.

Developer(+1)

Thanks for the info! We'll check it out ASAP.

(1 edit)

Hello!

I decided to try your free Lite version for review, and faced the endless loading of the library window (Clothes, poses, etc.)
The first launch was good but the second and subsequent ones disappoint me :|

(The screenshot was taken in a new file)


System: Windows 10 64-bit

CPU: i7-6700

RAM: 16gb

GPU: Nvidia GTX 745

What could be the reason for this behavior of the program?
Reinstallation does not help.

Developer

Hello! We're really sorry for your inconvenience, and thank you very much for the report! We'll check it out to find the possible cause and try to give solutions ASAP. Just for confirmation: based on your description above we understand that the app works fine for the first time, but has troubles after closing it and opening again at a later time, correct?

Yes

And here's what I noticed in such a situation, the application has to be closed through the Task Manager, because it completely stops responding.

If there are mistakes in the spelling of the English language, then this is the Google Russian to English translator.

Developer

Thanks for the confirmation! You can try to clear the configuration folder before launching the app again. To do this, delete the 'Mannequin' folder inside C:\Users\[yourusername]\AppData\Roaming

Let us know if this doesn't help. Thank you for your patience.

1. Deleted the folder you said.

2. Launching Mannequin via Itch.
3. I create a new file, everything works, the window is loaded.
4. Restart Mannequin.
5. I create a new file, everything works again, the window is loaded.
6. Save the character's test file.
7. Restart Mannequin.
8. I select a character file, and try to change the pose, clothes, etc. and again I get to the endless loading of the window.

It seems to me that this is a problem in the save files, when reading the file, an error may occur somewhere in the program code, check it.

I can give you a save file if you need it.

Developer

That would be very helpful! You can send your save file for further analysis by us via hello@ar14.works

Again, thank you very much for your cooperation!

(1 edit)

Some issues in the nightly. Certain gaze directions and poses will cause certain hairstyles (but not all of them) to have their front hair vanish, and looking rightward with some eye styles (at least the default, Flat, and Upward Slant) has a transparency problem. Doesn't happen with every hairstyle or every eye type. For instance, if I change the above hair from Bob (Blunt Bangs) to most other types of Bob, the front hair comes back, but it's missing for Bob (Side-parted Blunt Bangs, Ear Showing) as well.  The eye transparency thing is more commonplace; it seems to be happening for almost every non-Masculine eye style, specifically when looking directly right (up-right and down-right are fine and I've not seen any issues with looking left or up/down); it might not happen for one or two of the new iris types, but it will happen for the default type.

Finally, some of the Comedic eye effects are having strange issues. The expressions that are supposed to have white inside of shapes (Crying, Hearts, etc.) are for some reason not layering the white correctly, resulting in the skin color being visible beneath (was easily noticeable with a dark-skinned character but might go unnoticed on a light-skinned one). The "crying" layer for the Closed Crying expression also isn't showing, though the eye part is.

Developer

Thank you very much for the info! We're looking into it now. Will check it out for further details and provide fixes ASAP.

Hello! I'm having trouble using the PNG images I downloaded. I'm trying to upload it to Imgur but it won't work. And it won't show up in my folder!

Developer

Hello! We're sorry for this problem. What version of the app are you using and what OS are you running on? Does this also happen with a newly created character or just your specific character only?

(1 edit)

Having a similar issue to something I was having before: Wispy Bangs front hair will not appear for certain poses. The ones I noticed this time were Standby (Wide), also Arms Behind Back poses in general. Akimbo (Wide) also seems to fail to render one hand properly for certain clothing options (it works for long sleeves though, it seems), though it does get the bangs correct.

Seems like the front hair is having issues for various reasons, and sometimes isn't showing up under certain circumstances. The thing with eye gaze seems to have been fixed though in the latest nightly, so it's just finding new issues with different situations I guess.

EDIT: Had front hair vanish when I changed a character's shirt. Same pose with different outfits will or won't have front hair displayed. Not sure why, but it seems to be a thing.

Developer

Thank you very much for the info! We're currently still checking the issue regarding this problem with hair. As shown in your description, they appear a bit random so it is quite a bit difficult to pinpoint the underlying problem. We'll continue testing to find more about this problem.

On the latest version 0.3.11-lite.20201231 I have critical issues.

Export functionality is not working - the application just hangs after I click the big Export button on the export panel.  Also after any change done to characters, the application hangs in a similar way. Though this could be fixed by trying to close the application - it will show "Save changes" prompt and will hang no longer, so I can just cancel it and continue.

 These issues are present for both previous characters and newly created.

Developer

Thank you very much for the info, and sorry for your inconvenience. We'll look  into it and provide fixes ASAP.

Developer

Thank you again for the notice! The latest update to the lite version should fix this issue.

Just downloaded the newest version and it works like charm. And the performance is much better. Many thanks!

(2 edits)

Hello! I'm on the newest version of the software, and I've been having this issue with the comical eye set:


I've tried changing the backlight/skin glow settings, but none of that seems to put the eyes back in where they should be. Any suggestions?

AH also, I'd forgotten about this one, but while I'm here: when I try to open up old .mqn files, my characters get...well, beheaded?


Changing settings on the female body don't fix it, and when I try to change to the male to see if I can't change back (at least having some settings kept this way), it just pops the default male body out right from the start.

Perhaps even more bizarre, while I can't reattach her head, I CAN still change the settings on the body all I like! They just do, well, this:


For now I'm opting to remake the characters from scratch, but as far as bugs go it's pretty wild.

Developer(+1)

Hello! We're not sure why this is happened. If possible, can you send the problematic file to us (via hello@ar14.works) so we can investigate further for the cause?

(1 edit)

Is it expected behavior that the windows version (lite,stable and nightly) is not signed at all (at least when downloading it via website) so Windows Defender Smart Screen is complaining? :/. I only found the signing issue related to mac gatekeeper... 

Developer

Hello! Yes, that is the expected behavior at the moment. We don't mention it for Windows because SmartScreen warnings can be dismissed quite easily but bypassing Gatekeeper requires a more involved steps. However, we're working on steps to sign both the Windows and Mac versions to fix this problem.

Nightly build: seems to get stuck during PNG export (below) and closing character file tabs.

Developer

Hello! Thank you for your information and sorry for your inconvenience. Is this happening with a specific file only or happening with every character file (for example, creating a new character and then immediately exporting)? If it's happening with a specific file, then it will be really helpful to us if you can send a sample file via e-mail to hello@ar14.works

Issue: Endless refresh for item windows
Description: While in "Hair" or "Clothing" (I suspect it is all tabs), refreshing items shows endless spinner.

Version: 0.3.13-Stable20210601 (Latest, not nightly) from Steam
Medium: Latest Windows 10 x64

How to reproduce:

  • Open the editor and either make new character or open existing one.
  • Navigate to "Clothing tab" (for testing I have removed all clothing items to eliminate any possibility of a broken specific item)
  • Click "Add New"
  • In "Library Selection", click the arrow on the right of "Default Library" and select "Show All"
  • Click "Refresh" button

Tool shows the "loading" circle, never recovers and can't be closed through normal means. Process has to be terminated through TaskManager.

I've left it alone to check and got tired after 15 minutes. I've checked "Clothing" and "Hair" tabs with and without inventory, and would assume the same refresh issue is true to all tabs.

I have also checked with my Antivirus, just in case, since the paranoid thing often blocks "file access" requests, and there is nothing.

P.S. I plan to play with the tool a bunch and would love to turn in "ideas" and "bugs" through a better means then in a thread here. Is there a discord or an email I could use for faster and more precise communication? I am well familiar with developing software and QnA process. :)

Developer

Thank you for your information! This issue should have been fixed in the latest nightly builds, but we'll double check to make sure.

(1 edit)

Issue: Can not close item-list windows
Description: Close "X" button in the top-right of item windows does not work (Cancel works)

Version: 0.3.13-Stable20210601 (Latest, not nightly) from Steam
Medium: Latest Windows 10 x64

How to reproduce:

  • Open any item-list windows either by editing or adding a new item to the doll
  • Try to dismiss the window by clicking "x" in the top-right of the pop-up window
  • Notice it does not work

Note: Clicking "Cancel" closes the window

Correction: The issue is with "Add New" button, it seems. I was able to use "x" in an "Edit" action.

Developer

Thank you for your information! This issue should have been fixed in the latest nightly builds, but we'll double check to make sure.

Viewing posts 41 to 74 of 74 · Previous page · First page