🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Zelda 2 - The Adventure of Link

A topic by twitchyeye created 270 days ago Views: 2,656 Replies: 14
Viewing posts 1 to 6
(Edited 1 time) (+1)

I've started a rough looking setup for this game, here. Maybe someone can pick up and share progress.

(Edited 3 times) (+2)

For some reason I couldn't get your .3dn working so I made my own.

EDIT: I worked some more on the .3dn.

EDIT2: I worked on the .3dn just a little more.

Newest Link (10/18/16)

(Remember to rename the download to the name of the .nes file)

Old Link

Oldest Link

Screenshot Album

Let me know if you recommend any changes.

Looks good so far. The first village is a mess for me. Is it that way for you too? I'm assuming it's just an emulator issue, but I hope it's not my PC!

Hmm. The village looks fine on my end. Maybe I kept a bunch of the tiles at an "undefined" layer on accident.

No. This is majorly messed up. Scrambled character sprites and weird looking backgrounds. The text comes through fine though.

There are other games that do that for me as well. I just assumed it was like that for everyone.

It's just beautiful especially with the multi z-layers effect. I wonder if you can record a clip to showcase it?

(+1)

I recorded about 2 hours of gameplay and trimmed it down to about 10 minutes.

Video

This is super cool. I'm speechless. Without z-offset support, that's how z-scale should be used !!!!!!!!

Is it finished yet?

Unfortunately I don't think I'm skilled enough at Zelda II to get all the way through the game.

To be honest, I can't even beat the game with saving progress and a friend to help.

I might be able to set aside some time this week to reach beyond where I left off last time but I don't think I could ever reach the end in one run.

I've run into a bit of a problem. I cannot separate the background and the walls/floor of the second palace.

This means that Link must exist either in front of both the background and the ground he stands on, or behind both. Neither is pleasing.

I wish I had screen shots to demonstrate the problem, but I (stupidly) forgot to take them and I'm not ready to spend ~2 hours to get back to that point (for now, at least).

Look at this picture from the original. Now imagine that the background was (instead of bricks) a bunch of chains whose width scales the entire z-axis (from behind the red blocks to in front of Link).

This is strange because the first palace does about the same thing but can be separated just fine.

Is this a bug with 3DNes or some unfortunate effect of the way Zelda II was programmed?

https://itch.io/t/35441/dont-understand-how-it-gro...

Hey Poodledeedoop,

I'm guessing that your problem with the 2nd Palace is somewhat like the problems that I posted images of in the thread above. I have images for other games in other threads, but I think they're in the 3DN threads, so I didn't dig them up.

I don't think it's a bug with 3DNes or it can really be blamed on the way Zelda II was programmed. I think that this is just because 3DNes is still growing and these issues are just challenges that geod is working to overcome in future versions.


A few of us have already suggested the ability to select a group image and spit it up and manually re-group and re-shape it. We have not heard back from geod if this will be possible yet, but this would eliminate this issue if the user had more control to fine tune these things.

I wouldn't play the game again just to get a screenshot until save states are implemented. It wouldn't take a ton of time for you to get back there now that you've done a ton of the 3DN work, but it's not worth it just to make an image IMO. You'd have to do it again when the savestates were included.


I tried using the newest version of 3DNes to see if the second palace looks any better. Unfortunately this was not the case.

This time, however, I brought screenshots.

Album

I also have a save-state file if anyone wants to explore the glitch.

Could you send me the save state pls.

Thank you.

Here you go:

Zelda II Second Palace Save State