Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

BEACON

Sci-fi Action Roguelite. Collect DNA from enemies and mutate yourself to victory! 路 By monothetic

Need Help? How to Report Issues Sticky

A topic by monothetic created Apr 28, 2018 Views: 1,685 Replies: 73
Viewing posts 1 to 29
Developer (3 edits)

As an early-access game Beacon is bound to have a few bugs or other issues. You can help us help you by providing a descriptive report about any bugs or odd things you might encounter by following this simple template:

  • Let us know what kind of issue is this:
    • Bug: general things like "I fell off and my weapon no longer works"
    • Crash: the game crashed -- bummer
    • Other: general fluff like "this box is floating", or "there's a typo here". We know about pretty much every sorting-issue too, so don't worry about reporting that.
  • Your PC specs: OS, GPU, RAM, etc.
  • A screenshot or video or gif of the problem. It's not required, but it always helps!


You can also drop-by our Discord server and use the #bug-reporting channel here:

https://discord.gg/9FJrXXq

Developer unlocked this topic
(+1)

Hello, I can't edit my keybindings. I tried to modify the left movement and now it dissapeared and I have like 4 times move right binded to the same key.

Is there a way I can reset the keybindings somewhere?

Even in an ini file?

Regards

Developer(+1)

Hi there! I believe we found a makeshift solution on Discord for the time being (but posting here for posterity!)

You can delete the input file to reset the controls, located here:
C:\Users\%USER\AppData\LocalLow\Monothetic\Beacon\settings_input.xml

We'll look into fixing the key bindings menu as soon as we can!

Thanks

(1 edit)

Bug - Changing resolution in the options menu makes the mouse cursor vanish.

Once this has happened, the player can hit Enter to start a new game or hit Esc to close the game and return to Desktop.


Bug - Changing resolution to 1920 x 1200 makes the Controls options unreadable.

See attached screenshot.


My specs probably don't affect these, do they?

Developer

Hey! Thanks for bringing this to our attention & sorry you're having these issues!
We'll look into it as soon as we can!

(+1)

Crash - On starting the game for the first time it crashed just after displaying the Unity 5 splash screen.

  • Upon attempting to start the game a second time, it made it to the main menu, displaying it at minimal resolution, I switched the resolution to something higher, mouse dissapeared so I restart the game. Every subsequent start of the game failed, with the program crashing after displaying the Unity 5 splash screen.
  • I noted that the AppData/LocalLow/Monothetic/Beacon directory only had a Unity folder and ./Unity/{local.hexadecimal}/Analytics had two files 'config' and 'values' which were both 0 bytes in size. @Aseaton in the Discord suggested that I might find a log file in the same directory as the executable but it had not been written.
  • I managed to get the game working by using Window 10's comparability mode. Could reach the menu, set a screen resolution. Could start a new game. Could move around. Appears to run correctly.
  • Trying to narrow down which of those setting was critical was unsuccessful, as even with no compatibility settings the game started up. This may suggest its part of some Unity 5 initialization overhead? Or that it doesn't like my integrated GPU? Or that it doesn't like the 4K monitor of my iMac?

Settings

Windows 10 Version 10.0.16299 Build 16299

Intel i5 5675R

8GB RAM

Intel Iris Pro 6200


Windows 10 Home 64-bit

GeForce GTX 1070

16.0GB RAM

Intel Core i7 6700 @ 3.40GHz

The game crashed at boss fight on level 3, then "crash.dmp", "error.log" and "output_log.txt" has been created. How do I send it? The files are too long to post here.

Developer

Hi there! Please email it to mcorsaro@monothetic.com thanks! 

We will definitely look into it :)

Hi I'm getting crash on load, co can't play at all.

Error log - 

Unity Player [version: Unity 5.6.5p1_b5fcd78dd1ab]

Beacon.exe caused an Access Violation (0xc0000005)
  in module Beacon.exe at 0033:f5d829a0.

Error occurred at 2018-05-13_212630.
C:\Users\dahan\AppData\Roaming\itch\apps\BEACON\Beacon\Beacon.exe, run by itch-player-5af83b28.
36% memory in use.
16301 MB physical memory [10389 MB free].
19245 MB paging file [11875 MB free].
134217728 MB user address space [134213342 MB free].
Read from location 00000000 caused an access violation.

Context:
RDI:    0x03327190  RSI: 0x00000000  RAX:   0x00000000
RBX:    0x00000000  RCX: 0x00000022  RDX:   0x03327198
RIP:    0xf5d829a0  RBP: 0x04848c50  SegCs: 0x00000033
EFlags: 0x00010206  RSP: 0x00eff800  SegSs: 0x0000002b
R8:    0x00000044  R9: 0x0000001d  R10:   0x0000000e
R11:    0x0403a438  R12: 0x00000001  R13:   0x00000000
R14:    0x00000000  R15: 0x00000000

Bytes at CS:EIP:
4c 8b 00 48 8b c8 48 8b d8 41 ff 90 58 07 00 00 

Stack:
0x00eff800: 00000000 00000000 00000000 00000000 ................
0x00eff810: 00000000 00000000 00000000 00000000 ................
0x00eff820: 03327190 00000000 f583a704 00007ff6 .q2.............
0x00eff830: 00000000 00000000 00000000 00000000 ................
0x00eff840: 04848c50 00000000 3159414c 00000000 P.......LAY1....
0x00eff850: 04848c50 00000000 f5843387 00007ff6 P........3......
0x00eff860: 03327190 00000000 000010de 000013c2 .q2.............
0x00eff870: 853f1043 000000a1 d7b71e3e 11cf5082 C.?.....>....P..
0x00eff880: 04848c50 00000000 f5843584 00007ff6 P........5......
0x00eff890: 00000000 00000000 00000000 00000000 ................
0x00eff8a0: 04848c50 00000000 00000000 00000000 P...............
0x00eff8b0: 00000001 00000000 f5843314 00007ff6 .........3......
0x00eff8c0: 04039c10 00000000 0401a140 00000000 ........@.......
0x00eff8d0: 001b0984 00000000 0000013a 00000000 ........:.......
0x00eff8e0: 0000013a 00007ff6 000000d3 00000000 :...............
0x00eff8f0: 00000000 00000000 f58abe00 00007ff6 ................
0x00eff900: 00000000 00000000 00000001 00000000 ................
0x00eff910: 00eff930 00000000 00eff930 00000000 0.......0.......
0x00eff920: 00000001 00000000 f589d2ce 00007ff6 ................
0x00eff930: 00000004 00000000 04039c10 00000000 ................
0x00eff940: 00000001 00000000 00000000 00000000 ................
0x00eff950: 00000001 00000000 00000001 00000000 ................
0x00eff960: 00000000 00000000 f58ac036 00007ff6 ........6.......
0x00eff970: 048471a0 00000000 00000000 00000000 .q..............
0x00eff980: 00000001 00000000 0000001d 00000000 ................
0x00eff990: 00800000 00000000 00000065 00007ff6 ........e.......
0x00eff9a0: 00000000 00000000 00000000 00000000 ................
0x00eff9b0: 00effa19 00000000 f5822c82 00007ff6 .........,......
0x00eff9c0: 00000000 00000000 00000001 00000000 ................
0x00eff9d0: 00000000 00000000 04823c70 00000000 ........p<......
0x00eff9e0: f691f1b0 00007ff6 f5f72c7e 00007ff6 ........~,......
0x00eff9f0: 00000000 00000000 f66cf938 00007ff6 ........8.l.....
0x00effa00: 00000000 00000000 63726f66 66672d65 ........force-gf
0x00effa10: 6f6a2d78 00007362 0000000e 00000000 x-jobs..........
0x00effa20: 00000042 00007ff6 00effa88 00000000 B...............
0x00effa30: 00000000 00000000 00000000 00000000 ................
0x00effa40: 00000000 00000000 f5a01a0a 00007ff6 ................
0x00effa50: 0000000a 00000000 00000000 00000000 ................
0x00effa60: 00000000 00000000 00000000 00000000 ................
0x00effa70: 00effb20 00000000 f5d8dadb 00007ff6  ...............
0x00effa80: f66cf938 00007ff6 00000000 00000000 8.l.............
0x00effa90: 00000000 00000000 0330b5e0 00000000 ..........0.....
0x00effaa0: 00000000 00000000 f5d8b77e 00007ff6 ........~.......
0x00effab0: 0000776f 00000000 0000000a 00000000 ow..............
0x00effac0: 00000042 00746c75 f55c2b3e 00007ff6 B...ult.>+\.....
0x00effad0: 00000050 0000002b f55ca010 00007ff6 P...+.....\.....
0x00effae0: 00000000 00000000 0000000a 00000000 ................
0x00effaf0: 00000000 00000000 00000000 00000000 ................
0x00effb00: 00000000 00000000 00000000 00000000 ................
0x00effb10: 00000000 00000000 0330b5e0 00000000 ..........0.....
0x00effb20: 00effc30 00000000 f55cf1ca 00007ff6 0.........\.....
0x00effb30: 00ca0000 00000000 00000140 00000000 ........@.......
0x00effb40: 000000f0 00000000 00000000 00000000 ................
0x00effb50: 00000000 00000000 f5635a48 00007ff6 ........HZc.....
0x00effb60: f661d390 00007ff6 f6620ae0 00007ff6 ..a.......b.....
0x00effb70: 00000000 00000000 ffebffff 00000000 ................
0x00effb80: 00effc0c 00000000 f65ec368 00007ff6 ........h.^.....
0x00effb90: 02fd3310 00000000 f5f227bd 00007ff6 .3.......'......
0x00effba0: 00000000 00000000 00637465 00646567 ........etc.ged.
0x00effbb0: f691ffe0 00007ff6 00000003 00000000 ................
0x00effbc0: 00000042 00000000 032f78f0 00000000 B........x/.....
0x00effbd0: 032f7940 00000000 032f7940 00000000 @y/.....@y/.....
0x00effbe0: 00000000 00000000 02fd33e0 00000000 .........3......
0x00effbf0: 02fd33e0 00000000 032f7800 00000000 .3.......x/.....
0x00effc00: 00000047 00000000 00000408 0000000d G...............
0x00effc10: 00000047 00000000 00000042 00007ff8 G.......B.......
0x00effc20: 02fd3450 00000000 02fd33e0 00000000 P4.......3......
0x00effc30: 032efa30 00000000 00000050 00000000 0.......P.......
0x00effc40: 00effcb0 00000000 00000050 00000000 ........P.......
0x00effc50: 00000042 00004b01 032f78a0 00000000 B....K...x/.....
0x00effc60: 00000042 00000000 f5f7b4b6 00007ff6 B...............
0x00effc70: 00000042 00000000 00000042 00000000 B.......B.......
0x00effc80: 032f78f0 00000000 0000004a 00000000 .x/.....J.......
0x00effc90: 00000004 00000000 0000004a 00000000 ........J.......
0x00effca0: 00000042 00000000 032efc70 00000000 B.......p.......
0x00effcb0: 00000051 00000000 f5f7327a 00007ff6 Q.......z2......
0x00effcc0: 00000051 00000000 00000042 00007ff6 Q.......B.......
0x00effcd0: 0000000f 00000000 00000000 00000000 ................
0x00effce0: 00000000 00000000 f5f7331e 00007ff6 .........3......
0x00effcf0: 00000022 00000000 032f7760 00000000 ".......`w/.....
0x00effd00: 0000004b 00000000 00000000 00000000 K...............
0x00effd10: 0000004b 00000000 00000042 00007ff6 K.......B.......
0x00effd20: f691ffe0 00007ff6 013f1e40 00000000 ........@.?.....
0x00effd30: 013f0840 00000000 f6620a01 00007ff6 @.?.......b.....
0x00effd40: 00000000 00000000 f5f8523a 00007ff6 ........:R......
0x00effd50: 00000000 00000000 00000000 00000000 ................
0x00effd60: 00000000 00000000 f5560000 00007ff6 ..........V.....
0x00effd70: 00000000 00000000 f5f76e6c 00007ff6 ........ln......
0x00effd80: 00000000 00000000 00000000 00000000 ................
0x00effd90: 00000000 00000000 00000000 00000000 ................
0x00effda0: 00000000 00000000 00000000 00000000 ................
0x00effdb0: 00000068 00000000 00f227fa 00000000 h........'......
0x00effdc0: 00f227da 00000000 00f22756 00000000 .'......V'......
0x00effdd0: 00000000 00000000 00000000 00000000 ................
0x00effde0: 00000000 00000000 00000000 00000100 ................
0x00effdf0: 00000000 00000000 00000000 00000000 ................
0x00effe00: 00000000 00000000 0000000c 00000000 ................
0x00effe10: 00000010 00000000 00000000 00000000 ................
0x00effe20: 00000000 00000000 9b203034 00007ff8 ........40 .....
0x00effe30: 00000000 00000000 00000000 00000000 ................
0x00effe40: 00000000 00000000 00000000 00000000 ................
0x00effe50: 00000000 00000000 9c9d1551 00007ff8 ........Q.......
0x00effe60: 00000000 00000000 00000000 00000000 ................
0x00effe70: 00000000 00000000 00000000 00000000 ................
0x00effe80: 00000000 00000000 9928b940 00007ff8 ........@.(.....
0x00effe90: 00efe990 00000000 00efe990 00000000 ................
0x00effea0: 00000000 00000000 00000000 00000000 ................
0x00effeb0: 00000000 00000000 00000000 00000000 ................
0x00effec0: 00000000 00000000 00000000 00000000 ................
0x00effed0: 00000000 00000000 00000000 00000000 ................
0x00effee0: 00000000 00000000 00000000 00000000 ................
0x00effef0: 00000000 00000000 00000000 00000000 ................
0x00efff00: 00000000 00000000 00000000 00000000 ................
0x00efff10: 00000000 00000000 00000000 00000000 ................
0x00efff20: 00000000 00000000 00000000 00000000 ................
0x00efff30: 00000000 00000000 00000000 00000000 ................
0x00efff40: 00000000 00000000 00000000 00000000 ................
0x00efff50: 00000000 00000000 00000000 00000000 ................
0x00efff60: 00000000 00000000 00000000 00000000 ................
0x00efff70: 00000000 00000000 00000000 00000000 ................
0x00efff80: 00000000 00000000 00000000 00000000 ................
0x00efff90: 00000000 00000000 00000000 00000000 ................
0x00efffa0: 00000000 00000000 00000000 00000000 ................
0x00efffb0: 00000000 00000000 00000000 00000000 ................
0x00efffc0: 00000000 00000000 00000000 00000000 ................
0x00efffd0: 00000000 00000000 00000000 00000000 ................
0x00efffe0: 00000000 00000000 00000000 00000000 ................
0x00effff0: 00000000 00000000 00000000 00000000 ................

== [end of error.log] ==

Any ideas?

Developer

If you're still having that crash, our best guess on how to fix it is to try updating your video drivers! We also just updated the game to 1.0.4A with some fixes so be sure to download that as well. 

yep that was it, thanks! Game looks nice. Good job. I'll download updated version. 

I cannot seem to change my resolution from the in-game menu, I click the resolution bar but nothing happens. it is locked at 4k. any suggestions? Can I change it in a file instead?

Developer

Hello! You should be able to change it via the Registry under:

"HKEY_CURRENT_USER\Software\Monothetic\Beacon\Screenmanager Resolution Height_h2627697771"

and

"HKEY_CURRENT_USER\Software\Monothetic\Beacon\Screenmanager Resolution Width_h182942802"

Make sure you hit the "Decimal" button and then enter the values you wish to use.

To make sure this doesn't happen in the future, can you let me know the following:

  • Which resolution you're trying to use
  • The native desktop (default) resolution of your monitor
(2 edits)

I have died 7 times and then did a Reset on my DNA Now i can NOT put any DNA into my Genome or the game soft locks.

I use Windows 10, GTX 970, i7-4790, 16gb RAM

Developer

We'll take a look at the issue! Seems like something with the Reset button broke your genome. If you start a New Game from the menu it should reset your genome and work correctly again. 

It did Thx.

(+1)

Bug?

When I open the game, my mouse stops working.

Specs: RTX 2070 i7 CPU

(+1)

Bug - Yeah, My mouse isn't working either on startup. I'm able to use WASD to control the pointer, but selecting pretty much anything in the menu prompts me with "New Clone Detected" (The tutorial, presumably), a dialogue box which is by all apearance, non-interactive. At this point it softlocks the game.

Developer

Sorry about that, we've heard a few cases recently of players having input issues with keyboard/mouse but they're very rare. We'll try to get it fixed in a future update but it's difficult to track down why it's happening when we can't replicate it ourselves. 

I'm afraid I also have this problem. I'm happy to provide any help or input, development / trace builds of the game or whatever. Running as admin, restarting computer, and disabling AV didn't resolve the problem for me. No noticeable events in the event viewer.

Specs, just in case it's important:

AMD Ryzen 5 2600 X 6-Core Processor 3.6 GHz

16 GB DDR4 RAM

NVIDIA GeForce RTX 2080

Windows 10 Pro 64-bit ver. 1909 OS build 18363.900

DirectX 12

Not sure what changed, but updating to the most current version fixed the issue.

Hi! I just downloaded beacon from the itch.io bundle, but I can't seem to get the game running. After extracting, I try to open the beacon exe, but I get a "Windows cannot access the specified device, path, or file. You may not the appropriate permissions to access the item". I then get "The parameter is incorrect." when I try to open it again. I've also tried running as admin, but it's the same. Other games I've downloaded from the bundle are working alright, so I'm wondering if there's something I need to do?

Developer

I think this is an issue we can fix but it might take a couple of days. I'll respond back when a new build is uploaded that should fix it! 

Developer

Before we try the fix requiring a new build to be uploaded, could you check your Antivirus settings if you're using one? You might need to set it to "trust" the Beacon folder. 

Thank you for such a quick response! You were right about the antivirus. I recently switched so I didn't realize it wasn't notifying me when it just went ahead and put files in quarantine! The game is launching fine now. Sorry for the hassle!

I crashed when I was trying to fight a bunch of critters at once. There were about 6 of the chilopodrae and some chilopods supporting them. I threw a bloated pod acid grenade at them all and the game stopped, and after a bit windows said the game wasn't responding. I tried to screenshot but it didn't take it?

It hadn't crashed but the game has had lag when there's a whole bunch of enemies at once and when it's got a lot of effects on the screen.

Specs:
OS: Windows 10 ver 1903
Processor: Intel core i7-4790 CPU @ 3.60 GHz
Ram: 16 GB
GPU: Radeon RX 560

Developer(+1)

Have you updated the game to Patch 2.61? There was an issue with the Bloated Gland acid projectile where it would reflect and duplicate infinitely off of those enemies that should be fixed now. 

Ah, yep, that fixed it! Thanks!

Yeah I had to give up 2 runs because on the 2nd to last level I ran into impossible to escape scenarios. The first time was while exploring, a jump pad sent me to a impossible to escape platform where I could only suicide to get out. The second time was a puzzle involving directing lasers, (which somehow damage you no matter how far away you are, another bug), which generated a impossible to solve solution. What I mean by this is that the nodes you use to direct the lasers are destructible, and generated in such a way as to make solving it impossible making my run useless.
This is disappointing as I was enjoying my time with the game, and was looking forward to finishing it. I can't even look up a playthrough to see how it would have ended, as so little content exists for the game on youtube for example.

Developer

Sorry about the issues with the beam puzzles. I double checked the Level 5 puzzles for the latest patch and they should all be solveable, some of them seem a bit too confusing for a lot of players to figure out though. We'll work on telegraphing the correct path of the beam better in an upcoming patch. I haven't heard of the beam damaging the player the way you described but we'll check into that too. 

Level 5 is the current end of the game so you didn't end up missing out on that much content. When we leave Early Access with Patch 3.0 Level 6 and the game endings will be added. 

(1 edit)

Bug

The Excavation Droid can get stuck while positioning over a pylon. It remains in this state indefinitely. It remains invulnerable to damage in this state, since it is not in the process of extracting a pylon.

It was not on-screen when it became stuck, so I'm not sure what lead up to the event. The erroneous state of the droid is not fixed by damage, closure of open pylons, or the player falling off the world.

This affects version 2.6 of the game (I believe the most recent build.)

Screencapture

Gif of the bug. And of me dying, womp womp.

(Related question - that stun lasted a good 8 seconds. Is that normal? Status effects seem to swing pretty wildly in how long they last for me, but my builds usually hover around 100 resistance.)

Specifications

OS: Microsoft WIndows 10 Pro, version 10.0.18363 Build 18363

System Model: ASUS ROG G703GX

CPU: Intel Core i7-8750H CPU @ 2.20GHz, 2208 Mhz, 6 Cores, 12 Logical Processors

Graphics Card: NVIDIA GeForce RTX 2080, Driver Version: 26.21.14.4575

Installed Memory: 16GB, at least 9GB available while game is running


Thanks! Let me know if I can elaborate on anything. Loving the game :)

Developer

That is unfortunate, you were about to kill it too. This seems to be a pretty rare bug but we'll take a look at it and try to fix it. Do you remember what ammo mods you had? I think your own shot exploding near the droid stunned you and stacked up, and that might have also been what caused the boss to freeze there. I would guess it was Sonic Ammo or Concussive Ammo. 

Patch 2.61 was released a couple of days ago as well but it shouldn't affect this bug. We added the first pass on a Minimap though that you might be interested in. 

(1 edit)

I don't remember the mods specifically, but want to say I had picked up Concussive by this point, so what you're saying makes sense. (Especially about the status effect stacking -- I want to say I get long-term stunned a lot fighting raptors, and that could be because they like to all pounce on me at the same time. I'll bear that in mind!)

I just got killed by radiation and I don't know what I could've done to remove the effect. Once I got it it just kept ticking for a very very very long time until I died. I tried rolling, jumping off the cliff. Didn't help. Also the first time I played I saw one of those purple grass barriers and rolled into it, I got trapped inside and had to restart.

Developer

The Radiation debuff is definitely a bit too punishing right now when applied to the player, there will be a tweak to it in the next update. The only way it can apply to you is if one of your own bullets with radiation is reflected back at you, so if you collect that ammo mod just try to be careful when firing at Holoshields or barriers for now. 

Also I'm not sure where you are describing with "purple grass barriers", my best guess is you meant the Solus quill areas with the purple sacks littered around. If one of the quill gates blocked you, usually there is a Quill Nest nearby that needs to be destroyed to open the gate. It's possible you rolled behind a loot gate though and it didn't lower to let you out after skipping it. If you get stuck again try to take a screenshot where it was and it will be easier for us to locate and fix it. 

This is a similar barrier: In this barrier I can walk through the red-lined areas and I can make it all the way to the bottom. I can't roll/dodge through the bottom because I get 1/2 the way through the collision area and then get pushed back up but on the barrier I encountered earlier I was able to roll through an upper-left part and was not able to roll back. I know I can make these barriers come down, and all I'm saying is that I rolled against one and it trapped me inside it.

Also I think I had no mods at the time since it was the first time I played.

Hello! I've been really loving this game, but recently I've been playing a level where you have to move the large prisms to reflect light around the area, and whenever the light hits the final piece, my game crashes. This has happened several times now and it's making me very sad because I can't really progress on the game otherwise :(

OS: Microsoft Windows 10 Home, Version 1903, Build 18362.900

Processor: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz

Installed Memory: 16 GB, 15.9 GB Usable

Developer

I haven't heard about that crash before, I will take a look and see if I can replicate it. If you're talking about the beam puzzles in Level 5, you are nearly at the end of the current build anyway. Once we leave Early Access with patch 3.0 later this year Level 6 will be added to progress to after the beam puzzle is completed. 

Alright, thanks for letting me know. I'm really excited to see what else you guys have in store, and I'm loving what you already have!

Seconding this, crashed when turning the crystals. i7-5820k and 16 gb ram as well. It was on the beam puzzle. I turned the bottom-left one after having fired the first one at it, when it matched to the top it then crashed.

(1 edit)

3 more things: I was able to make the fire pistol have infinite ammo somehow, the LMG will continue to have piercing all the way through a reload if you keep the button pressed down, and I also managed to gib myself on a lift lol. That last one may be intentional now that I mention it.


Edit: just noticed that filling grenades from the cache in the exterior of the robot factory (in pic) changed my grenade type from rotvine to frag.


(2 edits)

Some Items seem to have no option to pick them up when they are on a pedastal or somthing similar. Here is one example that i came across.  No matter what i tried I couldn't get the option to try and pick it up.

Edit: Found another bug. The mutaion that allows you to teleport instead of roll (while great and feels really fun) if done in the direction of a ramp telports you behind it and generally leads to falling into the abyss. If you teleport in the direction of a worl wall that you shouldn't be able to teleport through same effect. I had times were trying to avoid an enemy i tellport through a rock wall and take damage from falling off the map.


Developer

I will fix the items spawning in those loot areas not being pick-uppable, that item in your screenshot shouldn't have been dropped in that area. 

The Telemite Hooves causing you to fall when teleported into a wall is the currently intended behavior, but we're considering changes how it works when you teleport through a wall rather than a barrier or other secret area. 

I think this is a bug, but I'm not sure how to really classify it.


I'm playing with a gamepad because it allows for a more smooth range of movement, but when I went to change my controls I found that it is impossible to navigate through menus using a gamepad as there seems to be no input comparable to clicking the lmb in menus. The gameplay works fine, it just causes a slight annoyance when I have to switch to my mouse every time a menu comes up.

Developer

This is an issue some players are having with the input system in the game. We're completely replacing the input system in a patch coming out this week, hopefully that will fix the issue for you! 

I'm currently having the same issue, on the newest version (2.63) except all mouse input (motion and clicks) is disabled when a gamepad is plugged in. This has locked me into a couple of menus and kept me from starting a game because I couldn't answer whether I wanted to run the tutorial.

(Win 7 SP1 64 bit, GeForce GTX 750 Ti, driver version 451.48)

Developer

If I understand correctly, that is working as intended in 2.63. When a controller is plugged in, mouse and keyboard will be disabled and the controller will take complete priority. You can either toggle the Disable Gamepad option in Controls, or unplug the controller and it will give you control with mouse and keyboard. We will eventually make it so you can at least use the mouse to toggle options and disable the gamepad while a controller is plugged in, but for now if you don't unplug you need to navigate there with the controller to disable it while it's active. 

Serious bug: inputs are broken in 2.81 when the game is started with a DirectInput controller plugged in.

The controller may not be supported (fair enough) but that leads to a weird mix where the mouse controls the cursor's position, which can hover and highlight menu items but not click, and the controller button #1 controls the clicks. Controller axes do nothing and the mouse buttons do nothing.

I did navigate the options with that combination of mouse and controller and did not find an option to disable the controller.

Then I exited the options and the continue / codex entries were overlapping for me too.

It is very unusual for a game to completely disable its keyboard support, and I would strongly recommend against it.

Developer

Thanks for the report, I'm not sure if we've tested any directinput controllers recently but I remember we tried a couple when we recently changed our input API and it was working back then. We will test it out again soon and see if there's a bug with them.  Can you be more specific with what controller it was? 

The game should be automatically detecting if Keyboard/Mouse was your last input and switch to it, but maybe the controller was interfering with that. If the game is restarted with the controller disconnected Keyboard/Mouse should be fine. 

So, I found an equipment crate, and it opened while I was behind it, and now I guess the lid has trapped me under its collision model.. and I think I might just be stuck and have to restart :/

Developer

I think I've seen one other person mention this crate causing that, it should be fixed in the patch coming out this week! 

Hello! I noticed that after my character gained the mutation "Pyro Boltfeet" which "replaces dodge with flame dash" I was suddenly unable to dodge. Pressing space still drains my stamina as it normally would, but my character doesn't move.

Developer

I think this might be because of the new Input System in 2.62. We'll take a look at it and try to get a fix out for it soon! 

Found a brand new place to get stuck!!

pic

The little drone that picks you back up when you fall off apparently knows of some secret, collision-enabled floors back behind that puzzle. In general that entire section seems a little wonky, several times before that the drone would attempt to put me back on "normal" ground, but fail to let go and try to take me with it to its home in the sky. Dodge rolling made it let go, though.

So this may just be a compatability in process issue, but my primary game pad is an Xbox360 controller.  I use both a wired and wireless one and I have a number of odd minor issues I am not sure if their is any direct way to resolve.  The most obvious one is the twin sticks dont work properly, they both want to move the character, and even though they are set to different commands it doesn't seem to know what to do. Additionally the dodge roll occasionally brings up the menue for some reason, and the b button will bring up the onscreen keyboard.  Start also wont bring up the menu properly I actually have to use the escape key to do so.

I am not sure what the specific problems that are causing this but it does happen on 2 seperate computers so..i assume it might have more to do with compatability with the xbox game pad than actual software issues.  I dont know if their is a resolution, but I figured it would be useful for you to know.

So..I discovered what was causing this I think, but I still dont know why.  I in poking around killed steam and epic.  I think the steam compability modules were what was causing it though.

And now everything works fine.  So apparently when playing through the itch.io download it doesnt much like steam running.  


A wierd but interesting little glitch.

Developer

Steam does do some weird things with controllers, but I haven't heard of it being that aggressive before especially when you weren't even playing the game through Steam. We'll see if we can do something to fix it, but I'm not sure how much control we have over it. It may also be something that only happens with 360 controller. 

Yeah totally its a very odd bug I had never seen before.  When i figured it out i realized its probabaly a good bug for you to know about, even if you cant do anything immediately about it.

Howdy, it would seem that the game sort of expects the player to immediately jump in rather than access the options menu, on a fresh install after purchasing the game (more specifically after downloading it from a bundle), which causes the following visual bug:

Additionally, accessing the codex... I believe the term is soft-locks you, as it does not seem to respond to any keyboard commands or show any button to press to go back (go up a level in the menu list). Which can be seen here:

I apologize for the large images, as I do not see a way to edit the size in the itch.io app's access to this forum.
My PC specs are the following (At least according to Windows' "This PC" properties, if more information is needed, please let me know.):

Windows 10 (update KB4569751) x64
AMD Ryzen 3 1300X Quad Processor 3.5GHz
20GB of installed memory (RAM)

Developer(+1)

Thanks for the report! We are aware of the Continue overlap after opening the options for the first time, I haven't seen the Codex bug though. I'd guess it's because you haven't discovered anything since you didn't play yet and it caused an error opening it. We'll try to replicate it and fix it soon. 

Also, it turns out that using the Teleport mutation in the fifth level, turn on the holo shield, and try to start spraying with the chain gun... The game might freeze.

(2 edits)

Hello! 

I have been playing your game when I purchased the Racial Justice bundle last year and I absolutely love it. I have been looking forward to the final level and the ending of the game until I heard of your patch 2.91A. I finished beating the boss in level 6, the Prism Mainframe, and I am later prompted to press the 'Spacebar' to view the ending but it did not work after pressing it and the music was still playing.

Tech Specs of my laptop:

OS: Windows 10 Home, 64-bit system

OS Build: 19042.746

Processor: Intel(R) Core(TM) i3-7100U CPU @ 2.40GHz   2.40 GHz (7th Generation)

Installed RAM: 8.00 GB

I am sort of new to computer gaming here but turns out it still plays well with an i3 processor even though the minimum requirement is an i5 processor which I found out later 馃槄

Thank you for your help 馃槉

Developer

Thanks for the report! I haven't heard of anyone else having issues proceeding through the ending but we'll try to replicate the bug and fix it if possible. Were you playing on a controller or a keyboard? 

Also I'm surprised the game runs decent on a laptop but it is good that we have optimized the game enough where it does! The minimum specs are probably outdated but they are also just a suggestion. 

Thank you for your reply!

I was playing on a keyboard for movement, handling weapons, etc. and a mouse to aim, shoot, reload and dodge.

Yes, I am grateful that I am able to enjoy the game on my not-so-fancy laptop 馃槀

If you wish to know more, I will gladly help. 

Have a good day/night 馃憤馃憤

Developer

If you are using a mouse to dodge I'm guessing you rebound it from Space to your mouse? That should be allowed, but I think that is why it wasn't working for the ending. I would try whatever key you rebound, and we will make sure that it works with space either way in one of the future updates. 

(1 edit)

To be specific, I use the click wheel to dodge and spacebar for melee.

I will do a swap today and update you over here if it works or not.

Thank you for the reply once again! 馃槉馃憤

Update 1: The Excavation Droid is pretty hard to beat and Freja died twice. I will keep you updated about the level 6 spacebar situation

Another bug spotted!

I tried to use the elevator to go down but I suddenly fell and lost 10 HP and I respawned behind the wall only to keep falling.

This sometimes happens when I try to find some equipment marked on the map and it happened before in Level 5- Panoptican Core.

Hope this info helps.

Thank you for your help 馃槉馃憤

Developer

The elevator allowing you to fall through is a glitch that happens usually when FPS is low I think. I haven't been able to replicate it myself but we've tried a few things to fix it before, obviously it isn't 100% fixed though if you're still getting it. We can try something to perhaps fix it for 2.92, if you fall through ideally it should at least reset you back near the elevator. 

We also have fixed the ending screen not working when being rebound for 2.92. Once the patch is released, space should always work as well as whatever you have rebound Dodge to. 

Regarding the elevator issue, it is going well since it is not a frequent thing in the game. About the low FPS, it could be that but it rarely happens.

Thank you for all your help and improving the game! I shall wait eagerly for patch 2.92 馃槉馃憤

(1 edit)

Hello, I've downloaded the update and have noticed that with a holoshield drove my attacks aren't following my cursor but are all directed at the holoshield drone. It happens with both the riot shotgun and the roadrunner. Here's a list of the mods I've got. Is there one that has resulted in this happening?


Developer

The holoshield is definitely bugged in the last few builds and is what's causing the issue, we'll try to have it fixed for the 2.93 patch coming out soon! 

(3 edits)

CORRECTION: I just saw that the message above me reported this too, so it's a known bug and being worked on. Sorry for the double post. Additional information if that helps:

Plasma Pistol, Riot Shotgun, Sonic Rifle (sorry I don't know the exact name, I'm new to the game still) all get drawn to the shield. BUT the Laser Engine works fine. 

My equipment is the following:



Specs:

System: Windows 10, 64bit

GPU: GeForce GTX 1060 6GB

CPU: Intel Core i5-3450 @3.10GHz

Memory: 16GB DDR 3


Bug:

Upon picking up the Holo Shield Drone, whenever it's shield is active, my character will shoot in the direction the drone is facing, no matter in which direction I aim. As soon as the shield is broken, my shots behave normally again.

Developer

Yeah we've seen the Holoshield bug a few times now. I thought it might have gotten fixed in 2.93 but unfortunately now it has to wait for 3.0 to be fixed. If you run into the item again in the current patch I'd just skip it. As far as I know every other item in the game is working correctly! 

I see, that's a fair choice :D The game is an absolute blast, so I'd also say gitting gud as a starter is better than relying on the holoshield drone anyway. 

Thanks for the rapid reply! <3