🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Known bugs Sticky

A topic by Rad Codex created 94 days ago Views: 473 Replies: 40
Viewing posts 1 to 24
Developer (Edited 10 times) (+1)

Thought I'd compile a list of bugs that I've diagnosed so far! Anyone experiencing these bugs, don't worry, fixes for them are coming next patch.

EDIT (6/11/17): updated list for bugs that remain in v1.03 and will be (hopefully) fixed in v1.04!

KNOWN BUGS:

  • Exiting a boat at a certain angle can leave the boat 2 tiles out from the shore, stranding you unless you have Ice magic
  • Critical Destroy seems to trigger even when you get KO'd


There are also some bugs that I have heard of but cannot yet replicate. If you experience these, or have any info about them, sharing it here would be greatly appreciated. : )

MYSTERY BUGS??:

  • A variety of resolution-based bugs that I need to investigate & replicate
  • Music fails to load on occasion for one of my testers (seems completely random)
  • Crash on placing certain items in certain places in the smithing area

I ran into a lighting bug in the fourth region. I was controlling a character using the Voidlight passive as my light source and another party member was equipped with a Laser Greatsword. Whenever I was in a pitch-black room the light source would alternate between that of my Voidlight and the much weaker light of the Laser Greatsword as I moved around, leaving me with nothing but the faint glow from the laser about 50% of the time. This occurred during the run in which I first encountered the giant eye monster so I have no clue if that had something to do with it, but I haven't been able to replicate this issue on future runs and I don't remember any other information.

(Edited 1 time)

If you stuff a Mask inside a bag and get back to town,the Mask will remain in the bag instead of showing up on the post exploration screen and Training ground.

I noticed the mask thing and it also applies to gems, blacksmith patterns, and anything else which is otherwise automatically removed upon going back to town. I also had a key from the fourth area disappear on me when I had it in my inventory upon going back to town, but I was able to keep it a second time around by putting it in a bag. I have no idea if it's meant to disappear or not.

(Edited 1 time)

I've had a bug where the walls and background will disappear from a room, although placed objects remain. This seems to apply to a room, even if I leave that room and come back. For instance, I had it happen to the town map, so that I could only see the buildings on a green grass background.


Also, the game seems to sometimes set its resolution to 800x600 then immediately crash when I try to alt-tab out while it's in fullscreen mode.

(Edited 2 times)

I don't think Humans are getting the 10% exp bonus. 

Developer

Thanks for the bug reports!  They've been very helpful.

I can confirm and have fixes coming for the missing XP bonus and items not being found inside bags.

I have a hunch about the Voidlight bug, will try it out.

The walls and background disappearing sounds pretty crazy. And I am not sure why the game would crash at low resolution... I'll have to investigate. Thanks for bringing it to my attention. If anyone else encounters the same bugs let me know.

For what it's worth, I started a new game, and I haven't had the disappearing walls bug again.


Also, to clarify, it's not that the game crashes when I set it to a low resolution-- rather, it tries to adjust the resolution on its own for some reason, and crashes at the same time. I wouldn't have even known about the resolution change if my monitor didn't have a box that appears whenever the resolution changes. (And if it weren't the fact that the resolution change persists when I start the game back up.)

The game seems to instantly crash if you kill a "Milane" enemy.

Developer

Thanks for the extra info Muspel. Is the resolution-changing still happening? If so, is there a typical time when it self-changes the resolution, or does it just seem completely random?

Regarding the enemy - "Milane" is a randomly generated nickname that can be applied to a number of different monsters. Can you describe the creature's appearance?

(Edited 2 times)

I downloaded 1.0.1, and the resolution change + crash is still happening. It only ever happens if I have the game in fullscreen mode, and I attempt to alt-tab out, at which point the game crashes (and when I open it back up, the resolution is set to 800x600). This happens 100% of the time, so I just started using windowed mode instead.

RE Milane: Hmm... I don't remember what it looked like off the top of my head. I encountered it in the first area, and I think it was some kind of worm thing, but I'm not 100% sure of that. I do remember that using "Look" didn't give me any kind of journal info, so perhaps it's existence is a bug and it didn't have various attributes properly set?

Spoiler: Just reached the red heart in the Apex but i can't interact with it in any way.

Had to go back to town.

Developer

Did you try to hit it with a weapon?

(Edited 1 time)

I first attacked it from a distance with a Gate Keeper spell: The spell fired but no damage was dealt and it didn't start the battle either.

I then tried to "Look"/Attack with a melee weapon/Checked for weaknesses...

Hope it helps, will get back to it and try to just get closer in case their is a specific trigger i messed up with the GK spell.

This time around it went fine, walked to it and used a close range melee...

I've been getting a bunch of crashes and now my autosaves are totally corrupted. guess I gotta head back and finish level 5 again, bleh. So it seems like the crashes are related to the inventory somehow in town. When I pick up an item and put it over it's slot in the inventory, sometimes it'll say can't place that item here. And if I do, I'm guess it knows it can but also thinks it cannot, has an aneurysm and then the game dies. If I wait a moment and it goes away it seems fine, but I don't think about it sometimes and down goes the game. It's the first time it's corrupted the autosaves though. At least I still have my actual save, even if I have to finish that mess again.

Had the same type of crash while moving stuff around in my inventories while being on the "sell screen" in the forge.

Developer

Dang, that sounds awful! I'm really sorry its corrupting saves. : (

My only guess is I did something wrong when I implemented equipment augments (inventory in Voidspire never had this kind of issue). I will perform some checks on selling augmented items. If you can remember what items you were moving when it crashed (was it an augmented piece of equipment?) then that could help me track it down.

In my case it was an augmented mythril flail i believe.

(Edited 3 times)

I've actually never augmented anything yet. I should probably mess around with it at some point but I've not figured it out yet. As for the game, let's see if I can get it to do it again. Okay, so I'm not sure what kicks it off exactly but this time it happened when in the barracks I moved one char out of my party and brought in another to take the Dark Mantle from their inventory. I put it into the stash. I closed the inventory, and put the characters back as they were. I opened inventory and the stash again, and then tried to put the dark mantle on the character, in the slot they had a hip flask already, and the game crashed. Doing it again, the same thing happened.

Oh and I have a bug where sometimes abilities disappear from my tool bar or clone themselves multiple times onto it. Removing the class and putting it back sometimes fixes it, but not always and I can't really do that in a fight. The good news is I can use moves from the character screen, but it is rather annoying.


I wonder if it;s trying to augment items with items not designed for augmentation and that is causing it? Its still happening after the new update though. It went off again when I made a shield out of the shellworm plate then tried to put it in a slot with a shield in it. I think instead of swapping items in your hands, it;s trying to augment them with non augments and crashing,

(Edited 2 times)

Im pretty sure the defiler ability sacrafice isnt boosting my mages power when blinded.Also the focus stone dosen't have the tooltip that lets you see that you can put it on weapons and armor.Also i killed the middle training dummy.

Developer

Thanks for the reports. Sacrifice should kick in on the mage's turn if you are Blinded/Silenced. Let me know if it doesn't happen like that for you.

Good catch on the Focus Stone.

What weapon or ability did you use to kill the training dummy?

(Edited 1 time)

I had used level one shroud on the mage outside battle trying to boost that first hit it does work once battle is going.And it was awhile ago on the training dummy and i just cant remember.

Developer

I figured out a cause of at least 1 kind of item bug. If a container is in the Stash - either bags or augmented equipment - then the game will crash on loading that save. : (

I'll get the next patch out ASAP. Until then, avoid putting bags or augmented equipment in the stash.

I've had a bag in the stash since day one so that's awkward haha. I thought there was still permadeath so I wanted to save it until I had a strong enough character to keep alive, then forgot it was there. Back out it goes!

Developer

If it's an empty bag then you're ok. : )
I shoulda specified that only containers with items in them cause a crash.

(Edited 1 time)

Welp thats a new one. I just had a character stop existing. I think because they swapped places with a Zoogbat that was despawning, so they both despawned. So that's fun. And it corrupted my autosaves to boot.

Developer

Uhh... oops. Yeah, I just checked... bats can delete your party members if they despawn while you walk through them... woops. That's going to the top of the priority list for fixes...!

Were the corrupted autosaves created after your party member was deleted?

No, they were from before. I'm not sure why. I can load a normal save from prior but it's pretty far back.

My save files keep getting corrupted (this would be the fourth time I've had to start over) and it seems to be happening at random moments. the game crashes then reloading the save files (including auto saves) makes the game crash again before loading. Since I can't pinpoint, what makes this happen, are there any files I could send you (like the save files) to help out?

Developer (Edited 1 time)

Sorry about that! That bug is fixed in v1.03, which is currently available on Steam. I was meaning to get it onto itch.io after a short test period, but I've been bad about that, and got sidetracked working on some other features...
: (

I'll try to get v1.03 onto itch.io ASAP for you.

Thanks for the reply. Cool, I forgot that we where getting steam keys, though I'd rather play it DRM free anyways. Glad you got that fixed. Is there any way I could scavenge the save files? (I was 10 hours in on that last one). Anyways, I'll play the latest one and let you know if I find anything.

Cheers.

Developer

Just got the patch out. As long as you didn't delete the files, they should load just fine in v1.03. : )

(Edited 1 time)

I tested it and it works! You have saved my save files, you are my hero.

(Edited 2 times)

So the new patch fixed my crash. I go walk into the next area from my fixed auto save. And well... I took a picture. Kinda a crappy picture but can see the problem I imagine. http://imgur.com/a/eXOJu Fortunatly abandoning the run seems to have worked around it, but figured you should know.

Also still crashing the game when I put an item on another item in the blacksmith's. This time a web whip on top of an empty bottle from my stash.

(Edited 1 time)

Does anyone still have that bug where when you try teaching new skills to party members obtained from the barracks, the new skills dont show up on the 'skill hotbar'?  

I ran into a bug today on the current Steam version (1.0.4) which I think might be caused by the beta controller support. Keyboard commands refused to work unless I pressed the key at least twice in a row. I disconnected my controller and the problem immediately went away; I didn't need to restart the game or anything. If it helps, I'm running Windows 10 and my controller is a DS3 which I'm using via a program called Scarlet Crush.

Developer

@Zilrax: when you put the item atop the other item, and it crashes, are you doing that specifically on top of the anvil?

@Parsley: I can't seem to replicate that issue. Is it happening to you?

@Seeric: Interesting- were you using the gamepad to play at the time, or did it just happen to be plugged in?

Thanks for the bug reports everyone!

I don't believe I was. Let's see... No, it was the forge not the anvil. I tested it. Here's what I did. First, I dropped a scarf on it, no crash. Next, I built a new web whip, put that on it. Nothing. deforged piece of iron, put it on it. Nothing. Picked up a web whip, clicked it on the forge then on a bottle. Crash. 

Wasn't sure what did it so went to recreate it. Took awhile but I'm certain now. The crash happens when you attempt to click while the text cannot use this item there is up and then an item is place on top of another item. This seems to usually happen if you try to put an item that can't be deconstructed in the forge, but I've had the text pop up at other times when moving items around.

My controller just happened to be plugged in and I hadn't touched it at all while playing (other than to disconnect it). I like using the mouse to move around and the keyboard for commands.

Does the ai think that preserve is a negative spell?  I saw an enemy cast preserve on his ally then another enemy use a wind spell to knock the target away as if to save him from a damaging spell.  This was in 1.03 in case the changes to preserve might have fixed this.