Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Bug Reports Sticky

A topic by lum created Jan 06, 2020 Views: 819 Replies: 22
Viewing posts 1 to 6
Developer

Hey all!

Here's a thread for people to leave any bugs they find. 

Please keep in mind I am a solo game dev, doing this in my spare time. As a result I can sometimes be slow to address bugs, but I will try my absolute best to fix any bugs players run into.

Whelp, the only recurring glitch in the full game I encountered is that enemies in both phases of the game have a continuous habit of getting stuck on the lightpost outside of The Only Bar. Each time I return it seems their pathing left them chipping into it eternally. 

Outside of that, great time. Glad this one turned out as good as the last.

Developer

Thanks for the info and the kind words! I'll add that to my bug list!

I encountered a glitch where if you put a bear trap in this specific hallway you can essentially infinitely lure enemies in to it to instantly kill them because the bear trap never shuts.

Developer(+1)

thanks for the bug report! I'll get on that as soon as I can

Developer(+1)

Hey! Just wanted you to know that I uploaded a patch for the game that should fix this bug. 

Thanks again! 

I saw! That was pretty fast too, thank you. 

HP regen seems to... not work? I'm talking about the buyable bonus that's supposed to regenenerate up to 25% of your HP.  Just not doing anything.

Developer

Thanks for bringing this to my attention! I'm taking a look at it now!

Developer(+1)

I uploaded a new build with a fix! 

It now "works", but only up to 25 HP, rather than the claimed 25 "percent" (my max is currently 200)... Was it changed, or is it still an issue?


By the way, is there ever a reason not to run? I feel like running should be default, and shift should be "walking"; holding shift 24/7 is giving me cramps...

Developer

ah, the percent is a typo. 

As for the running/walking question: running does make it easier for enemies to detect you. I'm sorry you're getting cramps from that! I'll try to add a toggle option in the next week or so. 

I... legitimately never noticed that! I guess it's because of how much importance I put into keeping a "safe" distance from enemies; if I get closer than the distance I'm used to, slowly at that, it only means they would easily be able to get at "hugging distance" if they detect me.

It did, after all, take me a really long time to notice that "hiding" worked on every enemy (which, I must add, made the game WAY more interesting once I started using it); I spent a long portion of the game thinking hiding was only used to hide from the facey-mc-face thingies. The first time I tried it against a "physical" enemy, I came to the conclusion that it didn't work on them when I saw that they were still headed towards the dumpster...

By the way, another thing I noticed: I have really no idea what triggers this, but from times to times, using C to look around no longer slows down time. On my first playthrough, this happened very rarely, and I think, if I recall correctly, was only happening on a look-around per look-around basis? (i.e. it would happen once, then you'd look around again, and time would be slowed down as normal again?)

I'm on a new playthrough on the "madness" difficulty (though it could be caused by v1.0.3 instead?), and this time, it's happening way more frequently, and once it happens, it stays like this for the rest of the session (until I go back to the main menu). You can easily detect this by holding shift before looking around, and looking at the speed at which your character tippy-taps.

It's... not actually something that's "that" bad... sometimes, you want to wait for things to happen at a distance (like enemies moving out of the way). Maybe use "shift" as a way to control whether or not time is slowed down when looking around? Doing this could also solve this very issue; if it happens, one would just need to toggle the slow down off and back on again to re-force it on?

UPDATE! I found more about the bug/glitch. It's linked to pausing!


That thing took me on a weird, wild ride... At first, I thought it was linked to how LONG you stayed paused (don't start looking into it right away, that's not actually it; I was mistaken). I paused, waited, looked at the time, unpaused, and there it was. I paused, quickly unpaused straight away, and it was gone.

So my theory was that it was linked to how long was your latest pause. The shortest time it took for the glitch to happen was 15 seconds ("wow, that short!??", I exclaimed). So if your latest pause was > 15 seconds, looking around would not slow down time. If it was shorter than that (or if you had not paused since entering the game), it would.

So, I tried to set up a recording of this. Set up a chronometer hooked to the "Escape" key, and used a program to record my screen, with the chronometer in sight.

I pressed "z" to un-pause (I was paused, and pressing escape would have started the chronometer; I wanted it to count when I was paused, not the other way around), and used C to look around. The game wasn't slowing down. Unsurprising, I thought, since it had been paused for a while now.

So then I pressed "escape" to pause, and waited 5 seconds. pressed "escape" again to unpause (also pausing the chronometer in the same keystroke, now displaying 5 seconds), and used C to look around. Time was slowing down as expected.

I continued, this time waiting 10 seconds. Looking around, time was slowed down. Nothing special here, only building up to when it WOULD slow down.

Again, this time waiting the dreaded 15 seconds. Looking around, time was... slowed down?? O- okay? Maybe I was wrong and the trigger was something like 18 seconds? Let me try again, this time waiting 20...

So I did, waiting 20 seconds... Looked around using C... time was slowed down. Huh???

Did it again, this time 30 seconds. It was STILL correctly slowed down.


At this point, many questions were running in my head. My first thought was: is either the recording software of the chronometer preventing the glitch from happening?

So I closed both, waited I-could-no-longer-be-sure-how-long seconds, and unpaused...

The time

was NOT

slowing

down.


I was now about to rage about the time I wasted setting all of this up since it was now useless, but it barely took me about 2 seconds to realize what I had just done...


I used Z...

to unpause...


Dumbfounded, I tried it again. Pressed Escape (pausing), then Z (un-pausing by selecting "RESUME")...

Looked around with C...

The time was NOT slowed down.


This glitch is not triggered by how LONG you last paused, but by HOW you last UN-PAUSED

Un-pausing with Z (i.e. "selecting RESUME") triggers this glitch

Un-pausing with Escape makes things go back to normal


The only reason I came to my previous conclusion was because when I would want to quickly pause-unpause, I would double-tap Escape

However, when I left the game paused for a while, I would obviously put my hands away from the keyboard, and once came the time to unpause, hitting "Z" would always be easier than having to reach for the "escape" key again...

... I feel dumb :|

Developer

I just wanted to say that I *greatly* appreciate the amount of effort you put into finding the cause of this obscure bug. Don't feel dumb! Game bugs can be so weird. QA/Bug Testers don't get enough credit for the work they do. 

Again, thank you so much for the effort into that! I should have time for game dev over the weekend, so hopefully I'll be able to get an update around then.

Thanks again!

(1 edit)

Hello! I would really love to play the game but when I run it, the image is so light and noisy I can't really see or read anything. I could barely read the scene that said "press z" to take me to the menu, and was just barely able to see enough to navigate to options (I thought maybe something was set wrong for my computer) but I couldn't see anything well enough to do anything. Maybe this is a problem on my end. But even if it is, would you happen to have any idea what I can do to fix this? I tried reinstalling it and that didn't help. Sorry and thanks in advance!

Developer

I'm so sorry you're running into that!

Are you running Windows or Mac? 

I'll try to look into this within the next week or so!

I'm running it on Windows. Thanks so much for the quick response. I can give any other info about my computer you need to figure out the problem. Once again, I apologize in advance if it turns out to just be some issue on my end haha

Developer

Are you by any chance able to send me a screenshot of what the game looks like? 

Also any more details about your computer is helpful! (ie: right-click This PC, select Properties, and let me know what your device specs are)

I have seen one other person mention a similar issue, but I wasn't able to track down the cause. I have a few ideas, but it may take me some time to figure out! Any more details you can think of will be super helpful :) 

Okay so I'm not great with computers so I apologize if this is more/less info about my computer than you need. It's 12GB RAM, 64-bit operating system and x64-based processor, 11th gen intel core i5, and its running Windows 10.

As for the game, I've attached a few screenshots below. Honestly they're better quality here than they appear on screen when I run the game.

These are some pre-menu loading screenshots:




This is the screen that tells me to press a button to continue:

And this is the menu itself:


Thanks so much! Let me know if you need anything else!
Developer

This is very helpful! Thank you for taking the time to get these screenshots and info!

Yeah that is definitely not how the game should look. I have a few hunches at what might be causing this, but I do just want you to know it may take quite a while before a fix comes out. I'll keep you posted as I work through this! 

I feel bad about having you wait on this, but if you're interested, I can send you a code for my newer game Search Party and/or a code for The Devil Haunts Me as an "apology" fee haha. Send me an e-mail at gamesbylum@gmail.com, if that's something you'd be interested in! 

Thanks so much!! Don't worry about it, take your time. I'm sure this stuff is complicated.

As for the other games, I'd feel bad getting an indie game without paying for it. But I'll look into them and might buy them when I have more funds in the future!

Thanks again!

Hi! I'm having the same problem.