Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics


Content Expansion for Nuclear Throne · By Yokin, THX


A topic by Yokin created Oct 16, 2019 Views: 3,311 Replies: 60
This topic is archived. It is unlisted and no new posts can be made.
Viewing posts 1 to 32

Reply to this post with any errors, bugs, or glitches you get - screenshots and descriptions are helpful



Fixed thank u

Is the massive lag normal? Watching the trailer the game looked to be running fine, but the entire aquatic path and most of the regular zones are all running hellishly slow for me. Not exactly playing on a potato, either...


Depends on your setup - I think CPU is a big factor in how much lag you get.

Enabling NTT's offline mode would probably help a little:

  1. Open NTT-Assemble.exe
  2. Press 5
  3. Overall performance should be improved since collisions are now imprecise or something (co-op is disabled unfortunately)

Hopefully we can get some further optimizations going for the areas, but I'm not sure how much can be done to mitigate it right now from the modder's side of things

Well, I'm running a Ryzen 5 2600, should be more than capable lol. My cpu usage stays ~10% while playing.
I've played modded nt a fair bit with larger ones like bruce's pack, this is the first time I've run into any major performance issues.

I tried toggling offline mode, which had very little effect. Game felt smoother for the first bit but the lag still picks up hard as soon as I go to the aquatic path or on the vanilla path gets gradually worse first becoming really noticeable in the crystal caves.
Also messing with the water quality options and toggling shaders didn't seem to make any performance changes positive or negative..?

Developer (4 edits)

Hard to say, some people get a constant 30fps and some chug along in the custom areas. Not entirely sure what makes the difference at the moment

Difference between this mod and something like Bruce Pack or Defpack is that NTTE has a lot more constantly-existing objects and constantly-running code, particularly in the custom areas. Plus Nuclear Throne Together is pretty darn slow in its code execution since mods need to be interpreted on the fly. NTT might get updated to run on Gamemaker Studio 2 at some point, which I've heard might speed things up?

If not already true, something else you could potentially try is making sure you don't have too much open in the background, I notice I get less lag when NTT is one of the only things open. Also I think it helps if your computer has been restarted somewhat recently, frees up stuff I guess

* also yeah water quality options probably won't do that much - they had a lot more impact earlier in the mod's development when the water effects used way more memory. Lots of optimizations since adding the sliders.

** also also the shader toggle is just for people whose computers don't support shaders, crashing the game

Yeah restarting computer and closing other stuff was one of the first things I did to see, makes a difference but game still becomes a slow-mo trainwreck for me unfortunately. Hopefully the move the gms2 will improve things, until then oh well.

Maybe try and get people to fill out a quick survey to see what kind of hardware people use and what general performance they get, a connection might be made.

Hey, just downloaded this, fantastic work by everyone involved. I've noticed that enemies can occasionally be seen on top of the walls,  and they can jump down off of the walls to attack you. Clearly this is working as designed. I don't think that Chests and Rad Canisters are supposed to get stuck in the wall though, unless you're meant to blow the walls up to get to them? I've only noticed this happening in Desert, but there could be more instances of this on other levels; I've only played for like 30 minutes. Also I am also noticing lag, but I'm sure that's expected and it's not too bad. Thanks again for this, I'll be sure to submit any more bugs I find, and take screenshots as well. 


Chests are supposed to be on top of the walls yeah, we'll probably make it more obvious in the next update or so

I have beaten the Boss in the turtle sewers and it said "crown of crime unlocked" I can't see it tho, dunno if its a bug or if i'm supposed to get into loop to fully unlock it. If so, the message would be really confusing 


That just means you can find it in the crown vault now, though I see why you'd be confused by that

(1 edit)

maybe this would  better fit under suggestions but i feel like ammo drop rates are reallly low, im playing the same way i play in vanilla and i rarely have ammo problems there, i could just be bad but after about an hour of play its like the one thing that keeps happening

edit: grammar


Are you having ammo problems everywhere or specifically in certain custom areas? We could mess around with the enemy drop rates for the custom areas if there don't seem to be enough ammo drops in them

I also noticed some ammo issues as well, happened for me when I was using some combined weapons. Ammo pickups weren't giving the ammo type the weapon used.

it seems to be everywhere until i get to the loop, maybe it's some other weird reason i havent considered but idk 

I personally haven't experienced any ammo issues whatsoever, ammo does seem to be relatively rare, but with any of the ammo perks it mitigates it.

Deleted 2 years ago
Deleted 2 years ago

what did you do wrong?

idk if its like a random thing on purpose, but i just got 2 big bandits on 1-3 without loop. didnt do anything special tho, so i cant describe the circumstances

Now i get this with parrot's ability

FATAL ERROR in Vertex Shader compilation
ShaderName: gu_shader_set_impl

D3DXCompile failed - result

called from - gml_Script_gu_shader_set (line 1)
called from - gml_Script_ref_shader_set (line 2)
called from - gml_Script_vm_gml_thread_exec_slice_call_fn0 (line 4)
called from - gml_Script_vm_gml_thread_exec_slice_call (line 3)
called from - gml_Script_gml_thread_exec (line 711)
called from - gml_Script_gml_program_call_v (line 10)
called from - gml_Script_mod_tagrefcall (line 24)
called from - gml_Object_CustomDraw_Draw_0 (line 3)


To fix that you'll need to click the "Toggle Shaders" button in the NTTE options menu

Hello, Is normal 2 big bandits in a 1-3 whiout loop?

Did you by any chance have 2 bones on you? same thing happened earlier with me

Developer (1 edit)

Next update will solve this thank u

*Next next

Hey, just got to the bosses in the new 2 - Pizza section, and beat them. After I beat them there was an enemy, picture attached, still alive that would not die. I pumped like 10 bolts, a dozen grenades, and lots of bullets into him, and he eventually killed me. Don't know if this is a bug or if there was a secret way you're supposed to kill him? He was shouting at me and this big like shockwave thing kept blowing up around him. Anyway, thanks again, that level blew my mind lol :) 


I think someone else got this bug too, will look into it

Cool, thanks :) 

Hey there :) i wanted to say that I have massive frame drops while playing with this mod. As someone else mentioned above I don't think it's my hardware but I do seem to have smooth fps when enemies aren't in the wall any bug related to that or the fact that NTT loads the mods that moment?


The latest update might run a bit smoother for you, at least in regards to wall-top stuff

Hey, got a better shot of the Immortal Bat glitch in case you wanted it. Still loving this, finding new stuff all the time :)


Fixed now in the latest update, thanks!

(2 edits)

I encounter a desyn error when I played with my friends on coop.

Potential spoiler alert, don't open the pictures and the video if you don't want to get spoiled

The area encircled by the red line in the picture will cause the disconnection between players when one of them step onto it

The bug can be easily replicated and I recorded the bug. 


Big thanks, will try to get it fixed


Alright the latest update has something that *might* fix the desync, but if you still get it make sure to report back. Thanks!

I redownloaded the zip and should be playing the newest version of NTTE, still encountered the same desync bug :( 

(do your update automatically take effect tho? I dont see any version number in the download location, do we reinstall the mod after every hotfix?)

Developer (4 edits)

Yeah the latest version doesn't fix the desync I don't think

We aren't entirely sure what the exact cause is though, since the main problem is that the desync seems to depend on the computers or the connection between the people playing the mod together, and we haven't been able to recreate it ourselves. Just hard to test fixes without being able to see the results, but hopefully it'll be fixed by the next update

The footage/images you provided really help narrow it down though!

*also yeah you have to manually redownload, it's not automatic

Tested with my friend, he installed the new NTTE version and hosted the game. Still encountered the bug :(

how to get into this location, say please :D

I've been trying to use this mod and have tried installing NT, NTT, and NTTE all over again now, but whenever I go to the main menu, the mod completely unloads itself from the game, and will also unload itself if I quit out of a run. If this is by design, and you're meant to /load NTTE before each run and each time you launch the game, it definitely makes it very hard to play, but if not, any idea how to stop the problem?


That's just how Nuclear Throne Together works, but if you want the mod to auto-load when you go back into the game you can create a file in your mods folder called "startup.txt" and put commands (like "/load NTTE") in there which will run when you open the character selection screen

I'm not sure if there's much reason to go back to the main menu though besides settings, but you can access that through the pause screen if need be

NANI?! 2 Big Bandit XD



Thank u it will be fixed in the next update

(1 edit)


1. There is perpetual controller rumble while holding a Bone in your active weapon slot.

2. Unable to select the NTTE crowns with controller.


1.  Chests and Rad Canisters can spawn on walls, meaning you can't get them without explosives.(intentional?)

2. Parrot will have the same crowns unlocked as the mutant you used to unlock Parrot (in this case, I used Crystal, who had Destiny and Curse crowns unlocked).


Unfortunately the 2nd gamepad bug and 2nd general bug aren't fixable right now, but hopefully a future NT:Together update will fix them. The general bug we have especially little control over.

The 1st gamepad bug is weird though, do you get the same thing if you type the command "/gml 0.wkick = 999" in chat? (Make sure a player exists, it'll give you an error otherwise)

I tried the command, and no, the rumble from holding a Bone in your main hand isn't nearly as severe as setting it to 999.

The chest on walls thing, is it actually intentional? it seems like even when they appear, you can still find the normal amount of chests on the level, so are they just a kind of random bonus if you have a way to destroy terrain?


Yeah they'll likely be polished up a bit in future updates, and will probably be made to spawn less often earlier

Just wanted to report that the enemies in the cursed crystal caves are making crow noises when they die instead of the normal shattered glass noise. Not sure about the regular crystal caves enemies though. 


That's just a normal-game thing, the enemies in cursed caves are "glitchy" by design

Gotcha, thanks

I didn't do anything to open this vault, it opened when I entered the level. Did the maggot nests remove the walls?

Playing with friend on this mod. There is a 33ms delay between each other. We get to Aquatic 3-1 and opened the shell weapon chest and desync occurs. He is hosting playing B-Skin Crystal while I am playing C-Skin YV. The desync has occurred every time my friend and I go to Aquatic 3-1.

I've been having the same issue with a friend. I know there was already some light shed on this bug but have there been any updates that may have fixed it?


It's definitely somehow caused by the player walking over the pit tiles, but I have no idea why.  The main problem with the bug is I can't do any trial and error to fix it cause I personally don't get the desync with anyone I've tested with for some reason, though it definitely happens for certain people

Bad experience


The invincible bat incarnation still persist, in pizza map.

Though a work around is wait for the boss character to split again.

Thought to bring this bug to your attention.

There is only this thing on level.

I have massive framrate issues whenever there is something standing on top of walls. Is there any possible fix or compatibility change i can do ? Because right now i can't play the mod with such low framerate. 

why is the baby scorpion invinsible? not only that but others from NTTE

(1 edit)

So like when i select fish  or rebel and open the loadout menu it spams error messages and they dont have the extra crowns

EDIT: Ok the problem gets worse and worse each time you open the NTTE menu so thats weird, also i can still start with the extra crowns if they were selected before they dissapeared.

Developer archived this topic