🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Mining 1.0 (A Blacksmith's Guide to Never Sleeping) Sticky

A topic by JTE created 45 days ago Views: 2,653 Replies: 11
Viewing posts 1 to 8
(Edited 24 times) (+2)

Starting in Alpha 0.0.8, you now have access to exceedingly profitable mining activities! This guide will tell you everything I know and how to get started. :3 You can do this at any time while your shop is closed, so when you get the "You feel tired" message telling you the customers are gone for the night, you can go do this while you wait for morning instead of sleeping, if you like.

Update: 0.0.82 changed how time works, so unfortunately you will have to sleep. :( A lot of other things have changed too, so please stand by while I figure out what to update here...

Meet your pickaxe

If you want to mine anything at all, first you're gonna need a pickaxe. If you're new to My Little Blacksmith Shop, a copper pickaxe head has already been provided to you on the crafting table, otherwise start by buying 3 ingots of the highest tier you can afford, as well as any 2 handed grip. Heat the ingots and place them on the anvil, then select Axe Head and hammer away. First you will get a double sided battle axe head, which immediately tries to fall off the anvil into the oil. Quickly catch it and set it back on the anvil and hammer it one more time to turn it into a hefty pickaxe head. Then take it to the crafting table and combine it with your 2h grip. Finished! This pickaxe will be your new best friend from now on.

To wield it, you'll need to press E to add it to your equipment, then you can switch to it with the number 3. Whenever you can afford a new type of ingot, make yourself a new pickaxe with it. You can only mine ores that are of the same variety as your pickaxe or below.

To the mines!

Now you are ready to go harvesting rock. In the yard behind your shop, you should notice a new horse and carriage. This will be your main ore transport. If you want, you can optionally load an open-topped crate or two onto your wagon before we get going, which can help you transport ores out of the mine easier by letting you carry more than one at a time. If you don't have any crates, see the Shopping trip section below for where to find them -- They're free shopping baskets.

Give your horse a Left Click to set it to follow you, then head straight out through the forest. The forest is heavily fogged over, but the path is fairly straight, just follow the widest opening. Your horse is as slow as the default walking speed (I do not believe it upgrades with your agility), so when you get to the cave entrance, stop and wait for the horse to catch up. Don't worry, your horse can path-find its way around obstacles easily enough, and if the cart gets turned over it will right itself by going straight for a while.

Once you and your horse are at the cave entrance, carefully guide your horse through a U-turn so it's facing towards home. This is important, because the horse isn't very good at making tight turns and may topple the cart while doing so, so you want to get turned around before you start loading it up with precious ores just to be safe. When you're done, click your horse again so it waits patiently outside for you.

Go inside and explore! There's a little bend in the tunnel and then you'll find a room filled with minable ore rocks. You can harvest any ores that are the same type as your pickaxe or below and they will respawn tomorrow. I have no idea what tier "Coal Ore" counts as, so it may be minable by any pickaxe. The rest directly correspond to ingot varieties you're already familiar with.

Ores that were harvested will automatically respawn the next day as a completely random ore type. There is a chance that it may respawn as ores that are too high-tier for you to harvest -- if this happens, the ore will remain there unharvestable until you either upgrade your pickaxe or quit and reload the game. Any ores you can't harvest won't allow you to swing your pickaxe at them at all.

When you hit an ore, either a Stone or an ore chunk will pop out. I don't know of any use for stone, so you'll only want to take the ore chunks for now. The mining room is actually on a completely separate map from the rest of the game (Thank you, seamless Unreal Engine level streaming!) so don't leave any precious metals unattended here or they might despawn, even if you only leave the cave for a moment. Instead, you can gather up all your individual ore chunks in the bendy hallway first (anywhere past the wooden doorway but before the stairs should be fine) and then take them out to your horse and load them up in the wagon.

If you brought any open-topped crates with you as suggested, instead of moving the ores one at a time through the map transition, you can bring an empty crate down into the mine with you, put your ores into it, and then lift with your knees (by crouching) to carry it. Don't overfill it, as your ores will have to deal with physics bouncing as you carry it around -- about 10 ores is the most you should be able to fit in it without problems. As long as you can manage holding the crate without making the ores go flying out of it again, you can carry the entire crate and its contents with you back to your wagon, drop it in, and take an empty crate back down to continue mining. It's okay to only take a single crate and simply unload it directly into your wagon, although I like to take two. As long as the ores are in the wagon, they should be okay to travel home with you, even if they're not in a crate. Caution: Do not attempt to turn crates over when they're in close proximity to your wagon, as their rotation point is on the bottom and they're likely to knock your wagon over.

You'll also find a floating crystal of fear in the mining area. Since it doesn't obey gravity, you'll have to carry that one home with you by hand if you want to keep it. As far as I know, it still serves no purpose and cannot yet be used to infuse anything with magic or similar, so for now it's simply a pretty glowing thing you can hold to experience some interesting render effects. It will reset its position back to where you found it when you reload the game, however.

You'll also find what appears to be a door at the back of the mining area. As far as I know, this cannot be opened yet, and will likely lead to more dangerous monster-filled dungeons and deeper mines in the future. For now, all ores will spawn in this one area, so don't worry about the door.

Then you can just tell your horse to follow you again, and assuming you can still make out the way home, just walk it back with you. I personally find it by following the largest gaps between the trees. Make sure you go slowly and keep an eye on your horse, so you'll see if any ores fall out of the wagon along the way. Guide your horse along the side of your fence to park it sideways, if you like. (Careful not to let the horse rub directly up against the fence or your wagon will turn over!) You can take the horse inside your yard, but there's not a lot of room in there to turn it around later.

Grab your axe

Now that you've got a load of ores, you'll need to fuel the smelter. Unlike the forge, you power the smelter with wood and coal, so unless you happened to get lucky with coal ores spawning in your mine, you'll need an axe now. Make a one-handed axe with two ingots, the axe head type, and a 1h grip. I do not know if the material used matters at all, the most it's likely to affect is how much "damage" trees and logs will take before splitting for you. Equip it using the E key and it will go to your 2 key equipment slot.

Your shop came ready with 3 initial logs to start with, which should be plenty for your first week of mining trips. When you run out, it's time to fell more trees. (You may consider taking your horse for this!) Find a tree that's nice and brown, and begin chopping away at the base of the trunk. If it's harvestable, you should see a "100%" or similar indicator pop up as you hit it. Keep going until you hear a loud sound effect of the tree falling. Then, continue chopping away at the fallen tree until it runs out of health, which will split it into logs, ready for you to take home and use as firewood. (In the future, you'll likely be able to craft these logs into wooden shields and grips.)

You cannot run out of wood. If you somehow stay in-game long enough to fell all of the trees and burn all of the firewood (such dedication!), you can simply save and reload the game and your 3 initial logs and trees will all return.

Smelting time

Split a log into firewood by hitting it with your axe, then load a few pieces of firewood (or coal) into the glowing hole in the side of the nearby smelter. Put your ores in the upper compartment and turn it on with the red button on the side to melt all the ores down at once. Remember to turn it off again when you're done so you don't waste fuel!

It does not matter if you mix different ore types when smelting them, the ingots will all come out just fine. Set the ingots on the ground as they spawn so there's room for the next one to come out, they'll cool on their own just from sitting out, so don't bother giving them an oil bath or anything. Now you've basically got a complete shipment of free ingots, which you can load onto the shelves next to your forge and use them take the next few orders you get from customers. Since you didn't pay anything for these ingots, their entire cost is added to your profits, which will send your gold supply soaring, making it easier and easier to get to the next tier of pickaxe, to harvest more ores, to sell to more customers.

Shopping trip

If you really want to absolutely maximize your profits while minimizing your expenditures, a new NPC shop was added to town in this update. Heading out from your shop's main entrance, up the path and off to the right a little, is a mostly unlabelled building with a door you can open. Step inside and you'll find every kind of grip for sale, including new Common tier ones, which are incredibly inexpensive. (A common one-handed grip is only worth 1 gold!) I believe in the future you may be able to craft wooden grips yourself with woodworking, but for now you can buy them here and take them back to your shop to use. To buy anything, simply exit the shop with it. The shop will despawn the moment you step out of the doorway, taking whatever money you owe it, and then when you step back inside the entire shop's contents will return ready to be bought again.

There is an open-topped wooden crate just in the corner of the shop near the doors you can use as a bucket to carry more than one thing home with you at once, if you're careful. When you go to lift the crate, remember to lift with your knees: Make sure you are crouched before you grab it to minimize the chances that the contents will immediately go flying from a physics jump, then uncrouch to hold it level in front of you as you walk. This crate will also respawn with the shop, but it's completely free to take, for your convenience.

No, you can't "steal" from the shop this way by simply holding the items indirectly -- the shop seems to charge you when it despawns based on what items were left inside it able to be removed, rather than checking what you took outside. Unfortunately you can't return (or "sell") things to the shop either, so be sure to bring your shopping basket back with you on future shopping trips unless you want to end up with more of them.

(+2)

great explanation thanks for that this will help a the new players a lot

(+1)

Thanks for the tips! I was wondering about the spawning of the ores, and you answered my question! Also, I find it helpful to place multiple things inside a box found in the back yard, then carry that around to transport them. Though you have to be careful when you pick it up or the ores or other items might go flying.

(+2)

I've found I can minimize spillage of the open boxes with items inside by crouching first, then grabbing the crate. It's pretty consistent.

You can close boxes with left click, items wont move into the box.

gotta remember to check date of post Skar.

33 days ago - you couldn't close boxes - That's a recent feature. - Lifting with your legs and not your back was the best/only way to reduce physics explosion pre-0.0.82

(Edited 3 times)

Thanks for the tip, I've incorporated it into the guide. Unfortunately I wasn't able to find any crates around the workshop anymore, but the one from the NPC shop is free to take and respawns with the shop, so you can have as many as you like.

Please let me know anything else I've missed. I'll try to keep this guide relevant.

A pointer that doesn't really factor in yet, and maybe will be pointed out when it does.

In 0.0.81 I was able (and saw from someone else) that "Shift-click" gave you the Quality mini-game on a still Piping hot Tool head.

You get about 4 chances, give or take, depending on how fast you are, waiting for the perfect chance may cost you a stack of benefits. - Didn't readily notice intelligence factor for it though after figuring out you could do it

Haven't tested in .82 - but the Flyer still says, smack and toss it into the oil - without mentioning the Shift-Click

Additionally, click is /not/ the fire button whilst in the quality mini-game - It's right click- Shift Click (left) to open it, Right to "fire"/close it - miss is 1, red is 10, and green is 30 (or was, in 0.0.81)

Dunno if you plan to update this or not, or how often you do.

There's quite a lot to overhaul in this as of .82

Lids on crates

16hr and 24hr fatigue (dear god those lids on crates )

cave is intensely dark, don't forget to remind them to take their lantern in one of the crates

(Edited 4 times)

Okay, I just loaded the game and now my horse and carriage is completely gone (there is no logic whatsoever to say "hey, if there wasn't a horse in the save, spawn the default new game one" because that would be too advanced), crates have sealable tops, but the contents of the shopping crate get stuck so now instead of being able to pick items up out of the crate, grabbing the item drags the whole crate and other items with it, slingshotting me into the air.

No wait, I started a new game and now I have a horse and carriage, and the carriage has a lamp, but the lamp is in the sky above it for some reason. Still looking for one I can actually hold and take with me personally. Edit: Nevermind. I found one and immediately lost it to the invisible map transition somewhere, so now it's permanently stuck inside a plain boulder, which I was using as a shelf because leaving the lamp on the floor is terrible for lighting, at the bottom of the steps near the cave entrance. Edit2: Tried again, successfully hauled and smelted a big load of copper ore, this is great. A lot of items seem to be getting stuck un-liftable until you left click them or bump them with something else, I guess? I don't know. The P menu for levelling up and setting your blacksmith's name just aims the camera straight down at the floor, rendering the menu completely unusuable. My Oculus install keeps popping up, so I assume the dev is only testing in VR or something? I would say the game is practically unplayable at the moment, but I suppose that levelling up and being able to see while mining (juggling the physics lamp with your one mouse hand and trying not to let it get stuck while you haul things) are technically optional...


Great job. Lots of bugs fixed and lots of new ones introduced, but if you keep taking two steps forward and one step back you're bound to get there eventually! =ω=

My reply is likely.. really long... bear with me.


The game now asks your Save-file where crystals and horse are saved - because they were never, ever written to the save file, and always spawned by the game/engine - they have no location saved, they don't even exist according to your save file... so. the game "loses them"

The game /does/ spawn one on a fresh save, so that your save file knows they exist and will track their location.
-------

Lamp on Cart is for seeing from the cart and nothing else really, which isn't recommended, as the horse is still extremely buggy - recommend only using the horse as you did in 0.81 - riding it has its own issues.

Riding it can, especially if it freaks out, result in character model desync

Character model desync results in character sheet desync. Which /can/ be permanently written to save http://mlbs.slipcor.net/ has a Player Model fixer, which should fix sheet desync as well

Horse desync can (maybe) be fixed from the fixer underneath the Player model one, in case the horse/cart are currently jumping over the moon.

----------

Mining - A) darkness intensity is controlled in part by graphics, and can be lessened with lower graphics. Keep this in mind

B) Lantern ontop of workbench wall-shelf - Instead of carrying it, Shove it into the box you plan on mining with

This reduces the overall light, but you get a Mining crate, which provides light, anywhere you stick the crate near.

C) Alternatively - Use the Light Crystal, saves crate room for more ore, and lights /almost/ as much (not as far a light range, not quite as bright)

D) Alternatively, you can /actively trigger/ that "item stuck" you're talking about (hold item, hit esc, release item, return to game, hold item again - item is now adhered to location you grabbed second at) (If you skip hold again, you can "toggle" holding it, so you don't have to keep the mouse button pressed - any other button than grab, releases it.

You could use this to set up crystals and the lantern in a way that act as a guiding path of light in the cave, Above you, so its both out of the way, and higher better lighting.  - I of course, don't recommend this, I use the Light crystal in my crate.

---------

Items stuck by aforementioning bug/glitch - can be destuck by using a crate's lid, Enclose item with crate, lid, unlid - item is free. - Harder to do if you can't get a crate around it.

However. On reload, most items "grabbed" by you, either once, twice, or etc - will be "ungrabbed" because /you/ left the equation, and /you/ are required for "grab" - they become normal/unlocked after that.

-------

Geofreys

... Just.. Don't use his shop, he's a swindler.

A) The Shopping basket, The Basket is its own item, and the crate you get outside, is a different item - When you lid it inside, you're lidding the basket, something you can never unlid when you get outside... because it swaps itself with a regular crate. - This is why if you take the crate back inside, it will never show a new pricing on the side - its /not/ a shopping basket, anymore. - If you don't lid the basket, you won't glue the items inside when you get home.

B) Lidding has its own issues as well - as the game sees lidded items as a separate set of items - So even when you reload and free the items from Geofrey's crate basket (basket crates despawn on reload, and because the basket no longer existed anyway, the item stop being physics disabled by it) - You're charged a second time (or at least, I felt like I was when I did this.) - this is because you never bought the unlidded set

The same applies for your own crate, or using the basket crate later. - If you leave with lidded items, those are the items you bought, unlidding it and using the items later, results in "Stolen" labels - which, seem to currently not be fully implemented- there's reports of people still managing to sell them to npcs. - but the game still sees it as "you bought the lidded set, how did you get that unlidded set outside of the shop without paying?? Stolen. Stop right there, criminal scum!

if your shop basket pricing gets "off" that too can result in "stolen" and the pricing is easy to be "off" and we likely never noticed it before because there was no "stolen" or other reasons we  would notice it - But items leaving the basket results in infinite game breaking - as they don't calculate correctly.

  • Its easiest to forego using Geofrey and just order handles.. but alternatively
    • Go into Geofrey's shop
    • Take a single item, place it in his basket (this will allow the basket to actually be liddable, it can't be lidded at all if you just carry it out, empty)
    • Carry it out, unlidded (you can test lidding inside just in case you don't feel confident it will be liddable outside, just make sure the lid is off when you leave.
    • Go back in, take items to doorway and push them out of shop - one.. by one....
      • This will (hopefully) prevent stolen, and ensure you pay each items "correct price" - and prevent glue/temptation to lid basket. (which is now already a crate)
    • Put now purchased items into now crate...crate - Keep in mind, if you lid this crate, it doesn't properly "disable physics" on the items inside, - be /gentle/ with it, as you could cause physics richochet on the inside which can keep the crate "unstable" when you set it down, or worse, they could explode out of the crate (harder to do, but possible if you rile up the engine enough)

tl;dr

Don't ride cart - buggy, use horse at discretion - still buggy

Don't use Geofrey unless you're uber delicate and careful.

Don't use lid inside of Geofrey's shop and then leave.

Don't hold an item - then hit esc - then try and hold the item again when you return - applies for any item, anywhere, anytime.


Additionally. Try and make sure you sleep between 9-11pm in game, before quitting.

The game forgets exhaustion/sleep schedule when you quit

If you say, quit at 9pm, instead of sleeping.

You will stay "untired" for the next 16hrs (After 1pm - you can go to sleep, and by 9pm again, you'll reach critical fatigue/level 2)

Quitting however, doesn't reset "ailments" - If you were fatigued, and couldn't run before quitting, you will be unable to run after reloading, even though you're now "no longer tired."

Prevent this by sleeping, before quitting, or at least only quitting at 5-7AM


For everything else you have or haven't encountered yet, I suggest checking K's Bug list - the 2nd post has the Bug List (mostly) as seen on Trello, but with the additional information known about cause/fix/workaround.

wheres the crafting table?

what does it look like at least