Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Strive for Power

Fantasy Slave Management/RPG Erotic Game · By Strive4Power

Bugs & Such.

A topic by Sabin Stargem created Sep 06, 2019 Views: 244 Replies: 12
Viewing posts 1 to 7

v0.5.25


1:  When creating a character with wings, the drop-down tab initially doesn't match the wings that the character has been generated with.  Selecting a new set of wings fixes this.

2:  While creating the protagonist, the generic racial talents aren't reported, such as the Seraph's +4 Combat Speed.

3:  When using double-attack weapons, the second attack is launched after the targeted foe has died already.  I think that this second attack should either strike a different foe, or simply not be made.

4:  The option for "Enhanced Scales" in the laboratory lacks a description.

5:  During the boffing mini-game, Lamia are described as "on all fours".

6:  Lamia cannot receive a 6th tattoo, due to a lack of legs.  However, I think their lower body would still be a fine way to display a tattoo.  Not sure what to call that body part, though.  Abdomen, maybe?

7:  When a servant molests another, taking both of them causes the boffing mini-game to have no servants participating.

8:  A servant who is unavailable will retain their job.  It would be useful to have a notification and the option to pick a replacement.

(4 edits)

A couple more.


9:  Gear counts towards a character's mental stats.  Until you remove the offending article, you won't be able to add more points to the stat, preventing you from reaching the cap.

10:  When using the "Unlock Abilities" panel for your protagonist, you can still click and type into the Default Title box.


11:  Non-humanoids can't perform boffing occupations.  This makes specialization in that area useless, and generally doesn't make sense.  I think that the restriction should be altered so that Uncivilized beings are unable to do the finer jobs.   Once the trait is removed, they can do more advanced boffing.


12:  Don't know the cause, but here goes:   I tried to break open a chest with a character, but she didn't have the strength.  Tried to do the same with my protagonist, but he didn't have the energy.   The thing is, the energy gauges for both characters were  25% full.  This was correct for the lady, but the protagonist only had 5 points according to the tooltip.  Something is making the protagonist's energy gauge a bit off.


13:  It seems like the Dark Elf racial trait is broken.   It states that temporary spells and potions last longer.  So I cast my Shield spell on the girl, but the duration only lasted three turns - the same as the protagonist.   Disclosure - The game was modded so that the protagonist had 10/10/10/10 stat potential, which might have reached the cap for spell potency.


14:  When making out with a lady(ies), sometimes they will have a desire.  However, that desire will not always be fulfilled if a current activity of the player is already performing the required action.  It seems like the desire will be completed by manually pressing a button related to it, or if a leading girl enters an action that qualifies.  

EG:  Fondling is ongoing, the desire to be touched appears, a turn of auto-fondling passes to no effect.  Clicking the fondle button makes the girl happy.

1.  I need a specific example for this, as I am not able to find this issue.  Not unlikely as manual character creation uses an entirely separate file for attributes than automatic character creation.
2.  Yeah, character creation is still quite underdeveloped.  Descriptions for slave racial traits also include the max stats for the race which don't effect the player.  It seems that either the player was originally conceived as significantly different than slaves or it was an oversight in designing the character creation interface.
3.  Yeah, currently it is functionally sufficient though not pretty.  It probably would simply skip the double attack if fixed.
4.  Yeah, the problem with implementing each operation separately is too many opportunities for typos.  It has a description, just doesn't display because one place uses "scales" and another uses "scale".
5.  Yeah, interactions are far from perfect.  It has it's own complex dynamic text system.  All participants are treated as humans by the text system, this also means that dogs and horses can talk.  Not terribly difficult to fix, just lots of potential cases to handle.
6.  Perhaps, there are 9 types of legs, only 4 types can have leg tattoos.  The following types currently cannot:  snake, avian, spider, horse, tentacles.  New logic, dynamic text, and GUI support would be needed to support a proper change.
7.  Yeah, daily events have been neglected for quite a while.  They are technically present for the interaction, but not considered participants because they don't end up in the proper array due to it being labeled as 'abuse'.
8.  There is no notification for slaves being away from their job, but other slaves can be assigned to that job to replace them.  A little room for improvement, but the mansion info panel was newly updated after inspiration from a mod.
9.  Yeah, no easy way around that with the current system.  It doesn't differentiate between bonus and base mental stats.
10.  Yeah, Maverik used an earlier version of my bugfix that hadn't corrected that yet.  I have a bugfix for the new version(Strive-win64-525-Bugfix-V1a.zip) posted on Discord(https://itch.io/t/284398/discord) in the mods channel.
11.  Sure, I could understand changes like that.  Though it seems deliberate, not sure what the intent was behind it.
12.  Not seeing anything broken, player and slaves seem to use the same code for rendering energy bars and using energy for opening chests.  Though it appears that energy bars are not refreshed between attempts at opening chests.
13.  Dark elf trait works fine for spells and potions on the daily time scale, but has no effect on combat.  Certainly seems like an oversight.
14.  Yeah, seems a bit odd, not sure whether I would have it generate requests which could be fulfilled by ongoing actions.  The sex system was left incomplete during a transition between 2 systems, there is a lot that is broken there.

For #1:   I start a story mode creation, with customization.   Once I get to the races section, I pick Seraph.  He is generated with white, feathery wings in the description box, but the drop-down tab says "feathered black".    I think this also happens with sandbox races.

Okay, found the problem.  It seems that for just the wings, the dropdown button is never updated to match the initially generated person

(1 edit)

More issues.

#15:  Arachnae have scales, and correspondingly have the 'enhanced scales' option in the laboratory.  From what I recall,  spiders aren't known for armor.   I assume this wasn't intended.

#16:  During the boffing mini-game, the ladies sometimes will not accept the "take lead" command, despite being all-green.  This happens for both humanoids and monstergals.  No reason or response is given for why the command won't take.

#17:  On occasion, the tooltip of a servant would be present during the boffing mini-game.  It doesn't go away, obscuring the text log of the session.  The latest time this happened, I noticed that Maple participated in the last boffing session - and it was her tooltip during the latest.

(1 edit)

tooltips: It is possible more places need a "sanity check" to clear possible artifacts that remain on screen.  That said, lingering tooltips do not have anything to do with the boffing mini-game at all.  Various tooltips are created generally from moving  the mouse across the border (from outside to inside) of items that have tooltips set on them.  These same tooltips are then hidden when the mouse moves across a border in the reverse direction of that same item or any other that shares the same tooltip feature.  There are ways to manipulate software such that the mouse never actually crosses the boundary in the reverse direction such that it can be detected (especially if using keyboard shortcuts to launch new screens).  All of this is generally not a problem until the player navigates to an entirely new screen when there is no usage of that same tooltip style and thus no boundary to cross to make it go away.

Long story short, the tooltip is almost certainly already on the screen (somewhat in error).  And then you are clicking and going into the boffing scene.  While it isn't a fix, you can pay closer attention to when tooltips are present when you do not desire them to be and move the mouse appropriately to close them prior to advancing on to a different environment (as a workaround until more sanity checks are in place).

But mentioning how you went about launching the boffing game without the tooltip already being turned off would be useful information.

Really though, the names of chars in the boffing area should be changed to have the char tooltip anyway (which would give the player a way to turn it off).

(1 edit)

15.  Scales does seem like a mismatched description.  Depending on the fantasy that the creator based them on spiders can have armor, though in reality that would be closer to crabs than spiders.  Considering the substantially increased weight due to increased size to suit a relatively normal sized human upper-body, it's not unreasonable to assume that the composition of the body could be different in order to support the increased weight.
16.  Indeed there is a problem with "take lead".  The only working condition for success is if you have ever successfully proposed intimacy in the meet interaction. Edit: actually, it seems I mistook a condition as something outdated, there is a very high obedience check as well.

(1 edit)

Moar.  Bugs.   :P


#18:   Something is off with the personal bedrooms.  I have the maximum number of 10, but two of them are full even when the communes house everyone.  I have been mostly reserving personal rooms and the master bed for quest characters, so that might be one vector for the bug.  Haven't sold off anyone, but have released some undesirable newcomers.


#19:  The aesthetic for the Umbra guild interface is a bit ugly, because it retains the adventure graphics.  This is different from the other city guilds, which clear away the interface to allow the background image.


#20:  If you don't have enough gold to teleport from a city, then sell enough goods to get the money, the teleport option won't be permitted.  You have to exit and enter the city to reactivate teleportation.

#21:  Cursed Blades are not considered to be enchanted items for the Umbra exchange.   Their description box has gold text, while their inventory listing is green colored.   I think that the green listing should be changed to gold.  Ditto goes for Anyaris's rapier.

#18 people that are "away" from the mansion still take up space in your mansion.  They effectively have a bed "reserved" for them that no one is allowed to use.  Which type of bed it is depends on what they were using at the time of their departure.  Away slaves include such things as Grade changing and Specialization learning from the slave guild, pregnancy recovering, injury recovery, laboratory recovery, Alchemy quest, and possibly more.  There is no way to remove someone from a reserved bed until they return to service in the mansion.

#21 not sure where you see green that you want to be gold.  Within my inventory both Cursed Blade and Ayneris's Rapier I only see gold text.  Within the tooltip for both of these weapons I see: gold name, white details, and yellow weight (there is no green anywhere).  If I click inspect on either weapon I again see only gold, white, and yellow colors.  If I equip them I still see no green anywhere.  Can you be more specific where the green is?

#18:  Yup, you are right.  Figures that I would miss that detail.  :)

There really should be a separate "benched" section for servants that acts as a sleeping space while they are away from the mansion.


#21:  The item list, on the left.  Anyhow, I figured it out - I loaded up a savefile after booting the game, and removed Anaryis's rapier.  It was listed as gold.  I got some cursed blades, did my usual thing, and removed her rapier again - green.  Did it with a living armor, and got the same result.


With further investigation, I found that the text color in the item list is dependent on which storage area you are in.  While in personal storage, all gold items are marked green, but will have their appropriate color while kept in the mansion inventory.

19.  Yeah, it's got a few GUI problems, probably fairly minor.
20.  Indeed, shops are pop-ups without location changes (easy way to tell the difference is screen fading) so no button updates are triggered.  Visiting anything in the city that causes a location change would have the same effect as leaving and returning.  I feel that screen fading needs to be improved in general, but it's not worth the effort as a bugfix.

(1 edit)

Another?


#22:  I can't give a lady the Geisha specialty.  She is of noble rank, has base 100 in all four mental stats, has boffed enough to have five sexual traits, and 70 beauty.   My guess is that the beauty aspect is where a bug cropped up.  She started at a fairly low number, but received a beauty treatment from the laboratory and has three nature tattoos, giving a +15 bonus.

Using the mind reading ability, I found that she has 55 base beauty, and 15 temporal beauty.  I am guessing temporal beauty is not accounted for specialization.