Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Asset Forge

Create your own 3D models and 2D sprites! · By Kenney

Blank editor screen

A topic by hamzamu created Jan 05, 2022 Views: 390 Replies: 12
Viewing posts 1 to 9


I have a strange issue with my Asset Forge Deluxe install, as the editor workspace does not show any object or element. 

I am using Solus Linux, with Gnome 40.1. 

This might be an issue related to your 3D drivers? We only officially support Ubuntu distributions so I'm afraid I can't help with this.

Tested on Ubuntu, ZorinOS (Ubuntu) , Solus, EndeavourOS (Arch), same problem.

I am using Gnome desktop. I will try another one.

Hi, I had the same issue. But launching it with `./Asset\ Forge.x86_64 -force-vulkan` command solved it.

It worked, Thank you, I hope they will fix it in the next release.

I'd like to echo and confirm this fixed it for me running Arch Linux, Gnome3 under Wayland.

"GDK_BACKEND=x11 ./Asset\ Forge.x86_64 -force-vulkan"

Thanks for all the help guys, I was having serious buyers remorse, even though I like supporting Kenny. :)

(1 edit)

Sorry about that, I really have to add (to the pages before purchasing) that I only test on Ubuntu - it's impossible for me test every Linux distro especially so because I'm not too knowledgeable on this. Glad this fixes the issue though!

Oh also; refunds are accepted if there's issues with running the program, of course.

I totally understand and don't at all blame you Kenny! I know a problem of my own creation when I see one. :)

I'd like to report that I had this issue as well on Ubuntu 22.04.1 LTS with the Deluxe Asset forge 2.2.1
Running it from the command line with '-force-vulkan' fixed the issue here as well.
Here's some system info. Hope this helps

Probably not necessary but I can also confirm that `-force-vulkan` was also necessary to run on Pop-OS (Ubuntu)

I'm running Pop_OS (a derivative of Ubuntu) here and can confirm that running it with the force-vulkan argument did the trick 

./Asset\ Forge.x86_64 -force-vulkan

Any chance of this getting added to the documentation or FAQ for Linux users? Or better yet a toggle or config when launching the app or something? I dont know if something could be integrated into the launcher?

Thanks all! I've added it to the documentation. It doesn't seem like something I can easily add as an option right now but I will keep it in mind when working on the next iteration of Asset Forge.

I am having the same issue here, but using -force-vulkan fails without error for me. I'm assuming my graphics card is just super old and doesn't have Vulkan support, anyone know of a way around this that doesn't involve -force-vulkan? I had this running just fine on a Mint install (at least version 2.2), but version 2.3 isn't working on my EndeavorOS install.