Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Ganbare! Super Strikers

Turn Based Tactical RPG Soccer Game. · By rese

Bug Report Sticky

A topic by rese created Jan 11, 2018 Views: 1,403 Replies: 37
Viewing posts 1 to 11
Developer

Hi!

You can use this Topic to submit any bug you might find in the game.

Hi, just tried the game, and there's a couple of things that didn't go as expected. I'm running a macOS version.
1. Not sure if story mode is implemented or not, but I'll get to this screen and can't progress. Clicking on either saves does nothing. Can't go back either, I can only force quit the game.

2. I went into offside once (it's been a while since I played or at least watched a football match :D ), the offside animation popped up, but after that I couldn't interact with the game anymore. There seems to be some kind of overlay going on.

Hope this helps. I'll let you know if I find anything else :)

Developer

Hi melancholerik,

Thanks so much for playing Ganbare! Super Strikers and for your help! Did you play any Quick Matches before going into Story Mode? I will have a look into this and will come back to you as soon as I find out what is the issue.

Thanks.

I played quick matches, yeah - that's where that offside bug happened.

Developer

I think I know what the issue is then. Both bugs are related. I will upload an update as soon as I fix it and will let you know.

Thanks again!

Developer

Hi melancholerik,

I have uploaded a new build (0.9.0.1) that should fix this issue that you are having. Your save file is corrupted because of this bug, so you need to go to the Options Menu and press the D key on your keyboard 5 times, this will show a Delete All Data button. Press that button and confirm that you want to delete all local data. After this you should be able to play the Story Mode.

Let me know if you have any other issues and thanks for your patience.

Thanks! Reinstalled and deleted save data like you told me and now it seems to work fine. I'm looking forward to play story mode :)
However, after I pressed the "delete all data" button, I couldn't interact with the game - seems similar to other two bugs. I couldn't tell if it did something or not, and couldn't go back either, so I had to quit the game from OS. Not a major problem, I opened the game again after that, and everything worked, I could create new save/character etc. 

Developer

Good to hear it's working fine now! Sorry about the game crashing after pressing "delete all data". I will have a look and find out what's going wrong.

Hello,

Second match in story mod, my player is about to shot, but the game is stuck in this position, can't do anything but move around or quit.


Developer

Hi Tchey,

I will have a look into this, thanks!

Hi!

Tried the Linux version, did not get to far, since I can't get trough the "Click to start" title screen. (No matter what I click or press, nothing happens.) I have an Intel GPU and I'm trying it on a laptop, with a touchpad, if that helps.

(-1)

Hi,

You have to Alt+F11 or Alt+Enter whatever your settings to go fullscreen/windowed, to fix the issue.

You can then return to fullscreen and play.

neither Alt+F11 or Alt+Enter switched me to full screen, did try to start the game full screen already,  but that still did not solve the issue.

I'm Linux Mint with XFCE, and Alt+F11 switch fullscreen in applications. Try to find your shortcut for that.

It's a Unity bug, happening quite often on Linux games, and the easiest way to fix it is to go windowed, move the window a little (unstick it from your taskbar), and go fullscreen again.

If it's not working, then it may be related to something else, but i'm pretty sure it's this Unity bug again, from what you said.

Developer

Thanks for this Tchey! I wasn't aware of this Unity bug.

Developer

Hi CruelAngel,

Sorry about the bug! Try what Tchey said,  go to windowed mode with whatever shortcut your Linux distribution has and let me know if that fixes it.

Hey, love the game. Just a minor bug but I seem to be unable to launch the game from the Itch client? When I click launch it just blinks and does nothing. I can however launch it from the application in the games folder.

Developer

Hi! Sorry about the bug, I will try to reproduce it on my end and see if I can fix it. 

Glad to hear you are enjoying the game :)

Developer

Hi again! I can't seem to reproduce this on my end. Does it only happen with Ganbare! Super Strikers? Is this on Windows?

(2 edits)

The game will sometimes hang and stop responding during the enemy's turn. I think it has something to do with the AI, but I dunno.

In fact, I think the bug has to do with the game's AI, because I remember in match 2 of story mode when the opposing team's captain would get the ball and be completely clear to shoot, but instead of shooting, he'd just stand there and end his turn.

Developer

Hi!

That does sound like the AI is taking too long to think of a move. I will see if I can reproduce it and fix it.

Thanks!

If it helps, it usually happens when I'm trying to off-side trap certain teams.

Developer

Thanks! I think I might know what's causing it. Just to double check, this is on version 1.0.9, right?

Yes, it's in version 1.0.9.

Developer

Thanks for confirming. I think I have found and fixed the bug. Since it's AI related I will need to do some testing because the smallest change can break a lot of other things, but I will try to upload a new version in the next few days.

Developer

Hi Gretgor! I have uploaded a new version that should fix this issue with the AI (along with some other minor fixes).

Yay :)

(+1)

I don't think it should do that. Movement is always 2 tiles, but when passing in front of someone, it seems to forget that.

Developer

Hi! There is a reason for that:

When there is no opponent in the way, there is virtually no difference between a path like the one on your screenshot and a more direct one, so the game calculates automatically the most efficient one. In the situation you shared, the player could want to do that on purpose to make the opponent tackle you automatically (for example if the chances of dribbling are high you might want to do that so the opponent gets stunned and out of the way), so the game can't assume you want to use the shortest way to move to that square.

Cheers!

Virtually? Well, moving 2 or 4 squares in a single move is a big difference. I would not allow this in a board game, or in a DND game or whatever.

Developer

I don't think you understood what I meant. If there is no opponent in the way, the outcome of the long path and the short path is the same, the only difference is how much SP the player it uses. That's why the computer DOES change it automatically to the most efficient one.

When there is an opponent in the way (the screenshot you shared), they are 2 completely different moves and a player might have a reason to choose one over the other. That's why the computer CAN'T assume that the player wants one move over the other. So if YOU want to move to that square in the shortest way possible, then YOU choose that exact path.

I understood. I just don't agree. It's your game.

(+1)

Maybe it's normal, but it seems impossible (in that case) to go down one tile, THEN left one tile. We are forced to walk in front of the defense. Can you explain?

Developer(+1)

You can drag the head of the arrow to select the exact path you want the player to follow.

Sorry, it's been a while. Can we drag using controllers?

Developer

Hey! Yeah, you can control the head of the arrow with controllers.

The linux version seems to have issues on Steam Deck by only displaying green screen. Any idea?

Developer

Hi,

I just replied on your other topic.