Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Strive for Power

Fantasy Slave Management/RPG Erotic Game · By Strive4Power

Portrait Pack Editor Redux (Not a Mod)

A topic by IsaacG created Mar 15, 2021 Views: 37,943 Replies: 70
Viewing posts 1 to 26
(50 edits) (+3)

Rewrote the companion tool for Kyler2's Improved Random Portraits mod. (including features added by Zepeteus)

Download 2.21 for Strive for Power -

or the Conquest version

Download 2.21 for Conquest


settings.json for Aric's Mod (Conquest)


Meant to help assist with renaming files in a portrait pack to follow the tags. Assists with viewing and setting tags for a portrait collection by renaming the portrait and body files in sync

What's New?

Custom filters.  Want to list only portraits of Demons with Red hair?  Or all Adults, no Males, without Breast Tags?  Click the Filter button a few times and go nuts.

Fuse/Separate checkbox added.  Added Create New Portrait by cropping existing body.

Demonstration for those interested

And for Aric's Mod additions

2.21

Fixed error in Compatibility Mode

2.20

Fixed out of bounds error for certain filetypes

2.19

Browse button now starts in current portrait directory

2.18

Compatibility Mode now Default

Added support to create portraits in "bmp" "gif" "webmp" and "jpeg"

previously could only save portraits in "png"

known issue:

Does not correctly save files in "webp" format

(repeated testing, sometimes it does save correctly, but usually it doesn't)

2.15

Fixed Create Portrait sizing issue

2.14

Create Portrait now updates Embiggen window

2.13

New Portrait

2.12

Refactoring

Optimizations

2.11

Fuse/Separate Checkbox now updates graphics without requiring additional user input

2.10

Added Fuse/Separate checkbox

Added six buttons related to Fuse/Separate checkbox

Fuse, Split, Label as Body, Label as Portrait, Label as Pregnant, and Label as Nude

(6 edits)

Old Changelog

2.07

Embiggen window now always on top

Layout can be customized in settings.json

Selected image can have its path copied to clipboard

Image resolution is now displayed

2.06

Increased Window Height

2.05

Fixed deletion bug

Fixed crash on many-file deletion

Changed layout (better?)

2.04

Made central list request focus whenever apply or delete is pressed

Fixed error where clear custom tags did nothing

Added Export Images checkbox, only appears if ExportDirectory is filled

Added hotkeys Enter for Apply and Delete for Delete

2.03

Fixed cosmetic issue introduced in 2.01 (much easier to read)


2.02

Now it really does have support for Aric's Mod

2.01

Fixed error that prevents large numbers of Tags from appearing (introduced minor cosmetic issue, too tired to fix right now)

2.0

Added support for Aric's Mod

Added Embiggen button

1.99

Fixed "Un Un Un Un Un Un Un Un"

Fixed some errors with REGEX (overlap between skin/hair, redundancies in hair e.g. treating Black_White as both Black and White)

Added image counter

1.98

Fixed "Missing Checkboxes"

1.97

Added Delete Button

1.96

Added Preliminary Support for WebP filetype

1.95

Fixed display bug Added "drag & drop" functionality


1.93

Minor refactoring

Added caching to speed up filter usage

1.92

Fixed error that prevents portraits from being loaded at first launch

1.91

Minor bugfix (BoobSort still not fully functional)

1.9

Initial beta release of BoobSort

Added last of 1.2 PPE features

Keyboard support within BoobSort, so you don't have to use the mouse

A and D

4 and 6

Left and Right Arrow Keys

1.8

Added support for Penis Size

Fixed error that occurs when clicking multiple label buttons

Fixed redundant label button clicking

Now able to control partial selecting individual tags

Now able to quickly filter on missing tags

1.7

Added support for Custom MetaData (anything in the filename that is neither whitespace nor matching any other tag)

Added support to force apply new formatting and force apply new CRC

Made "White Space" a variable found in settings.json

Added Tribal Elf in default settings

1.6

Fixed typo in Filter window

Removed unused code

(+1)

Seems it's missing penis sizes as well as the search function (which I think was useful). The 'is missing tag' filtering could also be nice.

(+1)

My word, there's a "penis size" tag now?  That can be added in the settings.json file.

There is a workaround for "is missing" tag.  Since multiple filters can be run at once, selecting all tags under the "has none" filter can do it.

"Is Missing Portrait" etc. should be added in 1.8 or 1.9, along with the search function and an explicit "is missing" tag


Thanks for the feedback

(+2)

And DONE

Both have been added

(+1)

Could you please explain me how to install this pack? I'm really stupid when it comes to this stuff

(1 edit) (+1)

There is nothing to install here, it is simply extracted and run using PortraitPackEditor.jar. This is a java program for creating portrait packs, not a mod nor a portrait pack.

(+1)

To show a renewed effort, I have added

the Drag & Drop functionality

No longer does one need to browse with the Portrait Pack Editor interface, just drag & drop your folder

(+1)

Up next, Aric's Mod expansion

still working on that

(2 edits) (+1)

so there is a issue im running into, I dont know if its just on my end but the apply button doesnt work 95% of the time. Ive redownloaded the zip, deleted and then freshly "installed" it again and it doesnt fix anything. Ive tried using different paths for the bodies / portraits on the same drive just different paths (ex C:\Strive to C:\packs) as well as on different drives (C:\Strive to D:\Packs or E:\Strive) Any input on fixing this would be great. 

And yes I have bot ha bodies and portraits folder in the same directory so (C:\Strive\bodies and C:\Strive\portraits) with both images being named the same, so (C:\Strive\bodies\elf.png and C:\Strive\portraits\elf.png)

it seems like it just "selects" the Apply text in the button instead of actually clicking apply.

unknown.png (78×38) (discordapp.com)

(1 edit) (+1)

It seems I introduced a host of bugs in 1.94

Until I get a handle on it, I'm replacing the upload with 1.93

(+1)

I believe it is fixed in 1.95

Deleted 2 years ago
(2 edits)

it usually means the settings.json file is missing or corrupted.  Getting a new copy of it should fix the problem

I haven't been able to test whether this is an issue with Mac

Deleted 2 years ago

that's the default value.  it tells the editor to find the portraits automatically

if changing the value to your portrait's actual directory helps, then the issue is with how the editor works in Mac

first try changing the PackDirectory to "C:\\"

the editor should still run even if the folder is incorrect

Is this mod supposed to show up in the in game mod menu?

This is not a mod, it's a program. So it will not show up in the mods menu and wouldn't work even if it did.

Ahh, okay, thanks!

Is it possible to turn off auto portrait/body selection for male characters/npc's only?

This isn't really a question specific to the editor, but no there isn't an option to limit the auto image selection. However, the improved random portraits mod will assign no image to males if there are no images tagged for males.

I only asked here since there is a settings file for this pack, I just didn't have a clue what I was doing. The mod your referring to is the one by Kyler2, right? Do I need that mod and then this as well, because this says it's a re-write of the companion tool for that mod.

The version by Zepeteus, is better than the original by Kyler2. https://itch.io/t/984434/randomportraits-and-portrait-pack-editor-for-the-10-ver...

The portait pack editor will technically work without the mod, but the vanilla game does not support most of the tags. https://itch.io/t/838806/core-tag-size-rules

Okay, I feel like an idiot. I installed everything, and all of my portraits/bodies are properly tagged with the SkinL, AssM etc... but when I load up Strive no one has any portraits. Am I doing something wrong, am I missing something totally obvious here? I'm so confused.

I assume you mean that when you start a new game nobody has any images. If you changed the image folder and tried to load an existing progress, then it may not be able to find the images because it only looks for an exact path.

The first possibility would be that the images are not in the right folder, or the in-game path to the image folders was changed. The second possibility would be that the tags are incorrect. This post covers some of the key mechanics of the IRP mod, specifically the tag filters: https://itch.io/post/493890

No the image folders are definitely correct. appdata/roaming/strive/ then the respective bodies & portraits folders. And when I go into a game and manually try and choose something, the images all show.

I'm assuming the tags are incorrect, which is odd because I went through with Zepeteus' updated program and re-applied all the tags to every portrait and body picture I use (which was torture lol), but I guess I'll have to just go through it all again today, start small with maybe just one race and re-do the tags then see if the game will recognize them, and if so, slowly do them all again.

I've modified the original editor to work with webp, but it lacks a lot of the functionality this one has. Could you post the source code or add support for webp?

I will add support for webp

Done 1.96

The webp portion seems to work fine but the missing tag system seems faulty.  The cause seems to be the more sophisticated regex. For example if you look for missing races ass and tits sizes, you'll see elves with big tits and small/big ass. You can work around this by just making custom filters as those seem to work fine. You can also fix it by changing the settings to simple string regex but that will probably mess with compatibility.

Took me a minute to replicate the bug, but yea, I see it now

Weird bug,

I already implemented custom filters internally, but the "missing checkboxes" were using the Regex instead

Since most of the Regex are the same value as the custom tags, this had escaped my notice

Currently my build doesn't distinguish between Tags, Regex, and Name.  All of them are stored as Strings instead.  I should enforced strong-type.  


Thank you, fixed in 1.98

Deleted 1 year ago
(+2)

Done

1.97

do you need java to run this pack.? Im new to modding this game but ive put the non compressed pack in to my mod folder but when i open my mod menu only constants show up. when i open the mod menu this shows up but idk if that's normal

(1 edit)

https://itch.io/post/5075767

https://itch.io/post/3403189

Not really sure what changed but it doesn't seem to work with webp anymore. I tried a fresh download, old 1.96 version, restarting, updating java and even a different pc, but it didn't work. Pngs still work fine though, so perhaps something related to webp library?

That is odd, it still works for me


Does it at least list the files, and fail to display them?  Or do the .webp files not show up at all?

(2 edits)

It works like before the webp was implemented. You can choose webp images but they don't show the picture and you can't edit them.

I finally figured how to get the error output from java so I got this. The last 2 errors repeat everytime I choose a different picture. I checked the temp folder and it does create a dll named like that.

https://pastebin.com/jZ3fMcMz


E: Ok so I managed to fix it. You have to have Visual studio 2019 with the cmake package installed for it to work. I think I uninstalled it around the time it stopped working (was around a week so a few things had changed). I also ran a dumpbin on it for dependents and I got this. If I had to guess I was missing the VCRUNTIME140D.dll.

Dump of file C:\Users\marku\AppData\Local\Temp\webp-imageio5311011599682056399.dll

File Type: DLL

  Image has the following dependencies:

    KERNEL32.dll

    VCRUNTIME140D.dll

    ucrtbased.dll

If a file name has Un, it will be removed and 8 Un will be added to the end. Tagging will still work but the 8 Un will remain at the end of the file (before the checksum).

The regex is faulty for a few things. Mostly between skin and hair colors. Adding pale blue skin will tag blue skin and blue hair. Black_Gray will add black and gray etc. The existing (?<!izes) do not work either. Apparently ?<! works for prefixes while ?! for suffixes. 

Adding a number for the amount of pictures with the current filters on would be nice.

at first I thought you meant the string "8 Un" but then I tested it

"Un Un Un Un Un Un Un Un"

Wow, I am really curious how that even happens


I'll look this over and get back to you

Fixed in 1.99

The "Un" thing was weird.  The result of old code that was supposed to be removed

(1 edit)

With the update to 2.02 I can see there are options to show missing tags for Aric's mod but I do not see any selection options to add the tags to images.

That is the next planned feature, the option to connect images or move them between Portraits, Bodies, Naked, and Pregnant

^.^;

Ah did not realize that. 

It means we're heading in the right direction

Added in 2.10

It's not pretty, but it works.

Click the Fuse/Separate checkbox, then click anywhere on the main list.  The new features will become visible.

Will have to check it out thanks.

Bumping for new content in 2.13

Portrait Maker is now included by default

Crop the body image to automatically generate a new portrait file (overwrites any existing portrait)

for some reason .jpg/.jpeg Portraits  made with Portrait maker do not work in-game, game only can see their names, but not the image. It works fine with .png format though. 

(+1)

I think I know what the cause is

Should be fixed in 2.18

well, already found a fix by making all my images into .png

is this normal? I can't see the rest of the tags.
https://cdn.discordapp.com/attachments/442183038399545344/1015654824282427572/un...

That's a common bug

One that I thought I had fixed by now, but it rears its ugly head again


Until I figure it out,

stretch the window, make it wider
That's the easiest fix

otherwise, this can happen when you have too many tags in total

(1 edit)

Magenta_Ivy made a modified version of your Pack Editor for his mod. It's a bit older version but you could use it for a basis for this problem. (Here the tags are on the side not below). At your version i cant even see the tags. Here is a link for the modified version: https://www.mediafire.com/file/12h0vip3pwbxnba/PortraitPackEditor_2.16_Modified....

i can't seem to open the .jar what am i doing wrong?

You should have Java installed on your PC

Try typing
java -jar PortraitPackEditor.jar
in the command prompt

It should either cause the editor to open, or it will display an error message to explain why it didn't

(1 edit)

I keep trying to start the editor, but the java window either keeps immediately closing or flashing me the error "Error: Could not find or load main class c:\Games\NSFW\Strive Conquest\added_mods\PortraitPackEditor 2.19 for Conquest\PortraitPackEditor.jar" and I can't tell what I'm doing wrong ;-;

(1 edit)

It might be a permissions error.  Hopefully it works if you type this in the command prompt

java -jar PortraitPackEditor.jar

It just closes on me anytime I try, maybe I didn't install it in the right spot?

The location shouldn't matter (because it's not a mod, and not technically limited to S4P), unless it's a permissions issue (moving it to a public directory, like Downloads or My Documents) or running as Administrator

The command prompt should display a message just before it closes, which would help explain

Holy shit we got it to work! Thank you!

(1 edit)

Is there a way that I'm supposed to be adding more? Right now I've got a few packs already installed and the only way I've been able to find the new images I've added is to drag them over to the bodies folder and then filter out all genders so the list goes from the several thousand names to just a couple.

thx

edit: nvmd that's not working either I guess

It's probably easier to sort out the new pack before adding it to S4P

Create a new folder named after the portrait pack

Extract the .zip into the folder

Drag and drop the folder /Bodies onto the Portrait Pack Editor

(3 edits)

I recently had some trouble getting portraits made with this to work like it usually does and I wonder if I'm kinda misunderstanding the process itself.  Basically it didn't work at all because it seemingly couldn't create the folder the portrait needed to be put into. But if I manually created said folder then it'll work like normal and create the portrait. So is needing to make the folder the portrait would be put in manually intended or maybe just caused by a weird combo of tags?

When possible, the editor is supposed to create the folders as needed

It could be a weird combination of tags, but my first guess is that it's a permissions issue.

I'm glad to hear you sorted it out.

wondering if theres any plans to add the races from arics mod to the editor now that both the versions of arics mod for both games have the arics races?

That can be accomplished with editing the settings.json file

I'd have to look up what the new races in Aric's Mod are to do it myself

appreciate it

(2 edits)

   i got all the races done, atleast for whats stated to be in the conquest version of aric's mod

    { "Name": "Giant", "Regex": "Giant", "Tag": "Giant"}

    { "Name": "Ogre", "Regex": "Ogre", "Tag": "Ogre"}

    { "Name": "Gnoll", "Regex": "Gnoll", "Tag": "Gnoll"}

    { "Name": "Lizardfolk", "Regex": "Lizardfolk", "Tag": "Lizardfolk"}

    { "Name": "Avali", "Regex": "Avali", "Tag": "Avali"}

    { "Name": "Boggard", "Regex": "Boggard", "Tag": "Boggard"}

    { "Name": "Beastkin Mouse", "Regex": "BeastkinMouse", "Tag": "BeastkinMouse"}

    { "Name": "Beastkin Squirrel", "Regex": "BeastkinSquirrel", "Tag": "BeastkinSquirrel"}

    { "Name": "Beastkin Otter", "Regex": "BeastkinOtter", "Tag": "BeastkinOtter"}

    { "Name": "Beastkin Bird", "Regex": "BeastkinBird", "Tag": "BeastkinBird"}

    { "Name": "Beastkin Rat", "Regex": "BeastkinRat", "Tag": "BeastkinRat"}

    { "Name": "Beastkin Sheep", "Regex": "BeastkinSheep", "Tag": "BeastkinSheep"}

    { "Name": "Halfkin Mouse", "Regex": "HalfkinMouse", "Tag": "HalfkinMouse"}

    { "Name": "Halfkin Squirrel", "Regex": "HalfkinSquirrel", "Tag": "HalfkinSquirrel"}

    { "Name": "Halfkin Otter", "Regex": "HalfkinOtter", "Tag": "HalfkinOtter"}

    { "Name": "Halfkin Bird", "Regex": "HalfkinBird", "Tag": "HalfkinBird"}

    { "Name": "Halfkin Rat", "Regex": "HalfkinRat", "Tag": "HalfkinRat"}

    { "Name": "Halfkin Sheep", "Regex": "HalfkinSheep", "Tag": "HalfkinSheep"}

when i put these in the settings the editor unfortunately wouldn't start so i dont quite know what i should do next

EDIT: nevermind i fixed it i forgot to put commas between each set

Couple of basic questions. Does the pic need to be in png format? To eliminate background on the pics in game, do I just need to 'white out' parts of the picture or something else?

The PNG format has an alpha channel per pixel that controls the transparency, so RGBA rather than RGB. I believe that setting the alpha to zero will make it transparent. There are no designated transparent colors so you cannot 'white out' parts of the picture to make them transparent. This means that although Strive will use PNG, JPG, and WebP image formats, most image packs will use PNG to make use of the transparency.

You don't need to remove the background if you don't want to, as some users have noted that since the Bugfix mod adds fading to the body images it is not as important as it once was. If you need help, the Discord (https://itch.io/t/284398/discord) has a channel where people are quite experienced at removing backgrounds.

This is great, a definite improvement over the old portrait tagging tool!

Thank you :D