Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

Strive for Power

Fantasy Slave Management/RPG Erotic Game · By Strive4Power

Chastity Belt Mod v1.3e (for Strive v1.0d)

A topic by Darin.w created Nov 29, 2020 Views: 33,029 Replies: 47
Viewing posts 1 to 18
(8 edits) (+6)(-2)

The Chastity Belt mod adds chastity belt options to sex scenes and a variety of new sex actions, largely focused around the chastity belt or more general S&M.

Download link version: 1.3e:

Install instuctions:

  • The Zip file contains 2 directories
    • Es-01-ExpandedSex
    • Es-02-ChastityBelt
  • Extact both directories to the Strive mods folder, enable both mods and apply.
  • Es-01-ExpandedSex must be above Es-02-ChastityBelt in the mods list as it is a requirment

This mod changes a lot of things, chances are it won't work very well with any other non trivial mod.

Brief overview of changes/additions:

  • The Mages Order has provided all Masters with chastity belts to use as they see fit
  • A variety of new sex actions have been added, largely focused around the chastity belt or more general S&M
  • The chastity belts are magical in nature which decrease sensitivity but do not prevent orgasms
  • There are orgasm blockers that can be used independently or with the chastity belts
  • Once a chastity belt is locked, the person who locked it on gets a key for it, and only they can unlock that chastity belt
  • In other related news, it has been discovered that rope can be reused and does not need to be cut off after each use

Changes for 1.3e:

  • Compatibility fix with mod: "Bugfix for 1.0d - V3 by ankmairdor". This mod works with or without the ankmairdor Bugfix mod

Changes for 1.3d:

  • Updated for Strive v1.0d
  • Fixed bug where incorrect person may lock players belt if it the keyholder had changed without reloading
  • Removed rope features as now part of base game

For more history you can view the old version

If you want to use just the Expanded Sex Mod without the Chastity Belt Mod changes, you can not extract it or download the stand alone version:

Just a head's up, the game does not reuse ropes. I tried it, and it consumes them every time. Could you re-adjust your mod to account for it?

As of v1.0a, vanilla should not always consume rope except for a couple of overlooked cases: when the player uses teleport stones and when the player ends sex with ropes still on slaves. These will both be fixed in 1.0b, which will be completed sometime this week, not sure when it will be released.

As Ank said it should be fixed soon in the base game and it didn't make a lot of sense for the mod to do work that the base game was already doing which why I removed the rope reusage stuff in this recent version.


Turns out that the rope in the base game cannot be reused.

Updated for Strive version 1.0c.

Updated for Strive version 1.0d.

(2 edits)

When I activate the mod and load a new game, I get an error message in the console: 

SCRIPT ERROR: GDScript::reload: Parse Error: Expected indented block after 'if'

 At: res://files/scripts/

ERROR: reload: Method/Function Failed, returning: ERR_PARSE_ERROR

 At modules/gdscript/gdscript.cpp:580

I'd imagine I somehow fucked up somewhere in installing it, but I'm not sure where.

EDIT: Nevermind, sorry. It appears to be a problem with my game, not this mod in particular.

Nope, it's because of this mod (or my failure to properly install it, I have no clue).

I haven't been able to exactly duplicate your error message, but I got lines 338 and 580 with the same messages so I think I've gotten fairly close. I managed to get those errors by using the current version of this mod with version 1.0a of Strive. I get no errors when using the most recent version of both.

Like ankmairdor said, looks like you may be using the wrong version of Strive. You need the latest version of Strive (1.0d) for the latest version of this mod.

If you really want to Stay on Strive 1.0a, you can use the version of CB mod for that version 

Bingo. I wasn't aware that v1.0d was a thing (I skimmed over the title), as I thought the main page was updated (it says v1.0a is the latest version).

Thank you.

Glad you could get it sorted.

Thank you.

Do you mind making past updates of your mods available once again? I'm trying to use Leo's expansion which only works for 1.0a, but the only versions of your mods available are for 1.0d.

Here is the link for the old version that works with Strive 1.0a

There will likely be a bunch of conflics with Leo's mod which you would have to sort out if you wanted to use both together.

(1 edit)

Thanks a lot. Also, he said he specifically tested them and Expanded is intended to be used with it, but Chastity Belt won't work.

I cant seem to get this to work. I downloaded the win64 public version 1.0d from the website. then downloaded this mod 1.3d. extracted this mod into the mod folder. and then activated both es-01 and es-02 with es-01 being on top. but then when im done with the char creation and it loads in as soon as it hits 99% it exits the game. I have no other mods active so im not sure where the error could be in.

Any1 know a solution or has the same issue?

(2 edits)

Normally you can check the log file located in the AppData, next to where you put the mod folders. (on Windows: %appdata%/Strive/logs)

If it's empty after the game closes, then I'd recommend trying the Debug mod( and checking the second window for errors. 

Edit: if you are changing the code yourself, then it will be tricky to help.

SCRIPT ERROR: UndoTempReleases: Invalid call. Nonexistent function ' cbMod' in base 'reference (' .

at: res://files/scripts/

is it missing a file or something?

(1 edit)

Your file is missing a critical mod function, which means that the mod did not install correctly or the file was tampered with afterwards. Edit: this problem seems to be specific to you, as it installed fine for me.

This is weird, because I had the problem i deleted everything, strive game, the mod and even the strive folder at appdata and redownloading everything, 3 times so far and it still just crashes.

This file, is it possible for you to upload it somewhere so i can download yours and throw it into my folder or does that not work

Indeed manual replacement is a possible fix, it would behave the same as manual code changes, but will be erased if you use the mod system to add or remove mods. You should be able to copy the contents of the file "...\Es-02-ChastityBelt\scripts\" directly into your version of the file and add it to the end of the file with a decent text editor (crude editor's like Window's Notepad do not handle newlines correctly). But the larger issue is that such problems tend to not appear alone, and you may find yourself fixing many files.

Just to be sure, the mod system does not report any problems with applying the mods? It should be fairly sensitive to most issues, though the bugfix mod improves that a bit. It should report a lot of unused files, but the new actions folder,, and can be ignored.

Thanks for the help mate, coppying stuff into my folder fixed the startup crash issue. heres hoping that was the only issue

It does sound like the mod has not been fully installed but I'm not sure what has happened to cause this and I would expect more issues to pop up if you fixed it my copying the contents of in manually. Have you installed other mods before?

Yeah in the end it didnt fix it completely. i didnt crash at start anymore, but when initiating sex and putting on chastity belt, as soon as i leave the sex screen and back to mansion a box shows up(supposibly have text in it but its empty) and i cant do anything at that point but just exit game.

I have installed diffrent mods before without issue. this one just seems to not install correctly. im using a new downloaded game so nothing is altered and there are no other mods installed on it, so its strange and my computer is just a dum dum.

When i try to apply the mod to the game it shows this, and when i start the game the only button that works is the mod button, all others from the main menu does not work. Can you help me?

Mod list has been changed. Game must close for changes to take effect.

No errors recorded.

Additional Mod Installation Information:

These are not errors, but may indicate the source of install problems.

Script files unique to mod (these scripts have a new relative path compared to game files):

























user://mods/Leo mod v1.7 for Strive v1.0d/Leo/


The messages you post do not indicate any problem with applying the mods; however, that is entirely different from the mods not creating code conflicts. Without seeing the error logs (found in the user data) I cannot be certain, but your problem is probably that you applied both Chastity Belt and Leo's mod. Leo states in the first post for his mod:

Tested with ES Expanded sex mod. Not compatible with Arics mod family. Not compatible with Chastity belt mod.

You probably need to remove either the Chastity Belt mod (Expanded Sex is fine) or Leo's mod to get it to work. If that does not work, then it is possible that you will need to copy the files manually from the "backup" folder into the "files" folder to get back to vanilla.

thanks sadge

hey, I know it is old but I am having the same issue and I even reinstalled the base game and only got this mod and still got this same issue. May you share how did you deal with this? Or did you ever over come it?

The mod kind of worked as I can pick the starting companion to be the key keeper but everything else do not work.

New version 1.3e

Changes for 1.3e:

  • Compatibility fix with mod: "Bugfix for 1.0d - V3 by ankmairdor". This mod works with or without the ankmairdor Bugfix mod

Darin I wanted to say that your mod is amazing! it changes the whole game experience and it is really well done.

are you going to keep updating it? maybe add more features?  i would love to give you suggestions, is there any way to contact you?

thanks for your amazing work!

Glad you like the mod.

I've not done any significant work on the mod for a while now and I have no current plans to any time soon.

Suggestions are welcome and I have implemented a few in the past if they interested me and were not too hard to implement.

Feel free to post suggestions in this thread if you like. I'm also on the Strive Discord server.

(1 edit)

wish this still worked with Arics Expansion

I don't think this ever worked with Arics.


If it did, that's news to me. We can make it work if you want. :P


I also think they were compatible sometime around 0.5 version. Recently I wanted to replay the game at 1.0 + your Expansion and I'm really missing the belts.

I remember you specifically making a compatible version on the older post. I think I still have it downloaded.

Both mods have moved from Strive 0.5.25 to 1.0d. It is very unlikely for mods from previous versions of Strive to remain compatible with the new version. Also, Aric's mod has increased significantly in scope, making it far more difficult to combine it with other mods. Furthermore, Aric's mod is in active development with new versions being released somewhat frequently, so any attempt to make a compatible version could be outdated in a week or two, especially as we are in the process of overhauling the mod's changes to the sex system.

If you wish for these two mods to be compatible, then I recommend learning how to mod Strive as that will be the fastest way to get what you want. I recommend using an online interactive Python tutorial to learn the programming basics, then switch to learning gdscript, the language that Strive uses, which very similar to Python. From there you can simply open up the Strive script files(.gd) with any decent text editor or the Godot Engine and have a look at the game's code.

(1 edit)

I don't want it that badly to learn this games code. I guess I'll just deal with it.

Having trouble installing the mods as directed... there's a litany of errors all saying "ERROR Restting file (File not found)". 

Also noticed that despite the download folder having "Version 1.3e" in the title, the in-game mods list says that both mods are "Version 1.3 Updated for Strive version 1.0a." 

Possibly the download link is headed to the wrong spot? Or am I just an idiot?

There are typos in the version information, but the mod itself is reliable.

"ERROR: Resetting file" means that there is a problem with using the "backup" folder found in the Strive program folder. "(File not found)" means that your "backup" folder appears to be empty. There are generally 2 causes for this: you are playing on MacOS or you have permissions problems with the Strive program folder. If you have MacOS, then use this post to follow the guide for setting up for mods:

Otherwise, you will need to setup your Strive program folder to a location with less restrictive permissions like the Desktop or some kind of documents folder. On Windows, the "Programs Files" folders are generally the worst place to put it but there are other folders that can have permission restrictions, so you may have to try a few locations. Generally you should be able to simply move the folder to the new location, but occasionally people have managed to inherit the permissions onto the program folder.

Interesting. I'm on Windows and have been fiddling around with the folders and still haven't found a solution. I'm going to try a complete reinstallation just for the sake of it.

This is an updated version that is hopefully compatable with bugfix v6.  This is not an official version and not fully supported. I tested a play through with the following mods loaded (the order is important):

Bugfix v6 - Random Portraits - Leo's v1.8 - Expanded sex 01 - Chastity Belt 02 (this version).

Changes - Some date validation for bugfix v6, removal of sex action 304 & 305 files from CB that were duplicted in ES, removal of multiple partners on chastity release (clash with bugfix v6).

I might be blind but I can't find the chastity belt or an option for it. The mod is loaded though

At the start of the game you can designate the starting slave as a keyholder. When you first have sex with the keyholder the chastity events start.

Hey, is this compatible with arics or should I just play with one or the other?