Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Karlstens

6
Posts
5
Topics
6
Following
A member registered Apr 25, 2017

Recent community posts

That feeling, where all I want to do is give you the deepest hug. My dude, this plug-in is amaze. Thank you.

(1 edit)

Hello,

I'm running GMS2 2.3 (STEAM) - Windows 10 (build ver 1909).

I've just purchased this app through the Yoyo market place, but the media file downloaded is different;

1580232283_cc.yal.gmlive.yymp

Where I see on the itchio page, the file to download is called;

GMLiveForGMS2.3+.yymps

The data imports into my GMS2 project OK, but running the below executable crashes;

datafiles\GMLive>gmlive-server.exe

The CMD output reads errors;

c:\DEV\Object Tags\datafiles\GMLive>gmlive-server.exe
Loading `c:/DEV/Object Tags/Object Tags.yyp`...
Called from ? line 1
Called from live/server/GmlLiveServer.hx line 277
Called from live/server/GmlLiveData.hx line 306
Called from live/server/GmlLiveData.hx line 228
Called from C:\Tools\Dev\HaxeToolkit\haxe\std/haxe/format/JsonParser.hx line 57
Called from C:\Tools\Dev\HaxeToolkit\haxe\std/haxe/format/JsonParser.hx line 90
Called from C:\Tools\Dev\HaxeToolkit\haxe\std/haxe/format/JsonParser.hx line 117
Called from C:\Tools\Dev\HaxeToolkit\haxe\std/haxe/format/JsonParser.hx line 90
Called from C:\Tools\Dev\HaxeToolkit\haxe\std/haxe/format/JsonParser.hx line 85
Called from C:\Tools\Dev\HaxeToolkit\haxe\std/haxe/format/JsonParser.hx line 314
Uncaught exception - Invalid char 125 at position 94

And obviously running my project with the obj_gmlive embedded in the first room simply generates a lot of compile errors :(

Script: gml_node_seek_all at line 1 : Fatal Error while compiling - bailing details below
Script: gml_parser_run at line 438 : got 'switch' expected '}'
Script: gml_std_string_hx_trim at line 8 : Assignment operator expected
Script: gml_node_is_simple at line 15 : Assignment operator expected
Script: gml_node_is_simple at line 17 : got 'return' expected '}'
Script: gml_node_equals_list at line 7 : Assignment operator expected
Script: gml_node_equals at line 662 : Assignment operator expected
Script: gml_node_equals at line 664 : got '>=' expected '}'
Script: gml_node_seek_all at line 202 : Assignment operator expected
Script: gml_node_seek_all at line 204 : got 'l_i' expected '}'
Script: gml_parser_run at line 436 : malformed assignment
Script: gml_parser_run at line 1 : Fatal Error while compiling - bailing details below
Script: gml_std_string_hx_trim at line 8 : malformed assignment
Script: gml_std_string_hx_trim at line 1 : Fatal Error while compiling - bailing details below
Script: gml_node_is_simple at line 15 : malformed assignment
Script: gml_node_is_simple at line 1 : Fatal Error while compiling - bailing details below
Script: gml_node_equals_list at line 7 : malformed assignment
Script: gml_node_equals_list at line 1 : Fatal Error while compiling - bailing details below
Script: gml_node_equals at line 662 : malformed assignment
Script: gml_node_equals at line 1 : Fatal Error while compiling - bailing details below
Script: gml_node_seek_all at line 202 : malformed assignment
Script: gml_parser_run at line 436 : Assignment operator expected

Appreciate any help I can get, as I'm very keen to get this plugin up and running. :)

Thanks for such a cool app, really enjoy creating 2D sprites for my games from 3D models.

I would love to see a shader drop down menu and some shader toggles (bloom and bloom intensity for example) that the user can configure prior to batch exporting to 2D sprites. Similar to such settings found with online 3D viewers such as p3d.in or sketchfab.com 

Would be handy to have this. :)

Yes, I'd love to see further shader and lighting options added for sprite output.

(2 edits)

Changing the Anti-alias setting to medium seems to have corrected the issue. Will provide an update after further use. Thanks!

EDIT: Erk, problem is back, with both Anti-alias and v-sync options off.

Whilst the slowdown bug is happening, all other Windows apps are also impacted too.

EDIT: Thing my GPU is on the fritz... RoR2 now hard resetting. :(

(1 edit)

Hello,

Brilliant app, but I seem to keep encountering massive lag that appears random, even after a clean reboot. It seems to impact the entire system too, only whilst the app is running. During the lag, it also caused a system reboot without bluescreen or error.

When the lag begins, I can usually make my way to closing the app in between the lag-pauses, where the app eventually does close - unless the system restarts before I get to close it.

Are there any other reports of users with this issue? What details may I send you to further troubleshoot? 

I'm on Windows 10, 24GB Ram, SSD, i7 2600K running a Geforce 770GTX - a few years old, yes - but it handles Risk Of Rain 2 just fine. :)

Got it.  🍦 

(1 edit)

Hello, 

First of all, OMG THIS APP IS AMAZE. 

Secondly, may I request the ability to center/re-align the 3D model in prep of 2D x 32 sprite output? If the model is built off-centre, then exporting introduces an offset axis effect, rather than the model spining about its volumetric centre. 

(Perhaps this feature exists, I'm still very new to the app)

Awesome, can't wait!!! Subscribed. :)