Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

The game starts but there is some weird black fog that doesnt let me see the entire map, i just can see things when i am next to them. Everything else goes dark. 

Specs:

OS: Kubuntu 18.10 (KDE)

Ram: 4 GB

Graphics card: Geforce 940 MX (2GB)

Graphics driver: NVIDIA 430.09

OpenGL:  4.6.0 

(+1)

Yeah its seems like the Linux version is broken now, because of one assets error. I'm discussing the problem with the assets creator, what we can do with this now. 

Thanks!

So that's why it isn't listed for Linux now?

Yep, you cant se farther then 1m in the game, its unplayable on Linux right now. I'll need some time to fix this.

I just tried 0.9.5 (downloaded it before you took it down but hadn't tried it) and it seemed fine on my system. I didn't do any extensive testing, but I could see pretty far in game.  SteamOS  beta, Nvidia GeForce GTX 960 (415.27 drivers).

https://steamcommunity.com/sharedfiles/filedetails/?id=1756930648

Yeah thats used a different technic for volumetric lights. I changed that to make it run smoother on linux, and thats backfired a little bit. There is a small bug, which will be fixed, but I'm waiting for someone to help in that, couse I'm not that good in shader programming.

oh, okay, thanks for the clarification!

Any progress?

Actually I'm searching someone who wuld try out one new test build. This is just on level with varied shaders. Hopefully this wont be that "black" https://www.dropbox.com/s/03u67nqfomattx4/01.zip?dl=0 If you have time, please telle me, what you experienced. ;)

(5 edits)

Tested it quickly on my work machine. An intel iGPU, so test was run in a 1280x720 window at a horrendous framerate, but seems like the bug is still there. Screenie below.

PS: First launch showed me a black screen for minutes after the unity logo, compiling shaders no doubt. Started quickly the second time.

EDIT: Errors in Unity's Player.log, maybe due to the iGPU?

The referenced script on this Behaviour (Game Object 'Light') is missing!
(Filename: ./Runtime/Mono/ManagedMonoBehaviourRef.cpp Line: 333)

and

OpenGL Error: Invalid texture unit!

(Filename: /home/builduser/buildslave/unity/build/Runtime/GfxDevice/opengles/DeviceStateGLES.cpp Line: 72)

The same problem on my gaming box with AMD graphics, errors and all.

Unfortunately, I am having the black fog on my system, too. The framerate seems fine but I cannot see anything until I get very close! AMD FX-9370 w/ 16Gb RAM, Nvidia GTX 970 with 430.26 driver, openSUSE Tumbleweed.