Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Problem installing some games on Linux

A topic by dimethylhexane created 27 days ago Views: 181 Replies: 10
Viewing posts 1 to 5

Hi, I've been trying to install some games using the itch app on Ubuntu 18.04 and there's been a problem with most of the ones I've tried. The games seem to download - the loading screen in the bottom right shows the download taking place - but then it just stops, it doesn't go into the library and the button on the game goes back to "Install" rather than "Launch" (it briefly shows "Installing..." but goes back to "Install").

I've tried to install the following games and none of them have worked:

The only game I've managed to install correctly is Baba Is You.

I've managed to run A Short Hike by just downloading the file from Firefox and extracting the zip file, and it seems to run fine, so it does appear to be an issue with what the app's trying to do.

I've tried looking at the logs in ~/.config/itch/logs and I'm not sure entirely what's going on, though there is an interesting difference in that Baba Is You seems to be extracting a .tar.gz file while all the others are extracting .zip files.  In case it helps, I've included the lines in the log for the failure of A Short Hike as an example in the link below. The other failed installs produce results similar to this with similar error messages.

https://pastebin.com/7ccvwznv

On the error log that you posted, I can see on line 78 this:

operation not supported\ngithub.com/itchio/ox.Preallocate\n\t/root/go/pkg/mod/github.com/itchio/ox@v0.0.0-20200301160301-4e131878ba64/preallocate_others.go:28\ngithub.com/itchio/savior.(*FolderSink).Preallocate\n\t/root/go/pkg/mod/github.com/itchio/savior@v0.0.0-20200303195615-7cac7998294c/folder_sink.go:186\ngithub.com/itchio/savior/zipextractor.(*ZipExtractor).

This seems to be related to what you described, and seems to be an error because the project is in a .zip file and the app can’t extract it.

I tried on my machine, and I downloaded two projects, one with .tar.bz2 and one with .zip files, and they both work. Could it be that there is something misconfigured on your system? If I may ask, what distro are you using? Do you have a program installed to unzip files? (I’m not sure if the Itch app is using it’s own unzip-er or expects the system to provide one)

I'm using Ubuntu 18.04.4 LTS 64 bit - let me know if you want any more information on my setup and I can try to look it up. It does look like there is a program to extract zip files as it manages to extract them fine in another install folder in a different partition (see my reply to Blubberquark Software's post below)

I have seen the same bug a while ago in the itch beta, and now that code is in production. I should have told Amos...

Anyway, is your home directory/itch directory mounted via FUSE or eCryptFS?

Facing a similar problem with Ubuntu 18.04 and A Normal Lost Phone just now, home directory is mounted via eCryptFS (I think). Managed to get Night in the Woods, PICO-8, and Celeste installed a month or two ago.

I admit i'm not entirely sure how to check which of those is mounting it. The directory is in a NTFS partition mounted by /etc/fstab - the relevant line is here:

UUID=1646E9926F0B62FE /home/jen/Media ntfs rw,auto,users,exec,nls=utf8,umask=003,gid=46,uid=1000    0   0

Interestingly, I have been able to install games in my home folder (~/.config/itch/apps), which is in the same ext4 partition as the root directory.  From this I have gotten a hacky solution to this issue where I install it into the home install folder and then just cut+paste the files over to the other partition, from which I can still run the game but obviously will cause complications down the line if anything ever needs updates.

(+1)

I'm pretty sure I know what causes the bug, and it's that this https://github.com/detailyang/go-fallocate/blob/master/fallocate_linux.go library that butler uses since the last revision doesn't implement the behaviour of posix_fallocate from libc.


Your use of NTFS is another case in point, fallocate probably fails. Either Amos fixes this in butler/ox, or we make a feature request in go-fallocate, or the linux NTFS drivers implement fallocate. I'll file a bug report in ox and go-fallocate now.

(1 edit) (+1)

A **super hacky** workaround is downloading an old butler v15.17 binary from here: https://broth.itch.ovh/butler and replacing the butler binary in your itch installation. What makes it **super hacky** is you need to overwrite the v15.18 binary to trick itch into thinking you have the latest butler version, otherwise itch will update from 15.17 to 15.18 again and overwrite the binary that works. Well, if this is fixed in 15.19, itch will think you're on 15.18 and overwrite the hacky workaround, so it won't mess up your itch installation for eternity, I think. Only do this if you know what you're doing.

My butler binary was at 

~/.config/itch/broth/butler/versions/15.18.0/butler

While it isn't really a solution to the problem and probably not worth the trouble, it's fairly easy to install a web server on ubuntu. I think if you decompress the zip in a directory you could run games in a browser, much in the same way itch does.

Admin (1 edit) (+1)

See https://github.com/itchio/ox/issues/3

butler v15.19.0 is out with this fix.

As usual, the itch app will automatically update to it over time, but you can force the update by going to Preferences (bottom-left button in sidebar), scrolling down to “Advanced”, and clicking “Check for updates”

After that, it should look like this:

image

(Please report back with whether or not this fixed your issue on NTFS, ZFS and eCryptFS filesystems)

(+1)

Thanks Amos and Blubberquark Software for looking into this - I've updated butler to 15.19.0 and games are now installing correctly on the ntfs partition.