Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Celeste

Brave hundreds of hand-crafted challenges as you help Madeline survive her journey to the top of Celeste Mountain! · By Maddy Makes Games

Can't lauch

A topic by Flores04 created Jun 10, 2020 Views: 4,382 Replies: 29
Viewing posts 1 to 11
(+7)

Hello! I am downloading Celeste for the first time and the game does not launch. I am probably just doing something wrong, so if anyone could help I would appreciate a lot. After I downloaded the game (windows 10) and extracted the application to my desktop, the game simply does not lauch and it does not show any error log. The only way I can lauch the game is by executing the application directly on the winrar folder. In this way I can play the game normaly, but it does not save. So I actually don't know which problem it is exactly and what I can do to solve it.

(+3)

I'm having the exact same issue, also on win10.

(+1)

I had to instal the OpenGL version for it to work for me!

(+2)(-1)

I also installed this version, but it did not work too. I also downloaded XNA Redistributable on Windows, but did not make a difference. Does anyone have an ideia of what I could do?

(+2)

Worked for me, thanks!

(-1)

The game requires the following as mentioned on the bundle download page:

This game requires XNA Redistributable on Windows:
https://www.microsoft.com/en-ca/download/details.aspx?id=20914

Thanks I downloaded this, but when i run the set up it says "Microsoft XNA Framework Redistributable 4.0 setup wizard ended prematurely"...

You're a life saver!

Hi, did the game create an "error_log.txt" in the same folder as Celeste.exe? If so, could you post that.

It did not on my end, but the OpenGL version of the game works as expected.

(+2)

Hello, I'm having the same problem here. I downloaded the XNA Redistributable and it just freezes my whole computer when I launch

Same problem here! Game won't lauch

(+4)

If you're unable to launch on Windows I would

  1. Make sure you have XNA Redistributable installed
  2. Make sure you have .NET Framework 4.5 installed
  3. Once those are installed, if it still doesn't launch, try the OpenGL Windows Version instead
  4. If that doesn't work, check to see if there is an "error_log.txt" in the Celeste directory, beside Celeste.exe, and post it here
  5. If there is no error log, and neither version runs, send me your PC specs I guess ... at this point I'm not sure what could be causing the problem.

Hi, thank you so much for the answer. I'm posting here the first error log that I got a few days ago when using the normal windows version. I tried to download the openGL version, but it did not launch anyway and it didn't show the error log anymore.

Celeste Error Log
==========================================

Ver 1.3.1.2
09/06/2020 23:10:56
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Monocle\MonocleDefault". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Monocle\MonocleDefault.xnb". File not found.
   em Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   --- Fim do rastreamento de pilha de exceções internas ---
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   em Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   em Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   em Monocle.Draw.Initialize(GraphicsDevice graphicsDevice)
   em Monocle.Engine.LoadContent()
   em Celeste.Celeste.LoadContent()
   em Microsoft.Xna.Framework.Game.Initialize()
   em Monocle.Engine.Initialize()
   em Celeste.Celeste.Initialize()
   em Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   em Monocle.Engine.RunWithLogging()

Ver 1.3.1.2
09/06/2020 23:07:09
System.DllNotFoundException: Não é possível carregar a DLL 'fmodstudio': Não foi possível encontrar o módulo especificado. (Exceção de HRESULT: 0x8007007E)
   em FMOD.Studio.System.FMOD_Studio_System_Create(IntPtr& studiosystem, UInt32 headerversion)
   em FMOD.Studio.System.create(System& studiosystem)
   em Celeste.Audio.Init()
   em Celeste.GameLoader.LoadThread()
   em Celeste.RunThread.RunThreadWithLogging(Action method)

Ver 1.3.1.2
09/06/2020 23:05:21
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Monocle\MonocleDefault". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Monocle\MonocleDefault.xnb". File not found.
   em Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   --- Fim do rastreamento de pilha de exceções internas ---
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   em Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   em Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   em Monocle.Draw.Initialize(GraphicsDevice graphicsDevice)
   em Monocle.Engine.LoadContent()
   em Celeste.Celeste.LoadContent()
   em Microsoft.Xna.Framework.Game.Initialize()
   em Monocle.Engine.Initialize()
   em Celeste.Celeste.Initialize()
   em Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   em Monocle.Engine.RunWithLogging()

Ver 1.3.1.2
09/06/2020 23:04:53
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Monocle\MonocleDefault". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Monocle\MonocleDefault.xnb". File not found.
   em Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   --- Fim do rastreamento de pilha de exceções internas ---
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   em Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   em Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   em Monocle.Draw.Initialize(GraphicsDevice graphicsDevice)
   em Monocle.Engine.LoadContent()
   em Celeste.Celeste.LoadContent()
   em Microsoft.Xna.Framework.Game.Initialize()
   em Monocle.Engine.Initialize()
   em Celeste.Celeste.Initialize()
   em Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   em Monocle.Engine.RunWithLogging()

Ver 1.3.1.2
09/06/2020 23:02:56
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Monocle\MonocleDefault". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Monocle\MonocleDefault.xnb". File not found.
   em Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   --- Fim do rastreamento de pilha de exceções internas ---
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   em Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   em Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   em Monocle.Draw.Initialize(GraphicsDevice graphicsDevice)
   em Monocle.Engine.LoadContent()
   em Celeste.Celeste.LoadContent()
   em Microsoft.Xna.Framework.Game.Initialize()
   em Monocle.Engine.Initialize()
   em Celeste.Celeste.Initialize()
   em Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   em Monocle.Engine.RunWithLogging()

Ver 1.3.1.2
09/06/2020 21:39:39
System.DllNotFoundException: Não é possível carregar a DLL 'fmodstudio': Não foi possível encontrar o módulo especificado. (Exceção de HRESULT: 0x8007007E)
   em FMOD.Studio.System.FMOD_Studio_System_Create(IntPtr& studiosystem, UInt32 headerversion)
   em FMOD.Studio.System.create(System& studiosystem)
   em Celeste.Audio.Init()
   em Celeste.GameLoader.LoadThread()
   em Celeste.RunThread.RunThreadWithLogging(Action method)

Ver 1.3.1.2
09/06/2020 21:38:14
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Monocle\MonocleDefault". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Monocle\MonocleDefault.xnb". File not found.
   em Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   --- Fim do rastreamento de pilha de exceções internas ---
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   em Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   em Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   em Monocle.Draw.Initialize(GraphicsDevice graphicsDevice)
   em Monocle.Engine.LoadContent()
   em Celeste.Celeste.LoadContent()
   em Microsoft.Xna.Framework.Game.Initialize()
   em Monocle.Engine.Initialize()
   em Celeste.Celeste.Initialize()
   em Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   em Monocle.Engine.RunWithLogging()

Ver 1.3.1.2
09/06/2020 21:38:06
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Monocle\MonocleDefault". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Monocle\MonocleDefault.xnb". File not found.
   em Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   --- Fim do rastreamento de pilha de exceções internas ---
   em Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   em Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   em Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   em Monocle.Draw.Initialize(GraphicsDevice graphicsDevice)
   em Monocle.Engine.LoadContent()
   em Celeste.Celeste.LoadContent()
   em Microsoft.Xna.Framework.Game.Initialize()
   em Monocle.Engine.Initialize()
   em Celeste.Celeste.Initialize()
   em Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   em Monocle.Engine.RunWithLogging()

The error logs above say that the game is unable to find Content (graphics / font files / etc). Is it possible the game is missing those, or you are running it from a location where it doesn't have read access? There's also a chance it thinks the working directory is somewhere else due to how it was launched, but that is unlikely unless you ran it through command line.

I've got the same problem and i'm sure it has read access and the content folder, so idk what to do.

So after finding this on the community page due to having the same issue but this comment, most specifically

"or you are running it from a location where it doesn't have read access?"

It got me thinking maybe the whole folder didnt get extracted and it turns out that the "Content" folder got left out.


To address the issue I simply extracted the "Content" folder into the same place that I had the full "Celeste" file and for neatness I had made a folder for the extract.


Hopefully I help other people get access to the game as well, cheers.

I've tried all this and the game still does not launch.  There is no "error_log.txt" in the directory.  I don't see how it could be my computer specs....

Processor: intel 8th gen core i7-8750H

Graphics Card: NVIDIA GEFORCE GTX 1060

Windows 10 is up to date

Yeah, that all looks totally fine. Is it possible the game is being launched in a location where it doesn't have read/write access? I'm trying to think what could be happening, but without any kind of error log it's difficult to debug :/ Celeste itself is a pretty simple .NET Framework 4.5 C# application, so it should at least launch and be able to make an error log of some kind. Sorry I don't have a better solution for you!

(1 edit)

hey Noel, i know your post is "a bit" old, but if you respond me, great. i have already installed everything, but it won't launch, so, here's my PC  specs:

3 GB Ram

Dual Core 2,00 GHz

64 MB Dedicated Video Ram

Graphics card:Mobile Intel 965 Express Chipset Family

idk :/ is probably my graphics card or my processor but  ok hope u respond me :D

Hey, does the game create an error_log.txt file?
You could alternatively try the OpenGL version for Windows and see if that works!

(1 edit)

POTENTIAL SOLUTION -  

i had a problem where i had both of these - 

 XNA Redistributable installed

.NET Framework 4.5 installed

but it still wouldent open, and came up with an error code - 

Ver 1.3.1.2
11/06/2020 22:31:41
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Monocle\MonocleDefault". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Monocle\MonocleDefault.xnb". File not found.
   at Microsoft.Xna.Framework.TitleContainer.OpenStream(String name)
   at Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   --- End of inner exception stack trace ---
   at Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
   at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   at Monocle.Draw.Initialize(GraphicsDevice graphicsDevice) in C:\Projects\C#\Celeste\Celeste\Celeste\Monocle\Util\Draw.cs:line 44
   at Monocle.Engine.LoadContent() in C:\Projects\C#\Celeste\Celeste\Celeste\Monocle\Engine.cs:line 196
   at Celeste.Celeste.LoadContent() in C:\Projects\C#\Celeste\Celeste\Celeste\Celeste.cs:line 125
   at Microsoft.Xna.Framework.Game.Initialize()
   at Monocle.Engine.Initialize() in C:\Projects\C#\Celeste\Celeste\Celeste\Monocle\Engine.cs:line 184
   at Celeste.Celeste.Initialize() in C:\Projects\C#\Celeste\Celeste\Celeste\Celeste.cs:line 113
   at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   at Monocle.Engine.RunWithLogging() in C:\Projects\C#\Celeste\Celeste\Celeste\Monocle\Engine.cs:line 339

if u look it seems like it cant find a monocle or something, i had 3 different folders with celeste stuff in each, stuff like the application, error log and whatever fmod is in one, then i had two different files called backups and content. because it said file not found i tried making its job easier and basically just chucked all the Celeste stuff on my computer in one folder and it works fine, the application opens and it had  my previous save.

i dont know if what i did actually fixed it or if it just fixed itself, but it worked for me.

(+1)

HEY THIS JUST WORKED! I have no idea why, but extracting all the files no one folder in my desktop solved all the problems and the game seems to be running normally. Thank you very much!!

(4 edits) (+1)

To help me with future problems, can you show me how the folder structure looked when it didn't work? It should look like this (the OpenGL version will have additional DLL files but it should generally be the same):

When it didn't work I had just extracted the "content" folder togheter with the application. It worked when I extracted ALL the files to the same folder (in the desktop). It was probably just a dumb mistake that I did, but thank you very much for the help.

And it also seems to only work in the OpenGl version

(+2)

Hey everyone! I apparently fixed the problem only by extracting all the files to a folder in my desktop. I don't know if this solved it, but the game seems to be running normaly. Note that I have downloaded the programs suggested in this topic and I'm using the openGL windows version. Thank you all for answering and I hope that you who couldn't launch the game either can solve the problem too!

i have a windows 8 and nothing is running for me.  Maybe just the computer but am i doing something wrong? Nothing will launch.

Did you try the steps listed here?
https://itch.io/t/833743/celeste-wont-run-on-windows-help-info

If so, does the game create an error_log.txt?

took me a while but I finally got it working ^^