Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs
Tags

Ephemeral Tale

An inevitable end. An unstoppable beginning. · By Dawdling Dog, ltd.

Bug Reporting 101 (Updated 6/28) Sticky

A topic by Dawdling Dog, ltd. created Feb 01, 2020 Views: 430 Replies: 39
Viewing posts 1 to 6
Developer (3 edits)

Hey all,

If you run across any issues during your playtime with Ephemeral Tale, please feel free to post them in this thread and see if they've already been addressed or are on the bug watch list. Really, report them in whatever fashion is most convenient for you: Twitter, email, here-- whatever works.

As I am just one guy, I would ask that you have patience in regards to any bugs that you do encounter or come across. Finding, recreating, and solving these bugs is a time consuming process. With that said, here is the "bug watch list":

  • COSMETIC ONLY - Opening the save menu and then backing out to the main menu can sometimes cause the main menu to open with the save menu’s backdrop
  • On certain machines, the screen can appear "zoomed in" in specific areas (like the Forgotten Forest). This can be worked around by setting the Visual Filters option to OFF, and restarting the game.
  • The name input screen can get a lil weird if you input a name like "MMMMMMM"
  • Save files can report inaccurate play times under certain circumstances [Solution being worked on]
  • Using consumable items can intermittently enter a state where the confirm button becomes unresponsive [Investigating]

Anything tagged "Cosmetic Only" means that the bug is purely visual, and that no save data/game state/etc has been impacted by these.

Performance related bugs (like the last one on the list) are currently being investigated, with a patch planned for the future. I'm not comfortable committing yet to a time frame on that, as we want to ensure that we do it properly.

(1 edit)

Windows 10 Home; tried launching the game (EDIT: latest version put up yesterday) and nothing popped up for over a minute straight. It even caused Task Manager to stop responding and for the Details tab to take over 10 seconds to show its list. When the game finally popped up, it got stuck in "Not Responding." I'm not sure of what's going on but this is the first bundle game that's caused a problem on this level for me.

Developer

Thanks, Keron-- I'll investigate. Out of curiosity, does a reboot resolve the issue & what anti-virus solution do you use? I've had reports from users that their anti-virus software gets freaked out by the way the game loads content (which is to dump the game into RAM for consistent loading times across devices), and have had to report it to a few of the major players to get it cleared.

I'm not sure that I want to try again without seeing any version update considering the noticeable impact it had on my processing. The only active guardian of any kind that I have going on is Kaspersky Free which mentioned nothing (neither did Malwarebytes Free).

Developer

No problem-- I'll try and recreate it on my end.

Developer(+1)

Hi there Keron,
After consulting w/ my internal programmer + some outside programmers, the best bet that we have is that your anti-virus was freaked out by the game. The game runs in a virtual sandbox for both asset protection purposes and stability across a wide array of hardware, and this is sometimes mistakenly flagged as malware by programs like Malwarebytes (that one in particular has thrown flags in the past). If it's attempting to quarantine that specific behavior (behind the scenes or otherwise), it would explain the massive hang. It should be on the whitelist, if at all possible, and if the behavior continues to persist while whitelisted we can try and investigate other avenues to pursue. Longer term (once out of EA, for example), we may try and go to a different platform like UWP or something similar as an alternative for situations like this.

Apologies for the delay, I wanted to make sure that I was talking to folks who knew that stuff well before saying for certain one way or another.
 -- Ryan

I don't know what to do. Even for the newest version that I just now tried, the game window never popped up. Malwarebytes Free does not perform active checks (that's only premium) and it wasn't even running at the time of launch, and none of my other security software gave notice of anything. This situation sucks... but at least it seems to be just a problem with me and not a lot of others.

Developer(+1)

Hey there Keron,

If the game is opening, it should show up twice in the Details tab in task manager:

I'll continue to research it on my end, but in the interim, I can look into packaging a UWP build for the upcoming version on Tuesday, if that would be an acceptable stop-gap? I can't guarantee how Windows would handle save files or anything of the like for version upgrades, as I've never actually tested a UWP build (or version upgrades for them). I can't guarantee weekly updates for that, either, as those builds are somewhat time consuming to get the ball rolling on.

Yep, I've had to kill it from TM each time. And no worries about the timing; I'm in no rush! Thanks for addressing this!

(+1)

Thanks, this answer kinda helped me with my Problem. Everytime I wanted to start the game the exe went missing as if it deleted itself. But my anti-virus had no logs for quarantine/deleting something. After deactivating Avast for a few Minutes I finally got the game to start. And now after the first start it seems that the exe no longer deletes itself when trying to start.

(+1)

Every time I try to use an item out of battle (potions, repair kits, etc) it highlights my character and the game stops reading my inputs. No mouse clicks, no keyboard inputs, no controller buttons. The game isn't crashing, the music keeps playing, it just won't read any button inputs.

Developer(+1)

Hey there Freeshark,

I've seen this happen intermittently myself. I'll add it to the list and try and track it down. Thanks for the report, and sorry for the trouble!

Can confirm I've had that happen too. The game softlocked when trying to use a repair kit.

Developer (1 edit)

Hey there,
I'm still investigating the cause of this bug. It seems to either be two separate bugs, or one bug that presents in different ways. So I'd like to collect more information, if you guys would be so kind:

  1. After a period of time, were you able to cancel out of the menu?
  2. Is it a consistent issue that occurs for you, every single time?
  3. What are your PC specs, if you know them?

I'm starting to get a rough idea as to what might be causing it, but I'm not entirely certain yet. The more information that I have, the better! I'm currently unable to recreate this in any form of consistent manner. So the more I know, the more I have to work with :)

(+1)

After a while I can SOMETIMES get it to back out of the menu, but not with any consistency and I haven't tried timing it

It happens to me every single time, it doesn't matter what kind of item

I'm on a years old lenovo laptop. I don't know the specific specs but I can usually run games like this without any problems. I can run Skyrim and New Vegas on medium settings so I don't think my specs are the problem

I don't know if this is related but I thought to try turning off the visual filters but every time I reset the game the setting goes back to being on

Developer

Hi Freeshark,

I went ahead and made a change on my internal build to try and address the issue. When the next update hits on Tuesday, hopefully it will be addressed. I'm not entirely sure if the change will work, as I can't get the issue to crop up for me, but if it doesn't then I can move towards another attempt at a fix. Sorry for the slow movement on it!

-- Ryan

(+1)

I tried the new update and can report that it's still happening, but now it sometimes works and sometimes becomes unresponsive. I did some experimenting and it'll go back to being responsive after 10-12 seconds.

Developer

Thanks for the update!  I'm gonna have to do some digging into the menu code to figure out what's going on. Sorry for the trouble, and I'm glad to hear that it works to some extent now (even if it's not anywhere close to ideal). I'll get back to you ASAP, once I better know what's occurring or how to approach it.

Tried the new update, the problem is still occurring. Still enjoying the game in spite of it.

Developer

Hey Shark,

Sorry to hear that, but thank you for the update! Can you tell me if there's any form of information in your log file (install location\www\log.txt) if you have it occur and then exit the game? 

Here's the situation: the main menu doesn't use the same input system as the rest of the game for reasons that are valid, but a bit in depth. What's occurring is that there appears to be fringe cases where the input is grabbed, but isn't properly handed off to the menu. It takes 10 or so seconds for this hand off to fail, and that's when it will allow you to try it again. I haven't been able to figure out what causes the hand off to fail, however, as it seems to be tied to hardware in some odd way.

I don't want you to think that I'm blowing you off, as I'm 100% dedicated to getting that bug squashed, just balancing between trying to recreate that bug, working on the weekly stuff, and the behind the scenes stuff. I've been in touch with a few folks trying to figure out exactly what the issue is. It's a very strange bug, and I'm happy to tell you that it's given some incredibly gifted programmers some head scratches!


But yes, if it's printed anything into that log file after the bug occurs (the log is cleared every time you launch the game), please do let me know!

Also, out of curiosity, does it occur when equipping gear or just for consumables? I've only ever seen it impact consumables myself, hence my asking.

I've never had any problems equipping things. I've only ever had it happen on consumables. I realized that I was able to use a "scroll of power" (or something, I don't remember the exact name) during an experiment so it seems to specifically be a problem when I have to specifically use the item on myself such as with potions and repair kits.

To see if anything appeared in the log I opened a save, lost a fight, started the blacksmith's sidequest, and tried using a potion a couple of times and accidentally discovered that the scroll item worked.  The following information was in the log after I exited the game:

[INFO 7/8/2020 07:27:31pm] [ConsoleTrace] Set trace level Debug in file Log.txt
[INFO 7/8/2020 07:28:47pm] custom value
[INFO 7/8/2020 07:28:47pm] custom value
[INFO 7/8/2020 07:28:47pm] custom value
[INFO 7/8/2020 07:28:47pm] custom value
[INFO 7/8/2020 07:28:58pm] 0.03
[INFO 7/8/2020 07:28:59pm] 0.08399999999999999
[INFO 7/8/2020 07:29:00pm] 0
[INFO 7/8/2020 07:29:07pm] 0.03
[INFO 7/8/2020 07:29:12pm] 0.08399999999999999
[INFO 7/8/2020 07:29:14pm] 0.03
[INFO 7/8/2020 07:29:15pm] 0.08399999999999999
[INFO 7/8/2020 07:29:16pm] 0
[INFO 7/8/2020 07:29:19pm] 0.08399999999999999
[INFO 7/8/2020 07:29:20pm] 0.08399999999999999
[INFO 7/8/2020 07:29:22pm] 0.03
[INFO 7/8/2020 07:29:23pm] 0.08399999999999999
[INFO 7/8/2020 07:29:24pm] 0.08399999999999999
[INFO 7/8/2020 07:29:31pm] 0
[INFO 7/8/2020 07:29:32pm] 0.08399999999999999
[INFO 7/8/2020 07:29:33pm] 0.08399999999999999
[INFO 7/8/2020 07:29:34pm] 0.08399999999999999
[INFO 7/8/2020 07:29:38pm] 0.0345
[INFO 7/8/2020 07:29:39pm] 0.08399999999999999
[INFO 7/8/2020 07:29:41pm] 0.08399999999999999
[INFO 7/8/2020 07:29:43pm] 0.0345
[INFO 7/8/2020 07:29:44pm] 0.08399999999999999
[INFO 7/8/2020 07:29:46pm] 0
[INFO 7/8/2020 07:29:52pm] 0.0345
[INFO 7/8/2020 07:29:54pm] 0.08399999999999999
[INFO 7/8/2020 07:34:25pm] false
[INFO 7/8/2020 07:34:47pm] false

Developer

Hi Freeshark,

Do you play on controller, or KB/M?

Developer

Hey Freeshark,

I've got a beta rewrite ready for the menu input issue, and was curious if you would be willing to give it a whirl.

I'd love to, but my old laptop finally gave up the ghost and refuses to turn on. I've got a new computer ordered but it isn't coming until next month.

Developer

I will make sure to put an F in the chat for your fallen comrade. Do you happen to have an Android phone? If so, I can get you on a beta branch over there in the coming days (not necessarily for testing the issue, just for your own enjoyment).

My laptop was delivered early and I'm pleased to report that on an Alienware M15 R2 that the menu freezing bug is not an issue.

Developer(+1)

I'm so glad to hear that!! Thank you for your incredible patience, and I hope you enjoy the game <3

Hi, when playing with a controller, when I select a consumable item such as a potion, the game immediately selects my character and uses it, even when I have a companion with me. If I use the mouse, this does not occur and I am able to use consumables on companions.

Developer

Hey there,
Seems that an old bug popped up at some point in our internal re-write of the menu code. Should be fixed in Tuesday's patch, as we've rolled back the menu to an older version while we finish the overhaul. Thanks for the notice!

I'm still having the same issue as of 09/10/20.

Developer

Thanks for the report. I'll investigate it. <3

Text error prior to fighting Tyronius Rex.  "There's an [18ominous"

Also, when you use the skill tree why does the dialog box after say [128]

Developer

Good catches! The [128] was a debugging check that got left in there by accident. Both should be fixed in the next patch.

(+2)

Hi, trying to run this on Pop!OS via Wine, and I get the following error:

wine: Unhandled page fault on read access to FFFFFFFF at address 7BC678BC (thread 0039)

I don't know if that is any use in troubleshooting. Itch tries to make their desktop app use Wine to improve cross-platform play, but it doesn't work there either.