🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

butler push updates not showing up in Feed

A topic by BunnyGun created 196 days ago Views: 129 Replies: 4
Viewing posts 1 to 4
(Edited 3 times)

I used butler to upload a build of the game originally, and it showed up in the feed. However, each time i push an update to the build, it does not show up as an update in the 'my feed' section... which makes me think people don't get feed notification when the build is updated? I'm wondering if this is a bug...

example syntax: butler push E:\builds\GGJ17\GGJ17.zip bunnygun/seashell-scuttle:win

The updates are making it to the site though, downloading the build is the correct copy.

Has anyone else experience this?

Or perhapse it's a matter of time, it has been less than 24 hours... if it's that, I'll report back about it.

Thanks!

10 hours later, still no update. I tried some experimenting with deleting the .zip file made by butler, and re-uploading the file using the itch.io website, and that was successful in creating a feed event just about instantly. I don't think the initial butler push events are going to make it to my Feed activity :/.

Admin(+1)

Hey, sorry for the confusion. Butler updates currently do not generate new feed items. We're going to be pushing out a system that gives developers finer control over how their updates are announced very soon. It will let you control which files/builds are included in an update post and give you an opportunity to write a changelog for it before the event is published. Thanks

(+1)

Any news on this? I didn't realize butler didn't alert users to updates, and I've just started using it for a new project.

I would really appreciate the ability for my butler uploads to notify users, as I have been making important bug fixes and adding new features.

Alright Leaf, thanks for the reply. Looking forward to it!