Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Feedback, frustrations and questions are welcome here! Sticky

A topic by Remerai created Oct 31, 2019 Views: 1,408 Replies: 22
Viewing posts 1 to 13
Developer

I didn't do nearly enough play testing with other people on this. If you encounter something that makes you go  "Huh, what?" or have any thoughts, do post them here. Constructive criticism is welcome! I did do this project to learn more about game development, after all.

Developer unlocked this topic

-When I entered the Cave with the Gun in it, I drowned upon entering the cave, and wound up with -43 HP.

-I got lost around the point of finding the empty grave of the king. I had read notes, so I also had the Dagger fragment from the Lake, the Shovel, the gun, and the Fossilized Root. I bumbled my way around searching for a burnt house near the lake, gave up on that, went southeast of the lighthouse, found a cave that I stumbled into, found that monster, and stuck the Root onto it and got Ending B. I don't know if I did any sort of unneeded skip, because the only hints I had were a Burnt out house near the lake I couldn't find, and to search where the lighthouse was pointing (which is where I found the monster cave). 

-When you die with a weapon equipped, you respawn holding it, and not the flashlight. If you die with the gun before you can save, you respawn with the gun while not even having it. Happens with any weapon.

-The stun from being hit is long enough to prevent any immediate counterswing. To be honest, I just avoided most enemies until I got the gun, given Melee combat usually results in losing too much valuable HP.

-Fixed camera, even with the Camera Item, makes it quite difficult to navigate through the unpathed forest.

I don't usually play Survival Horror games, especially with tank controls. It was alright to play, janky as expected, but I do feel from an Objective Standpoint that, unless the Monster's cave was where the Lighthouse was pointing, I bumbled upon an ending by accident.

The little bit I could run on my garbagey decade-old laptop I liked.

When I got to the first enemy neither I nor the enemy could deal any damage, save for one little hit taken when I elected to just walk away. This could have something to do with the fact that my framerate was likely under 10FPS, so it's possible this won't come up for anyone running this on a real computer.

While running away I jumped back over the first hurdle at an angle and clipped through the wall. I consider this an exciting feature that should be(and secretly is) in every game.

Anyway, good on you for making it. I hope to catch one of the schmucks playing it eventually.

Just got ending A, and for a learning project, I'd say it was pretty good! The only main glitch I really had any experience with was the aforementioned glitch of falling through the ground on screen transitions, though I couldn't find any way to consistently replicate it. Just kind of happened sometimes. 

I also share the sentiment on the combat jank, but it didn't really take me out of the gameplay experience too much until the final boss. Overall, I had a good time with it! I'm particularly fond of the graphics: I'm a sucker for those Super Beast/Best Friends animations, and when put into a game it has a real sorta original Alone in the Dark sorta vibe. Good stuff <3

(1 edit)

I'm barely an hour into the game, and I do like it so far, but I have a few things to say.


-Please add any kind of save option in the starting dungeon, perhaps right next to the healing tonic. With no way to skip dialogue, it is not fun having to sit through the beginning if you die to the knight in armour in the basement.

-The "game over" screen lasts for far too long and can't be skipped. When I die, I want to get right back into the game again but this isn't possible; a minute (if not longer) is wasted between dying and reloading a save. Is it possible to add a "Continue? Yes/No" option, and make the death animation and game over text appear much faster?

-Personal opinion, I would like it if the Camera item made you get a third-person over-the-shoulder camera like RE 4/5/6/Rev1/Rev2/RE2. The area where the camera can be used is built for exploration and the amount of trees heavily obscure the view, and when you are chased by monsters there's added pressure to get the right camera angle so you can see where you're going.

-The knights in armour's attack is too fast, I get stunlocked easily if I try to attack them. They can jab really quickly and all of Woolie's melee attacks are slow (I don't know if this reflects the real Woolie's ability to swing a melee weapon).

Yet I still think this is really promising. I don't know if you're gonna continue working on this game, but I really hope that you do. Great job for your first game!

Hey.

I love tank controls. I adore them. I also super love  static cinematic camera angles. I really miss that era of gaming and wish there'd be more modern renditions. The controls are nailed quite nicely here, although I would love more turning speed. Everything else is great, even the janky jump (fun with the fall damage out there)

I haven't even completed it yet but I already wanted to comment on how spot on you made a game that recognizes what it is to be a tank controlled survival horror. The snappy dialog takes me back to 90's adventure game (Great font choice and NPC yap sounds!) and the camera angles themselves are great. Might have some faulty triggers here and there but that's expected. That shit's hard. The graphics are a stylistic choice and I tend to like those yappy heads.

Funnily enough I am not a big fan of the Pat and Woolie show, but that might change now if their fans are capable of making this kinda stuff.

Gonna play more now, and I hope you might one time consider doing another one like these, spooky or funny(or both) your choice!

The real question is when will Woolie play this?

im really confused that no one complained about enemies moving and attacking during dialogue and item pickups and reading journals

is it a bug or by design

Developer

It's by design, but I have to keep in mind it's by bad design. I just really liked the idea of rewarding careful play, or making hasty play more tense, but that doesn't really work when most items are either unique and/or have unique descriptions where the length of text read is unpredictable.  That said, there are a couple of moments in the game where the player is practically guaranteed to get hurt if the game isn't paused, so I at least paused those.

If I make another game even close to the horror genre, I will definitely think about what I've learned here and minimize that as much as possible. Picking up items in that hypothetical game would be in a safe space that would then be made unsafe as a result, either by outright danger or by having the tension rise.

it seemed to work quite well for pats stream / in general

saw a few friends struggle immensely with the spider in the bathroom / poker key pickup sequence

Hi, how do I wipe my save? I re-downloaded it and deleted the old files but it still pulls my saves from somewhere

Developer

I used what could be described as Unity's default save  location, if you're on windows, I imagine that's in AppData/LocalLow/PA, at least it is for me. The files should be named Mystery of Castle Super Beast_SaveData1-5, along with Mystery of Castle Super Beast_ConstantData (The file that checks if you've gotten some endings, if you've saved in the first three slots, other things and also keeps count of how many saves you've made) Just deleting those files should clear progress and allow you to start over from scratch.

Looks like that worked! Thanks

Developer(+1)

A single guy on twitter asked about an overview. Why not?



And one without the trees, because again, why not?

Any chance of a Linux build?

Developer

Very sorry, but the answer will have to be no, at least for the time being. Porting to Linux may or may not be easy with Unity, but I'm so focused on another project right now that I don't want to stop.

So I went up to the Second Floor from the Courtyard staircase, realized I should probably go back to the Kitchen and save, so I turn around to go back, and Woolie sort of phased through the corner between the sidewall and the door. I laughed this off as a weird occurrence since the room started transitioning, but now Woolie is stuck falling in a black void. Screenshot here: http://prntscr.com/uieifr

I just replicated the bug. Walk at the corner and not the door and Woolie will continue walking through the wall instead of despawning and will transition to falling indefinitely.

Developer

I tried it in the Unity editor but couldn't replicate it. I'm curious, do you know how high your FPS were? If I know whether it was relatively high or low I can at least rule out a previous problem that I thought I had fixed.

Also, you said the room had started to transition. Could you tell which room it was transitioning to? If so, was it the library or the bottom floor? It's possible, even likely, a trigger might have been a bit too wide and caused a weird placement with a collision bug.

Either way, I'm a bit busy with a new project currently, so I'm not sure when (heck, even if) I get around to fixing it. That depends, was this only when you walked into the corner specifically, or did it happen even when you walked straight towards the stairs or the door? 

Hoping it's at least not a severe bug, but at least I'm aware of it now. Thank you for putting the time in and telling me about it. I appreciate it!

I hope you're otherwise enjoying/enjoyed the game.

My FPS may have been around 30

I was running under best quality assuming that it wouldn’t be too harsh on my average PC considering the simplicity of the character models and such

If you’d like, I can record a replication and send it to you somewhere?

Also, I enjoyed it, but I had some nitpicks with the game. I’m not familiar with this style of game so I’m assuming these nitpicks were intentionally implemented to emulate that style, which in this case worked perfectly as intended, so I commend you on that lol

Just recorded the replication (Going for Ending C while I’m playing again since I got lost previously and just watched Woolie play the game for Ending C)

It seems walking into that particular corner breaks the collision somehow, and Woolie walks out of the bounds of the room, so to speak, resulting an indefinite freefall.

I also tried this with other doors, and from what I’ve tried the issue only persists here

Developer

Really weird, but as I said I couldn't replicate it. It's good that you specified it was the collision and not the actual warping between rooms that did it, as that's another potential can of worms. I'll have to chalk it up to how I handled Unity's collision (or maybe the collision system itself, I dunno?). If more people mention it in the future, I'll go back and at the very least make some kind of workaround.

I wouldn't mind nitpicks, to be honest. This project was done mostly so that I could learn more about making a game after all. While I wouldn't be surprised if people have already mentioned them, it's still good to listen and for me to think about it for the next time I take a shot at this specific genre.