🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Help starting the game (Linux)

A topic by Joey546 created 176 days ago Views: 3,538 Replies: 32
Viewing posts 1 to 18
(+2)

I've downloaded the Linux Universal for both x86 and 64, but when I try to launch the game the "open with" window pops up. Is there something I'm missing or what?

Could you provide a screenshot?

Now how do you attach a screenshot here?

Take a screenshot, and upload it to imgur.com. Once uploaded successfully, copy the URL and paste it here.

Okay so I have it extracted and it is allowed as an executable. What program do I need to download to play the game? I tried archive mounter and nothing has happened?

(+1)(-1)

This post might help you

That link you have provided is not the answer. He has the Binary executable for Linux which run on Mono Runtime, what you've linked to instead is running Windows (EXE) files on Linux in Wine.

I dont use Linux, sorry that I cant help.

(+1)

Here's a screenshot:

https://postimg.org/image/59iyf72in/

(+5)

Perform a "chmod +x" or set the permissions on your file manager to allow executing on the executable and try again.

(+1)

That actually worked (believe it or not) Thank you.

Developers should provide the file with 'executable' already set. Also (.ZIP?) archive may cause losing the executable flag

(Edited 1 time) (+2)

I get the graphics and the resolution but after i select ok it doesn't load anything. help?

Me too, i am having the same issue.

(+1)

I am having the same thing on two different linux machines (ubuntu and arch)

(+1)

Right click on the executable file (V1.04_Raft_LinuxUniversal.x86_64 most likely), say Properties, then in Permissions tick Allow executing file as program. You can then click it to run. (See http://i.imgur.com/VvdSrd8.png for an example.)

I had done that the program runs but the game doesn't start after selecting graphics options

Yeah i have done that too but still doesn't launch after the graphics

(+1)
Try to run the game from terminal: Open terminal, cd into game executable directory and then run ./V1.04_Raft_LinuxUniversal.x86_64 copy and paste here everything it says after the game crashes. Most likely you have some libraries missing and that would help us figure out what they are.
(Edited 2 times)

I have the same problem.

After i select a resolution and a graphic quality and click the ok button nothing perhaps.

Hardware Information

Output from terminal

Developer(+1)

Hello fellow Linux users. We are not experienced with Linux but we tried to upload an untested version anyway so that you may experience our game as well.

If you would point us in the right direction towards uploading correctly next time we will do our best in the next update.

Thank you for that!

Itch has some article on this https://itch.io/docs/itch/integrating/platforms/li...

but it worked OK for me (installed using itch app). The problem with permissions described here is usually easy to resolve for a lot of users but it would be better if the executable file already has the executable permission set (I dont know how/if can you do that on windows or if Unity does that for you) and it is probably safer if it is packaged in something like .tgz instead of .zip.

(Edited 1 time)

I cannot figure out how to start the actual game, the only thing that pops up is the file.

Can someone Please help me with this!! It's very confusing!

If you right click the file, then hit "permissions". On the window that pops up there should be three tabs. Select "permissions" and then check the "allow executing this file as a program" box, close the tab and click on the file. You should be good to go!

Hope I helped,

LD

I'm having an issue where the mouse will not move from the middle, or it will move for a quarter of a second then it goes back to the middle again. The game is also extremely laggy even with the graphics on the fastest setting.

Specs of my pc (if they help)

Intel Pentinum G3528 @ 3.5GHZ (2cores)

8GB KINGSTON HYPERx SAVAGE RAM

SANDISK 256GB SSD

Nvidia GTX 750Ti MSI ed.

ASUS h81-GAMER MOBO

----

however the game works fine on windows, all through the download link seems to be broken for the 62bit & 32bit variants. i get to around 40 to 70 percent befroe it stops. So i'm still on 1.03 on windows.

(Edited 1 time)

Most Linux distros have the option of making a binary set as executable when you click on it, strange how it doesn't ask you that instead of trying to open with another app which isn't the normal behaviour of running a Linux application. but like others have stated right clicking on the game and going to Properties you can change it to executable from the Permissions tab, or by command line by doing chmod +x on the binary executable.

how do you start a game on itch.io

You don't. You need to download the game and extract to play the game.

I got it to work with this thread and it works okay (I used the 64 version) However while I play the cursor is stuck in the middle of the screen and I have the problem of it not improving in video quality.

i have done everything mentioned here but nothing works i have ubuntu 16.04 atm all that happens is the config menu pops up then click ok poof closes out any fixes for this? has anyone found a soloution for this issue

(Edited 1 time)

I've got a prob starting the game as well, It doesn't say Extract here, nor is there a tab saying permissions that allows me to change it so it's executable. i've got windows 7 so i downloaded the 32 ver but the only thing it says is open, always open or show in folder when i click it...

lubuntu 16.10 on hp laptop amd a6 vision. downloaded (not itch client), right clicked and extracted with archive manager. set execute bit on x86_64 file. worked fine. enjoyed my first rafting session. please keep making the linux builds!

almost none of the stuff ive gotten off of itch.io will work beyond the settings screen. itll open for a second and close