🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Stereo 3D supported?

A topic by relaxfpv created 296 days ago Views: 481 Replies: 29
Viewing posts 1 to 15

Is nvidia 3D vision supported?

I have a 3D projector next to me :)

if it's not supported, will it be in near future?

thanks a lot, great app!
Developer

Not supported at the moment, I guess it would be possible though, so maybe in the future if many people are interested.

Thank you!

It would be hard to implement? 3D vision driver can do the main job as i think.

Anyway, i can help you in testing, i have 3D monitor, TV and projector too.

Would be ultra realistic flying fpv in a dark room with a 3m size 3D picture :)

Developer (Edited 1 time)

Not sure how hard it would be, it would be necessary for me to have a 3D display myself to be able to properly test it, and I don't own one. Also, not sure how many people would actually be using it. But I agree, it would probably be pretty cool.

I did a quick search now and found this:

"nVidia 3D Vision provides stereoscopic 3D effects for most 3D games based on Unity, without needing any plugin. It does that by "expanding" the camera at the driver level (DirectX) while Unity is rendering the scene."

"not all effects in Unity are guaranteed to work improperly: cascading shadows and certain shaders have been known to work incorrectly."

So perhaps it might work already..?

For 1st step, you don't need a 3D display, only a red-cyan paperglasses, because 3d vision works in anaglyph mode too.

I could not activate it till now.

(Edited 1 time)

I tested with my passive monitor too. Many games works (dirt2, etc), but in FPV freerider nothing happens when i press the shortcut ctrl+t.

Why? It should be ok by default: "for most 3D games based on Unity, without needing any plugin"

So maybe something is disabled or set what stereo don't like? Can you check please?

You only need the free 3d vision driver and a cheap anaglyph paperglasses.

thank you in advance!!

ps: " you don't need to do anything in unity to get it to work. You merely compile the game, make sure that 3d vision is enabled in the control panel, then start the game in fullscreen. 3d vision should automatically start making the game 3d"


from here

(Edited 2 times)

Ok, i think i found the trick.

I downloaded a unity demo game, which works fine in 3D. At start i can select resolution and windowed mode (or not).
If i start in windowed mode and go to full screen with alt+enter screen blanks for 2 seconds, and 3D will be ok.

With your app changing mode with alt+enter i don't see black screen, the switch is immediately between fullscreen and windowed mode.

So it seems you don't use exclusive directx mode, which is needed for 3D, and i think this was the problem with my vsync tearing issue too.

"DirectDraw Exclusive Mode, an application takes exclusive control of the graphics hardware. This is useful for applications such as games" :)

Can you compile a new version with exclusive fullscreen mode?

See here

Build&run: don't select stereo and don't select windowed.

Much appreciated!

Developer

Thanks for the info.

I found an interesting thread, it seems like it is possible to force exclusive mode using command line parameters.

https://forum.unity3d.com/threads/exclusive-fullsc...

"Patch 5.3.3p2
Windows: Added a new command line argument for standalone builds: window-mode. Options: borderless, exclusive. It lets users override the default fullscreen window behavior.

Pass -window-mode=exclusive and enjoy adaptive-sync on any Unity game built on 5.3.4."

You could try that and see if it solves your screen tearing problem, and perhaps also makes it possible to use 3D.

Small correction :

You have to pass "-window-mode exclusive" in place of "-window-mode=exclusive" as command line argument to force exclusive mode and 3d stereo. I'm used to play on pc with a lot of 3d games and Freerider is pretty good. There is just 2 grey polygons along the horizon and Carpark is broken (mainly caused by lights and shadows I think) but it's still very fun to play like this.

Thanks you Freerider for this game. I can continue to test future updates in 3D if you want.

Thank you relaxfpv for this topic. (I'bought the game after reading it)


Glad you like it in 3D too :)

Sometimes i also see 2 grey polygons, but you can eliminate it by adjusting depth or convergence:
CTRL+ F3-F4-F5-F6, try with these keys!

Freerider also works with 3DTV Play, so you can play on ANY hdmi 1.4 compatible 3D display!
Resolution is 720p in 60Hz mode, but this still looks fantastic on my room wall with a cheap Acer 3D projector.
Another device is a passive LG monitor with the Zalman inf driver, so here i can use 1080/60 mode.

I thank you the developer agian, and hope the program will be even better in the future :)

Thank you for the tips to remove the polygons.

I play in 1080p/60Mhz on a GTX 970 + active monitor VIEWSONIC V3D245 and I keep 60fps all the time with highest graphics quality. Great !

The Carpark is more complex and there is no fix yet from the Helix mod community (http://helixmod.blogspot.be/2013/10/game-list-auto...) and the Bo3b's School for ShaderHackers tutorial is based on the Unreal Engine. I don't know if it would be helpful to fix broken 3d with the Unity Engine...

I will also look for a NVidia profile wich would help when I'll have time.



(Edited 2 times)

Exactly what i need! With exclusive mode 3D vision works finally, and it looks beautiful on a big screen :)

Can you compile with this mode so everybody (who don't read this thread) can also enjoy your sim in real 3D or just get better performance in 2D?

Thank you!

Developer

Glad to hear that it did the trick! I can imagine it must be pretty awesome on a big screen :)

I'm hesitant to compile with exclusive mode for now - as I understand it the reason that exclusive mode is not the default is because it can cause problems for some people.

But I will certainly add the info in the manual on how to force it using command line parameters, so that people will be aware of the possibility.

Ok, i don't read about problems, just better performance in exclusive mode.

Yeah, its awesome, and now i have my wireless simulator stick too for my i6X - bought just for your sim :)

thank you, cant wait the next release!

Hmm, life isn't so easy. Problem comes again :)

With exclusive mode and 3D, motion is not as smooth as in full screen windowed mode in 2D.

If i disable 3D, i still get dropped frames, etc.

Do you know why?

(Edited 1 time)

Here is the solution, you have to correct:

https://forum.unity3d.com/threads/impossible-to-get-perfectly-smooth-motion-with-unity.141417/

Please read and watch the video at the end.

Here another tips:

https://forum.unity3d.com/threads/linear-movement-stuttering.142754/

http://answers.unity3d.com/questions/275016/updatefixedupdate-motion-stutter-not-another-novic.html

At 50Hz both program is so smooooth, at 60 hz none of them.

I hope it can resolve the issue.

thx

Developer

Could you show a short video of the stuttering? I don't recognize on my machine.

In 3D the scene will need to be rendered two times. It will basically be twice as demanding, that could explain why the motion is not as smooth as in 2D.

Of course i know.

But as i said, it stutters in 2D-60 fps mode too.

Do you have silky smooth movement all time in 60fps?

Developer

Does it run smooth at 50Hz but not at 60Hz on your machine? Does the stutter occur at random or all the time? I had a look at the links but I couldn't find any definite conclusion for physic based games, there were so many theories. Seems it might have to do with Fixedupdate that is used for physics.

Yes, 50Hz good on a 50Hz monitor, 60Hz stutters (like 50-55Hz) on a 60Hz monitor. All the time.

I ask again: do you have absolutely smooth motion in 60Hz mode? If yes, what settings, what mode (win.aero, dx.exclusive, windowed?), your system, vga, etc?

thanks a lot

Developer

I did some more research now - you are correct, the simulation does in fact only run perfectly smooth at 50Hz.

The reason is that Unity's default update frequency for physics is 50Hz. (The physics needs to run at a fixed interval in order to be consistent and framerate independent).


I realize now that this stuttering was actually introduced when I was fixing another issue, which was apparently interconnected with this in an unexpected way.

I'll upload a fixed version as soon as possible since I think this is important.

Thank you for bringing this to my attention!

Wonderful news!

Developer (Edited 1 time)

Uploaded a new version where the screen stuttering issue have been fixed. It would be interesting to hear if it works well on your setup.

(I will soon upload a fix for the Android version too btw)

Thank you very much, finally its smooth even at 60fps! :)

I can activate stereo 3D with exclusive mode. At medium graphics settings Desert level is stable 60fps, but the Forest is not. Even at lowest quality it cannot do 60fps. I have a 750Ti card, time to get a 1050Ti? :)

Another question: is it normal, that my controller has around half sec delay? When i play with the throttle for example, quickly go to max, i can hear the motor's sound only after 0.3-0.5 sec. I have a 24 in 1 usb stick with A8S PPM receiver and i6X radio. But i tried with my wired usb simulator radio too, with the same result. Maybe a settings in windwows game controller properties, or you have to change something in Unity?

thanks again!

Developer

Glad to hear it's smooth now :)

Well, yes, I think the forest is definitely the most demanding scene. You could try running it at a lower resolution in order to get higher framerate. (You can set the resolution by using command line parameters as described in the manual).

There shouldn't be any noticeable delay on the stick input. Do you notice a delay when looking at the circles on the trim settings screen too? (You can access it directly by clicking "calibrate controller" and then "skip to trim settings").

ok, but how can i show the resolution selection window at start?
The command line -show-screen-selector not work by me.

With the circles, i notice just half the delay (0.2-0.3s) compared to while playing.
Its not unplayable, i can fly ok, just the reaction is not immediately to throttle, etc.

Developer (Edited 1 time)

That's right, Unity's resolution selection window doesn't work, you need to set the resolution manually.

For example:

-screen-fullscreen 1 -screen-width 1280 -screen-height 720

This will make it run at 1280x720 pixels fullscreen.

Ok, well, I'm not sure what might be causing that. I know some people get a delay when using Smartproplus to connect their radio, but with a USB dongle there generally shouldn't be any noticeable delay.

With other app, resolution selection window works.
Do you disable it? If yes, why? Now i made 2 batch file, one for 720p, one for 1080p

thx

Developer

No I haven't disabled it, honestly I don't know why it doesn't work. Tried it a few times early on and gave up. Yes it's pretty simple to create a few shortcuts if you need to run it at different resolutions, that's what I also do.

yes, but my desktop icons screw up already :)