Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Strive for Power

Fantasy Slave Management/RPG Erotic Game · By Strive4Power

Energy bug - not replenishing

A topic by Raymaxe created 29 days ago Views: 95 Replies: 7
Viewing posts 1 to 2
(2 edits)

I've created this account because I've encountered smth quite annoying

My energy simply doesn't reset after sleeping. It's stuck on 14 and nothing happens the next day

I've tried editing the save files, I've set my energy to 200, energy max to 200, energy modifier untouched and still, when i get into the game, with the 200 energy i press next day and it goes down to either 14 or 16 and there is no way to get energy otherwise


I'm not really adept at coding/figuring out what is going on but if anyone could help/advise me, it'd be much appreciated

There are three ways to regain energy - end of day at the mansion, resting after a leg of travel, and the invigorate spell. Are they all giving the same problem? Casting the dream spell on a slave will restore energy but you can't do that on the master.

Are any error messages coming up in the run time window that opens up behind the main game? What operating system are you on?

(1 edit)

Yeah I've figured out that I can replenish it with my invigorate each day to continue playing the game. The same goes for dream

However, even after that, each day I have to do it to be able to play. It's somewhat annoying.

Even if I end with 100 energy, after I press next day it just goes back to 14 or 16


P.S. no errors when ending the day

Apparently one of the versions has a bug with the tattoos - it sets your energy instead of adding  to your energy.

Do you have tattoos? Specifically the energy ones?

16 energy would be consistent with having 2 animalistic tattoos. Probably v0.5.24b.
The animalistic tattoos haven't worked correctly until v0.5.24c. Before v0.5.23c there was no code to apply them to anyone, in v0.5.24a players also could use them. So for the previous 2 to 4 versions, those tattoos have been sabotaging people.

yup, i do have 2 animalistic tattoos

(1 edit)

1) Open /files/scripts/effects.gd

2) Go to the bottom (not sure if my file has different line number)

3) Find the following:

func animalistic1(person):
person.energy = 8

func animalistic2(person):
person.energy = 16

func animalistic3(person):
person.energy = 25

4) Replace those lines with the following (Don't change formatting - just add the "+" in the right place):

func animalistic1(person): person.energy += 8

func animalistic2(person): person.energy += 16

func animalistic3(person): person.energy += 25

5) ...

6) Profit

5) Download my quick fix: https://itch.io/t/451573/cant-raise-the-children-of-slaves-after-they-give-birth...

The tattoo issue was fairly minor. Either use both fixes or just update to get the third fix(selling multiple slaves).