Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Voidrun

The Void will consume each parts of our universe. · By Benjamin Soulé

Bug report Sticky

A topic by Benjamin Soulé created Mar 27, 2019 Views: 337 Replies: 24
Viewing posts 1 to 12
Developer

Please post here when the game freeze or anything weird happens.

Not sure whether these are important enough to be classed as true bugs, but while playing the demo I have once had one of the purple snakes from demo-1 pass though a diagonal barrier I had placed, and one of the bullets from the snake on demo-3 did the same thing.  However, I have not seen these things more than once, so it may be inconsequential.  Also, just a small thing, not really a bug, but trying to place a ball in a specific spot is weird because the way they are placed does not seem consistent.  Sometimes they come out directly behind, but sometimes the appear more in the center, or to the front.  Other than that small thing, the game is great!

Developer

Current ball spawning rules works well when you hold action button but are not so good if you want to place a ball in a specific position. I will modify them asap

In the main game, the headless tanks in Zcor - 2 have no hitbox.  On Korb - 2, when the spinning things knock a ball out of the way, it will occasionally only move the image of the ball, but not the ball itself if that makes sense.  When you constantly collect balls for a few seconds, the music will cut out.  Most apparent when collecting a previously placed string that you couldn't connect.  Also, at the end of each song it usually pauses a  bit before restarting.

Developer

When the song end is the whole game game freezing ? or just the sound ?

Just the sound.

(1 edit)

Some more bugs, with a little bit of balance.

Giroid - 2 the splitting asteroid enemy is really annoying and takes a really long time to fight.  Much harder than other stages. Also is impossible to complete, as the shooting  thing not connected to  an asteroid is unkillable.  However, I do really like the concept of the stage, and I thing making the 2nd largest asteroids only split into 2 sew asteroids would make it a bit easier.  Also the asteroids seem to slip through diagonal lines more easily.

When you have a lot of orbs scattered around the stage, placing any will result in a screen-wide explosion.

If during the outro of a stage you hold the spacebar, run out of orbs, and it was the last stage of the planet, the “no orbs to place” noise will play continuously until you enter a new planet.

Any circle you complete on Nust seems to have the rift effect.

When the octopus creatures on Nust disappear, if it was the last enemy it will complete the stage, even though it hasn’t been killed.

Palettes don’t apply to the end of stage effect.


This error happened when a missile from Yarl - 3 ran into a line of orbs at the same time I completed it.

Null access

Called from local function #3932 (ent/Hero.hx line 1148)

Called from Fx.kill (Fx.hx line 78)

Called from fx.Wait.update (fx/Wait.hx line 18)

Called from $Fx.updateAll (Fx.hx line 82)

Called from Game.update (Game.hx line 1075)

Called from App.update (App.hx line 488)

Called from hxd.App.mainLoop (hxd/App.hx line 161)

Called from hxd.$System.mainLoop (hxd/System.hl.hx line 70)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 125)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 122)

Called from local function #5294 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 140)

Called from local function #5295 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 74)

Called from haxe.$MainLoop.tick (C:\HaxeToolkit\haxe\std/haxe/MainLoop.hx line 166)

Called from haxe.$EntryPoint.processEvents (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 104)

Called from haxe.$EntryPoint.run (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 136)

Developer

Thanks for the detailed report !

The girold 2 unkillable rolling pills should be already fixed on 0.79 ( you can see your version number above title on titlescreen ) Girold levels have also been reorganized. Please tell me is you still feel they're too long this way.

I will try to fix all the other bugs reported on the version 0.80 release ( probably  this week )

ennemies in noct 1 and 2 (the 3 legged ones) can get stuck on your voidballs

I have been playing a lot of 0.9, so here are some bugs I found.

Playing arcade mode, and at the start of wave 3 this came up three times in a row, then the game froze, though the music continued to play and I was able to bring up the pause menu.

Null access

Called from local function #3446 (Game.hx line 2002)

Called from Fx.kill (Fx.hx line 78)

Called from fx.Wait.update (fx/Wait.hx line 18)

Called from Game.updateFreeze (Game.hx line 1295)

Called from Game.update (Game.hx line 1121)

Called from App.update (App.hx line 596)

Called from hxd.App.mainLoop (hxd/App.hx line 161)

Called from hxd.$System.mainLoop (hxd/System.hl.hx line 70)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 125)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 122)

Called from local function #5759 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 140)

Called from local function #5760 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 74)

Called from haxe.$MainLoop.tick (C:\HaxeToolkit\haxe\std/haxe/MainLoop.hx line 166)

Called from haxe.$EntryPoint.processEvents (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 104)

Called from haxe.$EntryPoint.run (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 136)


It is impossible to leave adventure mode without closing the game.  You can’t open the pause menu in the map, and giving up while in a level sends you back to the map.  

Playing in classic, entered Yareal, then this error came up.


Null access

Called from ent.mon.SnowWorm.run (ent/mon/SnowWorm.hx line 69)

Called from ent.mon.$SnowWorm.__constructor__ (ent/mon/SnowWorm.hx line 27)

Called from Game.spawnBad (Game.hx line 865)

Called from $Game.__constructor__ (Game.hx line 402)

Called from local function #3659 (Sh.hx line 882)

Called from Module.kill (Module.hx line 71)

Called from mod.PlanetSelector.kill (mod/PlanetSelector.hx line 393)

Called from Fx.kill (Fx.hx line 78)

Called from local function #3616 (Sh.hx line 396)

Called from fx.Call.update (fx/Call.hx line 18)

Called from $Fx.updateAll (Fx.hx line 82)

Called from Module.update (Module.hx line 59)

Called from mod.PlanetSelector.update (mod/PlanetSelector.hx line 220)

Called from App.update (App.hx line 596)

Called from hxd.App.mainLoop (hxd/App.hx line 161)

Called from hxd.$System.mainLoop (hxd/System.hl.hx line 70)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 125)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 122)

Called from local function #5759 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 140)

Called from local function #5760 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 74)

Called from haxe.$MainLoop.tick (C:\HaxeToolkit\haxe\std/haxe/MainLoop.hx line 166)

Called from haxe.$EntryPoint.processEvents (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 104)

Called from haxe.$EntryPoint.run (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 136)


A second error came up (which I forgot to copy), the graphics loaded, and a third error came up repeatedly.  I pressed “dismiss all” and the error window disappeared, but the ship did not spawn in. However, the game continued and I was able to open the pause menu.


Null access

Called from ent.mon.SnowWorm.run (ent/mon/SnowWorm.hx line 69)

Called from Ent.update (Ent.hx line 184)

Called from ent.mon.SnowWorm.update (ent/mon/SnowWorm.hx line 38)

Called from Game.update (Game.hx line 1137)

Called from App.update (App.hx line 596)

Called from hxd.App.mainLoop (hxd/App.hx line 161)

Called from hxd.$System.mainLoop (hxd/System.hl.hx line 70)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 125)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 122)

Called from local function #5759 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 140)

Called from local function #5760 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 74)

Called from haxe.$MainLoop.tick (C:\HaxeToolkit\haxe\std/haxe/MainLoop.hx line 166)

Called from haxe.$EntryPoint.processEvents (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 104)

Called from haxe.$EntryPoint.run (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 136)


After I exited that game, I went to the arcade mode.  In the previous game of classic I had voided one of my sectors, and the same sector appeared to be voided in the ship select screen. I was able to do this multiple times, but only in arcade mode, not classic.

On return to Yareal, I did not spawn.  Pretty much identical to what happened before.  This time I checked the separate window that comes up when playing, and the same error was repeatedly appearing.

Rockets from the zeth core giant robots can also cancel the music, similar to collecting many balls in a row.  Maybe it has something to do with a limit on the number of sounds allowed at once?


Above all I want to congratulate you on this amazing game you have created.  

Some adventure mode bugs.

The 2nd shop on the right in adventure mode has the descriptive text slightly above the display bar.

I started the methuselah fight.  When the first snake began to move down the tree, this error came up continuously.


Null access

Called from ent.mon.Snake.move (ent/mon/Snake.hx line 58)

Called from local function #4286 (ent/mon/Methuselah.hx line 358)

Called from fx.Call.update (fx/Call.hx line 18)

Called from $Fx.updateAll (Fx.hx line 82)

Called from Game.update (Game.hx line 1139)

Called from App.update (App.hx line 596)

Called from hxd.App.mainLoop (hxd/App.hx line 161)

Called from hxd.$System.mainLoop (hxd/System.hl.hx line 70)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 125)

Called from hxd.$System.runMainLoop (hxd/System.hl.hx line 122)

Called from local function #5759 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 140)

Called from local function #5760 (C:\HaxeToolkit\haxe\std/haxe/Timer.hx line 74)

Called from haxe.$MainLoop.tick (C:\HaxeToolkit\haxe\std/haxe/MainLoop.hx line 166)

Called from haxe.$EntryPoint.processEvents (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 104)

Called from haxe.$EntryPoint.run (C:\HaxeToolkit\haxe\std/haxe/EntryPoint.hx line 136)


After I pressed “dismiss all”, the game continued, but the game became extremely laggy and the snakes did not spawn.

(+1)

Version 7 of the game does not load and only shows the error "Failed to load library sdl.hdll".

Developer

I made a fix for this from 6 to 7.

When I download the 7 version I have a sdl.hdll file in my game folder can you please tell me if you see it ?

Developer

OK I fixed it. The current version should work on your computer.

The game is running WAY faster than it's supposed to, probably set to monitor hz speed or something...

intel coreduo 3.0 ghz

nvidia gtx 1030

8 GB RAM

2 TB HDD

Monitor hz is 59

FULL version of the game, version 9. Yes, I bought the game.

Developer (1 edit)

The game is supposed to run at 60 FPS can you please check the gameplay video at https://store.steampowered.com/app/1048560/Voidrun/ and tell me if the game seems faster than this ?

100% for sure it runs faster. The game runs at normal speed when I play on version 5 though!

(1 edit)

To add a bit of detail, it seems that the game runs considerably faster with VSync turned ON. With it off, it seems to run at the same speed as the gameplay video on the Steam page. I have a 144hz monitor and a GTX 1060 6GB. This behavior does occur in the DirectX version as well. I just bought the game today and this behavior was experienced on Steam version 1.03.

Developer

I added a vsync flag to the option screen that should fix your problem

I'm hanging on an infinite black screen when I try to launch the game. I've tried uninstalling and re-installing, I've tried verifying the installation, I've tried removing the .sav file, and nothing seems to work. No debug information popping up anywhere, unfortunately.

Developer

Is it the first time you launch the game ? Or is the game used to work fine before on the same system ?

It was working fine the first day I downloaded it, and then I saw the behavior I described the next day. However I just checked again and it seems to be launching just fine now after a few days of definitely not launching. Unsure why. Anyway, I'll keep an eye out in case the launch failure comes back. Are there any generated files Voidrun creates that might be capturing error messages?

the demo doesn't seem to be working. It's  just a black screen with sdl.hdll

Could you check steam discussion please. I reported about two bugs there and made one suggestion.