Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Found bugs/problems? Sticky

A topic by Twonky created Feb 26, 2018 Views: 323 Replies: 13
Viewing posts 1 to 7
Developer

Hey if you find any bugs or had any troubles post them here and I'll try to fix them.

If you find a bug, tell me what happend and what you did before the bug happened. You can also try pressing F3 and see if there a error message and send me your save file/crash report if needed.

(1 edit)

I tried it out, and didn't see any religion events. I did, however, notice three errors in the script console, to the effect of "active settlement is null."

I'll try a new world later tonight.


Edit: Hah, oops. I had 1.1 loaded, instead of 1.2

Looks like you're missing a name pattern: 

Error processing pattern
   at UNM.Parser.Implementation.NameParser.Process(PatternProcessingParameters parameters)
   at Bronze.Common.Services.UnmNameSource.MakeUnitName(UnitData unitData, Tribe owningTribe)
   at Bronze.Common.World.Data.Structure.UpdateStructureOperation(SimulationContext context)
   at Bronze.Common.World.Data.Structure.StepSimulation(SimulationContext context)
   at Bronze.Common.Gameplay.WorldSimulator.StepSimulation(Single elapsedSeconds)
   at Bronze.Common.GameState.States.GameplayState.Update(Single elapsedSeconds, InputState inputState, IAudioService audioService, Boolean inForeground)
   at Bronze.Monogame.BronzeAgeGameBase.Update(GameTime gameTime)

Inner Exception Follows
No list matching name: _T_unit_name
   at Bronze.Common.Services.MultifileNamelistSource.GetNamelist(String name)
   at UNM.Parser.Implementation.NameParser.ProcessSubPattern(StringBuilder resultBuilder, PatternProcessingParameters parameters, PatternToken token)
   at UNM.Parser.Implementation.NameParser.DoProcess(PatternProcessingParameters parameters)
   at UNM.Parser.Implementation.NameParser.Process(PatternProcessingParameters parameters)

Happened after I build some Twelper Infusers, probably when the units finished training.

Developer

Pretty weird I didn't find the problem when testing. Anyway I checked and fixed it. 

Decided to remove the naming patterns for now because they weren't really impressive in any way.

I checked the contents of the zip file and didn't see a ,csv in there. Did a file not make it into the mod, perhaps?

Developer

Well I removed it. 

When I pause or build something new it resets my housing and food numbers ,then it goes back to normal.

Developer

I'm not sure if that's my Mods fault. Does it only happen with my mod?

Yes it does 

Developer

Well I'm gonna try to look into it.

There's a terrain art glitch for the pods. Only noticed when I turned off hex borders, so not a big deal.

        Also - What are the plans for reworking the Twelpster?

Developer

Yeah kept forgetting about that art glitch. it's fixed now tho. Thanks for reminding me.

I want to make him a lot more "monkeys paw" like but I'm not sure how I would allow the player to generate favour with him. I also do not know a lot of ways to allow him to monkeys paw players without it throwing off the balancing. Before this you could ask him for military help and would get something between a trader and Twelpwar. I also want him to be a little bit less of a risky choice now that you can always choose him. Before I took him out he could change you from playing the twelpers to some random maskling tribe which was fun but I can imagine some players having some problems with that. 

Maybe I could just let the player choose how much risk he wants to go for and have it be a little bit more risk/reward like in a sense that if you choose low risk and ask for military help you might just get a single soldier or trader if you go high risk it could be an actually good unit or he spawns an enemy invasion right on your doorstep. 

But really I'm open to ideas.

(1 edit)

There seems to be a "FATAL ERROR" message when trying to load the saves. Is this a bug for lower-end computers? It happens every time when loading a save

Developer

I'ld need some more information. Especially the crash log.

The Crash log is located inside the Bronze age folder. 

See if it contains any information as to why the game might have crashed. It should say "FATAL Exception" and have a timestamp at roughly the time it crashed. Try to copy that part and post it here. Or just send the whole file.

Alternativly you could also send me the save file.


There are save incompatabilites between some of the beta versions of bronze age. If you played the old version of the mod for bronze age .90 those won't work anymore. There might be some incompatabilities between newer versions. If you started the save in an older version that might be the case. There shouldn't be any problems running the mod on lower end PCs apart from the lag.