Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics

itch app not working

A topic by Rey4980 created Feb 10, 2018 Views: 4,893 Replies: 18
Viewing posts 1 to 11

I have a problem with the app. When I try to open it (on windows) the mouse would do a quick load animation and nothing. After uninstalling the game, the setup.exe would go about halfway and then close itself. I restarted my laptop a couple of times and nothing happened. any ideas on how to fix this?

just going to add that I get the files form the setup, but the app doesn't open nor do I get the shortcut

You mention "uninstalling the game" - which game?

By "the app" you do mean this app right?

Yesterday the itch app worked fine. Today it wont launch at all, I use windows 7 and have bitdefender installed. I have reinstalled itch app, and attempted to start it whit bitdefender off, but all that happens is that the mouse get the lading icon but it flashes like crazy on and off for about 1 min then noting happens

Hey Truth,

BitDefender is known to interfere with itch app operation - this page describes how you can set it up so it leaves itch alone:

In the future we're planning on working more closely with AV vendors to avoid this kind of issues. Thanks for your patience!

I have added all i could find in appdata to the excluded but i still can't get it to launch.

And i can't seem to find the folder named broth and prereqs


yeah. I also ment this app when I said 'game'. However the app works now because my laptop is stupid and decides things on it's own

Do you have Avast installed by any chance? Or another antivirus product ?


mine opens to a blank grey screen. i can't do anything.

do you have a good internet connection

Do you have any antivirus installed? Avast, AVG, Avira, something else?

same I don't know how to fix it 

Quit the app completely, (Ctrl+Q) download and run the installer from to make sure you have a clean install.

I cant install it, too. I do not install some  Antivirus software.  Reinstallation does not work, too. 

my computer wont load the file it might  be the computer cuz iits trash

Whenever I try to install it it says this:There was a problem during setup: Could not validate version 15.17.0 of butler


Likely a virus scanner removing critical files from the app during installation. Please try temporarily disabling all virus software on your computer while installing itch to see if it makes a difference. Also tell us what scanner you're using. Thanks

Im using webroot

I tried it and it works now

This topic has been auto-archived and can no longer be posted in because there haven't been any posts in a while.