🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

[Solved] Trouble adding Butler to path on OSX - Command not found

A topic by madameberry created 92 days ago Views: 156 Replies: 4
Viewing posts 1 to 5
(Edited 1 time)

I'm running a somewhat older (2009) Mac and I'm having trouble running butler without using the full file path.  I've added the file path to .bashrc, which now reads  

export PATH=“$PATH:~/Library/Application\ Support/itch/bin/“

If I remove the "\" from "Application\ Support, terminal throws an error "-bash: export: `Support/itch/bin/“': not a valid identifier" so I assume .bashrc is being at least read.   But with the readable file path in .bashrc, I get a "-bash: butler: command not found" error.

Dragging butler.exe into terminal to produce the full file path (with \ included), I can execute commands as expected.

Am I doing something wrong?

Admin (Edited 1 time)

It looks like your using special quote characters: “ instead of ".

Try this:

export PATH="$PATH:~/Library/Application\ Support/itch/bin/"

How do you do that with a keyboard?

Changing it (via copy/paste) didn't work, though, unfortunately.

Admin

Another issue I can see is that the space is backslash-escaped - you can use double quotes or backslashes, but not both: https://apple.stackexchange.com/a/11508

(+1)

I removed the quotes and that solved the issue.  Thanks!