Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

BIT RAT : Singularity

A hand-pixeled story-driven cyberpunk puzzler · By [bucket drum games]

Thread for comments, questions, feedback, etc!

A topic by [bucket drum games] created Jan 18, 2018 Views: 758 Replies: 29
Viewing posts 1 to 12
Developer

Hey again! This thread is for anything you'd like to share (publicly,  as is the nature of these types of forums) about BIT RAT: Singularity.

Find a bug? Love the puzzles? Hate the story? Have an idea for a mechanical tweak? Let us know -- or you can always email us at bucketdrumgames [at] gmail.com. We'd love to know what you think, and will be working hard to incorporate feedback into the full game.

In the meantime, thanks so much again for your support!

- bryan / Nick / [bucket drum games]

(+1)

Talked to you guys at MagFest, really awesome to see this on the front page of Itch.io!

Developer

Thanks! We're really thrilled to be here too! Hope you enjoy it. If you get a chance and you're so inclined, we're also always grateful for ratings/reviews!

(+1)

Took three days, but I finished the final level (so far!)  Excellent challenges and the developing storyline made this game feel less like a progressive puzzle and more like a thriller where you unearth a bit more of the story with each victory.  Some of the conversations were hard to follow, given the limited perspective, but they revealed their secrets in an realistic fashion.  Too bad MINOS coudn't communicate in its own way with the characters -- maybe in a future episode?

Thanks for a fun game, and I look forward to see what comes next!

Developer

Thanks so much, Carl! Awesome that you made it through. And great to hear the narrative maintains good tension. We're still tweaking dialogue and mailserver entries as we go, so hopefully we can improve continuity between some of the threads. And we've definitely got some ideas on the table for how to get MINOS interacting with the rest of the game's cast!

If you get a chance and are so inclined, we also really appreciate folks leaving us a rating/review on the game's main page. Thanks again!

Will do!

(+1)

I noticed the Server Transfer shown in the teaser isn't in the singularity game, but that's ok, still great game overall!

Developer(+1)

Ha, good catch! We're saving a handful of mechanics for the full game, but we couldn't resist using transfers for visual flair in the teaser.

Also thanks so much for your feedback and kind words! FYI, quicksaves are definitely on our to-do-list, as is more flexible control/key mapping.

Developer

Just a bit of additional context, the trailer on our website was mainly put together to accompany playable in-progress demo builds of BIT RAT for various events last year. This was before we decided to release the first part of the game as Singularity, so there are some levels and other stuff shown briefly in the trailer that you won't see in Singularity but will see in the full game.

Thanks for playing and commenting! It's honestly inspiring whenever someone enjoys the game enough to play through to the end, I know we didn't make it easy!

-Nick [bucket drum games]

(+1)

Just completed Singularity. Really enjoyed it. Thanks very much indeed!

(1 edit)

Hey! That's awesome! Thanks so much for playing! Hope it gave yr brain a good flex. If you're amenable to leaving a rating or review, we always appreciate the feedback!

-bryan (one of the devs, now realizing i'm signed into my other itch acct haha)

Just got this game as part of the Racial Justice bundle, and it looks really cool, I was super excited to play it. But after extracting the files and opening it, it would start up the game for a few seconds before this pooped up:

___________________________________________
############################################################################################
FATAL ERROR in Vertex Shader compilation
ShaderName: shader0

D3DXCompile failed - result

at gml_Script_scr_title_draw
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_scr_title_draw (line 0)
gml_Script_scr_game_master_draw
gml_Object_obj_game_master_Draw_0


I'm not sure what this means, or if there's anyway to fix it?

Developer

Hey! Thanks so much for checking out BIT RAT! The error you're seeing is, usually, related to a missing DirectX 9 runtime, which you can download here: https://www.microsoft.com/en-us/download/details.aspx?id=34429. This issue crops up sometimes with Gamemaker: Studio 1.4 games and is usually resolved by installing the above file and restarting the application.

If this doesn't get you up and running, please let us know and we'll troubleshoot from there!

Thanks again!

bryan/[bucket drum games]

(+1)

That worked great, thanks so much! I love the game so far, too! But as someone who loves rats and puzzle games with underlying stories as much as I do, I may be biased lol  

(+1)

I'm running this on my mac, and I'm trying to get it to recognize either my 8Bitdo gamepad or my PS4 controller and they're not working. Is there anything I can do?

Developer

Hey, thanks so much for writing! Hmm, I'm trying to think of the best way to troubleshoot this. I believe Gamemaker: Studio (which BIT RAT is built in) has somewhat limited controller support in OSX. The documentation suggests only xbox 360 and ps3 controllers are fully compatible. On Windows there are utilities that map DirectInput from basically any controller to XInput (Gamemaker's "preferred" input manager), but a quick Google search suggests there is no immediate analogous solution for Macs.

Are you able to access a 360 or PS3 controller? I know it's less than ideal, but worst case there's always the keyboard :/

Hope this helps a bit! Sorry I can't offer a more concrete solution. Let us know what you try!

bryan / [bucket drum games]

(+2)

just wanted to say, this game is fantastic.  i loved everything about it, from the corporate IT politics to the existential crisis of MINOS.  the puzzles got brain-burny really fast instead of taking 10-15 levels before becoming challenging.  i can't say enough good things, and look forward to purchasing the full game when it becomes available.  <3

Developer (1 edit)

Hey! Thanks so much for these kind words. It's super validating to hear that all the different elements of Singularity worked well for you! We'll keep ya posted on our (admittedly slow) progress; really appreciate your generous feedback in the meantime!

bryan/[bucket drum games]

(+1)

Just finished the game. Enjoyed it very much. Finished within 4 days.

As a person of moderate puzzle solving skills, heck, moderate smarts really if completely honest, this game had good difficulty: not a cakewalk, but not crushingly hard either.

I also enjoyed that it tutorialized all the features well. In my mind that's just another benchmark test in our times, and things like wall-of-text, or punishing the player with a mean learning curve are big no-noes.

The story is well written and told well; continuously in small bits, not impeding gameplay. Art work: also good, without hammering on the pixel art retro-chic too hard.

Would have enjoyed a more developed endgame, but the ending itself felt rewarding. Many points, will recommend.

Setting changes (audio volume) never actually saved for me between sessions  (despite it saying 'saved'), so had to turn it down every time anew.

Developer (1 edit) (+1)

Hey, thanks so much for playing, and for this great feedback! So glad you enjoyed the puzzles and difficulty curve. Integrating tutorials into the story/level progression without bogging things down has been one of the major challenges of development; we'll probably be re/tweaking the formula for as long as we work on the game.

Thanks also for yr note re: settings not saving. Can I ask what platform you're playing on? Some of our menu feature implementations are still a bit patchy, so we'll definitely look into getting that fixed.

bryan/[bucket drum games]

Oh, yes of course: It's Windows 10 Home

(+1)

Hi, I just picked this up today as part of a bundle and whenever I select New Game from the menu the game always crashes as soon as the initial cutscene ends, regardless of whether I skip or watch all the way through.  Event viewer is showing exception code 0xc0000094, which is making me think I might have mucked something up by accidentally running it from the zip folder when I first went to extract it, but I couldn't find any registry keys or AppData to delete to try a fresh 'install' so I'm not super sure what to try next.

Developer

Hey! Sorry about this! We'll try to get you up and running ASAP. What platform are you running on? We don't install any registry keys or AppData other than a really basic profile/save file, so it shouldn't be that. I know there might be some issues with 64 bit Mac OSes that might not be reconcilable with Gamemaker: Studio 1.4 (what BIT RAT is built in). If you're on Windows, the exception you get doesn't mention anything about DirectX, does it? There's a DX9c dependency that some modern systems don't have by default ( you can grab it for free on the MS website ).

Let me know and I'll dig around some more. Thanks so much!

bryan/[bucket drum games]

Sorry, should've mentioned that; I'm on Windows 10 Pro N 64-bit, and I do have the media feature pack installed since not having that breaks a whole lot of games.  I did attempt to install the DirectX update but the installer told me I already had it or a newer version.

There was no error message before or after the crash, or in the error logs.

Developer

Hey! Sorry for the slow reply.

I've tested the conditions you described (running from the un-extracted zip, etc.), and for the life of me I can't repro this bug. I know it's not ideal, but my co-dev Nick suggested trying to launch the game from the itch.io app (if you have it installed/don't mind using it, ofc) and seeing if that bypasses the error. The only consistent early game crash we've seen has been related to the DX9 dependency, and you've already addressed that, so I'm really not sure what's cropping up here.

Sorry for the lack of clarity on this; I'll keep prodding stuff on my end and see if I can recreate the crash. Thanks for your patience in the meantime!

bryan/[bucket drum games]

(+1)

I just finished Singularity and adored it! One question, one bit of feedback: Is there a way to rescue the rats who are trapped? It seemed like there were hints in the dialogue about that but I couldn't figure anything out. My only other frustration was that you automatically release your host human when using the error buffer! I get that you don't want players to be able to abuse the feature, but it sometimes left me in situations where i accidentally turned a conduit the wrong way, and the typo cost me a huge amount of work to rebuild my connection to the host's starting chamber. Is there a happy medium to be found? For instance, undoing moves doesn't release the host as long as those moves are in the chamber the host currently occupies? Just a thought. Thanks for your great work!

Developer(+1)

Hey, thanks so much for the kind words! And your thoughtful feedback. Doing my best to respond below:

1) Rescuing/interacting with the rats is, for the moment, only a narrative device. Our goal is to explore this dynamic a little more fulsomely later on, and we wanted to hint at those possibilities here, but you didn't miss anything mechanical!

2) Your frustrations w the error buffer are v well-stated. As you pointed out, if we allowed people to retain full control of hosts after undoing a move (or ten), it would fundamentally "break" many of the puzzles in a way that would also bypass other critical narrative/instructional/mechanical beats. That said, your suggestion of making an exception for moves within the same room might actually be totally viable! We'll have to take a closer look at what's possible, but it's super helpful to know this was a pain point. Thanks for thinking through this in any case!

Really appreciate your taking the time to write! And so glad you enjoyed the game overall!

bryan / [bucket drum games]

Sick! Looking forward to the full release!

(+1)

Got the Game from the BLM  bundle, got t play it at last, man that was good, fiendish puzzles, the last level took me a while, I was so close, just needed 1 electricity moved, but had to undo everything :D 
Congrats for the game it's really good, hope you'll do (or have done already, haven't checked yet) more levels or there puzzle games.

I agree with some of the previous comments releasing the host with the error buffer is not very intuitive, i understand it's needed for the puzzle but it's not super elegant.

Developer

Hey, thanks so much for playing, and for the kind words! Yeah, that last puzzle is tough! And we hear you about the host error buffer; as you noted, it's unfortunately necessary to keep the puzzles intact, but we'll work on making the mechanic feel a little more natural.

Really appreciate you taking the time to check our game out!

bryan/[bucket drum games]