Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles

Screen frame rate problems with the 2017-12-10 release of Recharged?

A topic by jting created Jan 13, 2018 Views: 513 Replies: 24
Viewing posts 1 to 5
(1 edit)

Hi, first off, excellent work. I have been flying the 2017-03-06 release of Recharge happily for months now, and have thoroughly enjoyed it. A few days ago, I decided to update it to the 2017-12-10 release to see what had changed. Loved the custom levels!

However, all is not well with this latest build. I have a reasonably fast i7 laptop that can play the usual games okay, and on the Recharge 2017-12-10 release, Car Park is unflyable due to the stuttering screen. I thought it was my laptop at first and did all the usual stuff, killing background programs and defrag my Windows 10, but to no avail. Then I switch back to the 2017-03-06 release and it went back to being smooth as silk. Any ideas? Something changed in Unity perhaps? Any chance I get can download the different builds in between 2017-03-06 and 2017-12-10 to see when it broke? Regards, Jeff.

GPU is more important than CPU 

Yeah, it's a recent Alienware gaming laptop with an Nvidia chipset. Plays all most of the current Unity and Unreal based games fine. As well as Velocidrone. The only thing it doesn't like is the Car Park in the latest release of Recharge.

Developer

That's interesting, thanks for reporting.

The main change in the 2017-12-10 release is that I increased the physics accuracy. That will put a bit more load on the CPU, but I don't think it will be noticeable actually, at least not on powerful processors such as the i7. Maybe that is still the cause though. I guess the best workaround I can suggest at the moment is to lower the graphics quality a notch or two and see if that makes it run smooth.

And thanks, glad to hear you like the sim!

Thanks for the reply. I guess it is some sort of Windows 10/software/driver issue because I tested it on the less powerful Windows 7 desktop at work (ssssh...) and it was fine. Any chance of a "Best Lap Times" scoreboard in future versions?  Or even multi-player? :)

(1 edit)

I also had this performance issue on my desktop with a GTX1060 6gb no matter the resolution or graphics quality, yet it runs ok on my old laptop with a GT750m. 

The framerate only drops when im flying close to the ground for example: -Desert: under the two arches -Park: when flying trough the gates -Parking lot: well.. basically it is unplayable for me except for the open area.  Never had these issues with earlier versions. I'll check if a driver update solves the problem.

Developer

I see, it would be interesting to hear if a driver update makes any difference. Graphics wise your rig shouldn't have any problems running it at full framerate. What CPU do you have?

Developer

I see, I will try an think of what might be causing that, but it sound mysterious that it runs better on a  less powerful machine.

Best lap times might be possible, multi player is put on hold since there are so many things that need to be solved to make it work well in a fast paced simulator and I'm only a single independent developer.

(1 edit)

Hi there, 

Love the sim, thank you so much for the HUGE efforts you're making to keep it going! Awesome work!

Unfortunately, I'm having the exact same problem. No matter what video quality I pick, the frame-rate drops in certain maps on the newer versions. 

Everything seems to work fine on older, about two versions prior the new custom maps arrived,  I think...

iMac 27" late 2013:

  • Intel Core i7-4771 3.5GHz
  • 24GB RAM DDR3 1600MHz
  • NVIDIA GTX780M 4GB. Driver 387.10.10.10.25.156
  • PCI-E 512GB SSD
  • OSX High Sierra 10.13.3

It should be more than enough. 

Thanks in advance! 

Developer (1 edit)

Thank you!

You're right, it should be more than enough, I'm surprised that it' struggling. It must be because I increased the physics accuracy in the December release. That will make it more demanding on the CPU, although I don't notice any real difference on my computer and it's certainly no supercomputer (It's a windows machine though, not sure if thats got anything to do with it).

In the December release I also introduced SSAO effect to the carpark level, but that shouldn't make a big difference.

Hi! Thanks for the quick response, 

That's the funny thing: 

  • CPU Usage:


  • GPU Memory:


  • GPU Cores:


It doesn't seems to be struggling at all. It won't event turn the fans on, and I'm making them trigger at 45ºC (113ºF).

CPU Usage won't go over 15%, and GPU memory won't go 10% over the usual usage. Also de GPU cores take that 91% peak and then... nothing.

When playing it feels like the game slows down, it doesn't really seems like a FPS drop but like it goes sluggy and then recovers and keeps going for a few more seconds.

Are there any debug CLI options I can pass to the app to gather more info? 


Thank you so much! 

Developer

You're right, there seems to be no struggle whatsoever. 

Perhaps you could try running the simulator in a window and/or at lower resolution and see if that makes any difference.

The command line parameters for that would be, for example:

-screen-fullscreen 0 -screen-width 800 -screen-height 450


Here is a list of all command line parameters that can be passed at runtime:

(It's under "Unity Standalone Player command line arguments")

https://docs.unity3d.com/Manual/CommandLineArguments.html

Hi, 

It seems to run better when windowed and at a lower resolution than the native one (2560*1440). Tried with 1920*1080 and I couldn't notice frame drop at all.

It's kinda weird as the GPU wasn't complaining at all when playing full screen @ 2560*1440... Anyway, if windowed with lower resolution makes the deal, so be it... 

Thanks for your time! 

Best regards

Developer

Yes that is weird. I'm glad that running it at lower resolution helped as a sort of workaround at least.

Best Regards

(2 edits)

Hi,

I have the following setup:

. Intel i3-7100 (GPU: HD630), 16GB

. Ubuntu 16.04 LTS

. Starting Freerider_recharged from a ramdisk with nice -20

. Resolution: 1360x768

. Game settings: lowest quality; motion blur off

From what I can tell by looking at intel_gpu_top, I have a GPU utilization of max. 60-70 percent. Yet I loose frames randomly and it seems that I do not have 60fps.

I was about to buy a RX560 (2-3times faster) or RX570 (5-6 times faster), but this thread makes me wonder.

Am I GPU limited with a 70% GPU utilization? Is there a way to show the frame rate and lost frames in game?

Could you provide some hardware guideline (CPU,GPU, expected frame rate)? For example, I would like to know if I could expected 60fps with my hardware and settings.

Best regards.


Edit: With -screen-width 800 -screen-height 450, it's basically the same issue.

Edit2: parking and dessert works relatively good; rocks and forest are bad

When I run "sudo intel_gpu_top -s 20000 -o gpu.txt" while playing the game, the game is relatively smooth. Not sure about the parameters though, but measuring GPU utilization with intel_gpu_top makes the game run smooth.

(Check points still tend to micro freeze; in particular the appearance of the next check point, to be precise).

Developer

I suspect it is the CPU usage. That would explain why you have the same problem when running at lower resolution, and, that the problem is worse close to gates. In the latest versions of Recharged I doubled the physics update frequency,  which makes the physics more accurate and more responsive, but is also makes it more demanding on the CPU. It is strange that it runs better when you measure the GPU usage though. Let me know if you manage to figure out anything more.

(1 edit)

I use an Intel i3-7100, released in 2017, 3.9GHz, 3MB L2 cache, dual core with HT (4 threads)

Over 95% of the time, all 4 threads are more than 70% idle. Only occasionally, one of the four threads drops to 40-50% idle.

After starting the program, the micro freezes (or frame drops?) during passing a gate occur only max. once per gate. Also, I have to pass the gate relatively fast. The issue is present in "forest" but I do not notice it in "dessert". There is no issue, when I pass the gate a second time.

It is possible that all this has to do with using an integrated graphics card (resides inside the CPU) or with some Intel driver in particular.

Edit: This post describes the situation during measuring the GPU utilization. Without measuring GPU utilization, forest is unplayable.

Developer

Do you mean that you notice it during Timed race?

Or, do you notice the micro freezes even when passing through a gate normally (Without times race turned on) ?

I get an error when I start the freerider 

Switching to resolution 0x0 failed, trying lower one
Switching to resolution 0x0 failed, trying lower one
All resolution switches have failed
Screen: DX11 could not switch resolution (0x4 fs=1 hz=0)


on win 10 wit nvidia 650 

monitor 1920x1080

Developer (1 edit)

Try setting the resolution manually as described in the manual.

You do it by setting command line parameters to the exe.

For example:

-screen-width 1920 -screen-height 1080 -screen-fullscreen 1

If that doesn't help try running the simulator in a window using the same method. For example:

-screen-width 800 -screen-height 450 -screen-fullscreen 0

Hope that helps.

I did some messing arround with the resolution

And it works 

I am flying 

Thanks for reply

Developer

Thank you, glad you got it working.