Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Comments on 'A Troll's Revenge'

A topic by Garry Francis created 61 days ago Views: 70 Replies: 13
Viewing posts 1 to 5
Submitted

Hey, hey, hey. It looks like I'm the first one to finish Gareth's game, 'The Magic Cave: A Troll's Revenge'. Great game, not easy, but not impossible. You have to do a lot of SEARCHing and retracing your tracks.

There are very few bugs (at least not that I discovered), so these comments are pretty pedantic.

General comments:
LISTEN: "though" should be "through".

Muddy Path:
X TRACKS: "deep. Very deep" should be "deep, very deep".

Beautiful Lake:
"distance you" should be "distance, you".

Outside Cave of Magic:
X CAVE: "days but" should be "days, but".
When you wake the troll, you should include a line to say that he takes the goblet from you before he runs off (unless you did and I forgot about it).
When you EXAMINE TROLL once he's awake, it says "You see nothing special.", followed by "'How rude', says the troll." Is the first response supposed to be there?

Inside Cave of Magic:
TALK TROLL: "bling then" should be "bling, then".

Farm Plot:
It might be nice if the image changed when the barn door is opened.

Inside Barn:
SEARCH BARN: "barn you" should be "barn, you".
I had problems with the cider press. It kept saying I needed more than one apple, because I had the apple (singular) as well as the apples (plural). In this case, it should have been testing for apples before apple. At some point the single apple became merged with the apples and everything was okay.

Cellar:
EMPTY BOTTLE: "Afterall" should be "After all,".

Bar:
When you TALK CHRIS, Gordo answers you.

Tables and Chairs:
X TABLES or X CHAIRS: Missing full stop at end of sentence.
When you TALK ALAN or TALK DEREK, Samara answers you.

Stables (with Vincent):
X VINCENT: "duty but," should be "duty, but,"; "stole" should be "stolen".
HIT VINCENT: "negative racial" should be "negative, racial".

Stables (with horse and cart):
"or to" should be "or, to".

Submitted (1 edit)

Thanks for the feedback, Garry., it's appreciated. A few typos I've missed, but I would probably disagree with the need for a few of the commas. 

Addressing the other points... 

The troll does take the goblet. 

The examine troll message is correct. That's the joke.

These are temporary graphics, so I won't be making the images change in response to what happens in the game. Although I do think that's very cool in the other games that have done this.

The TALK stuff... yeah, I guess that may be confusing if you're typing TALK followed by a name. I wanted players to just be able to type TALK rather than have to bother with the rest, but perhaps I should alter that there.

The apple/apple bug is annoying... because any time they come into contact they should be combined into a single entity... so I'm not sure how you've managed to keep them separate and are still able to use them with the press. Will look into that further.

Submitted

I'm a technical writer, so I tend to be very precise with comma usage.

I realise the troll takes the goblet, but I couldn't remember being told that he'd taken it at the time, because the screen had refreshed by the time I got around to taking the notes.

Regarding the apple and apples, I think I had them both in my inventory at one stage or both in the same room. I can't remember which. When I tried to use the press, I might have had the apple in the room and the apples in my inventory. Unfortunately, I was in playing mode, rather than testing mode, so I wasn't taking notes of steps to reproduce. I'm sure you'll work it out. Maybe just test for apples before testing for apple. Or are you doing something to test that the single apple has been merged with the other apples, like with the treasure?

Anyway, nice game and quite an original idea with the bandits and stuff. You might like to give some indication of how much treasure is still to be collected, as I had no idea how much was still to go. Every time I found more treasure, I thought that was the last of it, only to be told there was more to go.

Oh, I liked the graphics too. It would be a shame to change those.

Submitted

The only possible instance I can think of that may not be covered, would be the apple on the floor in the barn. with the apples in your inventory... the singular apple is always deleted whenever it comes into contact with the apples (i.e. when it's picked up).  I can easily sort out that, if that's the case... I don't think many people will put themselves in that situation, anyway.

The game was just a quick entry into the jam... not really a proper adventure... I had it done on the first day. (Although I did go back to it and add a couple of extra puzzles... and a lot more responses that probably nobody will ever see!)

I've just been waiting on the graphics. What I've already got for the game are excellent, but they won't all be done in time for the end of the jam, which is why this version (with my very quickly produced art) has been released. The 'old' version will always be available from my website, but the proper graphics are much (much) better. So I do hope they will eventually make it into the game.

Submitted (1 edit)

I'm glad you noticed the way the treasure changes... because the associated routines are pretty complicated! :) 

Submitted

I'll bet the treasure routines are complicated! Especially given that there are (from memory) five treasures that can be found in any order. This would be easy in any other adventure authoring language, but not so easy with Adventuron. You should see some of the complicated code in my game, just to do simple things.

And those responses in your game that nobody will ever see? I saw lots of them! That's one reason why I liked it. Apart from yours,  'Talk about love' (at the beginning at least) and mine, there weren't too many games that allowed for obscure commands. I was going to put a "Have you tried?" question at the end of mine, but commented it out when I realised there were so many interesting things to try, especially with the troll. You know, just little things like examining yourself or drinking water at the lake or trying to swim in the lake or singing/dancing/praying/thinking/jumping or trying magic words from other adventures. That sort of thing. That's where some of the funniest responses come from. And that's the difference between a dull game and a fun game. Yours is a fun game. I hope mine is too.

Submitted

Indeed it is. I think we have some very similar responses for some of the usual inputs too. :) 

Host

A really nice entry Gareth. 

Submitted(+1)

I really like this game - the humour is brilliant and I love the concept of continuing the story of the original game.

I'm stuck at the moment though. I'm trying to break the padlock to get into the hatch and it keeps telling me I need to hit it with something heavy. I have the spade but that doesn't seem to be working with any commands I've tried - do I need to find something else?  I'm sure I've searched (and dug and examined) absolutely everywhere.

Submitted(+1)

Go back to the lake and have a look around.

Submitted(+1)

Where would you use a spade if you were a farmer?

Submitted

Yeah... +1 to all those suggestions.

I'm glad you're enjoying the game, spiritofdee. 

Submitted

I've got the carrot  - I just assumed you must have to use the spade on the padlock as well 'cause I couldn't find anything else! Thanks.

Submitted(+2)

Finished it! Great stuff.