🤑 Indie game store🙌 Free games😂 Fun games😨 Horror games
👷 Game development🎨 Assets📚 Comics
🎉 Sales🎁 Bundles

Pad issues [RESOLVED]

A topic by tk1sbiglove created 119 days ago Views: 236 Replies: 23
Viewing posts 1 to 22

Hi, I like the look of this, but when I go to configure my pad, every option just says - ROLL AXIS

Developer

Strange.  What type of pad do you have? Do you have a double  adapter but only 1 pad plugged in?  Is it in the same port which you are trying to configure?

Tried an XB1 pad through USB and a wired 360 one  - no joy, unfortunately.

Developer

Wired 360 should work just fine.  I assume they both work with other PC games?

So basically, you selected JOYPAD PORT1 and it didn't register any buttons or analog sticks at all?

If you e-mail me on stevie@steviegoodwin.plus.com I'll create a quick test program for you?  Won't be until tomorrow though I'm afraid.

Developer

Hi,

Could anyone having Pad issues please download, unzip and run the follow.

https://stevieg.itch.io/pad-te...

It would be very helpful if you could confirm the following:

  1. What type of joypad you have?
  2. If the pad is wired or wireless?
  3. If your buttons and analog sticks register when pressed?
  4. The value of any buttons when nothing is pressed.  

Alternatively e-mail me details and a screenshot to stevie@steviegoodwin.plus.com.

Many thanks

Stevie

Ok, thanks, tried the pad program thing and all of the axes and buttons are registering and seem within normal parameters. I've had a few issues with a few games using this setups, but that just seems to be the thing with PC gaming. The wired 360 is generally always fine though. It just seems that when i go to configure the steering on the demo it immediately, instantly does the ROLL AXIS thing.

Messed around a bit, and managed to configure the controls using the XB1 pad when connected wirelessly by repeatedly selecting then tapping the desired direction/button. It's like it instantly defines it as soon as it's selected. Anyways, after the above fiddling around, i started the first challenge, could drive about a bit, but it wouldn't register that i'd driven onto the pad thing for the first task, tried it last night with the keyboard and it was ok.

Cheers. 

Developer

Thanks for that, much appreciated.

Yeah, the issue is that the xb360 has a default of -1 on the Roll Axis so the configuration process always thinks you're pressing it!!  On a Playstaion pad the Roll axis related to the right stick (left/right) and defaults to 0.  I'm working on a fix as we speak so hopefully get new versions uploaded in a few hours.  Please check back :)

Also, I'm certain that the issue you had with the first challenge is related to the fudge you were forced to do on the config.

Developer

Should be fixed now.  New versions of Demo and Full Game uploaded.

Let me know how it goes.

(Edited 1 time)

well, unfortunately it's still says "- ROLL AXIS", everytime that I try to reconfigure the analogue-sticks, but now also the START-button (i.e. "PAUSE") doesn't work on the controller... or rather I am able to select it perfectly fine in the menu and it acknowledges thus; but in-game it has seized to function...

I'm running Windows 7 x64, with an Xbox360 Original controller, wired - btw.

Also trying with PS3 w/ USB and Bluetooth

:edit re-binding "PAUSE" to any other button, except for "START" on the Xbox360 controller made it work

Developer

Please try again, new update uploaded 1 minute ago.

Stevie

now everything, except the "START" button works (i.e. can't bind any controls to "START" on the Xbox360 controller), but at least there's no issue binding the Analogue-sticks =)

Developer

Great - thanks Lord Santa.

If I remember the [Start] button the Xbox360 is Button 7. 

Could you try this and tell me if it registers, what the unpressed value and the pressed value are please?

https://stevieg.itch.io/pad-te...

(Edited 1 time)

oversight on my part; now it seems the Xbox360 "START" works fine (Button 8) - might have been due to controller-conflict, since I had two hooked up at once? either way, it seems to work perfectly fine now

Developer

Excellent!  Thanks again. 

Ok, cool - player one and two sorted with 1 XB1 pad, 1 360 wired - can't get player 3 working though for some reason. When i'm trying to define the P3 controls, it won't register the input. Any thoughts, or is this just for the demo?

Thanks again!

Developer (Edited 1 time)

You are most welcome and thank you for pointing this issue out early!  The individual who I had test the Xbox pads got a earful today at work :)

Yip, the demo 'Party Games'  mode is limited to 2 players, 1 min and no multiple game tournaments.  There's also no access to Timetrial and Sandbox modes in the demo and obviously only the first 10 challenges.

I should really deactivate the Joypad3 and 4 on the Control Setup for the Demo.  It isn't doing any harm so not up there in terms of priorities at the moment.

Cheers

Stevie

Hi,

Sorry to bother (again), bought the full version and i'm using 3x XB1 pads via the wireless adaptor and when i go to use redefine the controls it automatically defaults to -2 AXIS. Seems to be okay when using them via usb though.

Cheers!

Developer (Edited 1 time)

You sure it says '-2 Axis'? 

Do the controllers all register on the pad-test program below?  What axis/button are highlighted with values when you press nothing?

Do the wireless controllers work fine with other PC games?

https://stevieg.itch.io/pad-test?secret=uaWkw3q42ZPN7m1qQ0LNPy9DuM

Yep, definitely -2 AXIS, i tried to take a pic put it kept crashing. If i try to configure the buttons when the pad's connected via the wireless adapter all directions and both triggers change to that. Here's the defaults on the test program.

I've had a few issues via wireless in the past, but mostly they're sorted now, it's probably fine with  80%+ of games I reckon. The most common issue was that it would always pull the left analogue left, but on Polymaniacs it likes to accelerate.


Cheers!

Developer (Edited 1 time)

The test program checks exactly the same axis' as Polymaniacs does so '-2 Axis' makes no sense.   Your pads seem to be registering as 'Digital' rather than 'Analog'.    Presumably all the Axis' register (default values change) in the PadTest?

Does this '-2 Axis' appear regardless of which Port and action (turn left / special etc... ) you are trying to configure?

Could you do me a favour and paste the all the joypad data from [Data/Config/Settings.ini] so that I can take a look please?

e.g.

[JOYPAD PORT 1]
TURN_L2 = -1001.25
TURN_R2 = 1001.25
THROTTLE2 = -1003.25
BRAKE2 = 1003.25
SPECIAL2 = 1018
ACTION2 = 1016
THRUST_U2 = 1002.25
THRUST_D2 = -1002.25
REAR_VIEW2 = 1017
CHANGE_CAM2 = 1011
PAUSE2 = 1019

etc..


Thanks

Stevie

(Edited 1 time)

Yeah, the pad's values change in the test program and they seem accurate. -2 AXIS appears on all of the analogue inputs when you try to change them, so left stick and triggers and presumably the right stick too.


[JOYPAD PORT 1]

TURN_L2 = -1001.25
TURN_R2 = 1001.25
THROTTLE2 = -1003.25
BRAKE2 = 1003.25
SPECIAL2 = 1011
ACTION2 = 1012
THRUST_U2 = 1010.25
THRUST_D2 = -1010.25
REAR_VIEW2 = 1014
CHANGE_CAM2 = 1013
PAUSE2 = 1018

[JOYPAD PORT 2]
TURN_L3 = -2001.25
TURN_R3 = 2001.25
THROTTLE3 = -2003.25
BRAKE3 = 2003.25
SPECIAL3 = 2011
ACTION3 = 2012
THRUST_U3 = 2016.0
THRUST_D3 = 2015.0
REAR_VIEW3 = 2013
CHANGE_CAM3 = 2013
PAUSE3 = 2018

[JOYPAD PORT 3]
TURN_L4 = 0.0
TURN_R4 = 0.0
THROTTLE4 = 0.0
BRAKE4 = 0.0
SPECIAL4 = 0
ACTION4 = 0
THRUST_U4 = 0.0
THRUST_D4 = 0.0
REAR_VIEW4 = 0
CHANGE_CAM4 = 0
PAUSE4 = 0

Developer (Edited 2 times)

Pad1 and 2 are showing the X Axis for turning and Z Axis for throttle/brake so this doesn't match what you are telling me?  Maybe I didn't make myself clear - can you configure Port3 please (even if all the results are -2 Axis - leave them as that),  go back/back/back and then quit and then give me the settings data for that Pad please?

This is all three.

[JOYPAD PORT 1]
TURN_L2 = -1001.25
TURN_R2 = 1001.25
THROTTLE2 = -1003.25
BRAKE2 = 1003.25
SPECIAL2 = 1011
ACTION2 = 1012
THRUST_U2 = 1010.25
THRUST_D2 = -1010.25
REAR_VIEW2 = 1014
CHANGE_CAM2 = 1013
PAUSE2 = 1018

[JOYPAD PORT 2]
TURN_L3 = -2001.25
TURN_R3 = 2001.25
THROTTLE3 = -2003.25
BRAKE3 = 2003.25
SPECIAL3 = 2011
ACTION3 = 2012
THRUST_U3 = 2016.0
THRUST_D3 = 2015.0
REAR_VIEW3 = 2013
CHANGE_CAM3 = 2013
PAUSE3 = 2018

[JOYPAD PORT 3]
TURN_L4 = -3003.25
TURN_R4 = -3003.25
THROTTLE4 = -3003.25
BRAKE4 = -3003.25
SPECIAL4 = 3012
ACTION4 = 3011
THRUST_U4 = -3003.25
THRUST_D4 = -3003.25
REAR_VIEW4 = 3014
CHANGE_CAM4 = 3013
PAUSE4 = 3018

[JOYPAD PORT 4]
TURN_L5 = 0.0
TURN_R5 = 0.0
THROTTLE5 = 0.0
BRAKE5 = 0.0
SPECIAL5 = 0
ACTION5 = 0
THRUST_U5 = 0.0
THRUST_D5 = 0.0
REAR_VIEW5 = 0
CHANGE_CAM5 = 0
PAUSE5 = 0
PROFILE = 222122211110000000000000000000000000000000000000000000000000


I attempted to take a screenshot in game, but it kept crashing when i alt-tabbed out and the shot itself always came out blank, so I resorted to this. The buttons are fine, but the axes default to -2 AXIS. Wired is fine, wireless does this.

It's totally possible that the error is something on my end, but, like i said, this hasn't occurred before.

Thanks.

Developer

It's the '-Z Axis', not the '-2 Axis' which was confusing me! :)

The Z Axis should be the triggers for Xbox pads, where 0 is the default, -1 for right trigger and +1 for left.
So it looks like your right trigger is assumed to be down by default for all 3 pads.  What values did you get for the Z Axis in the PadTest when holding down left and right triggers?

I assume that for your wired controllers the Z Axis defaults to zero on the pad test?  Is that something you can try?

This might be a hardware/driver issue but I'd like to be sure by making a build which gives more more debug info for you to try.  I might be able to work around it.  Off to work right now but I'll get this done later.

In the meantime, assuming that the current setup for Pads 1 & 2 work fine in game (as long as you don't try to reconfigure them), you could copy the following over the top of the Pad3 data.

[JOYPAD PORT 3]
TURN_L2 = -3001.25
TURN_R2 = 3001.25
THROTTLE2 = -3003.25
BRAKE2 = 3003.25
SPECIAL2 = 3011
ACTION2 = 3012
THRUST_U2 = 3010.25
THRUST_D2 = -3010.25
REAR_VIEW2 = 3014
CHANGE_CAM2 = 3013
PAUSE2 = 3018

Cheers

Stevie