Indie game storeFree gamesFun gamesHorror games
Game developmentAssetsComics
SalesBundles
Jobs

Excessive butler.exe memory usage when running They Bleed Pixels

A topic by GibdoInferno created Jun 23, 2020 Views: 309 Replies: 7
Viewing posts 1 to 6
(+1)

When I launch They Bleed Pixels from the itch.io desktop app, the memory usage of the butler.exe process as reported by Task Manager immediately increases from the norm of under 50 MB to about 2 and a half GB. This memory stays allocated until the itch app is closed; simply closing the game doesn't help. Launching the game a second time without closing the itch app causes another allocation of the same magnitude. I wasn't able to replicate this behavior when I tested a handful of other games (WitchWay, Dujanah, 9 Till Void), but I'm not certain what about the specific game might cause this problem. The abnormal memory use occurs whether or not the itch sandbox is enabled.

System details: Windows 10 Home, 64-bit, version 1909. itch app 25.4.0, butler 15.17.0, itch-setup 1.23.0. This bug was brought to my attention by a user in a Discord chat, so it affects more than my system.

I had the same problem as above, and i am the user in the discord chat.

Moderator

I’m not familiar to how Butler works, but assuming that it is running the games itself, could it be that there is a memory leak in the game and not with Butler?

If you open a different game, does Butler’s memory usage change?

(+2)

They Bleed Pixels dev here! This is a mystery to us as well. I'm able to replicate the issue, but it doesn't seem to happen if you run They Bleed Pixels from explorer or run the Steam version. I just asked the programmer if he has an ideas of how this could be happening, but it appears to be on the itch side and not something on ours from what I can tell. 

(+2)

itch app maintainer here, that’s my bug (well, one of the dependencies, but let’s just say it just became my bug), I’m looking into it at the moment.

(+4)

I’ve found the bug, fixed it, and released butler v15.18.0.

Memory usage is back to normal:

Everyone will eventually be upgraded to butler v15.18.0, but if you want to force the update now, you can do so from Preferences => Advanced => Components => Check for updates

Fantastic, thank you!

Indeed, it worked for me too, thank you!

This topic has been auto-archived and can no longer be posted in because there haven't been any posts in a while.